Subject: [mpls] LDP newbie question

From: "Abhishek Verma" <[email-masked]>
Date: Sat, 23 Dec 2006 06:52:51 +0530

Hi,

LDP1 -- LDP2

I have two LDP peers 1 and 2. LDP1 advertises its loopback IP address
(say 1.1.1.1) to LDP2 with a label of 3. Is there a reason for LDP2
too also advertise 1.1.1.1 back to LDP1 with some label?

Thanks,
Abhishek

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: "Yu Yi" <[email-masked]>
Date: Tue, 26 Dec 2006 12:58:42 +1100

Hi Abhishek,

   It is because that LDP2 think it is possible that LDP1 will want LDP2 send a lable if the next hop is change to LDP2 on LDP1.   But in your case it is impossible. Because the fec(1.1.1.1) is a loopback IP address on LDP1.  There is no chance for LDP1 to select LDP2 as the nexthop for 1.1.1.1.  In this case LDP1 should release the label which LDP2 send.
   Please consider another case:
     |------------------------------|
  LDP1 -----  LDP2 ----- LDP3

    1.1.1.1 is a loopback IP address on LDP1.  So LDP3 will receive a mapping from LDP2 for fec 1.1.1.1(Suppose the metric of link between LDP1/LDP3 is very large).  LDP3 will send a mapping to LDP2. This label will be used if the link between LDP1/LDP2 is down.

Thanks,
Yu

-----Original Message-----
From: Abhishek Verma [mailto:[email-masked]] 
Sent: 2006年12月23日 9:23 AM
To: [email-masked]
Subject: [mpls] LDP newbie question

Hi,

LDP1 -- LDP2

I have two LDP peers 1 and 2. LDP1 advertises its loopback IP address (say 1.1.1.1) to LDP2 with a label of 3. Is there a reason for LDP2 too also advertise 1.1.1.1 back to LDP1 with some label?

Thanks,
Abhishek

---

From: "Abhishek Verma" <[email-masked]>
Date: Wed, 27 Dec 2006 09:46:47 +0530

Greetings Yu!

The example that you have taken is slightly different.

I don't mind LDP3 forwarding the label advertisement it learnt from
LDP1 to LDP2 or vice-versa. What i dont comprehend is why an LDP
router would advertise the label binding back to the neighbor it
learnt that label from?

Thanks,
Abhishek

---

From: "Dutta, Pranjal \(Pranjal\)" <[email-masked]>
Date: Wed, 27 Dec 2006 13:46:03 +0530

Hi,
           LDP uses platform wide label space and no specific to neigbor. So the LSR will adverstise the local binding for the loopback address to all neighbors irrespective of from whom it has received the remote binding.
It's upto the neigbor whether to release the label for its own loopback or not.
 
HTH,
Pranjal

________________________________

From: Abhishek Verma [mailto:[email-masked]]
Sent: Wed 12/27/2006 9:46 AM
To: Yu Yi
Cc: [email-masked]
Subject: Re: [mpls] LDP newbie question

Greetings Yu!

Thanks,
Abhishek

On 12/26/06, Yu Yi <[email-masked]> wrote:
> Sent: 2006?12?23? 9:23 AM
> To: [email-masked]