Subject: RE: [mpls] polling for three new working group documents

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Sat, 23 Dec 2006 00:13:22 +0100

Hi Loa, all,

> draft-nadeau-mpls-interas-lspping-02.txt

I support, but the processing on ASBRs in the ping mode should be
clarified.
It seems that section 7 only discusses the traceroute mode.
If we want the actual forwarding path to be excercised in the ping mode,
then transit ASBRs should not process the echo request and hence cannot
update the ASBR Trace Stack.
A solution would consist of running a LSP Traceroute so as to retrieve
the ASBR Trace stack and then this stack could be inserted within the
echo request in ping mode...
Also there are a lot of nits, and inconsitencies in the terminology
along the draft (I will provide comments in a separate email).  

> draft-nadeau-rfc4379-bis-link-bundle-00.txt

Support
 
> draft-thomas-mpls-ldp-typed-wildcard-00

Support

Regards,

JL

> 
> On 13.12.2006 13:52 Uhr, "Loa Andersson" <[email-masked]> wrote:
> 
> > All,
> > 
> > we have three documents there the authors have requested that they 
> > become working group documents. All three were on the agenda in San 
> > Diego and we registered support for the documents.
> > 
> > Please respond to the mailing list within a week whether you think 
> > they should be made working group docs or not.
> > 
> > The documents are:
> > 
> > 
> > draft-nadeau-mpls-interas-lspping-02.txt
> > 
> > draft-nadeau-rfc4379-bis-link-bundle-00.txt
> > 
> > and
> > 
> > draft-thomas-mpls-ldp-typed-wildcard-00
> > 
> > /Loa and George
> 
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mpls
> 

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 28 Dec 2006 09:51:12 -0500

Salut Jean-Louis,

> It seems that section 7 only discusses the traceroute mode.

	Agreed.  We need to clarify this.

> echo request in ping mode...

	Agreed.

> along the draft (I will provide comments in a separate email).

	Yes, I will attempt to fix these once you provide
comments.

	Merci,

	--Tom

---

From: "Nitin Bahadur" <[email-masked]>
Date: Thu, 28 Dec 2006 11:18:08 -0800

Hi Thomas,

The intentions and theory of operation of the draft look good. As
someone else also pointed out, please clarify behavior for ping vs
traceroute.
   
The draft does not clarify traceroutes spanning IPv4 - IPv6 - IPv4 ASes
and vice-versa. In other words, the traceroute ingress AS is IPv4 AS and
the next transit-AS is IPV6 AS. The draft does not address if this will
work and if it will; how will the visited ASBR stack and failed node
addresses look like in such scenarios. I haven't thought of this in
detail, but it seems there might be other caveats to doing
lsp-traceroute across IPv4 - IPv6 domains.

Some nits on the inter-AS lsp-ping draft.

Section 5.1.
  "The purpose of this object is to allow the upstream router to relay
a"

   I think this should be *downstream* router. Or it should be re-worded
to "to allow the router upstream of the failed node to relay a".

Failed node IP address:
   The sub-section talks about Downstream node IP address and Downstream
node Interface address. I am not clear if this is referring to the DSMAP
TLV or something else. If it is, then note that DSMAP TLV may not be
present if there was an error at the transit router.

Failed Node AS Number:
  This sub-section is repeated twice.

Thanks
Nitin