Subject: [mpls] [Technical Errata Reported] RFC5331 (1700)

From: RFC Errata System <[email-masked]>
Date: Mon, 2 Mar 2009 09:03:25 -0800 (PST)

The following errata report has been submitted for RFC5331,
"MPLS Upstream Label Assignment and Context-Specific Label Space".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5331&eid=1700

--------------------------------------
Type: Technical
Reported by: Alfred Hoenes <[email-masked]>

Section: 7, pg. 8

Original Text
-------------
   Some tunnels may not even require configuration, e.g., a Generic
   Routing Encapsulation (GRE) tunnel can be "created" just by
   encapsulating packets and transmitting them.  In such a case, the IP
   address of the root is considered to be the IP source address of the
|  encapsulated packets.
             ^^ 

Corrected Text
--------------
   Some tunnels may not even require configuration, e.g., a Generic
   Routing Encapsulation (GRE) tunnel can be "created" just by
   encapsulating packets and transmitting them.  In such a case, the IP
   address of the root is considered to be the IP source address of the
|  encapsulating packets.
             ^^^  

Notes
-----
Location is 4th paragraph on page 8.

Rationale:
  Earlier in the same section, the 2nd paragraph on page 7 defines
  the 'root' of a tunnel:

  "The root is identified by the head-end IP address of the tunnel."

  Consequentlially, in the case of 'ad-hoc' GRE tunnels the IP address
  of the 'root' obviously is the source address in the *outer* IP
  header, i.e. the source address of the _encapsulating_ packet, not
  the source IP address in the inner IP header, the _encapsulated_
  packet.  Thus, the verb form used in the text needs to be corrected.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5331 (draft-ietf-mpls-upstream-label-07)
--------------------------------------
Title               : MPLS Upstream Label Assignment and Context-Specific Label Space
Publication Date    : August 2008
Author(s)           : R. Aggarwal, Y. Rekhter, E. Rosen
Category            : PROPOSED STANDARD
Source              : Multiprotocol Label Switching
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Eric Gray" <[email-masked]>
Date: Thu, 12 Mar 2009 12:56:35 -0500

The original text in this case is more correct than the proposed
replacement
text. The expression "encapsulating packets" does not make sense in this
context ("encapsulating packets" is an appropriate adverb-verb phrase,
but 
"encapsulating" is not a sensible adjective to apply to the noun
"packet").

The result, however, of "encapsulating" packets is "encapsulated
packets."

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
RFC Errata System
Sent: Monday, March 02, 2009 12:03 PM
To: [email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [mpls] [Technical Errata Reported] RFC5331 (1700)

Section: 7, pg. 8

Original Text
-------------

Corrected Text
--------------

Notes
-----

Rationale:

Instructions:
-------------

--------------------------------------
RFC5331 (draft-ietf-mpls-upstream-label-07)
--------------------------------------
Title               : MPLS Upstream Label Assignment and
Context-Specific Label Space
Publication Date    : August 2008
Author(s)           : R. Aggarwal, Y. Rekhter, E. Rosen
Category            : PROPOSED STANDARD
Source              : Multiprotocol Label Switching
Area                : Routing
Stream              : IETF
Verifying Party     : IESG
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls