Subject: [mpls] Determining proper TTL of a tunnel in Fast LSP-alert Mechanism

From: Greg Mirsky <[email-masked]>
Date: Mon, 26 Jul 2010 13:53:19 -0700

Dear Authors,
the Section 3.2.2 states new requirement which ends with the sentence:
"An LSP label on the forwarded packet MUST continue to have TTL set to 1."
But at the same time, in Section 6 when outlining direction for future work,
it is said that in heterogeneous environment value of TTL must be determined
by each node that supports the Fast LSP-alert mechanism. Does that scenario
invalidates the requirement put forward in Section 3.2.2?

Regards,
Greg

---

From: Sriganesh Kini <[email-masked]>
Date: Mon, 26 Jul 2010 17:43:31 -0400

Greg,

I wouldn't interpret that as invalidating the requirement. Those are thoughts on potential workarounds and should be considered only for scenarios that have LSRs that don't support the functionality.

Thanks

- Sri

________________________________
From: Greg Mirsky [mailto:[email-masked]]
Sent: Monday, July 26, 2010 1:53 PM
To: Autumn Liu; Sriganesh Kini; [email-masked]
Subject: Determining proper TTL of a tunnel in Fast LSP-alert Mechanism

Dear Authors,
the Section 3.2.2 states new requirement which ends with the sentence:
"An LSP label on the forwarded packet MUST continue to have TTL set to 1."
But at the same time, in Section 6 when outlining direction for future work, it is said that in heterogeneous environment value of TTL must be determined by each node that supports the Fast LSP-alert mechanism. Does that scenario invalidates the requirement put forward in Section 3.2.2?

Regards,
Greg