Subject: [mpls] a question about draft-cheung-mpls-tp-mesh-protection-01

From: [email-masked]
Date: Fri, 30 Jul 2010 16:06:30 +0800

hi,
 today I reviewed your this draft, I have a few questions for mesh 
protection 
 1 in section 3, In my mind, there is a sentence : In both cases, 1:1 or 
1+1 protection may be used. 
   if there use 1+1 protection for each working path. it is no necessary 
to apply mesh protection.
   beacause the bandwidth resource of protection is equal to the sum of 
bandwidth resource of all 
   protected path. so I think 1+1 protection should not be used in the 
mesh protection.
   do you think so?

 2 about the Shared node SEN will send the protection locking message 
requesting 
      LoP to the end node of protected LSP. IMO, as SEN node is MIP of the 
protected 
      LSP , it can't generate unsolicit OAM packet to send other node. so 
how to generate
    the protection locking message requesting LOP in the SEN node ?

  Maybe i miss something important?
  thank you

  best regards
  liu

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: "Ryoo, Jeong-dong" <[email-masked]>
Date: Fri, 30 Jul 2010 19:22:47 +0900

Liu,

What you described in your email is aligned with the operations stated in the MPLS-TP mesh protection draft.

The protection locking message is not exactly a reply message, which goes to the originator of the request message.

It is certainly destined to other nodes, which share the common facility,

This is an additional function of SEN to provide the shared mesh protection.

What I would like to emphasize is that this message is not originated by a SEN (a MIP of the path for linear protection) if there is no protection switching event message arrived at the SEN,

Best regards,

Jeong-dong

==============================================
Jeong-dong Ryoo, Ph.D.
Principal Member of Research Staff
Network Research Department
Electronics and Telecommunications Research Institute (ETRI)
Phone: +82-42-860-5384, Fax: +82-42-860-6342
Email: [email-masked]
==============================================

-----Original Message-----
From: "[email-masked]" <[email-masked]>
From Date: 2010-07-30 PM 6:21:08
To: "Taesik Cheung" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [mpls] a question about draft-cheung-mpls-tp-mesh-protection-01

Taesik
thank you for replying .but I don't agree your opinions
According to your describles in the draft. I think the protection locking message isn't  a response to the protection state change notification message sent from a MEP.
and it is activley generate a Locking Request message for the SEN node.
for example. the following figure :
A------B------C  D------E------F
\   LPD1   /        \   LPD3  /
\            /            \            /
P-----Q----------R-----S
/                                   \
/           LPD2                \
/                                        \
G--------------H---------------J
a. Node G detects the failure, and initiates the linear protection
switching for the failed working path G-H-J;

b. At the same time, node G generates the protection switching event
message saying that a protection switching event happened to node
P and R, which are SENs for J->H->G.

c. The SEN P compares the protection switching priority of LPD2 with
that of LPD1. In this example, as the priority of LPD1 is higher
than LPD2, SEN P does not take an action to node A.
The SEN R compares the protection switching priority of LPD2 with
that of LPD3. In this example, as the priority of LPD3 is lower
than LPD2, SEN R sends the protection locking message requesting
LoP to node D.(if the Locking message is a response to the protection
state change , I think the Locking message should send to Node G ,
not node D. because at the time there is no protection state change for LPD2 .
Node D can't send any state change request to SEN node R firstly.
do you think so?  )

d. Node D takes the protection locking message as an input to the
linear protection switching, and follows the linear protection
switching procedure to process the end-to-end LoP command

maybe my understanding be wrong?

best regards
liu

"Taesik Cheung" <[email-masked]>
?件人:  [email-masked]

2010-07-30 16:45

?答? ?
Taesik Cheung <[email-masked]>

收件人

<[email-masked]>, <[email-masked]>

抄送

[email-masked], [email-masked]

主?

Re: [mpls] a question about draft-cheung-mpls-tp-mesh-protection-01

Hi Liu,

Thank you for the comments.
Please see in-line.

Regards,
Taesik

-----Original Message-----
From: "[email-masked]" <[email-masked]>
From Date: 2010-07-30 PM 5:06:30
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: a question about draft-cheung-mpls-tp-mesh-protection-01

hi,
today I reviewed your this draft, I have a few questions for mesh protection
1 in section 3, In my mind, there is a sentence : In both cases, 1:1 or 1+1 protection may be used.
if there use 1+1 protection for each working path. it is no necessary to apply mesh protection.
beacause the bandwidth resource of protection is equal to the sum of bandwidth resource of all
protected path. so I think 1+1 protection should not be used in the mesh protection.
do you think so?
[Taesik] Yes, if 1+1 protection is used, shared mesh protection is not necessary. The sentence is just generic one. Right after the sentence, we described that if 1:1 protection is used, the segment PQR can be shared by two protection paths.

2 about the Shared node SEN will send the protection locking message requesting
LoP to the end node of protected LSP. IMO, as SEN node is MIP of the protected
LSP , it can't generate unsolicit OAM packet to send other node. so how to generate
the protection locking message requesting LOP in the SEN node ?
[Taesik] The protection locking message is a response to the protection state change notification message sent from a MEP. It is similar to LTM/LTR or Lock Intruct / Lock Report relationship.

best regards
liu

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls