Subject: Re: [mpls] [PWE3] Multiple RSVP paths

From: John E Drake <[email-masked]>
Date: Tue, 6 Jul 2010 09:10:35 -0700

Hi,

A related ID:

http://www.ietf.org/id/draft-kompella-mpls-rsvp-ecmp-00.txt

Thanks,

John
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Curtis Villamizar
> Sent: Tuesday, July 06, 2010 8:30 AM
> To: [email-masked]
> Cc: [email-masked]; pwe3
> Subject: Re: [PWE3] Multiple RSVP paths
> 
> 
> In message <[email-masked]>
> Stewart Bryant writes:
> >
> > In response to a comment received during last call I have added a new
> > section 7.3 entitled : "Multiple RSVP-TE Paths" which says:
> >
> > In some networks it is desirable for a Label Edge Router (LER) to be
> > able to load balance a PW across multiple RSVP-TE tunnels. The flow
> > label mechanism described in this document may be used to provide the
> > LER with the required flow information, and necessary entropy to provide
> > this type of load balancing. Methods by which the LER is configured to
> > apply this type of ECMP is outside the scope of this document.
> >
> > - Stewart
> 
> 
> Stewart,
> 
> You could mention using a link bundle with the all ones component
> link as a possibility but still leave further details out of scope and
> not preclude other mechanisms that are local to the LER.
> 
> Curtis
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3

---

From: Curtis Villamizar <[email-masked]>
Date: Tue, 06 Jul 2010 14:12:15 -0400

> http://www.ietf.org/id/draft-kompella-mpls-rsvp-ecmp-00.txt

John,

The use of the E-bit is not clear.  If the sub-LSP all have E=0, is
the load split proportional to the sub-LSP reserved bandwidth?  If E=1
are the reserved bandwidths of the component LSP all ignored?  What
happens if E=0 for some sub-LSP and E=1 for others?

Also in the figure:

                          ------------- M -----
                         /                      \
                        /           --- P --     \
                       /           /         \    \
                      A --- X --- Y --- Q --- T --- B
                             \     \              / |
                              \     --- R -------   |
                               \                    |
                                ------- S ----------

It is possible to set up link bundle Y-P-T and Y-Q-T as Y-T at PSC-4,
then bundle Y-P-T-B and Y-R-B as Y-B at PSC-3, then X-Y-B and X-S-B as
X-B at PSC-2, and A-M-B and A-X-B as A-B as PSC-1.  Done with one PSC
value to spare (the implied PSC=0).

This use of link bundling would yield the finest control over the
allocation of resources.  Each link bundle is the sum of the
components.

The problem with link bundling and a limitation of the draft in
question is that some LSP over this bundled LSP cannot specify that it
*needs* to take one component (to be MPLS-TP compliant, for example),
and allow other LSP to indicate that it is fine to load split it.

[  And now a word for our sponsor.  :-)  ]
See draft-villamizar-mpls-tp-multipath-00 for further requirements.

Curtis

---

From: Yong Lucy <[email-masked]>
Date: Thu, 08 Jul 2010 17:15:08 -0500

Hi John,

It is not clear to me 

1) how the proposed solution works in Figure 1 situation of the draft. Even
the receiver B assigns the same label for all five sub-LSPs, because there
are intermediate nodes between A and B, the sender A will be asked to use
the different labels for five sub-LSPs, is that right?  

2) For the following MLSP case, do sub-LSPs start from node A or from node
W?

                           --L--   --P-- 
                          /     \ /     \
                  A------W       S---Q---B
                          \     / \     /
                           --M--   --R-- 

Thanks,
Lucy

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> John E Drake
> Sent: Tuesday, July 06, 2010 11:11 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; pwe3
> Subject: Re: [mpls] [PWE3] Multiple RSVP paths
> 
> Hi,
> 
> A related ID:
> 
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls