Subject: [mpls] New draft-vkst-mpls-tp-te-mib-00 draft for review

From: venkatesan mahalingam <[email-masked]>
Date: Sun, 27 Feb 2011 22:20:40 -0500

Hi Team,
We have uploaded the MPLS-TP TE MIB draft last week into IETF repository.

This document provides an enhancement to the RFC-3812 for managing the
Traffic Engineering tunnels
for MPLS based transport networks in IP and Non-IP operator environments.

Please review the draft and provide your valuable comments/suggestions.

A URL of the draft is:
http://tools.ietf.org/id/draft-vkst-mpls-tp-te-mib-00.txt
<http://tools.ietf.org/id/draft-vkst-mpls-tp-te-mib-00.txt>
-- 
Best Regards,
Venkatesan Mahalingam.

---

From: venkatesan mahalingam <[email-masked]>
Date: Mon, 28 Feb 2011 08:39:19 -0500

Hi Vijay,
Thanks for your review.

Please find the responses inline.

Regards,
Venkat.

On Mon, Feb 28, 2011 at 2:55 AM, Vijayanand C - ERS, HCL Tech <
[email-masked]> wrote:

>  Hi venkatesh and authors,
>
> This draft specifies that for bidirectional LSPs there will be two
> cross-connects with different mplsXCIndex but unique mplsXCLspId.
>
> VM>> There is a typo in the draft, there should be two cross-connects with
same mplsXCIndex for co-routed bidirectional tunnel.

> Are you saying thsat the mplsXCLspId has to be globally unique ( rfc3813
> says it’s the mplsLSPID  which rfc 3811 says is the two byte LSPID in the
> case of RSVP-TE LSPs) and be used to tie up the forward and reverse cross
> connect entries ?
>
>
>
> You have also used the mplsXCLspId in the mplsTunnelXCPointer filed of the mplsTunnelTable
>
> (mplsTunnelXCPointer          =
>
>                                  mplsXCLspId.4.0.0.0.1.1.0.4.0.0.0.12,
>
> )
>
>  The XCPointer usually holds the index of the XC entry. (
> xcindex,insegindex,outsegindex). For mpls-tp bidirectional LSPs are you
> mandating the use of mplsXClspid in the XCPointer implicitly makign it one
> of the index fields of the XCEntry ?
>
>
>
VM>> No, we are not implicitly making mplsXClspid as the index field. We
point any accessible XC mib object into an mplsTunnelXCPointer i.e associate
any forward or reverse XC entry to an tunnel entry to get the XC index. This
XC index will be used to fetch the forward and reverse XC informations for
co-routed bi-directional tunnel.

Hope this helps.

Regards
>
> Vijay
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
> *venkatesan mahalingam
> *Sent:* Monday, February 28, 2011 8:51 AM
> *To:* mpls; [email-masked]
> *Subject:* [mpls] New draft-vkst-mpls-tp-te-mib-00 draft for review
>
>
>
> Hi Team,
>
> ------------------------------
> ::DISCLAIMER::
>
> -----------------------------------------------------------------------------------------------------------------------
>
> The contents of this e-mail and any attachment(s) are confidential and
> intended for the named recipient(s) only.
> It shall not attach any liability on the originator or HCL or its
> affiliates. Any views or opinions presented in
> this email are solely those of the author and may not necessarily reflect
> the opinions of HCL or its affiliates.
> Any form of reproduction, dissemination, copying, disclosure, modification,
> distribution and / or publication of
> this message without the prior written consent of the author of this e-mail
> is strictly prohibited. If you have
> received this email in error please delete it and notify the sender
> immediately. Before opening any mail and
> attachments please check them for viruses and defect.
>
>
> -----------------------------------------------------------------------------------------------------------------------
>

-- 
Best Regards,
Venkatesan Mahalingam.