Subject: [mpls] Question about RFC 4875 (bud node behavior)

From: Egor Zimin <[email-masked]>
Date: Sat, 5 Mar 2011 18:01:03 +0300

Hi all,

Are there any document, which specify label allocation behavior for
bud nodes in P2MP LSPs (described in 4875) ?
Are there any statements about PHP on such nodes ?
If no, may be, it has a sense to describe label allocation process on
bud nodes in more details ?

At the moment there are at least two different implementations exist:
1) Using Implicit/Explicit-null labels, which cause unnecessary
replication before bud nodes
2) Using unreserved labels value

-- 
Best regards,
Egor Zimin

---

From: "Santiago Alvarez (saalvare)" <[email-masked]>
Date: Mon, 7 Mar 2011 15:33:40 -0800

It has been discussed before. Some implementations are known to behave as in 1 at least in some situations.  RFC 4875 doesn't preclude 1 from what I recall.  
Cheers.

SA
--

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Egor
> Zimin
> Sent: Saturday, March 05, 2011 7:01 AM
> To: [email-masked]
> Cc: Валерий Ястребов
> Subject: [mpls] Question about RFC 4875 (bud node behavior)
> 
> Hi all,
> 
> Are there any document, which specify label allocation behavior for bud
> nodes in P2MP LSPs (described in 4875) ?
> If no, may be, it has a sense to describe label allocation process on bud
> nodes in more details ?
> 
> 1) Using Implicit/Explicit-null labels, which cause unnecessary replication
> before bud nodes
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Mon, 7 Mar 2011 20:54:19 -0600

Hi- 

Please see in-line.  

Thanks

Regards ... Zafar 

> > If no, may be, it has a sense to describe label allocation process on

Please have a look at the following draft for signaling non-php behavior. 

http://trac.tools.ietf.org/rfcmarkup/draft-ietf-mpls-rsvp-te-no-php-oob-mapping

Thanks

Regards.. Zafar