Subject: Re: [mpls] Entropy label in hierarchical LSP

From: Lizhong Jin <[email-masked]>
Date: Tue, 16 Aug 2011 23:04:36 +0800

Hi John,
With regarding the scenario and figure in Zhi's email, LSP1 will be nested
by LSP2, and both LSP1 and LSP2 support entropy label. Then do you mean node
B will not add entropy label for the labeled traffic of LSP1, right? I think
the draft is not clear for an ingress node to encapsulate a labeled packet.
The received labeled packet maybe already contain entropy label.

Thanks
Lizhong

> ------------------------------
>
> Date: Tue, 16 Aug 2011 05:41:19 -0700
> From: John E Drake <[email-masked]>
> To: "[email-masked]" <[email-masked]>,
>        "[email-masked]"
>        <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Subject: Re: [mpls] Entropy label in hierarchical LSP
> Message-ID:
>        <[email-masked]>
> Content-Type: text/plain; charset="us-ascii"
>
> Hi,
>
> The intent of the draft is that the node that creates the label stack is
> the node that places the entropy label in the stack.  So, there is only one
> entropy label present in any given MPLS packet.  If this is not clear,
> please point me to the text that causes you confusion on this point.
>
> Thanks,
>
> John
>
> Sent from my iPhone
>
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Monday, August 15, 2011 1:58 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [mpls] Entropy label in hierarchical LSP
>
>
> Hi authors:
>
> About the use of entropy label, consider the hierarchical LSP case below:
>
>           LSP-2
>         _________
>         /         \
> A--...--B---...---C--...--D
> \________________________/
>           LSP-1
>
>
> In the above figure, an end-to-end LSP LSP-1 is between A and D, and
> another LSP LSP-2 goes over LSP-1 from B to C. Entropy labels are generated
> by the ingress LSRs, A as ingress for LSP-1 and B for LSP-2 respectively.
>
> So the label stack of the packets arrives at C, is like
> +-------------+       +-------------+
> | LSP-2 label |       | LSP-2 label |
> | LSP-1 label |       |    ELI-2    |
> |    ELI-1    |   OR  |    EL-2     |    ?
> |    EL-1     |       | LSP-1 label |
> |    ELI-2    |       |    ELI-1    |
> |    EL-2     |       |    EL-1     |
> +-------------+       +-------------+
>
> ELI-1: ELI for LSP-1; EL-1: EL for LSP-1;
> ELI-2: ELI for LSP-2; EL-2: EL for LSP-2;
>
> Which one is the correct format?
>
> Thanks
> Zhi
>
>
>

---

From: John E Drake <[email-masked]>
Date: Tue, 16 Aug 2011 08:24:34 -0700

Lizhong,

That's correct, only the ingress LER places an entropy label in the label stack.

I think part of the confusion arises because the authors, for some unknown reason (stupidity perhaps), use the term 'LSR' rather than 'LER' throughout.  This is covered by the statement in Section 1.1:

"The term ingress (or egress) LSR is used interchangeably with ingress  (or egress) LER."

But people may have missed this.

Thanks,

John

Sent from my iPhone

From: Lizhong Jin [mailto:[email-masked]]
Sent: Tuesday, August 16, 2011 8:05 AM
To: John E Drake
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [mpls] Entropy label in hierarchical LSP

Hi John,
With regarding the scenario and figure in Zhi's email, LSP1 will be nested by LSP2, and both LSP1 and LSP2 support entropy label. Then do you mean node B will not add entropy label for the labeled traffic of LSP1, right? I think the draft is not clear for an ingress node to encapsulate a labeled packet. The received labeled packet maybe already contain entropy label.

Thanks
Lizhong

Date: Tue, 16 Aug 2011 05:41:19 -0700
From: John E Drake <[email-masked]<mailto:[email-masked]>>
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>,
       "[email-masked]<mailto:[email-masked]>"
       <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [mpls] Entropy label in hierarchical LSP
Message-ID:
       <[email-masked]<mailto:[email-masked]>>
Content-Type: text/plain; charset="us-ascii"

Hi,

The intent of the draft is that the node that creates the label stack is the node that places the entropy label in the stack.  So, there is only one entropy label present in any given MPLS packet.  If this is not clear, please point me to the text that causes you confusion on this point.

Thanks,

John

Sent from my iPhone

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Monday, August 15, 2011 1:58 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [mpls] Entropy label in hierarchical LSP

Hi authors:

          LSP-2
        _________
        /         \

In the above figure, an end-to-end LSP LSP-1 is between A and D, and another LSP LSP-2 goes over LSP-1 from B to C. Entropy labels are generated by the ingress LSRs, A as ingress for LSP-1 and B for LSP-2 respectively.

Thanks
Zhi

---

From: John E Drake <[email-masked]>
Date: Tue, 16 Aug 2011 10:20:59 -0700

Hi,

My email, below, contained an example of self-deprecating humor which at least one person did not get.  So, in the interest of increased clarity, I would like to replace the phrase:  "the authors, for some unknown reason (stupidity perhaps)" with the phrase:  "the authors of the Entropy Label I-D (of which I am one), for some unknown reason (stupidity perhaps)"

Thanks,

John

Sent from my iPhone

From: John E Drake
Sent: Tuesday, August 16, 2011 8:25 AM
To: 'Lizhong Jin'
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [mpls] Entropy label in hierarchical LSP

Lizhong,

Thanks,

John

Sent from my iPhone

Hi John,

Thanks
Lizhong

Hi,

Thanks,

John

Sent from my iPhone

Hi authors:

          LSP-2
        _________
        /         \

Thanks
Zhi

---

From: Lizhong Jin <[email-masked]>
Date: Wed, 17 Aug 2011 22:48:48 +0800

Hi John,
For the hierarchical LSP case, it is possible for the ingress LER to add
entropy label for the incoming labeled packet. The ingress LER will not
know whether the incoming labeled packet already contains entropy label.
Then the packet sent out by ingress LER may contain two entropy labels, one
is from the original packet, the other is added by itself. Did I miss
something?
>From the draft-entropy-label, it seems it makes an assumption that the
incoming packet is not an MPLS packet.

Thanks
Lizhong

2011/8/16 John E Drake <[email-masked]>

>  Lizhong,****
>
> ** **
>
> That’s correct, only the ingress LER places an entropy label in the label
> stack.****
>
> ** **
>
> I think part of the confusion arises because the authors, for some unknown
> reason (stupidity perhaps), use the term ‘LSR’ rather than ‘LER’
> throughout.  This is covered by the statement in Section 1.1:****
>
> ** **
>
> “The term ingress (or egress) LSR is used interchangeably with ingress  (or
> egress) LER.”****
>
> ** **
>
> But people may have missed this.****
>
> ** **
>
> Thanks,****
>
> ** **
>
> John****
>
> ** **
>
> Sent from my iPhone****
>
> ** **
>
> *From:* Lizhong Jin [mailto:[email-masked]]
> *Sent:* Tuesday, August 16, 2011 8:05 AM
> *To:* John E Drake
> *Cc:* [email-masked]; [email-masked];
> [email-masked]
>
> *Subject:* Re: [mpls] Entropy label in hierarchical LSP****
>
>   ** **
>
> Hi John,****
>
> The received labeled packet maybe already contain entropy label.****
>
>  ****
>
> Thanks****
>
> Lizhong****
>
>  ****
>
>  ****
>
> ****

---

From: John E Drake <[email-masked]>
Date: Wed, 17 Aug 2011 08:44:30 -0700

Lizhong,

We are using the term ingress Label Edge Router (LER) to mean the node which creates and adds the MPLS label stack to a given packet.   There will be only one such node for a given packet and hence only one entropy label for a given packet.  If a given packet already contains an MPLS label stack, no other node in the network will add an entropy label to that stack.

As I asked you before,  is there specific text in the Entropy Label I-D which gives a contrary impression?

Thanks,

John

Sent from my iPhone

From: Lizhong Jin [mailto:[email-masked]]
Sent: Wednesday, August 17, 2011 7:49 AM
To: John E Drake
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [mpls] Entropy label in hierarchical LSP

Hi John,
For the hierarchical LSP case, it is possible for the ingress LER to add entropy label for the incoming labeled packet. The ingress LER will not know whether the incoming labeled packet already contains entropy label. Then the packet sent out by ingress LER may contain two entropy labels, one is from the original packet, the other is added by itself. Did I miss something?
>From the draft-entropy-label, it seems it makes an assumption that the incoming packet is not an MPLS packet.

Thanks
Lizhong

2011/8/16 John E Drake <[email-masked]<mailto:[email-masked]>>
Lizhong,

Thanks,

John

Sent from my iPhone

From: Lizhong Jin [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Tuesday, August 16, 2011 8:05 AM
To: John E Drake
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Hi John,

Thanks
Lizhong

Hi,

Thanks,

John

Sent from my iPhone

Hi authors:

          LSP-2
        _________
        /         \

Thanks
Zhi