Subject: Re: [mpls] Comments on draft-ietf-mpls-tp-linear-protection

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 2 Aug 2011 10:31:23 +0100

Hi Hideki,

I have no particular reason to support any protocol version number in the
document, but you said...

> You should infom the reason why you have changed the protocol version
> from 0 to 1 in the draft-08.
> This is very important to implement PSC protocol.

...and this made me curious,

Why is the value of the protocol version field in the final RFC so important?

Cheers,
Adrian

---

From: <[email-masked]>
Date: Fri, 5 Aug 2011 13:47:39 +0900

Hi Adrian,

I'm very sorry for my late response.

You are right.
A protocol version number normally doesn't matter in final RFC,
because previous version number is put away and the latest version is available.

However, I heard from Yaacov that
not only version number '1' but also '0' was availble in this draft.
The version '0' is to use ACH TLVs.
The version '1' is to use Optional TLVs which will be defined for the future.

Unfortunately, I think this solution has big fault as a protocol.
Because the version number is following ACH TLVs,
it is impossible to determine whether there are ACH TLVs or Optional TLVs in a packet.

I'd like to advertise the fact in WG.

BR,
Hideki

---

From: "Eric Osborne (eosborne)" <[email-masked]>
Date: Fri, 5 Aug 2011 07:38:58 -0500

Hi Hideki-

  I'm afraid you've been misinformed.  Version 0 is not in use.  We had
talked about ACH TLVs as some point, but do not use them.  Per rfc5586,
"If the G-ACh message MAY be preceded by one or more ACH TLVs, then this
MUST be explicitly specified in the definition of an ACH Channel Type"
and we do not make that explicit specification in the draft.

  Version 1 is the only version which we have defined, and it uses
optional TLVs below the PSC header.

eric

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> [email-masked]
> Sent: Friday, August 05, 2011 12:48 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [mpls] Comments on draft-ietf-mpls-tp-linear-protection
> 
> Hi Adrian,
> 
because
> previous version number is put away and the latest version is
available.
> Because the version number is following ACH TLVs, it is impossible to
> determine whether there are ACH TLVs or Optional TLVs in a packet.
> 
> >I have no particular reason to support any protocol version number in
> >the document, but you said...
> >
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: <[email-masked]>
Date: Sat, 6 Aug 2011 09:55:40 +0900

Hi Eric,

Thank you for clarifications.

I understand what you say.
However, it's different from what Yaacov said.
I'm confusing..

If your explanation is right status of this draft,
why did you changed the version number of PSC?
If the only one channel type for PSC is assigned,
you don't need to change the version number, do you?

BR,
Hideki

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 7 Aug 2011 18:46:17 +0100

Hi Hideki,

We didn't see Yaacov's email so we can't comment. But I think I agree with
Eric...
If it isn't documented in a current draft or an RFC, it doesn't exist.
So I think there is no definition of LP using ACH TLVs, and no version zero of
the protocol.

Cheers,
Adrian

> From: [email-masked] [mailto:[email-masked]]
> Sent: 06 August 2011 01:56
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re[2]: [mpls] Comments on draft-ietf-mpls-tp-linear-protection
> 
> Hi Eric,
>

---

From: <[email-masked]>
Date: Wed, 17 Aug 2011 10:07:21 +0900

Hi Adrian,

Thank you for your comments.

Yaacov,

Could you give us some comments, especially you and I discussed in Quebec?

BR,
Hideki