Subject: [mpls] Entropy label in hierarchical LSP

From: [email-masked]
Date: Mon, 15 Aug 2011 16:58:29 +0800

Hi authors:

About the use of entropy label, consider the hierarchical LSP case below:

           LSP-2
         _________
         /         \
A--...--B---...---C--...--D
\________________________/
           LSP-1

In the above figure, an end-to-end LSP LSP-1 is between A and D, and 
another LSP LSP-2 goes over LSP-1 from B to C. Entropy labels are 
generated by the ingress LSRs, A as ingress for LSP-1 and B for LSP-2 
respectively.

So the label stack of the packets arrives at C, is like
+-------------+       +-------------+ 
| LSP-2 label |       | LSP-2 label |
| LSP-1 label |       |    ELI-2    |
|    ELI-1    |   OR  |    EL-2     |    ?
|    EL-1     |       | LSP-1 label | 
|    ELI-2    |       |    ELI-1    | 
|    EL-2     |       |    EL-1     | 
+-------------+       +-------------+

ELI-1: ELI for LSP-1; EL-1: EL for LSP-1;
ELI-2: ELI for LSP-2; EL-2: EL for LSP-2;

Which one is the correct format?

Thanks
Zhi

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: John E Drake <[email-masked]>
Date: Tue, 16 Aug 2011 05:41:19 -0700

Hi,

The intent of the draft is that the node that creates the label stack is the node that places the entropy label in the stack.  So, there is only one entropy label present in any given MPLS packet.  If this is not clear, please point me to the text that causes you confusion on this point.

Thanks,

John

Sent from my iPhone

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, August 15, 2011 1:58 AM
To: [email-masked]
Cc: [email-masked]
Subject: [mpls] Entropy label in hierarchical LSP

Hi authors:

           LSP-2
         _________
         /         \

In the above figure, an end-to-end LSP LSP-1 is between A and D, and another LSP LSP-2 goes over LSP-1 from B to C. Entropy labels are generated by the ingress LSRs, A as ingress for LSP-1 and B for LSP-2 respectively.

Thanks
Zhi