Subject: Re: [mpls] new version of the per-interface MIP draft

From: Rui Costa <[email-masked]>
Date: Wed, 10 Aug 2011 19:23:12 +0100

Hi,	

1. In point 4, by the end of page 6, "Figure 2 depicts OAM using per-interface MIPs and MEPs": don't you actually mean "per-node"?	

2. In "6.1.  ID-based Solution", by the end: how does a node know an OAM message was "intended for its upstream neighbor's outgoing MIP"?	

Thanks. Regards,	
Rui	

-----Original Message-----	
From: [email-masked] [mailto:[email-masked]] On Behalf Of Rolf Winter	
Sent: terça-feira, 12 de Julho de 2011 08:28	
To: [email-masked]	
Subject: [mpls] new version of the per-interface MIP draft	

Hi WG,	

we have submitted a new version of the per-interface MIP draft (http://tools.ietf.org/html/draft-farrel-mpls-tp-mip-mep-map-04). In this new version things have changed significantly based on your valuable feedback. We would very much appreciate more feedback on this new version of the document.

Thanks,

Rolf

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: Rolf Winter <[email-masked]>
Date: Thu, 11 Aug 2011 14:04:26 +0000

Hi Rui,

Thanks for your comments. Do you have an opinion on which option to go for? More inline:

> 1. In point 4, by the end of page 6, "Figure 2 depicts OAM using per-
> interface MIPs and MEPs": don't you actually mean "per-node"?

Good catch. You're absolutely right.

> 2. In "6.1.  ID-based Solution", by the end: how does a node know an
> OAM message was "intended for its upstream neighbor's outgoing MIP"?

The last bullet point (in fact all bullet points) first state the requirement and then how it is handled. The rational here is that this situation should never arise, i.e. the downstream node should not even receive an OAM message that was intended for the upstream outgoing MIP (which is not present since we are talking about a per-node MIP node). The reason is that the TTL is addressing the node. That means the at the upstream node the TTL expires. The MIP will detect an ID mismatch and should discard the packet. Therefore, the packet should not even make it to the downstream node. I think I need to do some rewording to make this more clear.

Thanks again,

Rolf