Subject: [mpls] PSC: draft-rhd-mpls-tp-psc-sd-00

From: "Eric Osborne (eosborne)" <[email-masked]>
Date: Wed, 17 Apr 2013 12:26:04 +0000

This thread is for discussing draft-rhd-mpls-tp-psc-sd-00.  The draft provided extensions to the PSC state machine to handle Signal Degrade (SD).  It does not define SD or provide scope around where or how SD may be used.  There are some expired drafts that touch on the definition and use of SD, including:

draft-zhl-mpls-tp-sd-03
draft-rkhd-mpls-tp-sd-03

(this is not an exhaustive list.  It's the top two google hits.)

The questions I think are relevant are:

- do we need an SD mechanism in MPLS-TP?
- if so, is it reasonable to define state transitions for it before we have defined SD itself?
- if yes to both of the above, does this draft provide the right behavior?  Are there alternative approaches?

but of course any and all discussion is welcome.

eric

---

From: Alexander Vainshtein <[email-masked]>
Date: Sun, 21 Apr 2013 15:45:25 +0000

Eric, and all,
The issue has been discussed actively in the past.

I can only re-state my position during these discussions, namely that there is no way to define a reasonable analog of Signal Degrade (SD) in MPLS and, by implication, in the MPLS-TP data plane. By "reasonable" here I mean a method that does not depend on the actual traffic going thru the LSP.

The fact that we could not reach any consensus for such a definition in the past is not, of course, a mathematical proof of non-existence of SD.
But it is a good indication of a fundamental problem IMO.

As a consequence, IMHO and FWIW, there is no need in defining SD-related state transitions, behavior etc.

My 2c,
     Sasha

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric
> Osborne (eosborne)
> Sent: Wednesday, April 17, 2013 3:26 PM
> To: [email-masked]
> Subject: [mpls] PSC: draft-rhd-mpls-tp-psc-sd-00
> 
> This thread is for discussing draft-rhd-mpls-tp-psc-sd-00.  The draft provided
> extensions to the PSC state machine to handle Signal Degrade (SD).  It does not
> define SD or provide scope around where or how SD may be used.  There are
> some expired drafts that touch on the definition and use of SD, including:
> 
> draft-zhl-mpls-tp-sd-03
> draft-rkhd-mpls-tp-sd-03
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: "Eric Osborne (eosborne)" <[email-masked]>
Date: Mon, 22 Apr 2013 17:45:06 +0000

Hi Sasha-

 I tend to agree.  I fully admit that PSC is a little inconsistent in these matters, in that it provides a place for SD in the alarm hierarchy but not in the state machine.  However, I see little point in adding all the SD state machinery before we have some sort of SD mechanism.  It may be that we come up with an SD mechanism that is more powerful than its analog in the transport world, and it might provide operators with significant flexibility that wouldn't be possible with the current proposal.

  Why come up with highway legislation that describes the rules of the road for flying hovercars prior to inventing the flying hovercar?

eric

> From: Alexander Vainshtein [mailto:[email-masked]]
> Sent: Sunday, April 21, 2013 11:45 AM
> To: Eric Osborne (eosborne)
> Cc: [email-masked]; Rotem Cohen; Gideon Agmon; Yechiel Rosengarten; Shell
> Nakash
> Subject: RE: PSC: draft-rhd-mpls-tp-psc-sd-00
> 
> Eric, and all,
> I can only re-state my position during these discussions, namely that there is no
> way to define a reasonable analog of Signal Degrade (SD) in MPLS and, by
> implication, in the MPLS-TP data plane. By "reasonable" here I mean a method
> that does not depend on the actual traffic going thru the LSP.
> 
> The fact that we could not reach any consensus for such a definition in the past
> is not, of course, a mathematical proof of non-existence of SD.
> > From: [email-masked] [mailto:[email-masked]] On Behalf
> > Of Eric Osborne (eosborne)
> > This thread is for discussing draft-rhd-mpls-tp-psc-sd-00.  The draft
> > provided extensions to the PSC state machine to handle Signal Degrade
> > (SD).  It does not define SD or provide scope around where or how SD
> > may be used.  There are some expired drafts that touch on the definition and
> use of SD, including:
> >
> > draft-zhl-mpls-tp-sd-03
> > draft-rkhd-mpls-tp-sd-03
> >
> > - if yes to both of the above, does this draft provide the right
> > behavior?  Are there alternative approaches?
> >
> This e-mail message is intended for the recipient only and contains information
> which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you
> have received this transmission in error, please inform us by e-mail, phone or
> fax, and then delete the original and all copies thereof.

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 22 Apr 2013 17:57:36 +0000

Dear Sasha, Eric, et al.,
I too share Sasha's concern in regard to SD in packet transport networks. I think that before we as WG discuss SD handling by PSC, the SD in Packet Transport Network must be clearly defined. Otherwise it looks as we've been asked to discuss Something Happens and You Must React.

	Regards,
		Greg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alexander Vainshtein
Sent: Sunday, April 21, 2013 8:45 AM
To: Eric Osborne (eosborne)
Cc: [email-masked]; Shell Nakash; Gideon Agmon
Subject: Re: [mpls] PSC: draft-rhd-mpls-tp-psc-sd-00

Eric, and all,

My 2c,
     Sasha

> may be used.  There are some expired drafts that touch on the definition and use of SD, including:
> 
> draft-zhl-mpls-tp-sd-03
> draft-rkhd-mpls-tp-sd-03
>