Subject: [mpls] MPLS WG last call on draft-kompella-mpls-special-purpose-labels-04

From: Ross Callon <[email-masked]>
Date: Wed, 29 May 2013 20:19:44 +0000

Working Group,

this is to start a two week Working Group last call on
draft-kompella-mpls-special-purpose-labels-04.

Please send your comments to the mpls working group
mailing list ([email-masked]<mailto:[email-masked]>).

Please send both technical comments, and (if you are happy
with the document as is) also send indications of support.

There are no IPR claims against this draft.

The co-authors have earlier stated that they are not aware
of any IPR applicable to this draft.

If anyone else in the working group are aware of IPRs claims against
this draft, the time to disclose that is now.

This working group last call will end on June 13, 2013.

Ross
for the wg co-chairs

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 30 May 2013 03:07:40 +0000

Hi all,

I support.  Some minor comments for consideration:

1.       it said in section 3.1 “ A label after L (if any) is parsed as usual, and thus may be a regular  label, a special purpose label or (if prefixed by another extension  label) an extended special purpose label.”

Should the above be modified as:
“A label after L (if any) is parsed as usual, and thus may be a regular  label, a special purpose label or another extension  label.”

2.        it said in section 3.1:   “Values 0-6 and 8-15 of the extended special purpose label registry  are set aside as reserved; these MUST NOT appear in the data plane.  Label 7 (when received) retains its meaning as ELI whether a regular  or an extended special purpose label; however, an implementation  SHOULD NOT insert a label of 7 as an extended special purpose label,  preferring instead to send 7 as a regular special purpose label.”

I understand the regular special purpose label value MUST NOT appear following the Extension Label in the MPLS label stack. But what’s the special usage of making the ELI label of “7” as an exception (i.e., Label 7 (when received) retains its meaning as ELI whether a regular  or an extended special purpose label)?

3.        it said in section 5, “ Note: any new allocation from the Special Purpose MPLS Label   Values registry MUST be also say whether the same value needs to   be reserved in the Extended Special Purpose MPLS Label Values  registry.”

Wouldn’t this description conflict with the above statement that “Values 0-6 and 8-15 of the extended special purpose label registry  are set aside as reserved; these MUST NOT appear in the data plane.” By the way, in my understanding, as long as we have reserved one regular special purpose label  (i.e., 15) as the Extension Label, we would definitely have the capability to use the Extended special purpose label space in the future if NEEDED. Due to the uncertainty of this need from today’s point of view, how about explicitly stating that “The Extended special purpose labels SHOULD NOT be allocated by IANA until the regular special purpose label space (0-14) has been almost used out.” or something like that.

Best regards,
Xiaohu

发件人: [email-masked] [mailto:[email-masked]] 代表 Ross Callon
发送时间: 2013年5月30日 4:20
收件人: [email-masked]
抄送: [email-masked]; [email-masked]
主题: [mpls] MPLS WG last call on draft-kompella-mpls-special-purpose-labels-04

Working Group,

Ross
for the wg co-chairs

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 30 May 2013 11:32:59 +0100

On 30/05/2013 04:07, Xuxiaohu wrote:
> how about explicitly stating that “The Extended special purpose labels 
> SHOULD NOT be allocated by IANA until the regular special purpose 
> label space (0-14) has been almost used out.” or something like that.
>
I would disagree with that. There are far more of the new SP labels than 
the old, and the old one's take less stack space and less parsing, so I 
think the right think to do is to consider each application on its own 
merits.

Stewart (AD hat off)

---

From: Loa Andersson <[email-masked]>
Date: Thu, 30 May 2013 14:44:15 +0200

All,

I agree with Stewart, how the label will be parsed, will have a lot
of impact when we decide how to allocate a new special purspose label.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 30 May 2013 17:34:37 +0100

I kind of agree with Stewart and Xiaohu, but I note that the regular special purpose label space (0-14) *is*already* almost used out.
Thus, making the statement would have no effect because we are already passed the point.
And hence there is no point in adding the text.

Adrian (just a humble co-author)

> -----Original Message-----
> From: Loa Andersson [mailto:[email-masked]]
> Sent: 30 May 2013 13:44
> To: [email-masked]
> Cc: Xuxiaohu; MPLS WG Mailing List; draft-kompella-mpls-special-purpose-
> [email-masked]; [email-masked]
> Subject: Re: [mpls] 答复: MPLS WG last call on draft-kompella-mpls-special-
> purpose-labels-04
> 
> All,
>

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 30 May 2013 21:02:25 +0100

Adrian

That would suggest that we prefer to allocate from the new range and 
keep the
old range for critical new functions that really are stack size sensitive.

Stewart

On 30/05/2013 17:34, Adrian Farrel wrote:
> .

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 31 May 2013 03:31:23 +0100

Yes (or maybe).

I think it suggests that we should consider this on a case-by-case basis.

Since the labels are allocated as Standards Action (after this I-D becomes an RFC) it seems likely that "appropriate care" can be taken by the working group on a case-by-case basis.

Ciao,
Adrian

> From: Stewart Bryant [mailto:[email-masked]]
> Sent: 30 May 2013 21:02
> To: [email-masked]
> Cc: 'Loa Andersson'; 'Xuxiaohu'; 'MPLS WG Mailing List'; draft-kompella-mpls-
> [email-masked]; [email-masked]
> > I kind of agree with Stewart and Xiaohu, but I note that the regular special
> purpose label space (0-14) *is*already* almost used out.