Subject: [mpls] MPLS wg charter update

From: Loa Andersson <[email-masked]>
Date: Sat, 11 May 2013 10:42:44 +0200

Working Group,

The working group chairs have discussed an MPLS wg charter update
for sometime.

We have converged on the text below and while we understand that
it still not "perfect" (for some value of perfect) we believe that
it is good enough to serve as a basis for a working group discussion
of our charter.

Please note that this is not a "re-charter", but a normal charter update
(maintenance) that should take place when adopting new work items or
finalizing others. The only "issue" is that we have not maintained the
charter to the degree we should have during the last years when the
work load has been quite heavy.

Please view the text below as a starting point for an update of our
charter and send your comments to [email-masked]. We would like to see
your comments before June 7th, 2013.

-------------------- Proposed new charter text -------------------------

Description of Working Group

The MPLS working group is responsible for standardizing technology
for label switching and for the implementation of label-switched
paths over packet based link-level technologies.

The responsibility includes procedures and protocols for the
distribution of labels between Label Switching Routers (LSRs),
MPLS packet encapsulation, and for Operation, Administration, and
Maintenance (OAM) (including the necessary management objects
expressed as MIB modules or using other techniques).

The current WG work items are:

•	Maintain existing MPLS requirements, mechanisms, and protocols,
         in coordination with other working groups, e.g. CCAMP, PWE3
         and OPSAWG working groups.
•	Evolve key MPLS protocols, including LDP, tLDP, mLDP, RSVP-TE
         and LSP Ping to meet new requirements.
•	Define an overall OAM framework for topology-driven, traffic
         engineered, and transport profile MPLS applications.
•	Determine MPLS-specific aspects of traffic engineering for
         multi-areas/multi-AS in cooperation with the CCAMP WG
•	Define necessary extensions for MPLS key protocols for
         dual-stack and IPv6 only networks
•	Coordinate with the CCAMP working group on the extensions of
         MPLS and GMPLS protocols
•	Document current implementation practices for MPLS load sharing.
•	Document mechanisms for securing MPLS networks in coordination
         with the KARP working group.
•	Document mechanisms for adding multi-topology support to
         existing MPLS protocols.
•	Document use cases for MPLS protocols.

-------------------------- end proposed text ------------------------

Loa
(for the wg chairs)

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 11 May 2013 13:12:51 +0100

Chairs, WG,

I am going to enter this text into the datatracker. Updating charters is /
should be a similar process as for I-Ds. Using the datatracker allows us to see
the latest version and to compare with previous versions.

Putting the text under change control makes no statement about whether the text
is ready or whether the AD supports the change :-)

Cheers,
Adrian

> -----Original Message-----
> From: Loa Andersson [mailto:[email-masked]]
> Sent: 11 May 2013 09:43
> To: [email-masked]
> Cc: <[email-masked]>; [email-masked]; VIGOUREUX, MARTIN
> (MARTIN)
> Subject: MPLS wg charter update
> 
> Working Group,
> 
> .	Maintain existing MPLS requirements, mechanisms, and protocols,
> .	Evolve key MPLS protocols, including LDP, tLDP, mLDP, RSVP-TE
> .	Define an overall OAM framework for topology-driven, traffic
> .	Determine MPLS-specific aspects of traffic engineering for
> .	Define necessary extensions for MPLS key protocols for
> .	Coordinate with the CCAMP working group on the extensions of
>          MPLS and GMPLS protocols
> .	Document current implementation practices for MPLS load sharing.
> .	Document mechanisms for securing MPLS networks in coordination
> .	Document mechanisms for adding multi-topology support to
>          existing MPLS protocols.
> .	Document use cases for MPLS protocols.
>

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Sat, 11 May 2013 23:24:38 +0000

Hi Loa,

Please find two very small questions/comments inline.

Thumb typed by Carlos Pignataro.
Excuze typofraphicak errows

> The current WG work items are:

The text above looks good. A nit: are these "work items" or "focus areas"?

>        dual-stack and IPv6 only networks

In addition to defining extensions, could we add also a "gap analysis" of the IPv6 (dual stack and IPv6 only) state for MPLS key protocols and procedures?

Thanks,

Carlos. 

> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: Loa Andersson <[email-masked]>
Date: Sun, 12 May 2013 09:00:19 +0200

Carlos,

thanks for comments! My personal response too them would be:

1. Work items vs. focus areas.
    Not being a native English speaker I would need a better definition
    of the terms, tentatively I'd say that either would work for me,
    maybe say "work items and focus areas" if that aligns with how
    the  terms are defined.

2. IPv6 gap analysis
    I believe that the IPv6 gap analysis is part of "necessary
    extensions ... for dual stack and IPv6 only"
    The gap analysis will show up as a milestone when we accept
    an ID on that topic as a wg group document.

/Loa

--

---

From: t.petch <[email-masked]>
Date: Thu, 16 May 2013 10:07:51 +0100

---- Original Message -----
From: "Loa Andersson" <[email-masked]>
To: "Carlos Pignataro (cpignata)" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Sunday, May 12, 2013 8:00 AM

Carlos,

<tp>
Loa

I see focus areas as vague and woolly, like soft-focus only different,
useful for management speak that can later be redefined to mean
something different if the need arises:-)

Work items I would see as more specific, having an outcome that is
defined and can be measured eg was an I-D delivered to the IESG by March
2010?

Of the items listed, I think that most are work items but perhaps not

I would prefer those at the end, not the front, which is where I think
that catch-alls belong; and I would make them more action-oriented, such
as

•    Identify new requirements in key MPLS protocols, including but not
limited to LDP, tLDP, mLDP, RSVP-TE and LSP Ping, and define solutions
to meet them

Tom Petch
</tp>

2. IPv6 gap analysis

/Loa

On 2013-05-12 01:24, Carlos Pignataro (cpignata) wrote:
> In addition to defining extensions, could we add also a "gap analysis"
of the IPv6 (dual stack and IPv6 only) state for MPLS key protocols and
procedures?