Subject: Re: [mpls] MPLS-RT review of draft-farbryantrel-mpls-retire-ach-tlv

From: Alexander Vainshtein <[email-masked]>
Date: Sun, 9 Jun 2013 12:53:51 +0000

Jia and all,

I fully agree that the text explaining why ACH TLVs are not needed does not have to be very specific. 

At the same time I am not sure that MEP-ID TLV in RFC 6428 is a strong example for the need of HW processing of TLVs in G-ACH messages.

My 2c,
     Sasha

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Hejia (Jia)
> Sent: Thursday, May 23, 2013 2:52 PM
> To: Loa Andersson; Martin Vigoureux; draft-farbryantrel-mpls-retire-ach-
> [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [mpls] MPLS-RT review of draft-farbryantrel-mpls-retire-ach-tlv
> 
> Hi,
> 
> I noticed a 01 version of draft-farbryantrel-mpls-retire-ach-tlv is available. So I
> based my MPLS RT review on that version. I think the document is coherent,
> useful, technically sound and ready to be adopted as a WG draft. Just one
> comment:
> 
> 1) In the Abstract part, it is written as
> 
>    No Associated Channel Type yet defined uses a TLV. Furthermore, it
>    is believed that handling TLVs in hardware introduces significant
>    problems to the fast-path, and since G-ACh messages are intended to
>    be processed substantially in hardware, the use of TLVs in
>    undesirable.
> 
> The whole paragraph seems talking generally about TLVs for G-ACh messages,
> not specifically an ACH TLV. This might not be so accurate since we have some
> G-ACh channel type using TLVs in its message, e.g. RFC 6428 defines a source
> MEP-ID TLV for the MPLS-TP CV type which also requires hardware processing. I
> think it might be better to simply say ACH TLV is not used and may cause
> additional processing which is not desirable. Or some better wording...
> 
> Thanks!
> 
> 
> B.R.
> Jia
> 
> 
> -----邮件原件-----
> 发件人: Loa Andersson [mailto:[email-masked]]
> 发送时间: 2013年5月8日 16:01
> 收件人: Lizhong Jin; Hejia (Jia); Gregory Mirsky; Eric Osborne (eosborne);
> Martin Vigoureux
> 抄送: [email-masked]; mpls-
> [email-masked]
> 主题: MPLS-RT review of draft-farbryantrel-mpls-retire-ach-tlv
> 
> Jia, Lizhong, Greg and Eric,
> 
> You have been selected as an MPLS Review team reviewers for
> draft-farbryantrel-mpls-retire-ach-tlv-00.
> 
> Note to authors: You have been CC'd on this email so that you can know
> that this review is going on. However, please do not review your own
> document.
> 
> Reviews should comment on whether the document is coherent, is it
> useful (ie, is it likely to be actually useful in operational
> networks), and is the document technically sound?  We are interested
> in knowing whether the document is ready to be considered for WG
> adoption (ie, it doesn't have to be perfect at this point, but should be
> a good start).
> 
> Reviews should be sent to the document authors, WG co-chairs and
> WG secretary, and CC'd to the MPLS WG email list. If necessary, comments
> may be sent privately to only the WG chairs.
> 
> Are you able to review this draft by Mat 24, 2013?
> 
> Thanks, Loa
> (as MPLS WG chair)
> --
> 
> 
> Loa Andersson                        email: [email-masked]
> Senior MPLS Expert                          [email-masked]
> Huawei Technologies (consultant)     phone: +46 739 81 21 64
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: Alexander Vainshtein <[email-masked]>
Date: Sun, 9 Jun 2013 14:28:09 +0000

John,
Lots of thanks for a prompt response.

It fully matches my understanding of the situation, and this is why I've said that the example given by Jia is a strong one.

My 2c,
     Sasha

> From: John E Drake [mailto:[email-masked]]
> Sent: Sunday, June 09, 2013 5:14 PM
> To: Alexander Vainshtein
> Cc: Hejia (Jia); [email-masked];
> [email-masked]; [email-masked]; Loa Andersson
> Actually, the design allows CC to be processed in hardware and CV in software
> while allowing the presence of the *trailing* TLV used in CV to be detected in
> hardware.
> 
> Sent from my iPhone
> 
> On Jun 9, 2013, at 8:54 AM, "Alexander Vainshtein"
> <[email-masked]> wrote:
> 
> > Jia and all,
> >
> > At the same time I am not sure that MEP-ID TLV in RFC 6428 is a strong
> example for the need of HW processing of TLVs in G-ACH messages.
> >
> > My 2c,
> >     Sasha
> >
> > This e-mail message is intended for the recipient only and contains
> information which is CONFIDENTIAL and which may be proprietary to ECI
> Telecom. If you have received this transmission in error, please inform us by e-
> mail, phone or fax, and then delete the original and all copies thereof.
> >