Subject: Re: [mpls] MPLS-RT review of draft-wijnands-mpls-mldp-node-protection-02 and of draft-zhao-mpls-mldp-protections-03

From: IJsbrand Wijnands <[email-masked]>
Date: Fri, 21 Jun 2013 16:40:11 -0700

Hi Martin,

Thanks, these are great comments, see my response inline.

> 
>         In order to protect node N, all the members of the MP2MP must
>   participate in protecting node N by acting both as PLR and MPT LSR.
> 
> Is it really all the members of the MP2MP LSP or only the LDP peers of the root?
> Confusion can come from the fact that figure 2 shows a very simple MP2MP LSP where all members of the LSP are also directly-connected-to-N members

Ice: Yes, good point, its all directly connected LDP peers, I'll update the draft.

> Section 2.3
> s/If the PLR address on N changes for a give MP LSP/If the PLR address on N changes for a given MP LSP/

Ice: Ack.

> Section 3
> s/the PLR would have assign a Label Mapping/the PLR would have assigned a Label Mapping/

Ice: Ack.

> Section 4 and Section 5
> These sections need a bit more work to clarify the procedures and sequence of events, so as to lift potential misunderstandings.
> 
> With regards to the reachability of N. Beginning of Section 4 the text says:
>                    When LSR1 discovered that node N is unreachable, it
>   can't determine whether it is the 'LSR1 - N' link or node N that
>   failed.
> but first paragraph of Section 5 says:
>                                       The procedures following are
>   depending on whether the link 'LSR1 - N' has failed or node N itself.
> The two pieces of text seem contradictory. Information should be given on how (and when?) the distinction could be made.
> 
> Also, with regards to the reachability of N, it should be clarified if it is only considered through the 'LSR1 - N' link or not.
> 
> Also, the two following sentences seem to contradict each other:
>                                                   If only the link
>   failed, LSR2 and LSR3 will receive duplicate packets due to the two
>   protection mechanisms.  To prevent duplicate packets to be forwarded
>   to LSR2 and LSR3, either the primary upstream LSRs or the secondary
>   upstream LSRs should be forwarding MPLS packets, but never both at
>   the same time.
> The first one says that duplicate packets will be received while the second says that duplicate packets should not be received.
> Strictly speaking it seems that duplicate packets will be received by LSR2 and LSR3 but be dropped and that it will be the case until label is withdrawn, and from that point on no duplicate traffic will be received.
> 
> Also, in Section 4 the use of forwarding is somehow misleading. Indeed, rather than which primary or secondary LSR forwards the packets, the point seems to be more about which primary or secondary LSR do the MPTs decide to receive traffic from.

Ice: Great points, I'll update the text to make it more clear.

> 
> 
> Section 5.1 and 5.2
> Similarly to a previous remark, it appears that LSR2 and LSR3 need to be able to make a distinction between 'LSR1 - N' link failure and node N failure. While I understand that both the capability to detect that N is unreachable and the capability to make a distinction between the two types of failures is outside of the scope of the document, I believe that the described procedures strongly depends on this capability.
> If so, I would suggest to add somewhere something like "It MUST be possible to distinguish 'LSR1 - N' link failure from node N failure".

Ice: Its not really the case that either the upstream or downstream nodes need to determine if the link or node failed. The differentiator is really only the reachability between the protected node and the downstream nodes. The procedures on LSR1 (upstream) are the same for link or node failure. Its only the downstream nodes that also need to react of the protected node because unreachable. I'll see if I can make it more clear in the text.

> 
> One could wonder why Section 5.1 and 5.2 are not in Section 4.

Ice: Fixed.

> 
> 
> Section 5.2
> If N is still reachable why does LSR1 invoke the node protection mechanism?

Ice: I think you mis-intepreted, N is reachable from the POV of LSR2 and LSR3.

> More generally, the procedures described in the document are based on the fact that both protection mechanisms are invoked while Section 4 states that is is only a MAY.

Ice: Strictly speaking node protection can be enabled without link protection. So its not a MUST. It makes sense to apply both, otherwise we're not protected if the link between LSR1 and N fails. So the procedures described just try to accommodate both scenarios.

> 
> 
> Section 5.3
>                                         LSR1 will find that M is its
>   new primary upstream LSR to reach the Root and LSR3 will find Q.
> 
> I guess what was meant is:
>                                         LSR2 will find that P is its
>   new primary upstream LSR to reach the Root and LSR3 will find Q.

Ice: Ack.

> 
> Also I tend to think that M should be switched to P in:
>                                      As soon as the new primary
>   upstream LSRs M and Q are activated,
> 

Ice: Ack.

> 
> Section 10.1
> Update reference for draft-napierala-mpls-targeted-mldp

Ice: Ack.

Many thanks,

Ice.

---

From: Martin Vigoureux <[email-masked]>
Date: Mon, 24 Jun 2013 16:13:58 +0200

Ice,

thanks.
I went through rev 3 and 4 and I am ok with the updates.

Cheers,
Martin