Subject: [mpls] Request an early allocation of a UDP port for MPLS-in-UDP encapsulation

From: Ross Callon <[email-masked]>
Date: Fri, 21 Jun 2013 17:28:44 +0000

IANA;

We would like to request an early allocation of a UDP port for MPLS-in-UDP encapsulation, as described in the email below and in the referenced Internet Draft. My understanding of the process is that Adrian needs to approve this as AD for the MPLS WG. 

Thanks, Ross
(as MPLS WG co-chair)

-----Original Message-----
From: Xuxiaohu [mailto:[email-masked]] 
Sent: Friday, June 21, 2013 6:13 AM
To: [email-masked]
Subject: Request an early allocation of an UDP port for MPLS-in-UDP encapsulation

Hi MPLS WG Chairs:

We co-authors of draft-ietf-mpls-in-udp want to ask for an early allocation of an UDP port from the User Ports Range according to RFC4020 and RFC6335 and therefore request the MPLS wg chairs to initiate the procedures for this.

The following is the information for an early allocation:

  Service Name : MPLS-in-UDP
  Transport Protocol(s) : UDP
  Assignee: Xiaohu Xu <[email-masked]>
  Contact : Xiaohu Xu <[email-masked]>
  Description : Encapsulate MPLS packets in UDP tunnels for load balancing purpose.
  Reference : draft-ietf-mpls-in-udp (MPLS wg document)
  Motivation: The motivation and usage of MPLS-in-UDP is described in [draft-ietf-mpls-in-udp]. The reason why using a port number in the Dynamic Ports range is unsuitable is: some applications of MPLS-in-UDP (e.g., PWE3) don't have any mechanism for announcing the dynamic port number. In addition, IP-layer broadcast, multicast, or anycast communication would not be used in the application of MPLS-in-UDP.
  Port Number : a number from the User Ports range

Best regards,
Xiaohu

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 25 Jun 2013 13:26:46 +0100

Ross,

This registry (http://www.iana.org/assignments/service-names-port-numbers)
describes the allocation for User Ports...

| User Ports
| are assigned by IANA using the "IETF Review" process, the "IESG 
| Approval" process, or the "Expert Review" process, as per
| [RFC6335].

There is no provision for early allocation on this registry, but you can apply
for a user port under expert review. That is what you should do if you want a
port before this document becomes an RFC.

Please read RFC 6335 to see what information is required to support the expert
review.

Adrian

> From: Ross Callon [mailto:[email-masked]]
> Sent: 21 June 2013 18:29
> To: [email-masked]; [email-masked]
> Cc: Xuxiaohu; [email-masked]; [email-masked]
> Subject: Request an early allocation of a UDP port for MPLS-in-UDP
encapsulation
> 
> IANA;
> 
> We would like to request an early allocation of a UDP port for MPLS-in-UDP
> encapsulation, as described in the email below and in the referenced Internet
> Draft. My understanding of the process is that Adrian needs to approve this as
AD
> for the MPLS WG.
> We co-authors of draft-ietf-mpls-in-udp want to ask for an early allocation of
an
> UDP port from the User Ports Range according to RFC4020 and RFC6335 and
> therefore request the MPLS wg chairs to initiate the procedures for this.
> 
>   Motivation: The motivation and usage of MPLS-in-UDP is described in
[draft-ietf-
> mpls-in-udp]. The reason why using a port number in the Dynamic Ports range is
> unsuitable is: some applications of MPLS-in-UDP (e.g., PWE3) don't have any
> mechanism for announcing the dynamic port number. In addition, IP-layer
> broadcast, multicast, or anycast communication would not be used in the
> application of MPLS-in-UDP.