Subject: [mpls] Review of draft-hao-mpls-ip-hard-pipe-01

From: "Aissaoui, Mustapha (Mustapha)" <[email-masked]>
Date: Tue, 28 Apr 2015 16:01:10 +0000

Dear all,
I was asked to review this draft which is intended to be handled in the Independent Stream. Below are my comments to the authors. 

Members of this list can also provide comments to the authors. Please copy the Independent Submission Editorial Board at the following address:
[email-masked]

Regards,
Mustapha.
----------------------------
https://tools.ietf.org/html/draft-hao-mpls-ip-hard-pipe-01

1. Overall comment:
This document describes how a guaranteed bandwidth service can be deployed in a MPLS network by partitioning the network resources into two managed layers, referred to as strata. The  guaranteed service layer is referred to as "Hard Pipe" stratum.

The management of the resources and the placement of the MPLS tunnels and services into the  "Hard Pipe" stratum are performed with a management system. Thus the transport and service labels are static but this important information has not been stated upfront in the document. Only in section 6 that MPLS-TP was mentioned. Furthermore, the reference to T-LDP signaled labels in Section 3 adds to the confusion. 

I propose that the Introduction and Scope sections be explicit about the framework used to achieve the "Hard Pipe" stratum, that is by means of a management system and static transport and service labels. 

In fact, I would think the document value would be in describing more details of the framework including configuration aspects, resource and service management including resilience. These aspects have not been sufficiently addressed and the focus was more on how to use MPLS labels to differentiate the two strata.

2. Section 1.1 - Scope:
As part of the second bullet, I cannot find in the document how a router protects the traffic of the "Hard Pipe" stratum if the "Normal IP/MPLS" stratum overbooks a link. Having a separate label for the guaranteed service is not sufficient. The authors should describe if LSP pre-emption and/or QoS markings are used to differentiate the treatment across the strata.

3. Section 3:
If the document objective is to describe the framework used, then this section should begin by explaining the initial configuration performed by the NMS to lay the ground for the building of the two stratums. This includes the partitioning of the links, the assignment of transport and service label ranges in the routers, the overbooking strategy, etc.

Then, you can discuss how a guaranteed service is configured in the network using static transport labels and static service labels. This should cover the placement of the working and backup paths since Section 6 mentions MPLS-TP protection is used.

Next, a description of how the transport LSP and service are monitored for continuity and defects. 

Finally, the behavior when resources are overbooked and what services are pre-empted or degraded should be described.
------------------------------------

---

From: Loa Andersson <[email-masked]>
Date: Wed, 29 Apr 2015 09:21:07 +0200

Mustapha,

in line please.

On 2015-04-28 18:01, Aissaoui, Mustapha (Mustapha) wrote:
> The management of the resources and the placement of the MPLS tunnels and services into the  "Hard Pipe" stratum are performed with a management system. Thus the transport and service labels are static but this important information has not been stated upfront in the document.

Do you have a a definition of "static labels" that we can refer to?

/Loa
Only in section 6 that MPLS-TP was mentioned. Furthermore, the reference 
to T-LDP signaled labels in Section 3 adds to the confusion.

> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: "Aissaoui, Mustapha (Mustapha)" <[email-masked]>
Date: Wed, 29 Apr 2015 17:26:17 +0000

Hi Loa,
By static label, I meant a label which is assigned to a LSP or a PW by configuration and not by a control plane protocol. I believe this is what is being described in this draft but let me know if I am wrong.

Regards,
Mustapha.

> -----Original Message-----
> From: Loa Andersson [mailto:[email-masked]]
> Sent: Wednesday, April 29, 2015 3:21 AM
> To: Aissaoui, Mustapha (Mustapha); [email-masked]
> Cc: Nevil Brownlee
> Subject: Re: [mpls] Review of draft-hao-mpls-ip-hard-pipe-01
> 
> Mustapha,
> 
> in line please.
> 
> > I was asked to review this draft which is intended to be handled in the
> Independent Stream. Below are my comments to the authors.
> >
> > Members of this list can also provide comments to the authors. Please copy the
> Independent Submission Editorial Board at the following address:
> > [email-masked]
> >
> > Regards,
> > Mustapha.
> > This document describes how a guaranteed bandwidth service can be deployed
> in a MPLS network by partitioning the network resources into two managed layers,
> referred to as strata. The  guaranteed service layer is referred to as "Hard Pipe"
> stratum.
> >
> > The management of the resources and the placement of the MPLS tunnels and
> services into the  "Hard Pipe" stratum are performed with a management system.
> Thus the transport and service labels are static but this important information has
> not been stated upfront in the document.
> 
> Only in section 6 that MPLS-TP was mentioned. Furthermore, the reference to T-
> LDP signaled labels in Section 3 adds to the confusion.
> >
> 
> > I propose that the Introduction and Scope sections be explicit about the
> framework used to achieve the "Hard Pipe" stratum, that is by means of a
> management system and static transport and service labels.
> >
> > In fact, I would think the document value would be in describing more details of
> the framework including configuration aspects, resource and service management
> including resilience. These aspects have not been sufficiently addressed and the
> focus was more on how to use MPLS labels to differentiate the two strata.
> >
> > 2. Section 1.1 - Scope:
> > As part of the second bullet, I cannot find in the document how a router protects
> the traffic of the "Hard Pipe" stratum if the "Normal IP/MPLS" stratum overbooks a
> link. Having a separate label for the guaranteed service is not sufficient. The
> authors should describe if LSP pre-emption and/or QoS markings are used to
> differentiate the treatment across the strata.
> >
> > 3. Section 3:
> > If the document objective is to describe the framework used, then this section
> should begin by explaining the initial configuration performed by the NMS to lay
> the ground for the building of the two stratums. This includes the partitioning of the
> links, the assignment of transport and service label ranges in the routers, the
> overbooking strategy, etc.
> >
> > Then, you can discuss how a guaranteed service is configured in the network
> using static transport labels and static service labels. This should cover the
> placement of the working and backup paths since Section 6 mentions MPLS-TP
> protection is used.
> >

---

From: Loa Andersson <[email-masked]>
Date: Thu, 30 Apr 2015 09:41:14 +0200

Mustapha,

That is still not a definition possible to refrence.

I've always been a bit confused by the distinction between "static" and
"dynamic", especially when it comes to labels, a bit less so if we talk
about LSPs.

To me the term  "static" and "dynamic" seems to indicate how long lived
or how easy they are to change.

If an NMS or any centralized controller instal and remove LSPs/labels
with the same frequency as e.g. LDP are they still "static"?

I agree that there is a possible classification of "configured 
LSPs/labels" vs. "signaled LSPs/labels".

In that terminology I'd say that draft-hao-mpls-ip-hard-pipe uses
configured labels.

Would that terminology be acceptable for you?

/Loa

--

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 30 Apr 2015 08:52:03 -0400

Loa,

I think the reference that you're looking for is section 3.11 of RFC 5921.

Cheers,
Andy

On Thu, Apr 30, 2015 at 3:41 AM, Loa Andersson <[email-masked]> wrote:

>> By static label, I meant a label which is assigned to a LSP or a PW by
>> configuration and not by a control plane protocol. I believe this is what
>> is being described in this draft but let me know if I am wrong.
>>
>> Regards,
>> Mustapha.
>>
>>> to T-
>>>> Next, a description of how the transport LSP and service are monitored
>>>> for
>>>>
>>> continuity and defects.
>>>
>>>>
>>>> Finally, the behavior when resources are overbooked and what services
>>>> are pre-
>>>>
>>> empted or degraded should be described.
>>>

---

From: "Aissaoui, Mustapha (Mustapha)" <[email-masked]>
Date: Thu, 30 Apr 2015 13:42:28 +0000

Thanks Andy for the reference. Indeed, I was referring to assignment of initial label and of any subsequent label change of an LSP or a PW by configuration. This is sometimes referred to as “manual” configuration and the LSP or PW is referred to as static.

That definition fits I believe what is being described in draft-hao-mpls-ip-hard-pipe-01 but Loa can confirm.

Regards,
Mustapha.

From: Andrew G. Malis [mailto:[email-masked]]
Sent: Thursday, April 30, 2015 8:52 AM
To: Loa Andersson
Cc: Aissaoui, Mustapha (Mustapha); [email-masked]; Nevil Brownlee
Subject: Re: [mpls] Review of draft-hao-mpls-ip-hard-pipe-01

Loa,

Cheers,
Andy

On Thu, Apr 30, 2015 at 3:41 AM, Loa Andersson <[email-masked]<mailto:[email-masked]>> wrote:
Mustapha,

I agree that there is a possible classification of "configured LSPs/labels" vs. "signaled LSPs/labels".

/Loa

Regards,
Mustapha.
-----Original Message-----
From: Loa Andersson [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, April 29, 2015 3:21 AM
To: Aissaoui, Mustapha (Mustapha); [email-masked]<mailto:[email-masked]>
Cc: Nevil Brownlee
Subject: Re: [mpls] Review of draft-hao-mpls-ip-hard-pipe-01

Mustapha,

in line please.

Members of this list can also provide comments to the authors. Please copy the
Independent Submission Editorial Board at the following address:
[email-masked]<mailto:[email-masked]>

Regards,
Mustapha.

1. Overall comment:

/Loa

2. Section 1.1 - Scope:

3. Section 3:

Next, a description of how the transport LSP and service are monitored for
continuity and defects.

Finally, the behavior when resources are overbooked and what services are pre-
empted or degraded should be described.
------------------------------------

_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls

--

Loa Andersson                        email: [email-masked]<mailto:[email-masked]>
Senior MPLS Expert                          [email-masked]<mailto:[email-masked]>
Huawei Technologies (consultant)     phone: +46 739 81 21 64<tel:%2B46%20739%2081%2021%2064>

--

Loa Andersson                        email: [email-masked]<mailto:[email-masked]>
Senior MPLS Expert                          [email-masked]<mailto:[email-masked]>
Huawei Technologies (consultant)     phone: +46 739 81 21 64<tel:%2B46%20739%2081%2021%2064>

_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls