Subject: [mpls] Need clarification for the draft-cheng-mpls-tp-shared-ring-protection

From: Spencer Jackson <[email-masked]>
Date: Wed, 8 Apr 2015 20:47:17 +0000

Dear authors of draft-cheng-mpls-tp-shared-ring-protection_04,

We plan to implement the protocol and would like to get some clarification for the following questions.

1.       Section 4.3.1.1, in the given example the link failure is bi-directional.  Please clarify if both bi-directional and uni-directional link failures are covered in this draft.

2.       Figure 8.  Please clarify the meaning of I and S under each node.

3.       Section 4.4.4, 4th paragraph, "..... Nodes F and E will detect the failure ...." should be "..... Nodes F and D will detect the failure ....", right?

4.       Section 5.1.3.2. Short and long path needs to be clearly defined.

5.       Throughout the document, only operation of the clockwise working and anti-clockwise protection rings is described. The anti-clockwise working and clockwise protection rings are defined, but their operation is not described. What is the purpose of these additional rings? Is this intended to support steering (i.e. a node should select the clockwise working or anti-clockwise working ring, depending on the distance to the exit node)?

Thanks,
Spence

--

Spence Jackson
Austin Software Center Engineering Manager
PMC-Sierra
Wireless Infrastructure and Networking Division
6850 Austin Center Blvd., Suite 215, Austin, TX 78731
512-345-3808 x113 (Tel)
512-345-3828 (Fax)
512-589-9681 (Mobile)

http://pmcs.com/products/mobile/network_processors/ <http://www.pmc-sierra.com/network-processors/>

This message is sent in confidence for the addressee only. It may contain legally privileged information. The contents are not to be disclosed to anyone other than the addressee. Unauthorized recipients are requested to preserve this confidentiality, advise the sender immediately of any error in transmission and delete the email from their systems.

---

From: Huub van Helvoort <[email-masked]>
Date: Thu, 09 Apr 2015 00:43:27 +0200

Dear Spence,

You wrote:

> We plan to implement the protocol and would like to get some
> clarification for the following questions.

Very good. Please let me try to answer:

> 1.Section 4.3.1.1, in the given example the link failure is
> bi-directional.  Please clarify if both bi-directional and
> uni-directional link failures are covered in this draft.

Indeed, both bidirectional (e.g cable cut) and uni-directional
(e.g. single fiber cut) are covered.
If it is not obvious we will add text.

> 2.Figure 8.  Please clarify the meaning of I and S under each node.

The I and S are in fact indicating the status of the link between
two adjacent nodes. The "I" indicates "intact" the "S" indicates
"severed". In this example the link between nodes C and D is broken.

> 3.Section 4.4.4, 4^th paragraph, “….. Nodes F and E will detect the
> failure ….” should be “….. Nodes F and D will detect the failure ….”,
> right?

Good catch! will be corrected.

> 4.Section 5.1.3.2. Short and long path needs to be clearly defined.

OK, we will add text.

> 5.Throughout the document, only operation of the clockwise working
> and anti-clockwise protection rings is described. The anti-clockwise
> working and clockwise protection rings are defined, but their
> operation is not described. What is the purpose of these additional
> rings? Is this intended to support steering (i.e. a node should
> select the clockwise working or anti-clockwise working ring,
> depending on the distance to the exit node)?

Maybe we should add text to explain that the description is for CW 
working and ACW protection, but applicable in the same way to ACW
working and CW protection.

In general the working path prefers to take the shortest path
(to reduce the propagation delay), for example in Figure 3 the
shortest working path from A to C is clockwise, and the shortest
path from A to E is anti-clockwise.

Also in transport networks the traffic is in general bi-directional,
and co-routed.
This means that in the forward direction traffic may flow clockwise,
and in the reverse direction will consequently flow anti-clockwise.

> Thanks,

You're welcome.

Best regards, Huub.

-- 
*****************************************************************
               请记住，你是独一无二的，就像其他每一个人一样