Subject: [mpls] Seeking WG and chairs feedback on LDP/mLDP Yang doc split [Re: A quick update on LDP/mLDP Yang model (draft-ietf-mpls-ldp-mldp-yang)]

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Tue, 11 Oct 2016 19:07:23 +0000

Hello MPLS WG and WG chairs,

[Refer to our email two weeks ago]

Keeping in view some of the MPLS-RT review comments and the current size of the join document (draft-ietf-mpls-ldp-mldp-yang), we, the authors, are thinking of splitting the LDP/mLDP Yang model into two separate documents - one for LDP and other for mLDP - and would like to get WG and chairs feedback on this.

Please comment/advise accordingly.
Rgds.
-
Kamran
(on behalf of authors)

From: Syed Kamran Raza <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, September 27, 2016 at 1:14 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [mpls] A quick update on LDP/mLDP Yang model (draft-ietf-mpls-ldp-mldp-yang)

Hello MPLS WG and WG chairs,

This email is to give a quick update on the current work being done on  the IETF LDP/mLDP Yang draft (draft-ietf-mpls-ldp-mldp-yang-00).

  *   Multi-vendor team is meeting twice a month to progress on the model:
     *   Cisco, Juniper, Huawei, Ciena, Ericsson, Nokia
  *   The current focus of the team is to:
     *   address remaining MPLS-RT comments
     *   divide the model into "base" and "extended" features
     *   general cleanup
  *   We plan to submit a next revision before next IETF.
  *   We also want to get feedback from WG/chairs on whether it makes sense to divide this large document (which is already > 115 pages) into two separate documents - one covering LDP Yang and other mLDP yang.
     *   We will still keep mLDP model dependent on LDP.
     *   Please advise.

Rgds.
-
Kamran
(on behalf of authors)

---

From: Santosh Esale <[email-masked]>
Date: Wed, 12 Oct 2016 18:08:26 +0000

The present document which is around 115 pages long is only expected to
get bigger as we add more operational states in the upcoming revision. Please
let us know your comments and suggestions.

Thanks,
Santosh (on behalf of authors)
On 10/11/16, 12:07 PM, "mpls on behalf of Kamran Raza (skraza)" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Keeping in view some of the MPLS-RT review comments and the current size of the join document (draft-ietf-mpls-ldp-mldp-yang), we, the authors, are thinking of splitting the LDP/mLDP Yang model into two separate documents – one for LDP and other for mLDP - and would like to get WG and chairs feedback on this.

—
Kamran
(on behalf of authors)

  *   Multi-vendor team is meeting twice a month to progress on the model:
     *   Cisco, Juniper, Huawei, Ciena, Ericsson, Nokia
  *   The current focus of the team is to:
     *   address remaining MPLS-RT comments
     *   divide the model into “base” and “extended” features
     *   general cleanup
  *   We plan to submit a next revision before next IETF.
  *   We also want to get feedback from WG/chairs on whether it makes sense to divide this large document (which is already > 115 pages) into two separate documents – one covering LDP Yang and other mLDP yang.
     *   We will still keep mLDP model dependent on LDP.
     *   Please advise.

Rgds.
—
Kamran
(on behalf of authors)

---

From: Loa Andersson <[email-masked]>
Date: Tue, 18 Oct 2016 20:22:59 +0800

Folks,

One useful piece of information is what the relative size of the to 
documents would be. If we come tp som sort of "equal size" documents
I see no problem splitting the current document.

I would advice adding some info to both documents on the relationship
between the documents.

/Loa

On 2016-10-13 02:08, Santosh Esale wrote:
> On 10/11/16, 12:07 PM, "mpls on behalf of Kamran Raza (skraza)"
> <[email-masked] <mailto:[email-masked]> on behalf of
> [email-masked] <mailto:[email-masked]>> wrote:
>
>     Keeping in view some of the MPLS-RT review comments and the current
>     size of the join document (draft-ietf-mpls-ldp-mldp-yang), we, the
>     authors, are thinking of splitting the LDP/mLDP Yang model into two
>     separate documents – one for LDP and other for mLDP - and would like
>     to get WG and chairs feedback on this.
>
>     From: Syed Kamran Raza <[email-masked] <mailto:[email-masked]>>
>     To: "[email-masked] <mailto:[email-masked]>" <[email-masked]
>     <mailto:[email-masked]>>, "[email-masked]
>     <mailto:[email-masked]>" <[email-masked]
>     <mailto:[email-masked]>>
>     Cc: "[email-masked] <mailto:[email-masked]>"
>     <[email-masked] <mailto:[email-masked]>>,
>     "[email-masked]
>     <mailto:[email-masked]>"
>     <[email-masked]
>     <mailto:[email-masked]>>
>     This email is to give a quick update on the current work being done
>     on  the IETF LDP/mLDP Yang draft (draft-ietf-mpls-ldp-mldp-yang-00).
>
>           o Cisco, Juniper, Huawei, Ciena, Ericsson, Nokia
>           o address remaining MPLS-RT comments
>           o divide the model into “base” and “extended” features
>           o general cleanup
>       * We also want to get feedback from WG/chairs on whether it makes
>         sense to divide this large document (which is already > 115
>         pages) into two separate documents – one covering LDP Yang and
>         other mLDP yang.
>           o We will still keep mLDP model dependent on LDP.
>           o Please advise.
>
>     Rgds.
>     —
>     Kamran
>     (on behalf of authors)
>
>
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Tue, 18 Oct 2016 13:24:00 +0000

Hi Loa,

1. We expect LDP document to be little bigger than mLDP as it sets the
base for both LDP and mLDP.
2. Yes, both documents will be made related where mLDP one being dependent
on LDP document with proper x-ref.

Rgds.
‹
Kamran

On 2016-10-18, 8:22 AM, "Loa Andersson" <[email-masked]> wrote:

>>     separate documents  one for LDP and other for mLDP - and would like
>>     ‹
>>           o divide the model into ³base² and ³extended² features
>>           o general cleanup
>>         pages) into two separate documents  one covering LDP Yang and
>>         other mLDP yang.
>>     ‹

---

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Tue, 18 Oct 2016 19:07:45 +0000

+ Tarek

---

From: "Tarek Saad (tsaad)" <[email-masked]>
Date: Tue, 18 Oct 2016 19:58:45 +0000

Hi Kamran,

Thanks for adding. I also favor the split to two documents that allows the base LDP document to possibly mature/advance faster.
Along the same lines, will you be considering mLDP as a standalone YANG module (e.g. an augmentation of base LDP)?

Regards,
Tarek

On 2016-10-18, 3:07 PM, "Kamran Raza (skraza)" <[email-masked]> wrote:

    + Tarek