Subject: [mpls] MPLS WG LC request for draft-ietf-mpls-sfc-encapsulation-01

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 4 Dec 2018 12:43:34 -0500

MPLS WG and Chairs,

We (the co-authors) have just updated draft-ietf-mpls-sfc-encapsulation to
add additional material to the Security Considerations section.

With this update, we believe that this draft is now ready for MPLS WG last
call.

Given the subject material, I've cc'ed the SFC WG for their information as
well. The SFC WG should also be cc'ed on the WG last call.

Thanks,
Andy (for the authors)

---

From: Loa Andersson <[email-masked]>
Date: Wed, 5 Dec 2018 15:52:14 +0800

Andy, et.al.,

We will do the normal procedue

- wg chair review
- IPR poll
- wglc

I will need a few days to review

/Loa

On 2018-12-05 01:43, Andrew G. Malis wrote:
> MPLS WG and Chairs,
> 
> We (the co-authors) have just updated draft-ietf-mpls-sfc-encapsulation 
> to add additional material to the Security Considerations section.
> 
> With this update, we believe that this draft is now ready for MPLS WG 
> last call.
> 
> Given the subject material, I've cc'ed the SFC WG for their information 
> as well. The SFC WG should also be cc'ed on the WG last call.
> 
> Thanks,
> Andy (for the authors)
> 

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 5 Dec 2018 10:56:39 -0800

I think it would be useful for this document to reference
https://tools.ietf.org/html/draft-ietf-mpls-sfc
in the introduction to say that "using MPLS to replace the function of NSH
is described elsewhere [x]".

I think the following:

the SFF Label will rise to the top of the label stack before
the packet is forwarded to another node and before the packet
is dispatched to a higher layer.

would be better worded as:

"as a part of normal processing, the SFF Label will become

the top label in the stack before the packet is forwarded

to another node and before the packet is dispatched to a higher layer."

Thanks,
Anoop

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 5 Dec 2018 14:14:18 -0500

Anoop,

Thanks, I'll discuss these suggestions with my co-authors. Also, now that
we've requested WG LC, Loa may want to treat this as a last call comment.

Your first comment isn't quite correct, since draft-ietf-mpls-sfc only
replaces some of the functions of the NSH. For example, there's no
packet-by-packet metadata.

Cheers,
Andy

On Wed, Dec 5, 2018 at 1:57 PM Anoop Ghanwani <[email-masked]> wrote:

> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 5 Dec 2018 11:23:58 -0800

Hi Andy,

Yes, I agree my comment wasn't complete.  Perhaps this is better:
"using MPLS as a replacement for NSH (with some loss of functionality) is
described elsewhere [x]."

Also for the second comment, this may be better.

"as a part of normal processing, the SFF Label becomes

the top label in the stack."

Thanks,
Anoop

On Wed, Dec 5, 2018 at 11:14 AM Andrew G. Malis <[email-masked]> wrote:

>> in the introduction to say that "using MPLS to replace the function of
>> NSH is described elsewhere [x]".
>>
>> I think the following:
>> >>>
>>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 5 Dec 2018 14:39:07 -0500

Anoop,

Thanks again, we'll hold these for the next update. BTW, If we add a
reference to draft-ietf-mpls-sfc, then it may also be useful to add a
reference to draft-ietf-mpls-sfc-encapsulation in draft-ietf-mpls-sfc as
well. Since that's already gone to the IESG, that'll have to be an IETF LC
comment.

Cheers,
Andy

---

From: John E Drake <[email-masked]>
Date: Wed, 5 Dec 2018 19:47:03 +0000

Hi,

Comment inline

Yours Irrespectively,

John

From: mpls [mailto:[email-masked]] On Behalf Of Anoop Ghanwani
Sent: Wednesday, December 5, 2018 2:24 PM
To: [email-masked]
Subject: Re: [mpls] comments on draft-ietf-mpls-sfc-encapsulation-01

Hi Andy,

Yes, I agree my comment wasn't complete.  Perhaps this is better:
"using MPLS as a replacement for NSH (with some loss of functionality) is described elsewhere [x]."

[JD]  Using the MPLS label stack rather than the NSH to carry the Service Path Identifier (SPI) and Service Identifier (SI) is described in …

Thanks,
Anoop
On Wed, Dec 5, 2018 at 11:14 AM Andrew G. Malis <[email-masked]<mailto:[email-masked]>> wrote:
Anoop,

Thanks, I'll discuss these suggestions with my co-authors. Also, now that we've requested WG LC, Loa may want to treat this as a last call comment.

Your first comment isn't quite correct, since draft-ietf-mpls-sfc only replaces some of the functions of the NSH. For example, there's no packet-by-packet metadata.

Cheers,
Andy

On Wed, Dec 5, 2018 at 1:57 PM Anoop Ghanwani <[email-masked]<mailto:[email-masked]>> wrote:
I think it would be useful for this document to reference
https://tools.ietf.org/html/draft-ietf-mpls-sfc<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dmpls-2Dsfc&d=DwMFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=GF5N7QRjSUOtBmx2p0R4gvpBoU5Wyz5nwfbCtE_IUgI&s=db-AmKlTRZlCB0iVIkqVVs9ndN2e-Oo08TNef43l9O8&e=>
in the introduction to say that "using MPLS to replace the function of NSH is described elsewhere [x]".

I think the following:

Thanks,
Anoop
_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_mpls&d=DwMFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=GF5N7QRjSUOtBmx2p0R4gvpBoU5Wyz5nwfbCtE_IUgI&s=SjAIyvNitzG1Hl4Yhw8do0D7ABHmIC0VBmEBSNKSINU&e=>

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 5 Dec 2018 12:01:35 -0800

I agree, Andy.

Thanks,
Anoop

On Wed, Dec 5, 2018 at 11:39 AM Andrew G. Malis <[email-masked]> wrote:

>>> Thanks, I'll discuss these suggestions with my co-authors. Also, now
>>> that we've requested WG LC, Loa may want to treat this as a last call
>>> comment.
>>>

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 5 Dec 2018 12:04:45 -0800

Hi John,

It also allows for per-SFP or per-flow metadata.  Just doesn't allow for
per-packet metadata.

Thanks,
Anoop

On Wed, Dec 5, 2018 at 11:47 AM John E Drake <[email-masked]> wrote:

> Hi,
>
>
>
> Comment inline
>
>
>
> Yours Irrespectively,
>
>
>
> John
>
>
>
> *From:* mpls [mailto:[email-masked]] *On Behalf Of *Anoop Ghanwani
> *Sent:* Wednesday, December 5, 2018 2:24 PM
> *To:* [email-masked]
> *Subject:* Re: [mpls] comments on draft-ietf-mpls-sfc-encapsulation-01
>
>
>
> Hi Andy,
>
>
>
> *[JD]  Using the MPLS label stack rather than the NSH to carry the Service
> Path Identifier (SPI) and Service Identifier (SI) is described in …*
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dmpls-2Dsfc&d=DwMFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=GF5N7QRjSUOtBmx2p0R4gvpBoU5Wyz5nwfbCtE_IUgI&s=db-AmKlTRZlCB0iVIkqVVs9ndN2e-Oo08TNef43l9O8&e=>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_mpls&d=DwMFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=GF5N7QRjSUOtBmx2p0R4gvpBoU5Wyz5nwfbCtE_IUgI&s=SjAIyvNitzG1Hl4Yhw8do0D7ABHmIC0VBmEBSNKSINU&e=>
>
>

---

From: John E Drake <[email-masked]>
Date: Wed, 5 Dec 2018 20:24:43 +0000

Hi,

The point was that “(with some loss of functionality)” is a meaningless phrase.

Yours Irrespectively,

John

From: Anoop Ghanwani [mailto:[email-masked]]
Sent: Wednesday, December 5, 2018 3:05 PM
To: John E Drake <[email-masked]>
Cc: [email-masked]
Subject: Re: [mpls] comments on draft-ietf-mpls-sfc-encapsulation-01

Hi John,

It also allows for per-SFP or per-flow metadata.  Just doesn't allow for per-packet metadata.

Thanks,
Anoop

On Wed, Dec 5, 2018 at 11:47 AM John E Drake <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Comment inline

Yours Irrespectively,

John

From: mpls [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Anoop Ghanwani
Sent: Wednesday, December 5, 2018 2:24 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [mpls] comments on draft-ietf-mpls-sfc-encapsulation-01

Hi Andy,

Thanks,
Anoop

Cheers,
Andy

I think the following:

Thanks,
Anoop

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 5 Dec 2018 12:39:44 -0800

John,

How about:
"using MPLS as a replacement for NSH, covering use cases that do not need
per-packet metadata, is described elsewhere [x]."

Thanks,
Anoop

On Wed, Dec 5, 2018 at 12:24 PM John E Drake <[email-masked]> wrote:

> *From:* Anoop Ghanwani [mailto:[email-masked]]
> *Sent:* Wednesday, December 5, 2018 3:05 PM
> *To:* John E Drake <[email-masked]>
> *Cc:* [email-masked]

---

From: John E Drake <[email-masked]>
Date: Wed, 5 Dec 2018 20:45:07 +0000

Fine

Yours Irrespectively,

John

From: Anoop Ghanwani [mailto:[email-masked]]
Sent: Wednesday, December 5, 2018 3:40 PM
To: John E Drake <[email-masked]>
Cc: [email-masked]
Subject: Re: [mpls] comments on draft-ietf-mpls-sfc-encapsulation-01

John,

How about:
"using MPLS as a replacement for NSH, covering use cases that do not need per-packet metadata, is described elsewhere [x]."

Thanks,
Anoop

On Wed, Dec 5, 2018 at 12:24 PM John E Drake <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Yours Irrespectively,

John

From: Anoop Ghanwani [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, December 5, 2018 3:05 PM
To: John E Drake <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [mpls] comments on draft-ietf-mpls-sfc-encapsulation-01

Hi John,

Thanks,
Anoop

Comment inline

Yours Irrespectively,

John

Hi Andy,

Thanks,
Anoop

Cheers,
Andy

I think the following:

Thanks,
Anoop

---

From: Loa Andersson <[email-masked]>
Date: Thu, 6 Dec 2018 08:26:03 +0800

Andy,

Since I will do a chair review and may have comments, there is a chance
to fold this in with my comments. I like to do all possible updates
before we start the wglc, since experience says that the better shape a
document is in the smoother the wglc (or any other review).

/Loa

On 2018-12-06 03:14, Andrew G. Malis wrote:
>     [email-masked] <mailto:[email-masked]>

--