Subject: [mpls] Secdir telechat review of draft-ietf-mpls-lsp-ping-lag-multipath-06

From: Linda Dunbar via Datatracker <[email-masked]>
Date: Fri, 08 Mar 2019 09:21:45 -0800

Reviewer: Linda Dunbar
Review result: Ready

I have reviewed this document as part of the security directorate's ongoing
effort to review all IETF documents being processed by the IESG.  These
comments were written primarily for the benefit of the security area directors.
 Document editors and WG chairs should treat these comments just like any other
last call comments.

The document provides the detailed explanation of SR-MPLS processing in
addition to RFC 8402. Since SR-MPLS are in the trusted domain, it is assumed
that there is no malicious attacks to the nodes for the data plane and control
plane.  RFC8402 already has the good description on the Security Consideration
for both SR-MPLS & SRv6.

Best Regards, 
Linda Dunbar

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 8 Mar 2019 22:45:40 +0000

Need to modify my review comments:

Reviewer: Linda Dunbar
Review result: Ready

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.
 Document editors and WG chairs should treat these comments just like any other last call comments.

The described mechanism for LSP Multipath Ping is very clear.
The authors have added the text to address my comments to the 05 version on why there is no security risks of intermediate LSRs tampering data when the LSP Multipath Ping & response are traversing through. 

Linda Dunbar

-----Original Message-----
From: ietf [mailto:[email-masked]] On Behalf Of Linda Dunbar via Datatracker
Sent: Friday, March 08, 2019 11:22 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Secdir telechat review of draft-ietf-mpls-lsp-ping-lag-multipath-06

Reviewer: Linda Dunbar
Review result: Ready

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.
 Document editors and WG chairs should treat these comments just like any other last call comments.

The document provides the detailed explanation of SR-MPLS processing in addition to RFC 8402. Since SR-MPLS are in the trusted domain, it is assumed that there is no malicious attacks to the nodes for the data plane and control plane.  RFC8402 already has the good description on the Security Consideration for both SR-MPLS & SRv6.

Best Regards,
Linda Dunbar