Subject: [mpls] Updates to draft-gandhi-spring-ioam-sr-mpls

From: "Rakesh Gandhi (rgandhi)" <[email-masked]>
Date: Tue, 21 May 2019 22:49:20 +0000

Hi WG,

We have published an update to the following draft:
https://datatracker.ietf.org/doc/draft-gandhi-spring-ioam-sr-mpls/
draft-gandhi-spring-ioam-sr-mpls defines how IOAM data fields are transported with SR-MPLS encapsulation. The draft has been updated as following:

  1.  Add different methods of IOAM Indicator Label in Section 4.1.
  2.  Add Hashing function in Section 4.2.
  3.  Add Node capability in Section 4.3.
  4.  Cleanup/editorial changes

Welcome your review comments and suggestions.

Thanks,
Rakesh (on behalf of co-authors and contributors)

---

From: Loa Andersson <[email-masked]>
Date: Wed, 22 May 2019 14:40:07 +0800

Rakesh,

A couple of thoughts and questions.

- is it necessary to have three different ways to establish the
   IOAM Indicator Label?
- if it is necessary to use a Special Purpose Label, could you use
   a eSPL instead of a bSPL (for terminology see draft-andersson-mpls-
   spl-terminology)?
- will the label serving as as IOAM Indicator always be a the bottom
   of the stack and have the s-bit set?
- allocating SPL's is a decision that I would want the MPLS working
   group to take, this could be done in one of two ways, either we
   progress in the mpls wg or you split out the IANA allocation in a
   separate document and progress that in the mpls wg.

/Loa

On 2019-05-22 06:49, Rakesh Gandhi (rgandhi) wrote:
> /draft-gandhi-spring-ioam-sr-mpls/ defines how IOAM data fields are 
> transported with SR-MPLS encapsulation. The draft has been updated as 
> following://
> 
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
> 

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: "Rakesh Gandhi (rgandhi)" <[email-masked]>
Date: Fri, 24 May 2019 19:30:28 +0000

Hi Loa,

Thank you for the review comments. Please see inline with <RG>...

On 2019-05-22, 2:40 AM, "Loa Andersson" <[email-masked]> wrote:

    Rakesh,

<RG> There are three options possible, but after some discussions with the WGs, we can pick one or more.

<RG> We can use eSL (e.g. label value 18).

<RG> That may be easier, need to see if there is any complication that can come with it though.

<RG> Ok. At this time, we can keep both WGs in the loop with one document.

Thanks,
Rakesh

    /Loa

    --