Subject: [mpls] Comments on draft-gandhi-spring-ioam-sr-mpls

From: Tarek Saad <[email-masked]>
Date: Mon, 22 Jul 2019 13:41:48 +0000

Hi authors,

>From reviewing this draft, have the following comments:
   The ingress node needs to make sure the IOAM TLV does not start with
   a well known protocol type (e.g. 0x4 for IPv4 and 0x6 for IPv6) and
   does not alter the hashing function that uses the IP header.

How the ingress guarantee it does not alter hashing (on any transit LSR) that uses the IP header with inclusion of IOAM?
Most transit MPLS LSR(s) would do deep packet inspection to read up to the IP header so they do proper loadbalancing, I see introducing the IOAM data after the bottom of stack will have implications on ECMP hashing and may break ECMP..

Regards,
Tarek

---

From: Rakesh Gandhi <[email-masked]>
Date: Mon, 22 Jul 2019 11:19:40 -0400

Hi Tarek,
Thank you for the review of the draft and the comment. We will add some
text in the next revision on how it can be addressed.
Thanks,
Rakesh

On Mon, Jul 22, 2019 at 9:42 AM Tarek Saad <[email-masked]> wrote:

> How the ingress guarantee it does not alter hashing (on any transit LSR)
> that uses the IP header with inclusion of IOAM?
>
> Most transit MPLS LSR(s) would do deep packet inspection to read up to the
> IP header so they do proper loadbalancing, I see introducing the IOAM data
> after the bottom of stack will have implications on ECMP hashing and may
> break ECMP..
>
>
>
> Regards,
>
> Tarek
>
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>