Subject: Re: [mpls] WGLC, IPR and implementation poll for draft-ietf-mpls-mldp-yang-06

From: Tarek Saad <[email-masked]>
Date: Tue, 1 Oct 2019 19:27:34 +0000

This WGLC is now closed.
Authors,

There are comments that were received from Tom related to line length exceptions in the draft. Can those be addressed before we can proceed further?

Regards,
Tarek

From: Tarek Saad <[email-masked]>
Date: Friday, September 13, 2019 at 4:34 PM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: WGLC, IPR and implementation poll for draft-ietf-mpls-mldp-yang-06

Working Group,

This email starts WG Last Call, IPR and implementation poll for draft-ietf-mpls-mldp-yang-06. This WGLC ends on 9/27.
Please review the document and send any comments to the mpls wg mailing list ([email-masked]<mailto:[email-masked]>).

If you’re a co-author/contributor, please explicitly respond to this email and indicate whether or not you are aware of any relevant undisclosed IPR.

If you're not a co-author/contributor, you need to respond only if you are aware of any relevant IPR not yet disclosed in conformance with IETF rules.

Currently there are no disclosed IPRs that can be found here: https://datatracker.ietf.org/ipr/search/?draft=draft-ietf-mpls-mldp-yang&submit=draft&rfc=&doctitle=&group=&holder=&iprtitle=&patent=

We are also polling for any existing implementation.

Regards,
Tarek (for the MPLS WG Chairs)

---

From: tom petch <[email-masked]>
Date: Tue, 8 Oct 2019 12:00:50 +0000

Tarek

Well, yes.  I also commented about

"   [Ed Note: Some of the topics in the above list are to be addressed/
   extended in a later revision of this document]."
and
"8.  Open Items
   A list of open items that are to be addressed in future revisions of
   this document follows:
   o  Specify default values for configuration parameters"

both of which I would see as needing fixing before going further.
Nothing wrong with describing options for future work in an RFC but, as
written, it reads to me as if this I-D needs further work.

And I was hoping for a version where the line length was fixed, making
it easier to read, before submitting other comments.  I did note

s.1.1
/ alongwith  /along with /

s.3
                     +-- rw some_ldp_container
I do not understand this

/ipv4/IPv4/

s.4.2
/mldp/mLDP/

I suggest expand on first use VRF FRR AF

s.5.3.1
/address-familty /address-family /
(or  just AF)

RFC XXXX
stands for both
"Base YANG Data Model for MPLS mLDP"
and
"A YANG Data Model for MPLS LDP"
the first of which does not exist:-)  I suggest using XXXX for this I-D
and YYYY for MPLS LDP

   "         MP capabilities need to be explicitly enabled under
            container capability.";
I am uncertain which container this refers to - I need  a longer path

Tom Petch

----- Original Message -----
From: "Tarek Saad" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; "tom petch"
<[email-masked]>
Sent: Tuesday, October 01, 2019 8:27 PM
Subject: Re: WGLC, IPR and implementation poll for
draft-ietf-mpls-mldp-yang-06

This WGLC is now closed.
Authors,

There are comments that were received from Tom related to line length
exceptions in the draft. Can those be addressed before we can proceed
further?

Regards,
Tarek

From: Tarek Saad <[email-masked]>
Date: Friday, September 13, 2019 at 4:34 PM
To: "[email-masked]"
<[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]"
<[email-masked]>
Subject: WGLC, IPR and implementation poll for
draft-ietf-mpls-mldp-yang-06

Working Group,

This email starts WG Last Call, IPR and implementation poll for
draft-ietf-mpls-mldp-yang-06. This WGLC ends on 9/27.
Please review the document and send any comments to the mpls wg mailing
list ([email-masked]<mailto:[email-masked]>).

If you’re a co-author/contributor, please explicitly respond to this
email and indicate whether or not you are aware of any relevant
undisclosed IPR.

If you're not a co-author/contributor, you need to respond only if you
are aware of any relevant IPR not yet disclosed in conformance with IETF
rules.

Currently there are no disclosed IPRs that can be found here:
https://datatracker.ietf.org/ipr/search/?draft=draft-ietf-mpls-mldp-yang
&submit=draft&rfc=&doctitle=&group=&holder=&iprtitle=&patent=

Regards,

---

From: Tarek Saad <[email-masked]>
Date: Sat, 12 Oct 2019 17:35:27 +0000

Thanks Tom.

Authors, please look into those comments and update back. 
We will progress the draft once we have those addressed.

Regards,
Tarek

On 10/8/19, 8:00 AM, "tom petch" <[email-masked]> wrote:

    Tarek

    

    s.1.1
    
    s.3
    
    /ipv4/IPv4/
    
    s.4.2
    /mldp/mLDP/

    s.5.3.1

    RFC XXXX
    stands for both

    Tom Petch
    
    ----- Original Message -----
    From: "Tarek Saad" <[email-masked]>
    To: <[email-masked]>
    Cc: <[email-masked]>; <[email-masked]>; "tom petch"
    <[email-masked]>
    Sent: Tuesday, October 01, 2019 8:27 PM
    Subject: Re: WGLC, IPR and implementation poll for
    draft-ietf-mpls-mldp-yang-06

    This WGLC is now closed.
    Authors,

    Regards,
    Tarek

    Working Group,

    

    
    Regards,