Subject: Re: [mpls] MPLS wglc draft-ietf-mpls-base-yang

From: Rakesh Gandhi <[email-masked]>
Date: Thu, 2 Jan 2020 12:37:25 -0500

Hi Loa, WG,
As a co-author of this document, I believe this document is ready for
publication.

Thanks,
Rakesh

On Thu, Dec 19, 2019 at 5:22 AM Loa Andersson <[email-masked]> wrote:

> Working Group,
>
> This is to initiate a "two week" working group last call on
> draft-ietf-mpls-base-yang.
>
> Mote: We are allowing for the holiday season and intend to close the
> wglc on Friday January 10, 2020.
>
> Please send your comments to the mpls wg mailing list ([email-masked]).
>
> There are no IPR disclosures against draft-ietf-mpls-rmr.
>
> Both the authors and the contributors have stated on the working group
> mailing list that they are unaware of any non-disclosed IPRs that
> relates to this document.
>
> This working group last call ends Friday January 10, 2020.
>
> /Loa
> mpls wg co-chair
> --
>
>
> Loa Andersson                        email: [email-masked]
> Senior MPLS Expert
> Bronze Dragon Consulting             phone: +46 739 81 21 64
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: Tarek Saad <[email-masked]>
Date: Thu, 2 Jan 2020 18:12:06 +0000

Hi Loa/WG,

As co-author, I have reviewed this document and support its publication.

Regards,
Tarek

On 12/19/19, 5:22 AM, "Loa Andersson" <[email-masked]> wrote:

    Working Group,

    

    
    
    /Loa
    mpls wg co-chair
    --

---

From: Tarek Saad <[email-masked]>
Date: Thu, 2 Jan 2020 18:13:17 +0000

Hi Acee,

Thanks for the feedback. We will consider addressing those in the next revision.

Regards,
Tarek (for co-authors)

On 12/21/19, 2:14 PM, "Acee Lindem (acee)" <[email-masked]> wrote:

    Hi Loa, 
    
    I have rereviewed the draft and support publication. As a co-author of RFC 8349, I feel the augments are correct and straightforward. I have a couple nit-level comments.
    
       1. Since "loadshare" is not a well know compound word, I'd recommend replacing with "load-share". 
       2. Replace all instance of  "e.g. " with "e.g., ". 
    
    Thanks,
    Acee
    
    On 12/19/19, 3:22 AM, "mpls on behalf of Loa Andersson" <[email-masked] on behalf of [email-masked]> wrote:
    
        Working Group,

        

        
        
        /Loa
        mpls wg co-chair
        -- 

        _______________________________________________
        mpls mailing list
        [email-masked]
        https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/mpls__;!!NEt6yMaO-gk!VGKQgtKqVHiI1zGP-G9uMvo4t03TRLcKuDU34-dd4EdteUIIpacmZGXQQcRxUA$

---

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Tue, 7 Jan 2020 16:06:37 +0000

As a co-author, I support its publication too.

On 2020-01-02, 1:12 PM, "Tarek Saad" <[email-masked]> wrote:

    Hi Loa/WG,

    Regards,
    Tarek

        Working Group,

        

        
        
        /Loa
        mpls wg co-chair
        --

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Tue, 7 Jan 2020 10:32:20 -0600

I have reviewed the latest version of the draft -- looks ready to progress
to the next stage.

Regards,
-Pavan

---

From: tom petch <[email-masked]>
Date: Wed, 15 Jan 2020 14:17:27 +0000

Loa

I Mote that there are no IPR disclosures against  draft-ietf-mpls-rmr.

Would that also be true of draft-mpls-base yang :=)

Tom Petch

________________________________________
From: mpls <[email-masked]> on behalf of Loa Andersson <[email-masked]>
Sent: 19 December 2019 10:22
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [mpls] MPLS wglc draft-ietf-mpls-base-yang

Working Group,

/Loa
mpls wg co-chair
--

---

From: tom petch <[email-masked]>
Date: Tue, 21 Jan 2020 12:38:32 +0000

Some more technical thoughts on this I-D

Abstract

LSP is not in the RFC Editor list of 'so well known ...'

s.2.1
   The other MPLS route(s) that are non-IP prefix routes are modelled by
   introducing a new "mpls" address-family RIB as per recommendation .
Where is that?

s.2.2
   interfaces-mpls:
      A YANG grouping that describes the list of MPLS enabled interfaces
      on a device.

   label-blocks:
      A YANG grouping that describes the list of MPLS enabled interfaces
      on a device.

um?

YANG Module
     Copyright (c) 2018 IETF Trust

    leaf loadshare {
I  would  value a reference for this.

  grouping interface-mpls-properties {
...
      type boolean;
      description
       "'true' if mpls encapsulation is enabled on the interface.
       'false' if mpls encapsulation is enabled  on the interface.";

    leaf mtu {  type uint32; description
        "MPLS Maximum Transmission Unit (MTU) in bytes";

um what is included in MTU here  c.f.draft-ietf-netmod-intf-ext-yang-07
which  includes L2 header but not FCS in Layer 2 MTU;
a reference might help

  grouping interfaces-mpls {    description "List of MPLS interfaces";
    list interface {   key "name";  description "List of MPLS
interfaces";
      leaf name {   type if:interface-ref;
        description   "The name of a configured MPLS interface";

no conditional so every RIP or dial up X.25 e.g.is going to get this:-( probably ok

  augment "/rt:routing" {
ditto, although probably less significant

  augment "/rt:routing/rt:ribs/rt:rib/rt:routes/rt:route/"
        + "rt:next-hop/rt:next-hop-options/rt:simple-next-hop" {
    description
      "Augment 'simple-next-hop' case in IP unicast routes.";

other I-D augment control plane/protocols/static-routes

Tom Petch

________________________________________
From: mpls <[email-masked]> on behalf of tom petch <[email-masked]>
Sent: 15 January 2020 14:17
To: Loa Andersson; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [mpls] MPLS wglc draft-ietf-mpls-base-yang

---

From: Loa Andersson <[email-masked]>
Date: Sun, 26 Jan 2020 11:53:00 +0800

Working Group,

I have been holding this wglc open two weeks longer than I
intended. I had an off-line mail asking for more time, but since
the time is up and I haven't heard anything based on that request
it is time to close.

This working group last call is closed.

There have been comments, the authors should address the comments
and work with the reviewers so they are comfortable with how we
handle the comment. Post a new version as necessary.

/Loa
MPLS WG Co-chair

--

---

From: Loa Andersson <[email-masked]>
Date: Sun, 26 Jan 2020 11:58:35 +0800

Tom,

Thanks for cataching this, yes it is true that there are no IPR
disclosures against  draft-mpls-base yang.

I have now closed ths wglc, since there were no IPR disclosures
against this document I don't think ot had an impact.

/Loa

--