Subject: [multipathtcp] Nits on draft-ietf-mptcp-multiaddressed-04

From: Anumita Biswas <[email-masked]>
Date: Wed, 26 Oct 2011 13:35:29 -0700

Hi,

It may be good to clarify these 2 points regarding connection initiation further in the spec:

1. When the first subflow is created, the 4th octet that conveys the 'C' and the 'S' bits is sent on all 3 packets of the 3-way handshake. That is, S must be set on all 3 packets until the use of a new crypto algorithm is declared in a future spec. For the 'C' bit, the spec states that if 'C' is set on any of the 2 SYNs then checksumming must be mandatorily used. The spec should also clarify what the value of the bit should be in the ACK of the 3-way handshake. If it is 1 on any of the SYNs, then perhaps the 'C' bit on the ACK should be 1 too, else 0. 

2. The spec says that the server receiving the ACK of the 3-way handshake MUST respond with an ACK to ensure reliable delivery of the ACK conveying both client & server keys. The spec should also clarify what the client should do while waiting for this ACK. Typical clients will have data to send and may typically want to fire off data before waiting for the server ACK that completes the multi path TCP connection initiation. So, the spec should either say that the clients should hold off sending any data till the ACK arrives, or assume non-mp tcp flow for the first round trip until the ACK from the server arrives. In fact, it's probably important for the client to hold off sending data, because an ACK sent by the server after it receives data is cumulative and does not indicate if the pure ACK of the 3-way handshake was received or not.

thanks,
Anumita.

---

From: Costin Raiciu <[email-masked]>
Date: Fri, 28 Oct 2011 09:00:12 +0100

Dear Anumita,

Thanks a lot for your insightful comments. We are taking them into account as we are revising the spec.
Costin

On 26 Oct 2011, at 21:35, Anumita Biswas wrote:

> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp