Subject: Re: [multipathtcp] REMINDER: WG Last call for Multipath TCP API doc

From: <[email-masked]>
Date: Thu, 1 Mar 2012 11:01:16 +0000

Hi,
This doc has successfully passed WGLC. Thanks to everyone!
Michael, Alan - please can you confirm that v04 deals with all the issues raised. Yoshifumi and I will start the process of pushing it into the IESG

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 23 February 2012 14:37
To: [email-masked]
Subject: [multipathtcp] REMINDER: WG Last call for Multipath TCP API doc

Thanks for your comments so far on this. just a reminder that we're now in the final week for the WGLC
The comments so far have already been addressed in a slightly revised v-04 on 16th Feb, http://tools.ietf.org/html/draft-ietf-mptcp-api

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 03 February 2012 13:27
To: [email-masked]
Subject: [multipathtcp] WG Last call for Multipath TCP API doc

This is to announce the WG last call for "MPTCP Application Interface Considerations" http://tools.ietf.org/html/draft-ietf-mptcp-api-03

Since we are WG last calling the protocol doc as well, we will run until the end of Feb (Wed 29th).
Please send comments to the list

The purpose of a WGLC is to provide a final check that the WG has rough consensus to advance the document:
- The WG believes that this document is technically sound
- The WG believes that this document is useful
- The WG believes that this document is ready to go to the IESG

Please reply with positive support, as well as any comments /questions

Thanks
Phil & Yoshifumi

--

Abstract

   Multipath TCP (MPTCP) adds the capability of using multiple paths to
   a regular TCP session.  Even though it is designed to be totally
   backward compatible to applications, the data transport differs
   compared to regular TCP, and there are several additional degrees of
   freedom that applications may wish to exploit.  This document
   summarizes the impact that MPTCP may have on applications, such as
   changes in performance.  Furthermore, it discusses compatibility
   issues of MPTCP in combination with non-MPTCP-aware applications.
   Finally, the document describes a basic application interface for
   MPTCP-aware applications that provides access to multipath address
   information and a level of control equivalent to regular TCP.

---

From: "SCHARF, Michael" <[email-masked]>
Date: Thu, 1 Mar 2012 12:42:29 +0100

Hi Phil,

v04 addresses all comments raised during the WGLC:

- Security considerations (John)
- Binding to specific addresses  (John)
- Path differentiation vs. security (Joe/Scott)

Thus, I am not aware of anything that is missing.

Michael

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Thursday, March 01, 2012 12:01 PM
> Subject: Re: [multipathtcp] REMINDER: WG Last call for 
> Multipath TCP API doc
> 
> Hi,
> 
> Michael, Alan - please can you confirm that v04 deals with 
> all the issues raised. Yoshifumi and I will start the process 
> of pushing it into the IESG
> 
>  
> 
>  
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> The comments so far have already been addressed in a slightly 
> revised v-04 on 16th Feb, 
> http://tools.ietf.org/html/draft-ietf-mptcp-api 
> 
>  
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> This is to announce the WG last call for "MPTCP Application 
> Interface Considerations" 
> http://tools.ietf.org/html/draft-ietf-mptcp-api-03 
> 
>  
> 
> Since we are WG last calling the protocol doc as well, we 
> will run until the end of Feb (Wed 29th). 
> 
> The purpose of a WGLC is to provide a final check that the WG 
> has rough consensus to advance the document:
>