Subject: [multipathtcp] Congestion control work

From: <[email-masked]>
Date: Mon, 5 Aug 2013 16:54:06 +0100

I wanted to let you know that Ramin Khalili and I met with Martin Stiemerling, our AD.

Ramin has been working on a new coupled congestion control algorithm, which he presented in ICCRG this time (and MPTCP in Orlando).

Our current charter doesn't include work on coupled congestion control - the main item is to progress the protocol doc on the standards track. In order to keep the WG focus on our main aim, we won't add congestion control work at this time. We'll review this in about 6 months, to see if we've made enough progress to think about re-chartering.

In the meantime, Ramin will revise his drafts [from http://datatracker.ietf.org/wg/mptcp/] and of course would welcome reviews.

Best wishes
phil

---

From: Scott Brim <[email-masked]>
Date: Mon, 05 Aug 2013 16:41:44 -0400

On 08/05/13 11:54, [email-masked] allegedly wrote:
> Our current charter doesn’t include work on coupled congestion control –
> the main item is to progress the protocol doc on the standards track. In
> order to keep the WG focus on our main aim, we won’t add congestion
> control work at this time. We’ll review this in about 6 months, to see
> if we’ve made enough progress to think about re-chartering.

Phil, I'm a little surprised.  Since imho the main issue in making MPTCP
work was getting the coupled congestion control working, why is
improving it out of scope?

swb

---

From: Yoshifumi Nishida <[email-masked]>
Date: Mon, 5 Aug 2013 15:19:41 -0700

Hi Scott,

There's no big reason. It's just because we didn't see much energy for
it in the WG when we discussed re-chartering.
We brought it up several times during the discussion, but we didn't
see strong support for it.
I (personally) agree with you this is an important point.

Thanks,
--
Yoshifumi

On Mon, Aug 5, 2013 at 1:41 PM, Scott Brim <[email-masked]> wrote:
> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp

---

From: Scott Brim <[email-masked]>
Date: Tue, 6 Aug 2013 05:43:01 -0400

> I (personally) agree with you this is an important point.

OK.  Understood.  Thanks.