Subject: [multipathtcp] Discussion on Jordan's presentation

From: <[email-masked]>
Date: Fri, 14 Nov 2014 23:14:22 +0000

Interesting discussion just now.
I think it's very worthwhile for an eventual WG doc to capture (briefly) potential MPTCP-middlebox solutions that have problems - such as the one Lars and Jordan were discussing about hindering long-term deployment of mptcp. 

as the charter puts it "what proxy approach might be justified as compared against alternative solutions to the problems"

phil

---

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 14 Nov 2014 23:24:45 +0000

Hi,

> I think it's very worthwhile for an eventual WG doc to capture (briefly) potential MPTCP-middlebox solutions that have problems - such as the one Lars and Jordan were discussing about hindering lon…

you won't be surprised to hear me agree with you :-)

If the WG is to work on proxies, it's IMO a hard requirement that any proxying approach we do does not prevent the end-to-end use of MPTCP under any conditions (e.g., when subflows don't all go via the proxy or some move away from the proxy during their lifetime.)

Lars