Subject: [multipathtcp] FW: IETF hackathon

From: <[email-masked]>
Date: Sun, 17 May 2015 10:13:06 +0000

Anyone want to join the IETF Prague hackathon with some MPTCP related work?
________________________________________
From: WGChairs <[email-masked]> on behalf of Jari Arkko <[email-masked]>
Sent: 17 May 2015 10:17
To: IETF WG Chairs
Subject: IETF hackathon

Chairs,

I wanted to highlight that in Prague we will have a hackathon event:

http://www.ietf.org/blog/2015/05/ietf-hackathon/

Some of your working groups might have participants working actively on software who might benefit from some time together. Or could implement a small enhancement during the weekend. An opportunity for your consideration.

Jari

---

From: Olivier Bonaventure <[email-masked]>
Date: Tue, 19 May 2015 09:56:29 +0200

Phil,

> Anyone want to join the IETF Prague hackathon with some MPTCP related work?

If there are some members of the list who would be interested in working 
with us on the Multipath TCP implementation in the Linux kernel or 
related tools like mptcptrace or tracebox, we could organise something 
in Prague.

We are ready to come to Prague if we are not the only ones working on 
Multipath TCP related stuff there.

Olivier

> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp
> .
>

-- 
INL, ICTEAM, UCLouvain, Belgium, http://inl.info.ucl.ac.be

---

From: Costin Raiciu <[email-masked]>
Date: Tue, 19 May 2015 12:49:58 +0300

We could organize a hackathon to kickstart a larger scale (crowd-sourced) mobility experiment at the IETF. 

The basis for this would be our MultiWifi work published in this year’s NSDI paper (https://www.usenix.org/conference/nsdi15/technical-sessions/presentation/croitoru) 
that proposes that all mobile clients should connect to all Access Points they see and spread traffic over them with Multipath TCP. 

In this way, mobility is seamless, and no fast handover is needed when switching APs.

At the hackathon we will:
- make  our current implementation available to participants, e.g. via bootable usb sticks.
- write scripts to enable multiwifi to work in the IETF network seamlessly
- write monitoring software to test the performance of multiwifi as it is used around the IETF venue, in particular the number of connections, their performance, instantaneous throughput, etc.
- improve different parts of the code to cope with channel switching, etc.

The plan is then to assemble the data we have and show some of it during the MPTCP slot, together with a presentation of the design of multiwif.

Would people find this useful?
Costin

> On 19 May 2015, at 10:56, Olivier Bonaventure <[email-masked]> wrote:
> 
> Phil,
> 
> If there are some members of the list who would be interested in working with us on the Multipath TCP implementation in the Linux kernel or related tools like mptcptrace or tracebox, we could organise something in Prague.
> 
> We are ready to come to Prague if we are not the only ones working on Multipath TCP related stuff there.
> 
> 
> Olivier
> 
>

---

From: Thomas Dreibholz <[email-masked]>
Date: Tue, 26 May 2015 14:42 +0200

Hi,

> related tools like mptcptrace or tracebox, we could organise something 

This is a great idea!

I will be in Prague as well and can provide interested people access to the NorNet Core infrastructure. I have ~100 nodes with a pre-installed Linux MPTCP kernel, and I could further instantiate some full VMs with Linux and FreeBSD 10.1 for running modified MPTCP kernel versions. The NorNet Core systems are distributed at ca. 20 sites, most of them with IPv4/IPv6 multi-homing and many of the sites also have multiple independent ISPs. A list of the sites is provided at https://www.nntb.no/pub/nornet-configuration/NorNetCore-Sites.html . I think this is can be an interesting and challenging setup for some real-world MPTCP tests.

More details on NorNet Core are provided on the project website at https://www.nntb.no/ .

-- 
Best regards / Mit freundlichen Grüßen / Med vennlig hilsen

=======================================================================
 Thomas Dreibholz

 Simula Research Laboratory
 Simula Innovation AS, Network Systems Group
 Visiting address: Martin Linges vei 17, 1364 Fornebu, Norway
 Mailing address:  P.O.Box 134, 1325 Lysaker, Norway
-----------------------------------------------------------------------
 E-Mail:     [email-masked]
 Homepage:   http://simula.no/people/dreibh
=======================================================================