Subject: [multipathtcp] MPTCP Simulation

From: Vikas Raunak <[email-masked]>
Date: Thu, 29 Oct 2015 21:53:20 +1000

Hi

I am working on MPTCP using the ns-3 simulator
<https://hal.archives-ouvertes.fr/hal-00641539/document>. I have a very
important observation.

Please consider the attached figure. In this, the congestion window of
faster delay subflow (subflow 0) is reduced under Round Robin scheduling.

The simulator repeatedly halves the congestion window of the faster
subflow. Why is it happening ? As per MPTCP specifications this should not
happen.

Could you explain this observation. I have tried to seek the explanation
from a lot of people and yet, I have no answer.

Thanks a lot for your help.
Regards
Vikas

---

From: Martin Becke <[email-masked]>
Date: Sat, 31 Oct 2015 18:29:44 +0100

Hi, 

i created a simulation in omen++/inet  for several months. 
I had the same observation in some scenarios with short FIFO Queues. 
Here the behavior was caused by a short FIFO queue and a huge difference in the BDP (for example on connecting routers). 
Have you more information about your queue status and the BDP of both paths?
I was not able to reproduce this effect in a real testbed. 

Best,

Martin
 
> Am 29.10.2015 um 12:53 schrieb Vikas Raunak <[email-masked]>:
> 
> Hi
> 
> I am working on MPTCP using the ns-3 simulator <https://hal.archives-ouvertes.fr/hal-00641539/document>. I have a very important observation.
> 
> Please consider the attached figure. In this, the congestion window of faster delay subflow (subflow 0) is reduced under Round Robin scheduling.
> 
> The simulator repeatedly halves the congestion window of the faster subflow. Why is it happening ? As per MPTCP specifications this should not happen.
> 
> Could you explain this observation. I have tried to seek the explanation from a lot of people and yet, I have no answer.
> 
> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp