Subject: [multipathtcp] [Technical Errata Reported] RFC7430 (4565)

From: RFC Errata System <[email-masked]>
Date: Mon, 14 Dec 2015 07:45:27 -0800 (PST)

The following errata report has been submitted for RFC7430,
"Analysis of Residual Threats and Possible Fixes for Multipath TCP (MPTCP)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7430&eid=4565

--------------------------------------
Type: Technical
Reported by: Fabrizio Demaria <[email-masked]>

Section: 6

Original Text
-------------
   Summary of the attack:

      Type of attack: An attacker that can intercept the SYN/JOIN
      message can alter the source address being added.

      Type of attacker: partial-time on-path eavesdropper

   Description:

   The attacker is present along the path when the SYN/JOIN exchange
   takes place.  This allows the attacker to add any new address it
   wants to by simply substituting the source address of the SYN/JOIN
   packet for one it chooses.  This vulnerability was readily identified
   when designing the MPTCP security solution [RFC6181], and the threat
   was considered acceptable.

Corrected Text
--------------
   Summary of the attack:

      Type of attack: An attacker that can intercept the SYN/JOIN
      message can alter the source address being added.

      Type of attacker: partial-time on-path active attacker

   Description:

   The attacker is present along the path when the SYN/JOIN exchange
   takes place.  This allows the attacker to add any new address it
   wants to by simply substituting the source address of the SYN/JOIN
   packet for one it chooses.  This vulnerability was readily identified
   when designing the MPTCP security solution [RFC6181], and the threat
   was considered acceptable.

Notes
-----
As noted in section 1, an active attacker is able to change, discard, or delay some of the packets of the MPTCP session. This coincide with the description of the SYN/JOIN attack in section 6.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7430 (draft-ietf-mptcp-attacks-04)
--------------------------------------
Title               : Analysis of Residual Threats and Possible Fixes for Multipath TCP (MPTCP)
Publication Date    : July 2015
Author(s)           : M. Bagnulo, C. Paasch, F. Gont, O. Bonaventure, C. Raiciu
Category            : INFORMATIONAL
Source              : Multipath TCP
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: "Zeeshan Afzal" <[email-masked]>
Date: Tue, 15 Dec 2015 14:07:14 +0100

Hi all,

After seeing the errata report, I observed something in Section 3 (DoS 
Attack on MP_JOIN). 

Current text:

The attacker needs to know the token TB in order to perform the
described attack.  This can be achieved if it is a partial-time on-
path eavesdropper observing the 3-way handshake of the establishment
of an additional subflow between Host A and Host B.  If the attacker
is never on-path, it has to guess the 32-bit token.

Can't the attacker instead eavesdrop on the keys exchanged in the initial 
connection establishment handshake and then generate the same token?  
Eavesdropping on the subflow establishment handshake is not the only way to 
know the token I guess. I am not sure if it needs to be clarified though.

Zeeshan

-----Original Message-----
From: RFC Errata System <[email-masked]>
To: [email-masked], [email-masked], [email-masked], 
[email-masked], [email-masked], 
[email-masked], [email-masked], [email-masked], 
[email-masked]
Cc: [email-masked], [email-masked]
Date: Mon, 14 Dec 2015 07:45:27 -0800 (PST)
Subject: [multipathtcp] [Technical Errata Reported] RFC7430 (4565)

Section: 6

Original Text
-------------
   Summary of the attack:

   Description:

Corrected Text
--------------
   Summary of the attack:

   Description:

Notes
-----
As noted in section 1, an active attacker is able to change, discard, or 
delay some of the packets of the MPTCP session. This coincide with the 
description of the SYN/JOIN attack in section 6.

Instructions:
-------------

--------------------------------------
RFC7430 (draft-ietf-mptcp-attacks-04)
--------------------------------------
Title               : Analysis of Residual Threats and Possible Fixes for 
Multipath TCP (MPTCP)
Publication Date    : July 2015
Author(s)           : M. Bagnulo, C. Paasch, F. Gont, O. Bonaventure, C. 
Raiciu
Category            : INFORMATIONAL
Source              : Multipath TCP
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

_______________________________________________
multipathtcp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/multipathtcp

---

From: Christoph Paasch <[email-masked]>
Date: Tue, 15 Dec 2015 16:58:19 -0800

Hello,

> know the token I guess. I am not sure if it needs to be clarified though.

I think this would rather be the "Eavesdropper in the Initial
Handshake"-attack. As the attacker's possibilities to do harm are much higher
here, I don't think that we should combine this with the DoS Attack on
MP_JOIN.

Christoph