Subject: [multipathtcp] MPTCP Usage for VPN hub.

From: "rightkicktech.gmail.com" <[email-masked]>
Date: Tue, 01 Dec 2015 01:38:03 +0200

Hi All,

I've been searching on ways to aggregate bandwidth of multiple WAN links and the mptcp project struck me as an interesting way to share TCP traffic between links.

I've followed the intructions from the site and I was able to generate subflows on multiple WAN interfaces when reaching iperf server multipath-tcp.org. Im not able though to generate the same multipath flows when testing with my server using iperf. I've installed the mptcp enabled kernel on debian wheezy by installing the linux-mptcp package from the repo, both on the server and the client side, as mentioned on the site. Am I missing sth? The end goal is to use the server as the a mptcp proxy, to proxy and forward all mptcp traffic to plain tcp. The mptcp teaffic will be generated from a remote location, which has its own mptcp enabled router (debian wheezy with linux-mptcp installed) which will terminate to the server with at least two vpn tunnels. The server then, having a fast wan connection, will route the traffic to final destination with plain tcp, then back again with mptcp.

Any ideas or hints will be appreciated.
Alex

---

From: Yoshifumi Nishida <[email-masked]>
Date: Fri, 4 Dec 2015 10:41:33 -0800

Hi Alex,

I think what you're trying to do is a reasonable use case for mptcp.
Have you checked linux mptcp developer list? It seems that this is
linux related to stuff rather than protocol spec.
If not, please check  https://listes-2.sipr.ucl.ac.be/sympa/info/mptcp-dev

Thanks,
--
Yoshi

On Mon, Nov 30, 2015 at 3:38 PM, rightkicktech.gmail.com
<[email-masked]> wrote:
> Hi All,
>
> I've been searching on ways to aggregate bandwidth of multiple WAN links and
> the mptcp project struck me as an interesting way to share TCP traffic
> between links.
>
> I've followed the intructions from the site and I was able to generate
> subflows on multiple WAN interfaces when reaching iperf server
> multipath-tcp.org. Im not able though to generate the same multipath flows
> when testing with my server using iperf. I've installed the mptcp enabled
> kernel on debian wheezy by installing the linux-mptcp package from the repo,
> both on the server and the client side, as mentioned on the site. Am I
> missing sth? The end goal is to use the server as the a mptcp proxy, to
> proxy and forward all mptcp traffic to plain tcp. The mptcp teaffic will be
> generated from a remote location, which has its own mptcp enabled router
> (debian wheezy with linux-mptcp installed) which will terminate to the
> server with at least two vpn tunnels. The server then, having a fast wan
> connection, will route the traffic to final destination with plain tcp, then
> back again with mptcp.
>
> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp
>

---

From: Olivier Bonaventure <[email-masked]>
Date: Fri, 4 Dec 2015 19:50:18 +0100

Alex, Yoshifumi
> If not, please check  https://listes-2.sipr.ucl.ac.be/sympa/info/mptcp-dev

I also suggest to move this discussion to the mptcp-dev mailing list.
>> Any ideas or hints will be appreciated.

Some people have reported to use OpenVPN in TCP mode for this use case. 
Others have deployed SOCKS based solutions for this use case. The 
OverTheBox solution that is being developed by OVH relies on encrypted 
SOCKS tunnels to aggregate DSL links. This is probably very close to 
what you have in mind. The client side of their solution is open-source 
and builds upon OpenWrt, see https://github.com/ovh/overthebox-openwrt
for the current source. This version runs on x86 servers and there is 
documentation in French on https://www.ovhtelecom.fr/overthebox/
I don't think that they have released the server side of this service.

Olivier

---

From: "rightkicktech.gmail.com" <[email-masked]>
Date: Sat, 05 Dec 2015 03:40:06 +0200

Thanx Olivier and Yoshifumi,

I will divert the thread to dev list.
It will be very interesting to discuss further on this topic.

Cheers,
Alex

On December 4, 2015 8:50:18 PM EET, Olivier Bonaventure <[email-masked]> wrote:
>> If not, please check 
>https://listes-2.sipr.ucl.ac.be/sympa/info/mptcp-dev
>

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.