Subject: Re: [multipathtcp] Consensus call on potential MPTCP proxy work

From: <[email-masked]>
Date: Wed, 19 Apr 2017 06:00:12 +0000

Hi,

We support that work and have put forward some time ago what the use case and problems are we would like to see solved. I’m surprised this discussion starts over again.

And yes proxy might be a misleading term for some with its legacy co-notations, so feel free to propose an appropriate term (I thought some of the drafts have used different terminology).

Marcus

Von: multipathtcp <[email-masked]> im Auftrag von "[email-masked]" <[email-masked]>
Datum: Dienstag, 18. April 2017 um 10:17
An: "[email-masked]" <[email-masked]>
Betreff: [multipathtcp] Consensus call on potential MPTCP proxy work

Hi,
During the MPTCP meeting in Chicago we did several hums about potential MPTCP proxy work. Our interpretation of these hums is that we should do a consensus call for the following work:
--
MPTCP is now seeing widespread deployment in networks to bond together two accesses, such as fixed and mobile broadband, by using two MPTCP proxies, one in the home gateway or Customer Premises Equipment and one in the network. The WG develops a solution where the proxies are both under the control of the operator and where it is assumed that they are not on the default path. The solution is based on using the payload of an MPTCP packet to transfer a signalling message between the proxies. It is believed the solution will not require changes to RFC6824bis. The solution may require a means of configuring set-up information in the proxies, which would be done in coordination with other IETF WGs such as DHC. The WG does not develop a mechanism for the two proxies to discover each other.
--
Please say whether you support, or don’t support, such work – so we can see if there’s consensus for it.
Thanks
Phil & Yoshi

Hums during the meeting:

•         Should the MPTCP WG do any MPTCP proxy work, or do none – about 2:1 or 3:1 in favour of doing work

•         Should the MPTCP WG do proxy work based on option #1 in slide 12? Strongly more yes than no

•         Should the MPTCP WG do proxy work based on option #2 in slide 12? more no than yes

•         Should the MPTCP WG do proxy work based on option #3 in slide 12? Weak & roughly equal
Ref: https://www.ietf.org/proceedings/98/slides/slides-98-mptcp-sessa-chairs-01.pdf
We believe the work does not require an update to the MPTCP WG charter.

---

From: <[email-masked]>
Date: Thu, 20 Apr 2017 06:34:45 +0000

Hi Jordan,

SOCKS + TFO was discussed in the mailing list and also during the meeting in Chicago. Modifying SOCKS to provide 0-RTT will need to be yet specified...and therefore will need a new RFCed. There was clear consensus during the Chicago meeting to not work on SOCKS.

Modifying SOCKS will at best provide what we are doing in the plain mode, but still it does not provide address preservation feature that we want to ensure for IPv6.

Cheers,
Med

De : Jordan Melzer [mailto:[email-masked]]
Envoyé : mercredi 19 avril 2017 20:59
À : Joe Touch; BOUCADAIR Mohamed IMT/OLN; [email-masked]; [email-masked]
Objet : RE: [multipathtcp] Consensus call on potential MPTCP proxy work

It's a conventional proxy.  There are different sockets on each side of the proxy, different RTTs, different congestion control.  The proposal is to find a near-zero overhead way to do this when the proxy is off-path (ie, when it's not a simple connection hijack).  This may be totally possible without a new RFC - Christoph Paasch suggested that SOCKS + TFO could basically become this, but I am not sure anyone who cared either caught it or agreed.

Re b), it's off-topic, but what would you think of a multipath tunnel that was basically MPTCP with the retransmissions gutted out?  I had thought this would be what BANANA is doing, but I am not clear there are any two people in BANANA who agree on what it is.

From: multipathtcp [mailto:[email-masked]] On Behalf Of Joe Touch
Sent: April 19, 2017 02:17 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [multipathtcp] Consensus call on potential MPTCP proxy work

On 4/18/2017 10:26 PM, [email-masked]<mailto:[email-masked]> wrote:
As explained in my previous message, there is no layered congestion control. All packets are transported over plain TCP: no encap, no tunnel.
I did say "if"; I now understand better what you're trying to do, but there are plenty of parts still not addressed:

 I really reiterate my comment to read https://www.ietf.org/proceedings/98/slides/slides-98-mptcp-sessa-network-assisted-mptcp-03.pdf
Here's what those slides do not explain:

- is this system 1:1 per client TCP connection, or are you expecting a single MPTCP between proxies to support multiples?
- what is the congestion control interaction? I.e., does the client think the RTT is to the proxy (which will work), or to the TCP receiver past the end of the MPTCP connection?
    NOTE: if the latter, then you still end up with layered congestion control
- what is the proxy relaying?
    is it TCP data, or is it somehow trying to tunnel and reconstitute the entire packet?

    NOTE: if it reconstitutes the packet, what happens when you get an option you don't understand? E.g., EDO?

There are still plenty of more concerns with this system. Overall, you *still* appear to be doing one of two things:

    a) acting like a conventional application-layer proxy, which would be fine but would not require any new RFCs
    b) tunneling - or acting exactly like you're tunneling, by reconstituting packets on the other end - a TCP connection over TCP, which is a bad idea

So which is it? Or is it something else?

Joe