Subject: Re: [multipathtcp] Consensus call on potential MPTCP proxy work

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Tue, 18 Apr 2017 20:09:28 +0000

I fully support this work in MPTCP WG.

From: multipathtcp <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Tuesday, 18 April 2017 at 10:17
To: "[email-masked]" <[email-masked]>
Subject: [multipathtcp] Consensus call on potential MPTCP proxy work

Hi,
During the MPTCP meeting in Chicago we did several hums about potential MPTCP proxy work. Our interpretation of these hums is that we should do a consensus call for the following work:
--
MPTCP is now seeing widespread deployment in networks to bond together two accesses, such as fixed and mobile broadband, by using two MPTCP proxies, one in the home gateway or Customer Premises Equipment and one in the network. The WG develops a solution where the proxies are both under the control of the operator and where it is assumed that they are not on the default path. The solution is based on using the payload of an MPTCP packet to transfer a signalling message between the proxies. It is believed the solution will not require changes to RFC6824bis. The solution may require a means of configuring set-up information in the proxies, which would be done in coordination with other IETF WGs such as DHC. The WG does not develop a mechanism for the two proxies to discover each other.
--
Please say whether you support, or don’t support, such work – so we can see if there’s consensus for it.
Thanks
Phil & Yoshi

Hums during the meeting:

•         Should the MPTCP WG do any MPTCP proxy work, or do none – about 2:1 or 3:1 in favour of doing work

•         Should the MPTCP WG do proxy work based on option #1 in slide 12? Strongly more yes than no

•         Should the MPTCP WG do proxy work based on option #2 in slide 12? more no than yes

•         Should the MPTCP WG do proxy work based on option #3 in slide 12? Weak & roughly equal
Ref: https://www.ietf.org/proceedings/98/slides/slides-98-mptcp-sessa-chairs-01.pdf
We believe the work does not require an update to the MPTCP WG charter.

---

From: David Allan I <[email-masked]>
Date: Tue, 18 Apr 2017 22:06:22 +0000

Consider this email to be a hum in favour of the work.

Cheers D

From: multipathtcp <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 18 April 2017 at 10:17
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [multipathtcp] Consensus call on potential MPTCP proxy work

Hi,

Hums during the meeting: