Subject: Re: [multipathtcp] Changes to RFC6824bis

From: <[email-masked]>
Date: Mon, 23 Oct 2017 08:48:50 +0000

Is there any news about #2 and #3 below?
Thanks
phil
From: Eardley,PL,Philip,TUD1 R
Sent: 05 September 2017 17:32
To: Eardley,PL,Philip,TUD1 R <[email-masked]>; [email-masked]
Subject: RE: Changes to RFC6824bis

Just wanted to check where we are re these 3 changes.
#1 - thanks to Alan for making this change
#2 - Christoph, Olivier - any news?
#3 - Quentin - any news?
Thanks!
Phil

From: multipathtcp [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: 26 July 2017 08:51
To: [email-masked]<mailto:[email-masked]>
Subject: [multipathtcp] Changes to RFC6824bis

Hi,
During the discussions in Prague, we had good agreement about the following change to the bis. This is a change to the wire protocol. Please say as soon as possible if you disagree with this change, otherwise we'll go ahead and make this change:-

Remove address identifier from MP-PRIO, as it can be used as an attack.

Explanation at https://mailarchive.ietf.org/arch/msg/multipathtcp/WWWaQ3AKWEMgsBSPKc_R9Ct_YoI and follow up emails. The issue was briefly summarised during the Friday meeting in Prague - eg see the etherpad for a summary http://etherpad.tools.ietf.org:9000/p/notes-ietf-99-mptcp?useMonospaceFont=true

Alan - are you ok to make this change please?

--

In addition, we agreed in principle to the following (informational) changes to the bis - exact text to be proposed.

2.       Guidance about MPTCP & TFP interactions, based on https://www.ietf.org/proceedings/99/slides/slides-99-mptcp-sessb-mptcp-tfo-00.pdf - Christoph & Olivier, please propose text.

3.       There was a suggestion, arising from the hackathon, to discuss on the list whether clarifications or extra 'reason codes' would be useful in the context of reset option. Quentin (& others), please make a proposal.
Best wishes,
Phil & Yoshi

---

From: Christoph Paasch <[email-masked]>
Date: Sun, 29 Oct 2017 20:56:32 -0700

Hello Phil,

> Is there any news about #2 and #3 below?

sorry, I didn't find the time to work on the MPTCP & TFO interaction. I
doubt we will be able to update the draft before the cutoff tomorrow.

I will try to get to it as soon as possible.

Christoph

> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp