Subject: Re: [multipathtcp] Finishing RFC6824bis

From: <[email-masked]>
Date: Mon, 29 Jan 2018 13:42:48 +0000

Hi,
Is there any news or plans about the list of items to finalise the bis?

Also, the bis needs re-activating, as the draft is about to expire

Thanks
phil

From: multipathtcp [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 23 October 2017 09:52
To: [email-masked]
Subject: Re: [multipathtcp] Finishing RFC6824bis

Hi,
<< Implementers - implement SHA-256. As I understand it, this is the only part of the bis for which we don't have at least one implementation. Is there any timescale for implementing this?>>
I was wondering if there was an update or plans about this. Alternatively, we may decide it's ok to go ahead with last call without an implementation for this aspect.
Thanks
phil
From: Eardley,PL,Philip,TUD1 R
Sent: 26 July 2017 15:46
To: Eardley,PL,Philip,TUD1 R <[email-masked]<mailto:[email-masked]>>
Subject: Finishing RFC6824bis

We are close to finalising the bis and being able to WG Last call and send it to the IESG. Here's a list of actions. If we've forgotten anything, or anyone has another mod /addition to the bis, please say.

1.      Make the changes agreed - see email below.

2.      Implementers - implement SHA-256. As I understand it, this is the only part of the bis for which we don't have at least one implementation. Is there any timescale for implementing this?

3.      Chairs /all - list of changes between RFC & bis, along with a short justification

4.      Chairs /all - a short justification for obsoleting RFC6824

5.      Chairs /all - List of implementations of the protocol & bis (ie a check of which parts are implemented once or also in iOS)
Our proposed plan is that once the various parts of #1 are done, we'll do a WGLC. Items 3, 4 & 5 are things that will be useful to the IESG. Item 2 is certainly something that would be nice to have - if there'll be a significant delay implementing it, then we should discuss whether to wait, or whether it's acceptable to progress without an implementation of this part.
Finally a reminder that the plan is that RFC6824bis advances on the Standards track

From: Eardley,PL,Philip,TUD1 R
Sent: 26 July 2017 08:51
To: multipathtcp <[email-masked]<mailto:[email-masked]>>
Subject: Changes to RFC6824bis

Hi,
During the discussions in Prague, we had good agreement about the following change to the bis. This is a change to the wire protocol. Please say as soon as possible if you disagree with this change, otherwise we'll go ahead and make this change:-

Remove address identifier from MP-PRIO, as it can be used as an attack.

Explanation at https://mailarchive.ietf.org/arch/msg/multipathtcp/WWWaQ3AKWEMgsBSPKc_R9Ct_YoI and follow up emails. The issue was briefly summarised during the Friday meeting in Prague - eg see the etherpad for a summary http://etherpad.tools.ietf.org:9000/p/notes-ietf-99-mptcp?useMonospaceFont=true

Alan - are you ok to make this change please?

--

In addition, we agreed in principle to the following (informational) changes to the bis - exact text to be proposed.

2. Guidance about MPTCP & TFP interactions, based on https://www.ietf.org/proceedings/99/slides/slides-99-mptcp-sessb-mptcp-tfo-00.pdf - Christoph & Olivier, please propose text.

3. There was a suggestion, arising from the hackathon, to discuss on the list whether clarifications or extra 'reason codes' would be useful in the context of reset option. Quentin (& others), please make a proposal.
Best wishes,
Phil & Yoshi

---

From: Christoph Paasch <[email-masked]>
Date: Mon, 29 Jan 2018 22:45:27 -0800

> Is there any news or plans about the list of items to finalise the bis?

Currently, there isn't yet an implementation of SHA-256. I will see what I
can do (if someone wants to give it a shot, that would be great! Code is at
https://multipath-tcp.org :-)).

> Also, the bis needs re-activating, as the draft is about to expire

We posted an update of draft-barre-mptcp-tfo-02 a few months back. Could we
integrate this in the bis before we finalize it? I can provide the text for
it.

Christoph

> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp

---

From: <[email-masked]>
Date: Tue, 30 Jan 2018 08:54:22 +0000

Yes, please can you provide text as soon as possible. It was agreed to add text back in July.....

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 30 January 2018 06:45
To: Eardley,PL,Philip,TUD1 R <[email-masked]>
Cc: [email-masked]
Subject: Re: [multipathtcp] Finishing RFC6824bis

> Is there any news or plans about the list of items to finalise the bis?

Currently, there isn't yet an implementation of SHA-256. I will see what I can do (if someone wants to give it a shot, that would be great! Code is at https://multipath-tcp.org :-)).

> Also, the bis needs re-activating, as the draft is about to expire

We posted an update of draft-barre-mptcp-tfo-02 a few months back. Could we integrate this in the bis before we finalize it? I can provide the text for it.

Christoph

> << Implementers - implement SHA-256. As I understand it, this is the 
> only part of the bis for which we don't have at least one implementation. Is there any timescale for implementing this?>> I was wondering if there was an update or plans about this. Alternatively, we may decide it's ok to go ahead with last call without an implementation for this aspect.
> Thanks
> phil
> To: Eardley,PL,Philip,TUD1 R 
> <[email-masked]<mailto:[email-masked]>>
> During the discussions in Prague, we had good agreement about the 
> following change to the bis. This is a change to the wire protocol. 
> Please say as soon as possible if you disagree with this change, 
> otherwise we'll go ahead and make this change:-
> 
> Explanation at 
> https://mailarchive.ietf.org/arch/msg/multipathtcp/WWWaQ3AKWEMgsBSPKc_
> R9Ct_YoI and follow up emails. The issue was briefly summarised during 
> the Friday meeting in Prague - eg see the etherpad for a summary 
> http://etherpad.tools.ietf.org:9000/p/notes-ietf-99-mptcp?useMonospace
> Font=true
>