Subject: Re: draft-itojun-ipv6-nodeinfo-revlookup-00.txt

From: Alain Durand <[email-masked]>
Date: Thu, 18 Jul 2002 15:04:00 +0200

On Thursday, July 18, 2002, at 02:03 PM, Jeroen Massar wrote:
> <grin> That would give very interresting results indeed, so let's add
> the fact
> that it for example BIND have to be configged for such a delegation
> like:
>
> zone "4.2.0.0.0.0.2.4.1.1.8.e.f.f.3.ip6.int" {
>         type ipv6nodeinfo;
>         allow_names "*.unfix.org";
> 	  check_forward yes;
> };
>
> This would then tell BIND to do nodeinfo queries for
> 3ffe:8114:2000:240::/60.

This approach will work for the reverse mapping of
Site Local addresses if and only if the primary server and
all its secondary are all in the _same_ site local zone.

If not the ICMP will go to the wrong place...

	- Alain.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: David Terrell <[email-masked]>
Date: Sat, 20 Jul 2002 00:55:21 -0700

> If not the ICMP will go to the wrong place...

This is yet another general problem with SL addressing which has
been discussed before.  One might imagine a configuration option
that lets you restrict query access for SL addressing to site local
(zone-based or otherwise configured local prefixes) requesters.

Regardless, I like ICMP node lookup.  Information is good.  Being
able to provide information is good.

-- 
David Terrell          | Just another satan-worshipping Harry Potter reader.
[email-masked]           | 
Nebcorp Prime Minister | 
http://wwn.nebcorp.com |