Subject: Re: wildcard as empty non terminal

From: [email-masked]
Date: Thu, 16 Oct 2003 22:59:55 +1000

> Hello,
> 
> while reading the wildcard clarification draft and trying to implement it in
> NSD, we had the following discussion.
> 
> The draft states:
> 
> 2. Defining the Wild Card Domain Name
> 
>    A wild card domain name is defined by having the initial label be:
> 
>         0000 0001 0010 1010 (binary) = 0x01 0x2a (hexadecimal)
> 
>    This defines domain names that may play a role in being a wild card,
>    that is, being a source for synthesized answers.  Domain names
>    conforming to this definition that appear in queries and RDATA
>    sections do not have any special role.  These cases will be described
>    in more detail in following sections.
> 
> That is clear. In (to pick one) *.com, the '*' is a wildcard, in 
> a.*.com the '*' is not a wildcard.
> 
> Next consider this:
> we have a zone file with this:
> 	
> 	a.*.b		rdata
> 
> 	(this implicitely defines *.b as an empty non terminal)
> 
> Next we get a query for x.y.b. Ok, we process the query, find the closest
> encloser, which is .b. Then we look for *.b, now it does start with a '*' so 
> it
> has to be considered a wildcard.  So x.y.b will match on *.b?

	Yes.
 
> Is this correct reasening? If not, where do we go wrong?
> 
>     grtz  Miek
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/namedroppers/>
--
Mark Andrews, Internet Software Consortium
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Miek Gieben <[email-masked]>
Date: Thu, 16 Oct 2003 15:35:42 +0200

[On 16 Oct, @14:59, Mark.Andre wrote in "Re: wildcard as empty non term ..."]
> > has to be considered a wildcard.  So x.y.b will match on *.b?

ok, so a "lonely" '*' in a zonefile is always to be considered a wildcard,
only stuff like aba*.com does not qualify?

grtz Miek

---

From: masataka ohta <[email-masked]>
Date: Thu, 16 Oct 2003 22:41:08 +0900

Mark;

>>has to be considered a wildcard.  So x.y.b will match on *.b?

I think it is a reasonable clarification following 4.3.2, even though
4.3.3 states:

: In the previous algorithm, special treatment was given to RRs with owner
: names starting with the label "*".  Such RRs are called wildcards.

4.3.3 should, instead, have stated

: In the previous algorithm, special treatment was given to owner names
: starting with the label "*".  Such owner names are called wildcards.

							Masataka Ohta

---

From: Olafur Gudmundsson <[email-masked]>
Date: Sat, 18 Oct 2003 09:06:04 -0400 (EDT)

On Thu, 16 Oct 2003, Miek Gieben wrote:

> encloser, which is .b. Then we look for *.b, now it does start with a '*' so it

</chair>
IMHO, wildcard algorigthm is only applicalble to terminal nodes in
the tree. your system should see that when it reaches node *.b that there
is a child node,or at least flag that this name has a child.

Thus the wildcard algorithm should be disabled for that *.b.

	Olafur