Subject: I-D ACTION:draft-ietf-dnsext-insensitive-06.txt

From: [email-masked]
Date: Wed, 20 Jul 2005 18:50:02 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DNS Extensions Working Group of the IETF.

	Title		: Domain Name System (DNS) Case Insensitivity Clarification
	Author(s)	: D. Eastlake
	Filename	: draft-ietf-dnsext-insensitive-06.txt
	Pages		: 13
	Date		: 2005-7-20
	
Domain Name System (DNS) names are "case insensitive". This document
   explains exactly what that means and provides a clear specification
   of the rules. This clarification updates RFCs 1034 and 1035.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-dnsext-insensitive-06.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-dnsext-insensitive-06.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-dnsext-insensitive-06.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Eastlake III Donald-LDE008 <[email-masked]>
Date: Thu, 21 Jul 2005 15:36:06 -0400

Hi,

This draft revision is intended to respond to IESG comments. (You can find these comments via the ID Tracker https://datatracker.ietf.org/public/pidtracker.cgi.)

I consider the most significant IESG comment to be that related to label case insensitivity in new CLASSes. I believe that it was always intended that classic labels be case insensitive for all CLASSes. This is essential for a recursive server to handle unknown CLASSes, for example. If you want labels that act differently, for example to be case sensitive, I think you need to define a new label type, whether these hypothetical new labels are being used in a new CLASS or an existing CLASS.

There was also some confusion among some IESG members concerning the part of the draft where the draft pointed out that if you "input" names with inconsistent case, a server can keep the case of the first input or let later input override the case or keep inconsistent case internally. But "input" in this instance means loading from a master file or dynamic update or the like. Some IESG members seem to have interpreted "input" as also including queries and somehow believed that I was saying you might get case dependent partial RR sets in your answer, exactly the opposite of "case insensitivity". I've tried to be much clearer in this version.

There are also some minor changes. See appendix in the drafts.

Thanks,
Donald

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, July 20, 2005 6:50 PM
To: [email-masked]
Cc: [email-masked]
Subject: I-D ACTION:draft-ietf-dnsext-insensitive-06.txt 

	

To remove yourself from the I-D Announcement list, send a message to [email-masked] with the word unsubscribe in the body of the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username "anonymous" and a password of your e-mail address. After logging in, type "cd internet-drafts" and then
	"get draft-ietf-dnsext-insensitive-06.txt".

A list of Internet-Drafts directories can be found in http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Send a message to:
	[email-masked].
In the body type:

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>