Subject: Re: [dnsext] Moving policy data away from DNS

From: Jay Daley <[email-masked]>
Date: Mon, 17 Jan 2011 14:25:08 +1300

(back from vacation)

On 28/12/2010, at 12:19 AM, Phillip Hallam-Baker wrote:

> The principle objection to putting policy in the DNS seems to be that doing so represents a slippery slope and that we might end up with people putting so much information in their DNS that it 'breaks'.

I was going a step further than that.

I'm of the view that adding RRs to DNS that are protocol specific is sub-optimal for a host of reasons (though I don't think they will 'break' the DNS) and instead we should go for additions that have a higher level of usage.  For example:

- RRs about the tree such as those that describe the tree or redirect people around the tree
- RRs that can be used by any protocol such as those that point to policy or provide credentials

Another way of putting it is creating a toolkit of RRs (using current requirements) that other protocol developers can just use off the shelf without any changes to DNS.

What I would call a strategic plan.

cheers
Jay

-- 
Jay Daley
Chief Executive
.nz Registry Services (New Zealand Domain Name Registry Limited)
desk: +64 4 931 6977
mobile: +64 21 678840

_______________________________________________
dnsext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsext

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 16 Jan 2011 21:52:56 -0500

On Sun, Jan 16, 2011 at 8:25 PM, Jay Daley <[email-masked]> wrote:

> > The principle objection to putting policy in the DNS seems to be that
> doing so represents a slippery slope and that we might end up with people
> putting so much information in their DNS that it 'breaks'.
>
> I'm of the view that adding RRs to DNS that are protocol specific is
> sub-optimal for a host of reasons (though I don't think they will 'break'
> the DNS) and instead we should go for additions that have a higher level of
> usage.  For example:
>

Given that in the Web Services world we are going to have to deal with
thousands of protocols, the DNS should not have protocol specific features.

The discovery and policy mechanism should be independent of the protocol
that is going to make use of it. Otherwise it would be like having a
different way to look up IP addresses for HTTP to FTP.

Another way of putting it is creating a toolkit of RRs (using current
> requirements) that other protocol developers can just use off the shelf
> without any changes to DNS.
>

It is what architecture should be.

-- 
Website: http://hallambaker.com/
_______________________________________________
dnsext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsext