Subject: [NAT] RE: Regarding NAT MIB <draft-ietf-nat-natmib-00>

From: Pyda Srisuresh <[email-masked]>
Date: Fri, 21 Dec 2001 19:10:39 -0800 (PST)

Rohit and Rajendra,

I believe, the following discussion deserves wider participation. 
SO, I am taking the liberty of Ccing to the NAT list. Hope you 
dont mind my doing so.

Rohit - Why not merge all elements of natConfEntry and 
        natConfAddrMapTable name into NatInterfaceEntry?

This will ensure that the configuration has the following information 
on a per-interface basis.

      InterfaceIndex - Interface ID.
      Realm          - Realm of attachment to the interface
      ServiceType    - TraditionalNat (or) Bi-DirectionalNat (or) Twice-NAT
      AddrMapTableName - Name of the AddressMap Table 
      Status         - NAT enabled (or0 NAT disabled
      
cheers,
suresh

--- Rohit Rohit <[email-masked]> wrote:
> Hi Rajendra, 
> 
>   I do see your point; and i think that adding natConfName to the
> natInterface
>   Table should solve this issue.
> 
>   I will take care of this in the next version of the MIB.
>   I guess, that we also need to add a section describing that
>   once we have got a packet on the interface, then how do we apply
>   all of our config tables.
>   
>   Thanks
>   Rohit
> 
> -----Original Message-----
> From: Rajendra Prasad [mailto:[email-masked]]
> Sent: Wednesday, December 19, 2001 9:30 PM
> To: Rohit Rohit
> Cc: Rajiv Raghunarayan; [email-masked]; Pyda Srisuresh; Wang,Cliff;
> [email-masked]
> Subject: Regarding NAT MIB <draft-ietf-nat-natmib-00>
> 
> 
> 
> Hi Rohit,
> 
>  Thank you for the reply. Yes, natInterfaceStatus will give me whether NAT is
> enabled on an interface. But, it doesnot give me any information about which
> type of NAT(NAPT/TWICENAT/Two Way/Traditional) is enabled on that interface.
> When a packet is recieved on an interface, we know that the packet has to be
> translated since NAT is enabled on that interface. But How do we know that we
> have to translate it using NAT/NAPT/TwiceNAT/TwoWayNAT?
> 
> Am I clear with the question? If so, Please clarify this. 
> 
> Thanks,
> Rajendra Prasad  
> 
> On Wed, 19 Dec 2001 Rohit Rohit wrote :
> > Hi, 
> > 
> >   natInterfaceStatus is to indicate whether nat is 
> > enabled
> >   on the interface or not. 
> >   I guess that i did answer your question.
> > 
> >   Thanks
> >   Rohit
> > 
> > -----Original Message-----
> > From: Rajendra Prasad [mailto:[email-masked]]
> > Sent: Wednesday, December 19, 2001 6:08 AM
> > To: [email-masked]
> > Cc: Rajiv Raghunarayan; [email-masked]; Rohit Rohit; 
> > Pyda Srisuresh;
> > Wang,Cliff
> > Subject: Regarding NAT MIB <draft-ietf-nat-natmib-00>
> > 
> > 
> > 
> > Hi,
> > 
> > I have a doubt in natConfTable and natInterfaceTable
> > 
> >   In NAT MIB draft <draft-ietf-natmib-mib-00>, the 
> > natConfTable is used to enable NAT/NAPT/Two Way 
> > NAT/Twice NAT. The index for the entry in this table is 
> > 'IMPLIED natConfName'. 
> > 
> >  There is Interface Table(natInterfaceTable) which 
> > contains the interface information. Each entry in this 
> > table holds information regarding an interface on which 
> > NAT is enabled. But, how do I say whether NAT is 
> > enabled on that interface or not? Is there any implicit 
> > relationship between natConfTable and natInterfaceTable.
> > 
> >  Why can't we club these two tables and make the index 
> > as 'natInterfaceIndex and natConfName' for the 
> > resultant table? Doing this, we can get whether NAT is 
> > enabled on an interface or not without any extra 
> > processing.
> > 
> > please do clarify me on this.
> > 
> > Thanks
> > B.Rajendra Prasad 
> > 
>  
> 

=====

__________________________________________________
Do You Yahoo!?
Send your FREE holiday greetings online!
http://greetings.yahoo.com

_______________________________________________
nat mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nat

---

From: Pyda Srisuresh <[email-masked]>
Date: Fri, 21 Dec 2001 19:10:39 -0800 (PST)

Rohit and Rajendra,

      
cheers,
suresh

=====