Subject: [NAT] RE: Re RE: Regarding NAT MIB <draft-ietf-nat-natmib-02>

From: "Rohit Rohit" <[email-masked]>
Date: Wed, 26 Dec 2001 11:01:20 -0800

Hi, 

  The main idea behind dividing the config info in the three
  tables is the modularity and clarity.
  
  There are three steps in configuring the NAT :-> 

  1. enable\disable on the particular interface.
  2. define the type of nat and other protocol specific parameters.
  3. define the addrMap.

  So the three different tables just represent these three steps.

  Once a config entry is created, then it can be applied to any of the
  addrMap Entries, and it can be associated with any of the interface.

  If we have interfaceIndex as an index to the confTable, 
  then for each interface we will have to repeat the config info even if they
  are the same.

  Once we are through with this discussion, then i will be adding the comments
  we have received for the draft and i guess then we should be close to  make
  a final call on this.

  Thanks
  Rohit

-----Original Message-----
From: Pyda Srisuresh [mailto:[email-masked]]
Sent: Monday, December 24, 2001 6:54 PM
To: Rajendra Prasad; Rohit Rohit
Cc: Rajiv Raghunarayan; [email-masked]; Pyda Srisuresh; Wang,Cliff;
[email-masked]
Subject: Re: Re RE: Regarding NAT MIB <draft-ietf-nat-natmib-00>

Folks,

This is good discussion. Please be sure to Cc the nat mailing
list on this. Thanks.

cheers,
suresh

--- Rajendra  Prasad <[email-masked]> wrote:
> 
> Hi Rohit,
> 
>  Yes adding ConfName to Interface table will solve the problem. I have a
> suggestion -
> 1. Since NAT is going to be interface specific, Can't we merge ConfTable and
> Interface Table?
> 
> If both tables are merged, the implementation and processing becomes simpler.
> 
> Moreover, What is advantange of having ConfName? If this natConfName was
> designed to accomadate various instances of NAT on a router, Is there any
> scenario where we run two instances of NAT run on same interface. 
> 
> May I know the expected date of the next NAT MIB release? 
> 
> Thanks,
> B.Rajendra Prasad
> 
>    
> On Sat, 22 Dec 2001 Rohit Rohit wrote :
> > Hi Rajendra, 
> > 
> >   I do see your point; and i think that adding 
> > natConfName to the natInterface
> >   Table should solve this issue.
> > 
> >   I will take care of this in the next version of the 
> > MIB.
> >   I guess, that we also need to add a section 
> > describing that
> >   once we have got a packet on the interface, then how 
> > do we apply
> >   all of our config tables.
> >   
> >   Thanks
> >   Rohit
> > 
> > -----Original Message-----
> > From: Rajendra Prasad [mailto:[email-masked]]
> > Sent: Wednesday, December 19, 2001 9:30 PM
> > To: Rohit Rohit
> > Cc: Rajiv Raghunarayan; [email-masked]; Pyda Srisuresh; 
> > Wang,Cliff;
> > [email-masked]
> > Subject: Regarding NAT MIB <draft-ietf-nat-natmib-00>
> > 
> > 
> > 
> > Hi Rohit,
> > 
> >  Thank you for the reply. Yes, natInterfaceStatus will 
> > give me whether NAT is enabled on an interface. But, it 
> > doesnot give me any information about which type of 
> > NAT(NAPT/TWICENAT/Two Way/Traditional) is enabled on 
> > that interface. When a packet is recieved on an 
> > interface, we know that the packet has to be translated 
> > since NAT is enabled on that interface. But How do we 
> > know that we have to translate it using 
> > NAT/NAPT/TwiceNAT/TwoWayNAT?
> > 
> > Am I clear with the question? If so, Please clarify 
> > this. 
> > 
> > Thanks,
> > Rajendra Prasad  
> > 
> > On Wed, 19 Dec 2001 Rohit Rohit wrote :
> > > Hi, 
> > > 
> > >   natInterfaceStatus is to indicate whether nat is 
> > > enabled
> > >   on the interface or not. 
> > >   I guess that i did answer your question.
> > > 
> > >   Thanks
> > >   Rohit
> > > 
> > > -----Original Message-----
> > > From: Rajendra Prasad [mailto:[email-masked]]
> > > Sent: Wednesday, December 19, 2001 6:08 AM
> > > To: [email-masked]
> > > Cc: Rajiv Raghunarayan; [email-masked]; Rohit Rohit; 
> > > Pyda Srisuresh;
> > > Wang,Cliff
> > > Subject: Regarding NAT MIB <draft-ietf-nat-natmib-00>
> > > 
> > > 
> > > 
> > > Hi,
> > > 
> > > I have a doubt in natConfTable and natInterfaceTable
> > > 
> > >   In NAT MIB draft <draft-ietf-natmib-mib-00>, the 
> > > natConfTable is used to enable NAT/NAPT/Two Way 
> > > NAT/Twice NAT. The index for the entry in this table 
> > is 
> > > 'IMPLIED natConfName'. 
> > > 
> > >  There is Interface Table(natInterfaceTable) which 
> > > contains the interface information. Each entry in 
> > this 
> > > table holds information regarding an interface on 
> > which 
> > > NAT is enabled. But, how do I say whether NAT is 
> > > enabled on that interface or not? Is there any 
> > implicit 
> > > relationship between natConfTable and 
> > natInterfaceTable.
> > > 
> > >  Why can't we club these two tables and make the 
> > index 
> > > as 'natInterfaceIndex and natConfName' for the 
> > > resultant table? Doing this, we can get whether NAT 
> > is 
> > > enabled on an interface or not without any extra 
> > > processing.
> > > 
> > > please do clarify me on this.
> > > 
> > > Thanks
> > > B.Rajendra Prasad 
> > > 
> >  
> > 
>  
> 

=====

__________________________________________________
Do You Yahoo!?
Send your FREE holiday greetings online!
http://greetings.yahoo.com

_______________________________________________
nat mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nat

---

From: Pyda Srisuresh <[email-masked]>
Date: Wed, 26 Dec 2001 19:17:13 -0800 (PST)

>   So the three different tables just represent these three steps.
This is good.

I see that each interface configuration is covered by NatInterfaceEntry.
Within NatInterfaceEntry, I see 
  1) is covered by natInterfaceStatus, Even though I believe, there should
     be 2 fields - One to control the NAT enable/Disable and 
     the second field to query teh status from NAT device.
  
As for item 2), this is "natConfServiceType" field in NatConfEntry as below.
    NatConfEntry ::= SEQUENCE {
        natConfName                 SnmpAdminString,
        natConfServiceType          INTEGER,
        natConfProtConfigName       SnmpAdminString,
        natConfStorageType          StorageType,
        natConfStatus               RowStatus
    }
So, including natConfName as a field within NatInterfcaeEntry will 
do the job, as you say.

As for item 3, I am confused as to how an address map table is 
associated with the Interface. 
I understand, natConfig is constituted of:
      natConfTable, natConfAddrMapTable, natInterfaceTable, 
      natConfUdpDefIdleTimeout, natConfIcmpDefIdleTimeout, 
      natConfOtherDefIdleTimeout, natConfTcpDefIdleTimeout

Now, How do you associate an Addressmap table with a specific 
interface? 

How is NatConfEntry (associated with a specific InterfaceTableEntry)
associated with an AddrMaptable? Thanks.

cheers,
suresh

=====

---

From: Pyda Srisuresh <[email-masked]>
Date: Wed, 26 Dec 2001 19:17:13 -0800 (PST)

This is good.

cheers,
suresh

=====