Subject: [nemo] Request for your comments on a new RO draft

From: "Jaehoon Jeong" <[email-masked]>
Date: Sun, 15 Jun 2003 12:25:02 +0900

Hello, nemo guys! 

I submitted a new draft about the Route Optimization (RO) for mobile nodes in mobile network. 

 Title : ND-Proxy based Route Optimization for Mobile Nodes in Mobile Network 
 URL for the Draft : http://www.ietf.org/internet-drafts/draft-jeong-nemo-ro-ndproxy-00.txt 

It is based on ND-Proxy for supporting multi-link subnet.
Whenever a mobile router moves into another access network, 
it provides its mobile network nodes with the network prefix of the access network.
This scheme makes the access network and mobile network become a multi-link subnet, 
allowing the local or visiting mobile nodes within the mobile network
to perform binding update for route optimization.

Though RO is not the current issue in nemo wg, I think, the research for RO is important in nemo. 
Through on-line discussion about RO, it may be good for us to prepare RO issue 
that can be discussed in earnest next year. 
So, I'd like to request your comments on my draft. 
Thanks. 

Regards, 
Jaehoon

---

From: "Na, Jong Keun" <[email-masked]>
Date: Mon, 16 Jun 2003 10:15:23 +0900

Hi Jaehoon,
 
I have a concern in your draft.
Is it right direction to give the burden of mobility management to each
MNNs, not MRs?
To the best of my knowledge, In NEMO, it's a basic principal for MR to
manage the mobility of mobile network transparently to nodes behind it.
If nodes behind MR get new CoA of the access link via Proxy-ND each time
MR changes the point of attachment, all of nodes have to directly
process each their handover(L3 address changed). How do you think of my
point?
If something missed, please correct me. Thanks.
 
/Jong
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Jaehoon Jeong
Sent: Sunday, June 15, 2003 12:25 PM
To: [email-masked]
Subject: [nemo] Request for your comments on a new RO draft
 
Hello, nemo guys! 
 
I submitted a new draft about the Route Optimization (RO) for mobile
nodes in mobile network. 
 
 Title : ND-Proxy based Route Optimization for Mobile Nodes in Mobile
Network 
 URL for the Draft :
http://www.ietf.org/internet-drafts/draft-jeong-nemo-ro-ndproxy-00.txt 
 
It is based on ND-Proxy for supporting multi-link subnet.
Whenever a mobile router moves into another access network, 
it provides its mobile network nodes with the network prefix of the
access network.
This scheme makes the access network and mobile network become a
multi-link subnet, 
allowing the local or visiting mobile nodes within the mobile network
to perform binding update for route optimization.
 
Though RO is not the current issue in nemo wg, I think, the research for
RO is important in nemo. 
Through on-line discussion about RO, it may be good for us to prepare RO
issue 
that can be discussed in earnest next year. 
So, I'd like to request your comments on my draft. 
Thanks. 
 
Regards, 
Jaehoon

---

From: "Na, Jong Keun" <[email-masked]>
Date: Mon, 16 Jun 2003 10:15:23 +0900

Hi Jaehoon,

/Jong
 
-----Original Message-----
 
Hello, nemo guys! 

 

Regards, 
Jaehoon

---

From: "Jaehoon Jeong" <[email-masked]>
Date: Mon, 16 Jun 2003 15:51:17 +0900

Hi, Jong Keun.

inlines:-)

> ----- Original Message ----- 
> From: Na, Jong Keun 
> To: 'Jaehoon Jeong' ; [email-masked] 
> Sent: Monday, June 16, 2003 10:15 AM
> Subject: RE: [nemo] Request for your comments on a new RO draft
>
>
> Hi Jaehoon,
> 
> Is it right direction to give the burden of mobility management to each MNNs, not MRs?

    For Route Optimization (RO), I think, each MNN (VMN or LMN) should perform 
    the mobility management related to RO.
    Because RO uses the access network directly, each mobile node is efficient to perform its RO
    in the same manner as MIPv6. 

> 
> To the best of my knowledge, In NEMO, it’s a basic principal for MR to manage the mobility of 
> mobile network transparently to nodes behind it.
> 
    Only when RO is excluded in NENO operation, it is right.
    For local fixed node (LFN), the mobility of NEMO is still transparent.
    The scope of RO of my draft is for mobile nodes, either local mobile node (LMN) or 
    visiting mobile node (VMN).  

> 
> If nodes behind MR get new CoA of the access link via Proxy-ND each time MR changes 
> the point of attachment, all of nodes have to directly process each their handover(L3 address changed).

     All mobile nodes need not participate in the RO suggested in my draft. 
     How about only mobile nodes that need RO performing the RO? 
     RO can be performed only by mobile nodes that can understand the extended prefix information option
     of RA message, including the prefix of a new access network.
     It is reasonable, I think.
     In conclusion, for RO, each mobile node is reasonable to perform its return routability and 
     binding update procedure by itself.

> 
> How do you think of my point?

    Thanks for your interest.
    
    /Jaehoon

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Jaehoon Jeong

---

From: "Jaehoon Jeong" <[email-masked]>
Date: Mon, 16 Jun 2003 15:51:17 +0900

Hi, Jong Keun.

inlines:-)

    
    /Jaehoon