Subject: RE: [nemo] FW: [nemo-base-dt] IPRs on base solution

From: Soliman Hesham <[email-masked]>
Date: Thu, 19 Jun 2003 22:27:45 -0400

TJ, 

We might need some feedback from the ADs about 
IETF policy here. But, having been through this 
in other WGs. I was always told that the IETF
does not want base solutions to be IPRed. Examples
of these has taken place in other WGs like VRRP, SEND..etc. 

In the case where a base spec were encumbered, the 
second best solution is specified. In this case 
this might be the PSBU. 

My 2 cents
Hesham

 > -----Original Message-----
 > From: T.J. Kniveton [mailto:[email-masked]]
 > Sent: Thursday, June 19, 2003 4:06 PM
 > To: [email-masked]
 > Subject: [nemo] FW: [nemo-base-dt] IPRs on base solution
 > 
 > 
 > 
 > ------ Forwarded Message
 > From: "T.J. Kniveton" <[email-masked]>
 > Date: Wed, 11 Jun 2003 09:24:38 -0700
 > To: Alexandru Petrescu <[email-masked]>
 > Cc: [email-masked]
 > Subject: Re: [nemo-base-dt] IPRs on base solution
 > 
 > Alexandru Petrescu wrote:
 > > 
 > > Hello TJ, thank you for the update.
 > > 
 > > > I know there are a lot of concerns about IPR, and it is 
 > hard to be
 > > > totally sure what the situation is.
 > > 
 > > Exactly, that fits my view too; it is hard for me to find 
 > out what the
 > > best practice at IETF is.
 > > 
 > > Please allow me to take one possible aspect of the 
 > situation.  I'm not
 > > claiming that this is covering entirely the IPR issues, it 
 > is just one
 > > possibility.  I've heard some people at IETF saying that 
 > WG's and the
 > > IESG are trying to stay away from anything that is 
 > "encumbered". (more
 > > specifically, a Mobile IP WG co-chair wrote in private; at 
 > last manet WG
 > > meeting an IESG member said that people in IESG are trying to
 > > avoid "encumbered" drafts; and a Mobile IP WG member who 
 > wrote on the
 > > list saying he doesn't "want to become a lawyer" when I 
 > suggested him
 > > that defensive IPR's are probably not very bad).
 > 
 > 
 > Yes, we can see that this is an unchartered area and 
 > everyone reacts in a
 > slightly different way! Of course being a researcher, I 
 > recognize that
 > unencumbered technology may be the most flexible. I also 
 > agree with you that
 > defensive IPRs are not that bad, but what I have come to 
 > understand after
 > talking to the lawyers is that this would be fine in a 
 > perfect world with no
 > malicious companies. But unfortunately, defensive stances cause the
 > defense-only company to pay royalties to a non-defensive 
 > company (especially
 > if
 > it doesn't compete in the same market segment), and not 
 > vice-versa. Nokia
 > already has a statement registered on the IETF web site and 
 > is committed to
 > "play fair."
 > 
 > So anyhow, back to this specific case.. I have gotten a 
 > response from our
 > lawyers and they are concerned to make sure that we conform 
 > to the IETF
 > process
 > and play by the rules. At this early stage, we can give a statement
 > identifying
 > the application, the work it affects and some licensing 
 > statement. We can
 > give
 > more detailed statements when the std is frozen or the 
 > patent is granted.
 > And I
 > will personally make sure that future necessary 
 > clarifications will be
 > addressed by the lawyers.
 > 
 > Thanks, TJ
 > 
 > -- 
 >         T.J. Kniveton
 >    Communication Systems Lab
 >      Nokia Research Center
 > 
 > 
 > ------ End of Forwarded Message
 > 
 >

---

From: Jari Arkko <[email-masked]>
Date: Fri, 20 Jun 2003 09:01:50 +0300

TJ, Hesham,

I agree with Hesham here. IPRs *are* an issue, and
I'm not sure labeling some of the IPR as "defensive"
is very useful. Here's one practical problem: how does
this technology get deployed in Linux & BSD? If the
IPR licenses grant a free (not just "fair") use,
then we are OK. If not, we have a problem. At the
very least there should be a base solution which is
free of IPRs, even if advanced optimizations etc.
would be IPR-only stuff.

--Jari

---

From: Jari Arkko <[email-masked]>
Date: Fri, 20 Jun 2003 09:01:50 +0300

TJ, Hesham,

--Jari

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 20 Jun 2003 15:07:10 +0200

Jari, Hesham, thanks for following up on this.

I agree with most of your comments.  One conclusion seems to lack a
basis though.

I prefer wait the base spec is out when it is out so we have a base for
discussion.

Alex
GBU

Jari Arkko wrote:
> 
> TJ, Hesham,
> 
> I agree with Hesham here. IPRs *are* an issue, and I'm not sure 
> labeling some of the IPR as "defensive" is very useful. Here's one 
> practical problem: how does this technology get deployed in Linux & 
> BSD? If the IPR licenses grant a free (not just "fair") use, then we 
> are OK. If not, we have a problem. At the very least there should be 
> a base solution which is free of IPRs, even if advanced optimizations
> etc. would be IPR-only stuff.
> 
> --Jari
> 
> Soliman Hesham wrote:
> 
>> TJ, We might need some feedback from the ADs about IETF policy 
>> here. But, having been through this in other WGs. I was always told
>>  that the IETF does not want base solutions to be IPRed. Examples 
>> of these has taken place in other WGs like VRRP, SEND..etc. In the 
>> case where a base spec were encumbered, the second best solution is
>> specified. In this case this might be the PSBU.
> 
> 
> 
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 20 Jun 2003 15:07:10 +0200

Alex
GBU

---

From: "T.J. Kniveton" <[email-masked]>
Date: Sat, 21 Jun 2003 21:04:51 -0700

Thanks for your comments Jari; it sounds like everyone is interested in
making sure we are on top of the IPR issue, which is good. The purpose for
labeling IPR as "defensive" is the same as getting a free license -- it is
helpful for those implementing something to know that they will not be
targeted for using a technology by predatory licensing practices.

I would suppose this technology would be deployed in Linux & BSD by an
interested party implementing it as open source. I believe that Nokia
already has created and/or specified many, many technologies that have been
used in this way, and I don't see why the existing IPR policy or future
clarifications within NEMO would have to be any different. As for other
companies' IPR, I can not speak for them. Hopefully they would be equally
cooperative. Can you suggest a way to ensure that no other companies have
any IPR on a possible basic solution that we use?

TJ

---

From: "T.J. Kniveton" <[email-masked]>
Date: Sat, 21 Jun 2003 21:04:51 -0700

TJ