Subject: [nemo] nemo basic support ptotocol draft.

From: "Muhammad Ali Malik" <[email-masked]>
Date: Tue, 24 Jun 2003 15:37:37 +1000

Hi

I have following question about multicast group for mobile router.

>> If mobile router want to join a multicast group while MR is in foreign
location, it needs to join the multicast group via bidirectional tunnel.

>> Is there any way by which mobile network node can individually join the
multicast group.

Cheers
Muhammad

---

From: Greg Daley <[email-masked]>
Date: Tue, 24 Jun 2003 16:47:56 +1000

Hi Muhammad,

I guess that the Mobile Router will be running PIM,
rather than MLD/IGMP.

In this case, MLD/IGMP Reports/Group joins will
be handled the same way in which fixed network traffic is
handled.  The MR makes a request for routing a multicast
group/source over its tunnelled interface.
This allows MNNs to have the full multicast capabilities
of a fixed node.

It may be a valuable situation if the MR could join groups
on visited networks (like a host), although this would
require significant investigation, in my guess.

Greg

Muhammad Ali Malik wrote:
>>>  Is there any way by which mobile network node can individually join 
> the multicast group.
> 
>  
> 
> Cheers
> 
> Muhammad
>

---

From: Greg Daley <[email-masked]>
Date: Tue, 24 Jun 2003 16:47:56 +1000

Hi Muhammad,

Greg

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 24 Jun 2003 12:34:16 +0200

Greg Daley wrote:
> Hi Muhammad,
> 
> I guess that the Mobile Router will be running PIM, rather than 
> MLD/IGMP.

I would say both.  Interaction between MR and HA would be with PIM but
MR would also send MLD packets towards the first underlying segment of
the mobile network.

> It may be a valuable situation if the MR could join groups on visited
>  networks (like a host), although this would require significant 
> investigation, in my guess.

I'd say that MR, or MH for that matter, joining a multicast group on the
foreign link other than link scope ("remote subsription") amounts to MR
using routing protocol interactions with the foreign network, and more.
  I agree with you that this would demand significant research results.
In fact I'm searching for these research results since some time, I have
a bunch of paper references, if you're interested, but none addresses
this issue directly.

Alex
GBU

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 24 Jun 2003 12:34:16 +0200

Alex
GBU

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 24 Jun 2003 15:04:10 +0200

Muhammad Ali Malik wrote:
>>> If mobile router want to join a multicast group while MR is in
> foreign location, it needs to join the multicast group via 
> bidirectional tunnel.
>

I think that hosts in the mobile network, that are placed immediately
under the MR, e.g. on a link immediately below MR will indeed
individually join the multicast groups with MLD.  Those hosts will see
no change in the multicast tree when the MR changes its Care-of Address.

I think that routers in the mobile network will join groups but
not with MLD.

Alex
GBU

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 24 Jun 2003 15:04:10 +0200

Alex
GBU