Subject: Re: [nemo] Request for your comments on a new RO draft

From: "Jaehoon Jeong" <[email-masked]>
Date: Wed, 18 Jun 2003 22:45:54 +0900

Inlines :-)
  ----- Original Message ----- 
  From: Na, Jong Keun 
  To: 'Jaehoon Jeong' 
  Cc: 'NEMO WG' ; '박정수' ; '김형준' ; '이경진' ; '김병엽' ; '차현욱' 
  Sent: Tuesday, June 17, 2003 7:21 PM
  Subject: RE: [nemo] Request for your comments on a new RO draft

  Hi Jaehoon, 

  Thanks for your quick reply.

  At these days, I’m considering how to solve the nested tunnels problem.

  -> It is important to solve the problem, I agree.

  IMHO, this nested tunnels optimization is very important in the area of NEMO RO problem.

  In this aspect, I think it is needed to consider this kind of optimization in your draft.

  -> In this respect, I disagree.

       Because my scheme is based on multi-link subnet, there happens no nested tunnel problem

       for mobile nodes within NEMO.

  How about MRs do ND-proxy based RO about their egress interface?

  -> In my draft, like your suggestion, MRs plays the role of ND-proxy for their own egress interface and

       plays the normal router for their own ingress interface.

       Refer to "Multi-link Subnet Support in IPv6" draft for detailed mechanism.

       http://www.amaranthnetworks.com/ietf/drafts/draft-ietf-ipv6-multilink-subnets-00.txt

  If MR can do that, the nodes behind MR will get the effect of nested tunnels optimization.

  There will be no more nested tunnel if MRs use one address allocated in access link prefix as their CoA of the egress interface and MRs on the path operate in ND-Proxy mode. 

  -> Right. Because there are no nested tunnels between root-MR and sub-MR owing to multi-link subnet,

       the nested tunnels optimization is not related to my sheme. Therefore, my scheme need not consider

       the nested tunnels optimization.

  I think it’s possible this approach can be a candidate solution for the nested tunnels optimization already touched by RRH-based and ARO-based proposed solutions, even though there are some arguments on the general feasibility of ND-proxy based solution.

  -> I agree. I am thinking the scalability of my scheme now.

       I think my scheme is useful for a few level NEMO, not deep level NEMO.

       For example, it will be used for NEMO within Internet car and bus.

  Do you think of this optimization is possible? Please let me know your opinion. Thanks.

  /Jong

  -> Thanks for your good comments.

       /Jaehoon

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]] On Behalf Of Jaehoon Jeong
  Sent: Monday, June 16, 2003 3:51 PM
  To: Na, Jong Keun
  Cc: NEMO WG; 박정수; 김형준; 이경진; 김병엽; 차현욱; 정재훈
  Subject: Re: [nemo] Request for your comments on a new RO draft

  Hi, Jong Keun.

  inlines:-)

  > ----- Original Message ----- 
  > From: Na, Jong Keun 
  > To: 'Jaehoon Jeong' ; [email-masked] 
  > Sent: Monday, June 16, 2003 10:15 AM
  > Subject: RE: [nemo] Request for your comments on a new RO draft
  >
  >
  > Hi Jaehoon,
  > 
  > I have a concern in your draft.
  > Is it right direction to give the burden of mobility management to each MNNs, not MRs?

      For Route Optimization (RO), I think, each MNN (VMN or LMN) should perform 

      the mobility management related to RO.
      Because RO uses the access network directly, each mobile node is efficient to perform its RO

      in the same manner as MIPv6. 

  > 
  > To the best of my knowledge, In NEMO, it’s a basic principal for MR to manage the mobility of 
  > mobile network transparently to nodes behind it.
  > 
      Only when RO is excluded in NENO operation, it is right.
      For local fixed node (LFN), the mobility of NEMO is still transparent.

      The scope of RO of my draft is for mobile nodes, either local mobile node (LMN) or 

      visiting mobile node (VMN).  

  > 
  > If nodes behind MR get new CoA of the access link via Proxy-ND each time MR changes 

  > the point of attachment, all of nodes have to directly process each their handover(L3 address changed).

       All mobile nodes need not participate in the RO suggested in my draft. 
       How about only mobile nodes that need RO performing the RO? 
       RO can be performed only by mobile nodes that can understand the extended prefix information option

       of RA message, including the prefix of a new access network.
       It is reasonable, I think.
       In conclusion, for RO, each mobile node is reasonable to perform its return routability and 
       binding update procedure by itself.

  > 
  > How do you think of my point?
  > If something missed, please correct me. Thanks.
  >  
  > /Jong

      Thanks for your interest.

      /Jaehoon

  > -----Original Message-----
  > From: [email-masked] [mailto:[email-masked]] On Behalf Of Jaehoon Jeong
  > Sent: Sunday, June 15, 2003 12:25 PM
  > To: [email-masked]
  > Subject: [nemo] Request for your comments on a new RO draft
  >  
  > Hello, nemo guys! 
  >  
  > I submitted a new draft about the Route Optimization (RO) for mobile nodes in mobile network. 
  >  
  >  Title : ND-Proxy based Route Optimization for Mobile Nodes in Mobile Network 
  >  URL for the Draft : http://www.ietf.org/internet-drafts/draft-jeong-nemo-ro-ndproxy-00.txt 
  >  
  > It is based on ND-Proxy for supporting multi-link subnet.
  > Whenever a mobile router moves into another access network, 
  > it provides its mobile network nodes with the network prefix of the access network.
  > This scheme makes the access network and mobile network become a multi-link subnet, 
  > allowing the local or visiting mobile nodes within the mobile network
  > to perform binding update for route optimization.
  >  
  > Though RO is not the current issue in nemo wg, I think, the research for RO is important in nemo. 
  > Through on-line discussion about RO, it may be good for us to prepare RO issue 
  > that can be discussed in earnest next year. 
  > So, I'd like to request your comments on my draft. 
  > Thanks. 
  >  
  > Regards, 
  > Jaehoon

---

From: "Jaehoon Jeong" <[email-masked]>
Date: Wed, 18 Jun 2003 22:45:54 +0900

Inlines :-)
  ----- Original Message ----- 
  From: Na, Jong Keun 
  To: 'Jaehoon Jeong' 
  Cc: 'NEMO WG' ; '박정수' ; '김형준' ; '이경진' ; '김병엽' ; '차현욱' 
  Sent: Tuesday, June 17, 2003 7:21 PM
  Subject: RE: [nemo] Request for your comments on a new RO draft

  Hi Jaehoon, 

  /Jong

       /Jaehoon

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]] On Behalf Of Jaehoon Jeong
  Sent: Monday, June 16, 2003 3:51 PM
  To: Na, Jong Keun
  Cc: NEMO WG; 박정수; 김형준; 이경진; 김병엽; 차현욱; 정재훈
  Subject: Re: [nemo] Request for your comments on a new RO draft

  Hi, Jong Keun.

  inlines:-)

      /Jaehoon