Subject: [nemo] nemo basic support ptotocol draft.

From: "Muhammad Ali Malik" <[email-masked]>
Date: Tue, 24 Jun 2003 15:37:37 +1000

Hi

I have following question about multicast group for mobile router.

>> If mobile router want to join a multicast group while MR is in foreign
location, it needs to join the multicast group via bidirectional tunnel.

>> Is there any way by which mobile network node can individually join the
multicast group.

Cheers
Muhammad

---

From: Greg Daley <[email-masked]>
Date: Wed, 25 Jun 2003 11:10:20 +1000

Hi Muhammad,

Muhammad Ali Malik wrote:
 >           Hi Greg
 >
 > This means that mobile network node (MNN) should request MR, if it
 > wants to join any multicast group. Even with multicasting, all message
 > From MNN to CH will have to travel on bi-directional tunnels.

The MNN has to join the group on its AR which may or may not
be an MR.

Multicast routing could be run on the NEMO,
over the tunnel, but the packet flow is
unidirectional for client multicast traffic.

 >            Is there any way we can avoid the bi-directional tunneling by
 > requesting MR to join the multicast group on behalf of Mobile Network.

Yes, Maybe.

There's nothing defined yet. (there's not even much work
done for mobile hosts in this case, that would have to be done
first, since the MR is a host to the visited net).

Greg

---

From: Greg Daley <[email-masked]>
Date: Wed, 25 Jun 2003 11:10:20 +1000

Hi Muhammad,

Yes, Maybe.

Greg