Subject: [nemo] please help me

From: ashok kumar <[email-masked]>
Date: Wed, 4 Jun 2003 21:11:11 -0700 (PDT)

sir,
i ashok is pursuing M-Tech is working on a project on mobile ip .i have some questoins regarding foreign agent visitors list.
 
(i) How does a foreing agent maintains the database of the mobile nodes (ie what data sturcture it uses)
(ii) how to determine the optimum number of  mobile node FA can support without degradations of services (ie what are the considerartionms to be kept in mind to determine the optimum number.
madam i will be grate full to u
 
ashok

---------------------------------
Do you Yahoo!?
Free online calendar with sync to Outlook(TM).

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 06 Jun 2003 12:35:49 +0200

Hello Ashok,

ashok kumar wrote:
> i ashok is pursuing M-Tech is working on a project on mobile ip .i 
> have some questoins regarding foreign agent visitors list.

Foreign Agents are a concept mostly related to Mobile IPv4 for Mobile
Hosts; so maybe this question can be easily asnwered by someone in the
Mobile IP WG.  I think in this WG people look mostly at moving networks
(entire sets of hosts that move homogeneously), rather than Mobile Hosts.

> nodes (ie what data sturcture it uses)

Personally I do not know.  But I suppose you can imagine a list, or a table.

> (ii) how to determine the optimum number of  mobile node FA can 
> support without degradations of services (ie what are the 
> considerartionms to be kept in mind to determine the optimum number.

I suppose that can be determined by experimentation.  Install an FA and
an HA.  Then use a Mobile Host under the FA to file transfer a file from
a CN.  Then use two MH's under the same FA, doing the same file
transfer.  Then try three, four and so on, until a degradation in
service is noticed.

Publicly available software is available publicly to do these
experimentations.

Alex
GBU

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 06 Jun 2003 12:35:49 +0200

Hello Ashok,

Alex
GBU

---

From: William D Ivancic <[email-masked]>
Date: Mon, 09 Jun 2003 07:40:00 -0400

>
>>(ii) how to determine the optimum number of  mobile node FA can support 
>>without degradations of services (ie what are the considerartionms to be 
>>kept in mind to determine the optimum number.

This is a difficult question as it depends on may factors.  Those factor 
include:
Number of hosts
Type and amount of traffic being generated by each host
Size (computing power) of the FA
Computing power of the HA
Type of radio(s) used between the FA and Mobile Nodes.
Amount of movement into and out of the FA
FA, Mobile Node and HA advertisement, registration and binding timers.

For radio systems such as 802.11, I suspect the first area you would see 
performance drop off would be at the radio (bandwidth limit).

Will Ivancic

---

From: William D Ivancic <[email-masked]>
Date: Mon, 09 Jun 2003 07:40:00 -0400

Will Ivancic