Subject: [nemo] Security considerations for NEMO?

From: Greg Daley <[email-masked]>
Date: Mon, 30 Jun 2003 17:00:59 +1000

Hi All,

I've not heard any responses to Thierry's request for
NEMO security analysis?

Is anyone working on this now?

How about we look at issues in 3 areas:

Attacks on the MR at the visiting network
(similar to MIPv6 host issues, although
there may be further consequences for a
network).

Attacks on the NEMO's Resources,
(i.e, Bidirectional tunnel bandwidth,
routing attacks)

Attacks on nodes within a NEMO (are there any
special attacks?)

Are there any further areas to look at?

It may not look like a particularly interesting
area with the basic-NEMO solution, but we need a
basic security analysis before we can tackle RO.

Greg

---

From: "Souhwan Jung" <[email-masked]>
Date: Tue, 1 Jul 2003 06:23:47 +0900

Hi Greg and all,

We have been working on the threat analysis for NEMO, and we submitted a draft.
You can find my draft on the following location.
http://www.ietf.org/internet-drafts/draft-jung-nemo-threat-analysis-00.txt

Our approach is to build a generic threat model and to consider all possible threats from the scratch, which means that the threats are based on the assumption that no security mechanisms are available  for NEMO yet. This may not be true with the new draft of NEMO basic protocol.
In fact, our work was done before the new draft is announced.
 
Anyway, we keep working on updating our draft while analyzing the feasibility of those threats assuming the security mechanisms available in the draft of basic NEMO protocol.

Any comments to our draft will be helpful for us to update the draft.

Thanks.

Souhwan

---

From: "Souhwan Jung" <[email-masked]>
Date: Tue, 1 Jul 2003 06:23:47 +0900

Hi Greg and all,

 

Thanks.

Souhwan

---

From: Greg Daley <[email-masked]>
Date: Tue, 01 Jul 2003 10:20:48 +1000

Hello Souhwan

> Any comments to our draft will be helpful for us to update the draft.

I'll have to have a read of this before the meeting.

It may be a good thing to discuss some of the issues
on the list so that we get wide discussion of the
topics, and are able to identify additional areas
to cover.

I'll try to get some comments back as soon as possible.

Greg

---

From: Greg Daley <[email-masked]>
Date: Tue, 01 Jul 2003 10:20:48 +1000

Hello Souhwan

Greg