Subject: Re: [NEMO] Behavior of HA

From: cam <[email-masked]>
Date: Wed, 05 Nov 2003 19:11:37 -0000

On Wed, 05 Nov 2003 12:22:04 +0000, MATSUMOTO Taisuke 
<[email-masked]> wrote:

> I'm trying to implement the NEMO protocol stack, and I find a problem.
>
> I set up my test network according to the figure 1 in the basic support 
> draft page 28. See below.
>
>  +-------------------+ 3:: 2+-------+
>  |     Internet      |------| CN_MR |
>  +-------------------+      +-------+
>          4::      |
>                   |
>    2+-------------+3
>  +--+-+       +---+---+
>  | MR |       | HA_MR |
>  +--+-+       +-------+
> 5:: |1
> ----------
>     2|   +--+-+
>   | LFN|
>   +--+-+>>
>
> I tried to run the MR in the explicit prefix length mode. When the 
> mobile router was attached to the foreign link, the MR tried to send the 
> binding update message which consists of '5::1' for the home address and 
> '64' for the prefix length.
>
> But the HA rejected that BU message and returned the BA message with the 
> status code 132. This behavior is defined in the section 10.3.1 of the 
> mobile IPv6 draft, draft-ietf-mobileip-ipv6-24.txt.
>
>
> The explicit prefix length mode uses the IP address of the ingress 
> interface as the home address of the mobile router. In this case, the IP 
> address of the ingress interface is not an on-link IP address of the HA.

As a side issue, am I right in saying that the assumption for Explicit 
Prefix Length Mode is that the Home Address is the address on the MR's 
ingress interface?  This is something that confused me when I recently 
read the NEMO spec.  I had thought, as with MIPv6, that the Home Address 
would be the address on the egress interface and so, couldn't see how the 
prefix could be obtained from the Home Address.

Should the spec make this clear?

Cheers,
cam
-- 
[email-masked]

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 05 Nov 2003 12:00:43 -0800

cam wrote:

> ingress interface?  

yes.

> This is something that confused me when I recently 
> would be the address on the egress interface 

Nemo relaxes this. the Home Address can be assigned to any interface
(even a virtual interface).

and so, couldn't see how
> the prefix could be obtained from the Home Address.

> Should the spec make this clear?

section 3 contains

    A Mobile Router has an unique Home Address through which it is always
    reachable.  The Home Address is configured from a prefix that is
    aggregated and advertised by its Home Agent.  The prefix could either
    be the prefix advertised on the home link or the prefix delegated to
    the Mobile Router.  The Mobile Router can have more than one Home
    Address if there are multiple prefixes in the home link.

what clarification are you looking for?

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 05 Nov 2003 12:00:43 -0800

yes.

and so, couldn't see how

section 3 contains

Vijay

---

From: Thierry Ernst <[email-masked]>
Date: Thu, 6 Nov 2003 11:09:08 +0900

Hi,

> what clarification are you looking for?

May be a mention about "ingress interface" or "egress interface" of the MR ?

But my understanding is that this will be clarified in other document, won't it ?

Thierry.

---

From: Thierry Ernst <[email-masked]>
Date: Thu, 6 Nov 2003 11:09:08 +0900

Hi,

Thierry.

---

From: MATSUMOTO Taisuke <[email-masked]>
Date: Thu, 06 Nov 2003 10:04:58 +0000

Hi Thierry and all,

> But my understanding is that this will be clarified in other document, won't it ?

I'm sorry but I feel difficult to agree with your opinion. I think 
that the nemo basic support document should be enough to implement 
the basic mobile network.

I could implement the explicit prefix length mode because I knew 
Mr. Wakikawa's personal draft inputed before the San Francisco 
meeting. But after I read Mr./Ms. Cam's mail, I think that the 
basic support draft should be revised to have the clear 
description about the configuration of entities.

Any comments?

Taisuke

---

From: MATSUMOTO Taisuke <[email-masked]>
Date: Thu, 06 Nov 2003 10:04:58 +0000

Hi Thierry and all,

Any comments?

Taisuke

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 06 Nov 2003 22:32:49 +0100

cam wrote:
> As a side issue, am I right in saying that the assumption for 
> Explicit Prefix Length Mode is that the Home Address is the address 
> on the MR's ingress interface?  This is something that confused me 
> when I recently read the NEMO spec.  I had thought, as with MIPv6, 
> that the Home Address would be the address on the egress interface 
> and so, couldn't see how the prefix could be obtained from the Home 
> Address.

With implicit mode and explicit network mode, the Home Address is indeed
the address of the egress interface (the one that connects to the home
link).

People are free to implement whatever mode they see best fit.

With explicit prefix len mode, one could try to get a better
understanding by reading the explicit prefix len companion
draft-thubert-nemo-basic-usages-00.txt that describes particular home
networks that best accomodate the explicit prefix len mode.

> Should the spec make this clear?

There are several ways in which this spec can make the explicit prefix
len mode clearer.  One would be to eliminate entirely this mode from
basic, another would be to change the draft-thubert-... into a WG item
and yet another way would be to add a short phrase somewhere in the
current basic draft.  In this latter way please suggest a short phrase
that looks clear to you cam (Camelia?  C.A.M.?).

Also, if one considers the IPR aspects then it seems that the explicit 
prefix len mode is the only non-IPR'ed mode, that adds to the discussion.

Alex
GBU

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 06 Nov 2003 22:32:49 +0100

Alex
GBU