Subject: RE: [nemo] Explicit Prefix Length Option

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 25 Nov 2003 11:44:16 -0000

> -----Original Message-----
> From: Alexandru Petrescu [mailto:[email-masked]]
> Sent: mardi 25 novembre 2003 12:22
> To: Pascal Thubert (pthubert)
> Cc: [email-masked]
> Subject: Re: [nemo] Explicit Prefix Length Option
> 
> Pascal Thubert (pthubert) wrote:
> >
> >>-----Original Message-----
> >>From: Alexandru Petrescu [mailto:[email-masked]]
> >>Sent: mardi 25 novembre 2003 12:00
> >>To: Pascal Thubert (pthubert)
> >>Cc: James Kempf; [email-masked]
> >>Subject: Re: [nemo] RE: Explicit Prefix Length Option
> >>
> >>Pascal Thubert (pthubert) wrote:
> >>
> >>>This is what I was trying to say. Keep the MIPv6 model, and
> >>>implicitly extend that authorization to a given prefix length
around
> >>> the static home address. You can configure that HA to accept the
> >>>registration for a prefix around the home address, provided that
the
> >>> MR has proven its identity (the MIPv6 way), and with a minimum
> >>>configured prefix length. The explicit prefix extends the implicit
> >>>authorization in MIPv6.
> >>
> >>I think I understand what you're trying to say.  Authorize the Home
> >>Address as MIPv6 does it, and add a model where the value of the
> >
> > prefix
> >
> >>length is authorized too.
> >>
> >>But, an even _simpler_ method is to to authorize the Home Address as
> >>MIPv6 does it, and use the model of the Prefix Table where the
prefix
> >>itself is authorized too.  The Prefix Table is already described in
> >
> > the
> >
> >>base nemo spec.
> >>
> >>
> >>>This is what I was trying to say. Keep the MIPv6 model, and
> >>>implicitly extend that authorization to a given prefix length
around
> >>> the static home address.
> >>
> >>I'm not sure that the current nemo spec has the "extension" you
> >
> > propose.
> >
> >>Or I don't understand the "implicitly"(?)
> >>
> >>Anyways, I'm not saying that that extension of the len authorization
> >>you're mentioning above should be described in the basic support
> >
> > either,
> >
> >>based on the fact some advantages of the explicit prefix mode len
> >>itself (compared to implicit and explicit network modes) are yet to
be
> >>unveiled, IMHO.
> >>
> >>Alex
> >
> > Agreed: this is for the usage draft
> 
> So why not moving the prefix len option together with its yet-to-be
> written authorization entirely in the "usages" draft?
> 
"Usages" is not normative. If we need to standardize something, it's not
the right place. 

Pascal

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 25 Nov 2003 12:53:58 +0100

Pascal Thubert (pthubert) wrote:
> "Usages" is not normative. If we need to standardize something, it's 
> not the right place.

Yes, combine this with: if we need to standardize something it should be
advantageous, secure and straightforward implementation.

The only advantage of explicit prefix len mode up to now is savings in
bit-space in the BU messages.  Please analyze these savings for us.

With respect to security: it is in no way more secure to use the prefix
len mode rather than the implicit or the explicit network modes.  It is
less secure, see Alexis' post.

Straightforward implementation: there is an implementation of the
explicit prefix len mode.  It is not straightforward in that it poses
limits in the ways the Home Addresses are assigned to several mobile
routers of same HA such that MNP's don't overlap.  It is even less
straightforward in that it requires an implementer to read the "usages"
draft too.

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 25 Nov 2003 12:53:58 +0100

Alex