Subject: [nemo] Re: [Mip6] MIPv6 and IANA actions -- Status codes

From: Vijay Devarapalli <[email-masked]>
Date: Sun, 09 Nov 2003 13:41:29 -0800

I agree IANA action is required. the Nemo basic protocol
draft-ietf-nemo-basic-support-01.txt defines new binding ack status
values. this was discussed in the Nemo WG and we werent sure what to
do because Mobile IPv6 spec did not require IANA action.

the text you propose looks fine.

Vijay

Jari Arkko wrote:

> 
> Hi,
> 
> We are currently setting up the IANA registry for Mobile
> IPv6 reserved numbers with IANA. While doing this, we
> noticed that the current IANA Considerations section
> does not say anything about Status codes. Our thinking
> is that these values too need to be registered at IANA
> in the same manner as MH type codes and options.
> 
> If you think this is acceptable, I'd like to insert
> the following text to the draft (perhaps in AUTH48):
> 
>      Finally, this document creates a third new name space "Status
>      Code" for the Status field in the Binding Acknowledgement
>      message. The current values are described in Section 6.1.8, and
>      are the following:
> 
>            0 Binding Update accepted
> 
>            1 Accepted but prefix discovery necessary
> 
>          128 Reason unspecified
> 
>          129 Administratively prohibited
> 
>          130 Insufficient resources
> 
>          131 Home registration not supported
> 
>          132 Not home subnet
> 
>          133 Not home agent for this mobile node
> 
>          134 Duplicate Address Detection failed
> 
>          135 Sequence number out of window
> 
>          136 Expired home nonce index
> 
>          137 Expired care-of nonce index
> 
>          138 Expired nonces
> 
>          139 Registration type change disallowed
> 
>     Future values of the Status field can be allocated using standards
>     action [10].
> 
> --Jari
> 
> 
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mip6

---

From: Vijay Devarapalli <[email-masked]>
Date: Sun, 09 Nov 2003 13:41:29 -0800

Vijay