Subject: Re: [nemo] Explicit Prefix Length Option

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 25 Nov 2003 12:21:57 +0100

Pascal Thubert (pthubert) wrote:
> 
>>-----Original Message-----
>>From: Alexandru Petrescu [mailto:[email-masked]]
>>Sent: mardi 25 novembre 2003 12:00
>>To: Pascal Thubert (pthubert)
>>Cc: James Kempf; [email-masked]
>>Subject: Re: [nemo] RE: Explicit Prefix Length Option
>>
>>Pascal Thubert (pthubert) wrote:
>>
>>>This is what I was trying to say. Keep the MIPv6 model, and
>>>implicitly extend that authorization to a given prefix length around
>>> the static home address. You can configure that HA to accept the
>>>registration for a prefix around the home address, provided that the
>>> MR has proven its identity (the MIPv6 way), and with a minimum
>>>configured prefix length. The explicit prefix extends the implicit
>>>authorization in MIPv6.
>>
>>I think I understand what you're trying to say.  Authorize the Home
>>Address as MIPv6 does it, and add a model where the value of the
> 
> prefix
> 
>>length is authorized too.
>>
>>But, an even _simpler_ method is to to authorize the Home Address as
>>MIPv6 does it, and use the model of the Prefix Table where the prefix
>>itself is authorized too.  The Prefix Table is already described in
> 
> the
> 
>>base nemo spec.
>>
>>
>>>This is what I was trying to say. Keep the MIPv6 model, and
>>>implicitly extend that authorization to a given prefix length around
>>> the static home address.
>>
>>I'm not sure that the current nemo spec has the "extension" you
> 
> propose.
> 
>>Or I don't understand the "implicitly"(?)
>>
>>Anyways, I'm not saying that that extension of the len authorization
>>you're mentioning above should be described in the basic support
> 
> either,
> 
>>based on the fact some advantages of the explicit prefix mode len
>>itself (compared to implicit and explicit network modes) are yet to be
>>unveiled, IMHO.
>>
>>Alex
> 
> Agreed: this is for the usage draft

So why not moving the prefix len option together with its yet-to-be 
written authorization entirely in the "usages" draft?

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 25 Nov 2003 12:21:57 +0100

Alex