Subject: RE: [nemo] Charter proposal

From: "Vijay Devarapalli" <[email-masked]>
Date: Mon, 27 Mar 2006 11:11:15 -0800

hi Terry,

Global HAHA can address the two requirements. 
(http://www.ietf.org/internet-drafts/draft-thubert-nemo-global-haha-01.txt)
but for some reason, the NEMO WG has not been
able to take a decision on Global HAHA (its
been bouncing back and forth between NEMO and
Monami6 WGs). the NEMO WG has been sitting on
this draft for more than two years now, even
though you have expressed interest in it 
numerous times. there is no home for it 
currently.

Vijay

> 1- Without route optimization, a global platform (ship or plane) winds
> up with all their traffic then flowing in triangular routing as they
> move around the global.  Connexion by Boeing has demonstrated 
> that this
> triangular routing, when you are one or two continents 
> removed from your
> HA, can add up to three seconds of latency making it completely
> unacceptable for many applications.  (See our presentation to 
> the IAB in
> March of 2005)
> 
> 2- The normal state for an aircraft or ship will be to be connected to
> multiple INDENPENDANT (!!) service providers.  This is critical as not
> all providers are certified to carry "safety critical" 
> communications to
> these platforms.  Likewise, as the new global air traffic control
> systems grow, an aircraft will be connected to multiple "Navigation
> Service Providers(NSP)" (FAA, CAA, JAA, Eurocontrol, etc) 
> simultaneously
> especially as the handoff control from one nation's NSP to the next
> nation's.  Likewise, the more narrow bandwidth communication 
> links used
> for safety services and air traffic control will NOT be shared with
> general passenger Internet and voice services for obvious reasons
> (security, priority, QOS, etc).
> 
> Without meeting these two requirements, anything produced by NEMO is
> quite likely unusable by the large mobile network platforms, 
> especially
> aircraft.

> 
> Take care
> 
> Terry L Davis, P.E
> Boeing Technical Fellow
> 
> 
> > -----Original Message-----
> > From: Zhigang Huang [mailto:[email-masked]]
> > Sent: Friday, March 24, 2006 7:01 PM
> > To: T.J. Kniveton; ml-nemo WG
> > Subject: Re: [nemo] Charter proposal
> > 
> > Hi, T.J. Kniveton:
> > 
> > I think it is difficult to differentiate whether route optimization,
> > multihoming or other problems are relevant to NEMO 
> deployments or not.
> > 
> > would you like to describe it in detail?
> > 
> > ----- Original Message -----
> > From: "T.J. Kniveton" <[email-masked]>
> > To: "ml-nemo WG" <[email-masked]>
> > Sent: Saturday, March 25, 2006 4:27 AM
> > Subject: [nemo] Charter proposal
> > 
> > 
> > > Here is a starting point for charter update. Please send your
> comments.
> > >
> > > TJ
> > >
> > 
> > 
> 
> 
>

---

From: "Davis, Terry L" <[email-masked]>
Date: Mon, 27 Mar 2006 14:14:42 -0800

Vijay

I know it's in limbo.  :-)

I'm hopeful that more of the aviation and maritime industry folks will
begin to get interested this year to help us push the requirements for
our platforms.

My response was to make sure that NEMO knows we still have requirements
in the coming years as we begin to transition to IP-v6 and add more
connectivity to our platforms.

Take care
Terry

> From: Vijay Devarapalli [mailto:[email-masked]]
> Sent: Monday, March 27, 2006 11:11 AM
> To: Davis, Terry L; Zhigang Huang; T.J. Kniveton; ml-nemo WG
> Subject: RE: [nemo] Charter proposal
> 
> hi Terry,
>

---

From: "Dul, Andrew L" <[email-masked]>
Date: Tue, 28 Mar 2006 13:14:49 -0800

> Global HAHA can address the two requirements. 
(http://www.ietf.org/internet-drafts/draft-thubert-nemo-global-haha-01.t
xt)
> but for some reason, the NEMO WG has not been able to take a 
> decision on Global HAHA (its been bouncing back and forth 
> between NEMO and
> Monami6 WGs). the NEMO WG has been sitting on this draft for 
> more than two years now, even though you have expressed 
> interest in it numerous times. there is no home for it currently.
> 

I think there are other reasons why this draft hasn't moved forward
other than trying to figure out which working group should be solving
the problems. 

Aviation & maritime platforms are globally mobile, because they are
globally mobile this makes route optimization also an InterDomain
Routing issue.  

Even if you had global-haha implemented it would require multiple ASNs
to announce the mobile platform's address space.  That would likely
require cooperation among a number of network operators to truly get
route-optimization.   These network operators would also have to agree
to provide transit to other operators where the mobile platform was
currently homed.

Alternatively the mobile service provider would have to setup
infrastructure in multiple well connected and well peered global
locations just to prevent triangle routing from occuring.  The mobile
service provider would also have to provide a transit network to
transport traffic between the HA and the current attachment point.

I personally think there are interesting ideas in the global-haha draft,
but I'm not don't know if the operational deployment issues make it the
best path forward.

Andrew

> > move around the global.  Connexion by Boeing has demonstrated that 
> > this triangular routing, when you are one or two continents removed 
> > from your HA, can add up to three seconds of latency making it 
> > completely unacceptable for many applications.  (See our 
> presentation 
> > to the IAB in March of 2005)
> > 
> > multiple INDENPENDANT (!!) service providers.