Subject: RE: [nemo] I-D ACTION:draft-ietf-nemo-dhcpv6-pd-01.txt

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Mon, 6 Mar 2006 17:28:06 +0100

Hi Vijay:

That is a good question, with a larger scope than this draft. As you
say, we have the same problem with all the new extensions to MIP6,
including the NEMO based PD and MIPTRANS. We have to find a way to know
if one HA will be able to provide the service we want, and find out
which; and for that reason, in NEMO, we added the R bit.

For the next supports to come, I can see 2 options:

1) for purely incremental features, we could order them and have a level
in DHAAD. MN asks for a HA that supports at least version X and the
response has the list of all HAs with version >= requested.

2) for functions that could be turned on or off regardless of the level
of software (which is the case in DHCPv6PD for NEMO), I think we need a
bit to signal it.

I'd look at it the other way. What if we do not signal it? It seems to
cause limitations in deployment, like if one HA has it, all HAs MUST
have it. For DHCPv6PD, one could want to deploy with one HA being DR and
all the others not participating; without the bit, you force that all
HAs are at least relays... which in short term is non obvious since
relays are not standardized.

Now, what if the MR needs a prefix and one of the HA does not have the
support because it is back-level, or is not configured correctly whereas
at least one HA is configured appropriately? 
What happens? Do we force to upgrade all HAs? If not, the Delegation
might or might not fail; how then do we help the admin figure out the
problem? 

There are a number of reasons why we did it. Note that there is still a
lot of room (2 bytes) in both impacted places. I'd wish there was
another way, and maybe the list can help. But doing nothing is not
acceptable, is it?

Maybe we should have a general discussion on this in MIP6?

Pascal

>-----Original Message-----
>From: Vijay Devarapallli [mailto:[email-masked]]
>Sent: Friday, March 03, 2006 8:38 PM
>To: Ralph Droms (rdroms); Pascal Thubert (pthubert)
>Cc: [email-masked]; T.J. Kniveton; Thierry Ernst
>Subject: Re: [nemo] I-D ACTION:draft-ietf-nemo-dhcpv6-pd-01.txt
>
>hi,
>
>the draft looks good. I think its ready for a WG
>last call.
>
>however, I noticed that a whole new section on
>extending dynamic home agent address
>discovery has been included. I wonder if this
>necessary. we are adding a lot of new features
>to MIPv6 and NEMO. I dont think we should be
>extending DHAAD every time we define a new
>feature/extension. and there has also been a
>talk about deprecating DHAAD (I disagree with
>deprecating DHAAD). there is also a lot of work
>going on in the MIP6 WG on bootstrapping a
>mobile node. this includes configuring the right
>home agent for the right mobile node.
>
>section 3.5 by itself is fine with me.
>
>section
>
>Vijay
>
>On 3/2/06, [email-masked] <[email-masked]> wrote:
>> A New Internet-Draft is available from the on-line Internet-Drafts
directories.
>> This draft is a work item of the Network Mobility Working Group of
the IETF.
>>
>>         Title           : DHCPv6 Prefix Delegation for NEMO
>>         Author(s)       : R. Droms, P. Thubert
>>         Filename        : draft-ietf-nemo-dhcpv6-pd-01.txt
>>         Pages           : 11
>>         Date            : 2006-3-2
>>
>> One aspect of network mobility support is the assignment of a prefix
>>    or prefixes to a Mobile Router (MR) for use on the links in the
>>    Mobile Network.  DHCPv6 prefix delegation can be used for this
>>    configuration task.
>>
>> A URL for this Internet-Draft is:
>> http://www.ietf.org/internet-drafts/draft-ietf-nemo-dhcpv6-pd-01.txt
>>
>> To remove yourself from the I-D Announcement list, send a message to
>> [email-masked] with the word unsubscribe in the body
of the message.
>> You can also visit
https://www1.ietf.org/mailman/listinfo/I-D-announce
>> to change your subscription settings.
>>
>>
>> Internet-Drafts are also available by anonymous FTP. Login with the
username
>> "anonymous" and a password of your e-mail address. After logging in,
>> type "cd internet-drafts" and then
>>         "get draft-ietf-nemo-dhcpv6-pd-01.txt".
>>
>> A list of Internet-Drafts directories can be found in
>> http://www.ietf.org/shadow.html
>> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>>
>>
>> Internet-Drafts can also be obtained by e-mail.
>>
>> Send a message to:
>>         [email-masked].
>> In the body type:
>>         "FILE /internet-drafts/draft-ietf-nemo-dhcpv6-pd-01.txt".
>>
>> NOTE:   The mail server at ietf.org can return the document in
>>         MIME-encoded form by using the "mpack" utility.  To use this
>>         feature, insert the command "ENCODING mime" before the "FILE"
>>         command.  To decode the response(s), you will need "munpack"
or
>>         a MIME-compliant mail reader.  Different MIME-compliant mail
readers
>>         exhibit different behavior, especially when dealing with
>>         "multipart" MIME messages (i.e. documents which have been
split
>>         up into multiple messages), so check your local documentation
on
>>         how to manipulate these messages.
>>
>>
>> Below is the data which will enable a MIME compliant mail reader
>> implementation to automatically retrieve the ASCII version of the
>> Internet-Draft.
>>
>>
>>
>>
>>

---

From: "Vijay Devarapallli" <[email-masked]>
Date: Mon, 6 Mar 2006 12:21:16 -0800

> of software (which is the case in DHCPv6PD for NEMO), I think we need a

lets say DNS lookup for the HA's address as described
in draft-ietf-mip6-bootstrapping-split becomes the most
used mechanism to bootstrap a HA. extending DHAAD
is not going to help. we might need a new QNAME,
"_nemopd_ipv6_example.com". the DNS response would
list only HAs that support NEMO prefix delegation
(assuming those that support NEMO prefix delegation
support NEMO Basic Support also).

> another way, and maybe the list can help. But doing nothing is not

I dont know. maybe it is okay. it could be a deployment
issue. one should configure the mobile node with the
right home agent.

> Maybe we should have a general discussion on this in MIP6?

yes. that would help.

Vijay