Subject: RE: draft-thubert-nemo-global-haha-01.txt (was:[nemo]Charter proposal)

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Fri, 31 Mar 2006 16:56:49 +0200

Hi Marcelo:

I'lm not sure we 100% agree on the model.

In the draft, the fine grained Home routes are announced inside a mesh of tunnels between partner ISPs; like a VPN if you wish.

POPs (HAs or satellites) announce aggregations of homes, for their own, and their partners. When a POP gets packets for partners, it will route the packets over the mesh of tunnels. 

The main BGP sees only the main Home aggregations. That would be one entry per service provider that plays the game or something.

The value appears when there are a lot of satellites (as many as GGSNs?) with MIP proxy HAs deployed. In that case, some NHRP allows my proxy to find your proxy and they mount a tunnel dynamically for the traffic we exchange.

Pascal

>-----Original Message-----
>From: marcelo bagnulo braun [mailto:[email-masked]]
>Sent: Thursday, March 30, 2006 1:01 PM
>To: Ben McCarthy
>Cc: 'ml-nemo WG'
>Subject: Re: draft-thubert-nemo-global-haha-01.txt (was:[nemo]Charter proposal)
>
>So, we do agree that global HAHA implies announcing the home network
>into the global BGP routing table, and that each distributed home
>network impacts with an additional entry in the bgp table, right?
>
>wouldn't this imply global routing system scalability concerns?
>
>Regards, marcelo
>
>
>El 30/03/2006, a las 13:54, Ben McCarthy escribió:
>
>> Sorry, I read your initial question wrong, I thought you were
>> referring to
>> Boeing's BGP manipulation technique they use...
>> http://www.apnic.net/meetings/19/docs/sigs/routing/routing-pres-skeen-
>> global
>> -ip-netmob.pdf
>>
>> not Global HA-HA, my mistake.
>>
>> -----Original Message-----
>> From: marcelo bagnulo braun [mailto:[email-masked]]
>> Sent: 30 March 2006 11:26
>> To: Ben McCarthy
>> Cc: 'ml-nemo WG'; 'Simon Oosthoek'
>> Subject: Re: draft-thubert-nemo-global-haha-01.txt (was: [nemo]Charter
>> proposal)
>>
>>>
>>> [Ben] Apart from optimising the route between the MR and CNs or
>>> altering
>>> BGP, then the other option is exactly what Pascal is proposing
>>> (switching to
>>> a HA closer to the point-of-attachment to optimise the triangular
>>> route).
>>>
>>
>> perhaps i am failing to understand how this works, but wouldn't this
>> implies that each home network must be announced separately in BGP?
>>
>> regards, marcelo
>>
>>> Apart from that...???
>>>
>>> Cheers,
>>>
>>> Ben
>>>
>>>> Ben
>>>>
>>>>
>>>
>>

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 31 Mar 2006 17:20:53 +0200

Pascal Thubert (pthubert) wrote:
> In the draft, the fine grained Home routes are announced inside a 
> mesh of tunnels between partner ISPs; like a VPN if you wish.

"overlay networks"?

I think it is possible to build a working HAHA in a overlay network with
VPN.  But that would still be a closed network with a unique 
owner/admin/provider.

> When a POP gets packets for partners, it will route the packets over
> the mesh of tunnels.

Not clear how that works.

> The main BGP sees only the main Home aggregations. That would be one 
> entry per service provider that plays the game or something.
> 
> The value appears when there are a lot of satellites (as many as 
> GGSNs?) with MIP proxy HAs deployed. In that case, some NHRP allows 
> my proxy to find your proxy and they mount a tunnel dynamically for 
> the traffic we exchange.

Not sure how that works either.

I think for this work to progress it needs to be delimited in a more 
precise scope.  It's clear HAHA can't be done for the whole of the Internet.

Alex