Subject: RE: draft-thubert-nemo-global-haha-01.txt (was: [nemo] Charter proposal)

From: "Vijay Devarapalli" <[email-masked]>
Date: Thu, 30 Mar 2006 10:17:10 -0800

> > The good news is that TJ's revised charter has a line that 
> could cover
> > these discussions:
> > Aug 2006          Submit -00 draft on Route Optimization for
> > geographically distributed HAs
> >
> 
> right, but the proposed charted also states that:
> 
> The WG will:
> 
> - Ensure that solutions will scale and function for the different
> mobile network configurations, without requiring changes to
> Correspondent Nodes in the Internet. All solutions will aim at
> preserving route aggregation within the Internet and will satisfy an
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> acceptable level of security (a thorough survey of new threats and an
> analysis of their severity will be conducted for any changes 
> introduced  
> to the network).
> 
> I guess one of the points Andrew is pointing out is exactly with  
> respect to this issues, namely:
> 
> >> Even if you had global-haha implemented it would require 
> multiple ASNs
> >> to announce the mobile platform's address space.  That would likely
> 
> how would this affect aggregation?

it is very common today to advertise reachability 
to a particular network from different points in 
the Internet.

ofcourse, I do agree that route aggregation should
be preserved.

Vijay

> 
> imho we should first discuss and figure out if the operational  
> practices resulting from such a solution are acceptable before  
> chartering the work. I mean we should first figure out at least if  
> there seems to be a viable approach that fulfills the needs and  
> preserves scalability of the routing system
> 
> Regards, marcelo
> 
> 
> > We can propose global HAHA as a candidate, compete with 
> other proposals
> > and try to keep the best from all.
> >
> > Pascal
> >
> 
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 30 Mar 2006 20:49:26 +0200

[empirical playing with some numbers.]

> to a particular network from different points in 

That's /8 or less, from less than 10 points.  Here we talk /24 or more 
(there are 255 /8 prefixes, while there are 16777216 /24s).  And mobiles 
can be attached to much more than just 10 points.  No one could ever 
advertise that large number of routes from that many parts of Internet, 
not even two parts.

Worse with IPv6, where we talk /32 (usual operator boundary) vs /64 
prefixes (Ethernet end-user boundary).  /64 prefixes are much more 
numerous than IPv4 /24 prefixes.

Aggregation routing tables at core routers are like 120000 entries or 
so.  There'll be some time before they can run application traffic for 
16777216 routes, and run their routing protocol at the same time.

> ofcourse, I do agree that route aggregation should

I agree.

Alex