Subject: Re: [MEXT] FW: I-D Action:draft-muhanna-mext-binding-revocation-00.txt

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 1 May 2008 08:15:59 -0700 (PDT)

Hi Brian,
  I agree that generic notifications can support binding revocation. My concern is that there is no use case clearly defined in the generic notifications draft. As such it is too "generic". On the other hand binding revocation is more clearly defined, in fact it is (should be) part of BU/BA exchange semantics.
  For example, can you say that generic notifications can be used for handover? 
  Regards,

Behcet
----- Original Message ----
From: Brian Haley <[email-masked]>
To: Vijay Devarapallli <[email-masked]>
Cc: mext <[email-masked]>
Sent: Wednesday, April 30, 2008 1:48:02 PM
Subject: Re: [MEXT] FW: I-D Action:draft-muhanna-mext-binding-revocation-00.txt

Hi Vijay,

I've been talking with Ahmad and Sri about this off-line and we're 
trying to come to an agreement over some of the text in gen-notification 
to more easily support the revocation draft.  Hopefully an update will 
be agreeable to everyone, but I wouldn't necessarily hold-up the current 
revocation draft for it.  That's my thoughts at least.

-Brian

Vijay Devarapallli wrote:
> Hi Ahmad and others,
> 
> We previously had a discussion on this draft on the MIP6 mailing list
> and it was agreed that the binding revocation message will be a
> sub-type in the Generic Notification Message.
> http://www.ietf.org/internet-drafts/draft-haley-mext-generic-notification-message-00.txt
> 
> We would need to modify the generic notification message to include a
> new 'subtype' field. We had discussed this in the past and made no
> progress. We can start with the following values
> 
> 0 - Reserved, not used
> 1 - Notification message indicated by Mobility Options
> 2 - Binding Revocation Indication
> 3 - Binding Revocation Acknowledgement
> 4-255 reserved
> 
> The Generic Notification message draft is quite simple and shouldn't
> take too long to standardize. It would be a good idea to use the
> Generic Notification message as much as
> possible when you have something to notify to either the mobile node
> or the home agent. Otherwise we might end up with a proliferation of
> notification messages using up a lot of mobility header message types.
> 
> Vijay
> 
> On Tue, Apr 29, 2008 at 6:32 PM, Ahmad Muhanna <[email-masked]> wrote:
>> Hello All,
>>
>>  Please find the latest Binding Revocation for IPv6 Mobility draft at the
>>  below link.
>>  We highly value your review and comments!
>>
>>  Many Thanks in advance!
>>
>>  Best Regards,
>>  Ahmad
>>
>>
>>  -----Original Message-----
>>  From: [email-masked]
>>  [mailto:[email-masked]] On Behalf Of
>>  [email-masked]
>>  Sent: Tuesday, April 29, 2008 8:30 PM
>>  To: [email-masked]
>>  Subject: I-D Action:draft-muhanna-mext-binding-revocation-00.txt
>>
>>  A New Internet-Draft is available from the on-line Internet-Drafts
>>  directories.
>>
>>         Title           : Binding Revocation for IPv6 Mobility
>>         Author(s)       : A. Muhanna, et al.
>>         Filename        : draft-muhanna-mext-binding-revocation-00.txt
>>         Pages           : 32
>>         Date            : 2008-04-29
>>
>>  This document defines the revocation semantics for terminating a mobile
>>  node's mobility session and associated resources.  These semantics are
>>  generic enough and can be used by mobility entities in the case of
>>  Client Mobile IPv6 and its extensions.  This mechanism allows the
>>  mobility entity which initiates the revocation procedure to request its
>>  corresponding one to terminate either one, multiple or all specified
>>  binding cache entries.
>>
>>  A URL for this Internet-Draft is:
>>  http://www.ietf.org/internet-drafts/draft-muhanna-mext-binding-revocatio
>>  n-00.txt
>>
>>  Internet-Drafts are also available by anonymous FTP at:
>>  ftp://ftp.ietf.org/internet-drafts/
>>
>>  Below is the data which will enable a MIME compliant mail reader
>>  implementation to automatically retrieve the ASCII version of the
>>  Internet-Draft.
>>
>> _______________________________________________
>>  MEXT mailing list
>>  [email-masked]
>>  https://www.ietf.org/mailman/listinfo/mext
>>
>>
> 
_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: Brian Haley <[email-masked]>
Date: Fri, 02 May 2008 11:05:34 -0400

Hi Behcet,

Behcet Sarikaya wrote:
> Hi Brian,
>   I agree that generic notifications can support binding revocation. My 
> concern is that there is no use case clearly defined in the generic 
> notifications draft. As such it is too "generic". On the other hand 
> binding revocation is more clearly defined, in fact it is (should be) 
> part of BU/BA exchange semantics.

I'll let WG consensus decide if revocation should define two new MH 
types or use gen-notification.

>   For example, can you say that generic notifications can be used for 

Well, if I wrote the Generic Notification draft first, HA Switch could 
have maybe just been a mobility option.

-Brian

> Subject: Re: [MEXT] FW: I-D 
> Action:draft-muhanna-mext-binding-revocation-00.txt
> 
> Hi Vijay,
> 
>  > On Tue, Apr 29, 2008 at 6:32 PM, Ahmad Muhanna <[email-masked] 
> <mailto:[email-masked]>> wrote:
>  >> Hello All,
>  >>
> <mailto:[email-masked]>
>  >>  [mailto:[email-masked] 
> <mailto:[email-masked]>] On Behalf Of
>  >>  [email-masked] <mailto:[email-masked]>
>  >>  To: [email-masked] <mailto:[email-masked]>
>  >>  [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Fri, 2 May 2008 16:01:42 -0500

Hi Behcet, 
 
Thanks for your comments. 
Please see my comments inline.

Regards, 
Ahmad

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Behcet Sarikaya
	Sent: Thursday, May 01, 2008 10:16 AM
	To: Brian Haley
	Cc: [email-masked]
	Subject: Re: [MEXT] FW: I-D
Action:draft-muhanna-mext-binding-revocation-00.txt

	Hi Brian,
	  I agree that generic notifications can support binding
revocation.  
	[Ahmad]
	 
	Actually as you may remember, we spent a lot of time discussing
this few months back and the conclusion was that the semantic of Binding
Revocation is totally different than the Generic Notification Message
"Send it and forget about it, to borrow a line from MK posting:) 
	Actually, that why I personally proposed a compromise to kill
two birds in one stone: 

	1. Provide a mechanism to preserve the MH Type field by
Introducing a new Generic MH Subtype field to be used to define Generic
Mobility Header Subtype messages, e.g. Revocation messages, Generic
notification message, etc.
	 
	2. Provide a Generic framework to allow the introduction of
messages with different semantics and mechanism to co-exist, e.g.,
BRI/BRA and Generic Notification Message.
	 
	 My concern is that there is no use case clearly defined in the
generic notifications draft. As such it is too "generic".  
	 On the other hand binding revocation is more clearly defined,  
	[Ahmad]
	Thanks!
	 
	  in fact it is (should be) part of BU/BA exchange semantics.
	  For example, can you say that generic notifications can be
used for handover? 
	  Regards,
	
	Behcet
	
	----- Original Message ----
	From: Brian Haley <[email-masked]>
	To: Vijay Devarapallli <[email-masked]>
	Cc: mext <[email-masked]>
	Sent: Wednesday, April 30, 2008 1:48:02 PM
	Subject: Re: [MEXT] FW: I-D
	
	Hi Vijay,
	
	I've been talking with Ahmad and Sri about this off-line and
we're 
	trying to come to an agreement over some of the text in
gen-notification 
	to more easily support the revocation draft.  Hopefully an
update will 
	be agreeable to everyone, but I wouldn't necessarily hold-up the
current 
	revocation draft for it.  That's my thoughts at least.
	
	-Brian
	
	> sub-type in the Generic Notification Message.
http://www.ietf.org/internet-drafts/draft-haley-mext-generic-notificatio
n-message-00.txt
	>>  Subject: I-D
	>>        Filename        :
draft-muhanna-mext-binding-revocation-00.txt

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Fri, 2 May 2008 16:24:25 -0500

Hi Brian,
Please see comment inline.

Regards,
Ahmad

> > My concern is that there is no use case clearly defined in 
> the generic 
> I'll let WG consensus decide if revocation should define two 
> new MH types or use gen-notification.
> 
> >   For example, can you say that generic notifications can 
> be used for 
> > handover?
> 
> Well, if I wrote the Generic Notification draft first, HA 
> Switch could have maybe just been a mobility option.

[Ahmad]
It actually depends on the scope, for example, if we go a little back in
time and according to the "request/Reply" scope for the Generic
Notification Message that was mentioned earlier: may be; we could have
defined MIP6 BU/BA as Generic Notification Messages and closed all the
books and saved ourselves a lot of time and resources.

Cheers!

> > gen-notification to more easily support the revocation draft.  
> > Hopefully an update will be agreeable to everyone, but I wouldn't 
> > necessarily hold-up the current revocation draft for it.  
> That's my thoughts at least.
> > 
> > -Brian
> > 
> >  > We previously had a discussion on this draft on the MIP6 mailing 
> > list  > and it was agreed that the binding revocation 
> message will be 
> > a  > sub-type in the Generic Notification Message.
> >  >
> > 
> >  > We would need to modify the generic notification message 
> to include 
> > a  > new 'subtype' field. We had discussed this in the past 
> and made 
> > no  > progress. We can start with the following values  >  > 0 - 
> > Reserved, not used  > 1 - Notification message indicated by 
> Mobility 
> > Options  > 2 - Binding Revocation Indication  > 3 - Binding 
> Revocation 
> > Acknowledgement  > 4-255 reserved  >  > The Generic Notification 
> > message draft is quite simple and shouldn't  > take too long to 
> > standardize. It would be a good idea to use the  > Generic 
> > Notification message as much as  > possible when you have 
> something to 
> > notify to either the mobile node  > or the home agent. Otherwise we 
> > might end up with a proliferation of  > notification 
> messages using up 
> > a lot of mobility header message types.
> >  >
> >  > Vijay
> >  >
> >  >>  Please find the latest Binding Revocation for IPv6 
> Mobility draft 
> > at the  >>  below link.
> > <mailto:[email-masked]>] On Behalf Of  >>  
> >>  Sent: 
> > Tuesday, April 29, 2008 8:30 PM  >>  To: [email-masked] 
> > <mailto:[email-masked]>  >>  Subject: I-D 
> >  >>  A New Internet-Draft is available from the on-line 
> > Internet-Drafts  >>  directories.
> >  >>
> >  >>  This document defines the revocation semantics for 
> terminating a 
> > mobile  >>  node's mobility session and associated 
> resources.  These 
> > semantics are  >>  generic enough and can be used by 
> mobility entities 
> > in the case of  >>  Client Mobile IPv6 and its extensions.  This 
> > mechanism allows the  >>  mobility entity which initiates the 
> > revocation procedure to request its  >>  corresponding one to 
> > terminate either one, multiple or all specified  >>  
> binding cache entries.
> >  >>
> >  >>  [email-masked] <mailto:[email-masked]>  >>

---

From: Basavaraj Patil <[email-masked]>
Date: Fri, 16 May 2008 17:32:16 -0500

FWIW, I think Ahmad does have a point about whether to define a new MH type
message for revocation or to reuse the gen-notification message.
It is possible to consider revocation as merely a notification to the MN or
the MAG in the case of PMIP6 in which case the gen-notification approach is
sufficient.
However I think that the revocation of the binding is more than mere
notification. IMO, gen-notification is for purposes such as informing the MN
about other non-critical things. Revocation is tied to the mobility of the
MN and hence would be used to trigger possibly other actions (such as
recharging a prepaid account or connecting the MN to a provisioning site
etc.). 
So it makes sense to define revocation messages via new MH type.

While we can utilize the gen-notification messages to solve the revocation
problem as I do not see a major technical issue with it, it may not be the
most elegant one and this difference of views is more semantic than
syntactic.

-Raj

---

From: "Suresh Krishnan" <[email-masked]>
Date: Wed, 21 May 2008 17:36:58 -0400

Hi Folks,
  I think it is better to use different MH types for the revocation and
generic notification messages

a) The semantics of the messages are different
b) The security requirements for the messages are different

Cheers
Suresh 

> Behalf Of Basavaraj Patil
> Sent: May-16-08 6:32 PM
> To: ext Ahmad Muhanna; Brian Haley; Behcet Sarikaya
> Cc: [email-masked]
> FWIW, I think Ahmad does have a point about whether to define 
> a new MH type message for revocation or to reuse the 
> gen-notification message.
> It is possible to consider revocation as merely a 
> notification to the MN or the MAG in the case of PMIP6 in 
> which case the gen-notification approach is sufficient.
> However I think that the revocation of the binding is more 
> than mere notification. IMO, gen-notification is for purposes 
> such as informing the MN about other non-critical things. 
> Revocation is tied to the mobility of the MN and hence would 
> be used to trigger possibly other actions (such as recharging 
> a prepaid account or connecting the MN to a provisioning site etc.). 
> While we can utilize the gen-notification messages to solve 
> the revocation problem as I do not see a major technical 
> issue with it, it may not be the most elegant one and this 
> difference of views is more semantic than syntactic.
> 
> -Raj
> 
> 
> >> Well, if I wrote the Generic Notification draft first, HA Switch 
> >> could have maybe just been a mobility option.
> > 
> > [Ahmad]
> > It actually depends on the scope, for example, if we go a 
> little back 
> > in time and according to the "request/Reply" scope for the Generic 
> http://www.ietf.org/internet-drafts/draft-haley-mext-generic-notifica
> >> t
> >>> ion-message-00.txt
> >>>> 
> http://www.ietf.org/internet-drafts/draft-muhanna-mext-binding-revoca
> >> t
> >>> io
> >>>>>  n-00.txt
> >>>>>