Subject: Re: [MEXT] [IPsec] IPsec maintenance/extensions WG, summary so far

From: "Hui Deng" <[email-masked]>
Date: Fri, 16 May 2008 00:17:09 +0800

thanks Pasi's elaboration, see inline with ==>
Please allow me to cc MEXT,

2008/5/14  <[email-masked]>:
> Arnaud Ebalard wrote:
>
>> Sorry for joigning the discussion a little bit late. I should have
>> posted to make a proposal for some work on MIPv6/IPsec/IKE
>> interactions as WG items before.
>>
>> The IPsec-related elements you cite in your P.S. for MEXT were *not*
>> taken as Working Group items during the recent recharter (decision
>> of the chairs) even if there were people interested by working on
>> it. Some other functionalities have been preferred.
>>
>> At the moment, even if MIPv6 specification expects interactions
>> between IPsec stack and MIPv6 module for IPSec to survive movement,
>> no interface is defined. The 2 proposals I am aware of on that
>> topic:
>>
>> - draft-sugimoto-mip6-pfkey-migrate-04
>> - draft-qi-mip6-ikev2-interfacing-01
>>
>> are still now simple external documents.
>>
>> IMO, the main issue here is that the topic crosses different WG or
>> is related to different subjects (IPsec, MIPv6, IKE, PF_KEY). As you
>> wrote for the IPsec WG "the intent is *not* to collect all
>> IPsec-related work to one WG".
>>
>> What is happening in practice is that IPsec and MIPv6 will be
>> *separately* added new features (probably useful in a sense) but
>> will not or badly work together.
>>
>> Where should associated efforts and discussions be handled?
>
> When I mentioned Mobile IP specific extensions to IPsec, I meant
> things like RFC 5026.
==> So here you mean that it will be in the scope of Mobile IP WG?
after that, it need Security review for this kind of work?

thanks

-Hui
>
> As I wrote in my email, I think PF_KEY work does not fit within
> the scope of the possible WG charter (at least not now).
>
> Best regards,
> Pasi
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec
>
_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: <[email-masked]>
Date: Thu, 15 May 2008 23:00:10 +0300

Hui Deng wrote:

> >> The IPsec-related elements you cite in your P.S. for MEXT were
> >> *not* taken as Working Group items during the recent recharter
> >> (decision of the chairs) even if there were people interested by
> >> working on it. Some other functionalities have been preferred.
> >>
> >> is related to different subjects (IPsec, MIPv6, IKE, 
> >> PF_KEY). As you wrote for the IPsec WG "the intent is *not* to 
> >> collect all IPsec-related work to one WG".
> >>

I'm not taking any opinion on whether these drafts should be in 
the scope of MEXT WG or not. (But as I said earlier, nothing in the
IPsec maintenance/extensions WG discussion is intended to prevent 
other WGs from working on IPsec-related topics, if they choose 
to do so.)

Best regards,
Pasi