Subject: [Netconf] UTC in monitoring draft

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 29 Jul 2008 20:18:58 +0200

Hi,

the monitoring draft says:

   loginTime:
     Time (UTC) at which the session was established.

Since the data type is xs:dateTime, I think the '(UTC)' part does not
make sense and should be removed.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: "Mark Scott" <[email-masked]>
Date: Wed, 30 Jul 2008 11:03:27 -0400

Hi,

I'm not sure it doesn't make sense but UTC handling is already defined
in the xs:dateTime definition.

So I will remove it.

thx,
mark

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Juergen Schoenwaelder
Sent: Tuesday, July 29, 2008 2:19 PM
To: [email-masked]
Subject: [Netconf] UTC in monitoring draft

Hi,

   loginTime:

/js

---

From: "Mark Scott" <[email-masked]>
Date: Wed, 30 Jul 2008 11:03:27 -0400

Hi,

So I will remove it.

thx,
mark

-----Original Message-----

Hi,

   loginTime:

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 30 Jul 2008 17:31:04 +0200

On Wed, Jul 30, 2008 at 11:03:27AM -0400, Mark Scott wrote:
 
> I'm not sure it doesn't make sense but UTC handling is already
> defined in the xs:dateTime definition.

Since xs:dateTime takes care of time zones, why do you want to
restrict things to UTC? If you have a reason to restrict the timezone
to UTC, you might want to spell it out since I could not imagine one.

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 30 Jul 2008 17:31:04 +0200

/js

---

From: "Mark Scott" <[email-masked]>
Date: Wed, 30 Jul 2008 11:47:36 -0400

Sorry, I should have been clearer.  I said I would remove the reference
and the implied restriction.

This still leaves implementors free to limit the time reported to UTC if
they choose.  This is consistent with our products.  We report all
management data in UTC (where supported) to facilitate correlation
without the need for timezone conversion.  We defer conversion to the
presentation layer if/when needed.

Mark

-----Original Message-----
From: Juergen Schoenwaelder
[mailto:[email-masked]] 
Sent: Wednesday, July 30, 2008 11:31 AM
To: Scott, Mark (CAR:2Y01)
Cc: [email-masked]
Subject: Re: [Netconf] UTC in monitoring draft

> in the xs:dateTime definition.

Since xs:dateTime takes care of time zones, why do you want to restrict
things to UTC? If you have a reason to restrict the timezone to UTC, you
might want to spell it out since I could not imagine one.

/js

---

From: "Mark Scott" <[email-masked]>
Date: Wed, 30 Jul 2008 11:47:36 -0400

Mark

-----Original Message-----

/js