Subject: [Netconf] Netconf-partial-lock comment/discuss

From: Balazs Lengyel <[email-masked]>
Date: Mon, 19 Oct 2009 14:52:49 +0200

Hello Dan,
In the tracker https://datatracker.ietf.org/idtracker/ballot/3035 about the 
draft-ietf-netconf-partial-lock-09 you have the comment:

Discuss [2009-08-12]:
Late discussions among the editors and implementers of the NETCONF standard
raised the issue of possibly removing partial-lock for startup, since it was
clarified in 4741bis that startup cannot be modified with
edit-config. I am
holding a DISCUSS until the WG reaches the consensus on this issue.

ANSWER: startup and candidate datastores removed from the scope in the already stored -10 
draft. They can not be locked with partial-lock. Startup was removed due to the argument you 
raised, candidate because:
- partial-locking was always aimed predominantly towards the running database. 
Partially-Locking the candidate was always seen as a lesser use-case included for completeness.
- a number of people objected that having partial locking with a global commit operation will 
lead to problems
- the workgroup consensus was not broad enough

Please indicate if you can accept these answers!

regards Balazs

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320                  email: [email-masked]

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 20 Oct 2009 15:08:26 +0200

This looks fine. I have cleared my DISCUSS and changed my vote to a
'Yes'. 

Thank you for addressing my concerns. 

Regards,

Dan

> -----Original Message-----
> From: Balazs Lengyel [mailto:[email-masked]] 
> Sent: Monday, October 19, 2009 2:53 PM
> To: [email-masked]; Romascanu, Dan (Dan)
> Cc: netconf mailing list; [email-masked]
> Subject: Netconf-partial-lock comment/discuss
> 
> Hello Dan,
> In the tracker 
> https://datatracker.ietf.org/idtracker/ballot/3035 about the
> Late discussions among the editors and implementers of the 
> NETCONF standard raised the issue of possibly removing 
> partial-lock for startup, since it was clarified in 4741bis 
> that startup cannot be modified with edit-config. I am 
> ANSWER: startup and candidate datastores removed from the 
> scope in the already stored -10 draft. They can not be locked 
> with partial-lock. Startup was removed due to the argument 
> you raised, candidate because:
> - a number of people objected that having partial locking 
> with a global commit operation will lead to problems

---

From: "Bert (IETF) Wijnen" <[email-masked]>
Date: Tue, 20 Oct 2009 16:01:53 +0200

Thanks Dan,

So the last DISCUSS we're dealing with is the one from Alexey.
Lookingat that right now.

Bert Wijnen
Document shepherd