Subject: Re: [Netconf] Comments on draft-ietf-netconf-monitoring-08

From: Martin Bjorklund <[email-masked]>
Date: Thu, 01 Oct 2009 09:55:34 +0200 (CEST)

Juergen Schoenwaelder <[email-masked]> wrote:
> On Thu, Oct 01, 2009 at 08:43:05AM +0200, Martin Bjorklund wrote:
>  
> > > I am wondering why you use zero-based-counter32 and not just
> > > counter32.  Do we worry about the fact that this might rollover and
> > > become ambiguous?
> > 
> > This way you can easily see if e.g. any errors has happend in a
> > session.  You know that it starts from 0 when the session starts.
> 
> This is true only under the assumption that the counter did never roll
> over in a session. Is this assumption reasonable to make for the
> counters?

If the client knows that it has sent less than 2^32 rpcs on a session,
yes.

/martin

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 1 Oct 2009 12:37:32 +0200

> If the client knows that it has sent less than 2^32 rpcs on a session,

I am actually more concerned about this:

    container statistics {
      // ...
      uses CommonCounters {
        description
          "Global counters, accumulated from all sessions.";
      }
    }

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 1 Oct 2009 14:06:41 +0200

Hi,

> > Furthermore, we
> > should import relevant types from ietf-netconf (SessionId 
> can clearly
> > be imported). The NETCONFDatastoreType should probably be 
> provided by
> > ietf-netconf (after renaming).
> 
> I agree in principle, but that would mean that this document will wait
> not only for YANG, but also for rfc4741bis.  Do we want to do that?

I wouldn't mind to define NETCONFDatastoreType in 
the monitoring draft based on RFC4741.

I think it is good if we can avoid any additional 
dependencies and delay.

Cheers,
Mehmet

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of ext Martin Bjorklund
> Sent: Thursday, October 01, 2009 8:43 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Netconf] Comments on draft-ietf-netconf-monitoring-08
> 
> Hi,
> 
> I will comment on some of your issues, and let Mark reply to the
> others.
> 
> 
> > On Mon, Sep 28, 2009 at 07:05:15PM +0200, Mark Scott wrote:
> >  
> > > This version addresses action items from IETF75 and mailing list
> > > comments.  Most significant is the decision to adopt YANG as
> > > normative for this draft.
> > 
> > I still do not like the capitalized identifiers.
> 
> +1
> 
> > Furthermore, we
> > should import relevant types from ietf-netconf (SessionId 
> can clearly
> > be imported). The NETCONFDatastoreType should probably be 
> provided by
> > ietf-netconf (after renaming).
> 
> I agree in principle, but that would mean that this document will wait
> not only for YANG, but also for rfc4741bis.  Do we want to do that?
> 
> > I think all definitions should have proper descriptions. 
> Not all have
> > them.
> > 
> > What is the reason to define groupings inline?
> 
> Do you prefer to export all groupings?
> 
> 
> /martin
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>