Subject: Re: [Netconf] [Technical Errata Reported] RFC4742 (1903)

From: Margaret Wasserman <[email-masked]>
Date: Mon, 12 Oct 2009 13:19:35 -0400

Hi Bert,

My ThingMagic e-mail address is no longer valid, please use [email-masked] 
.

I have reviewed the errata, and I think that the report is correct;  
the namespace is missing from the example and should be added.

Margaret

On Oct 11, 2009, at 4:05 PM, Bert Wijnen (IETF) wrote:

> Hi Margaret,
> does your email at thingmagic still work?
> Do you ever look at it?
> Anyway at that email address there is an email about an errata rport  
> for RFc4742.
> Would be good if you could take a look and respond.
>
> Thanks, Bert
>
> ----- Original Message -----
> From: RFC Errata System
> To: [email-masked] ; [email-masked] ; [email-masked] 
>  ; [email-masked] ; [email-masked] ;[email-masked]
> Cc: [email-masked] ; [email-masked] ; [email-masked]
> Sent: Wednesday, October 07, 2009 7:22 PM
> Subject: [Technical Errata Reported] RFC4742 (1903)
>
>
> The following errata report has been submitted for RFC4742,
> "Using the NETCONF Configuration Protocol over Secure SHell (SSH)".
>
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=4742&eid=1903
>
> --------------------------------------
> Type: Technical
> Reported by: Xiang Li <[email-masked]>
>
> Section: 3.1
>
> Original Text
> -------------
> S: <?xml version="1.0" encoding="UTF-8"?>
>    S: <hello>
>    S:   <capabilities>
>    S:     <capability>
>    S:       urn:ietf:params:xml:ns:netconf:base:1.0
>    S:     </capability>
>    S:     <capability>
>    S:       urn:ietf:params:ns:netconf:capability:startup:1.0
>    S:     </capability>
>    S:   </capabilities>
>    S:   <session-id>4<session-id>
>    S: </hello>
>    S: ]]>]]>
>
>    C: <?xml version="1.0" encoding="UTF-8"?>
>    C: <hello>
>    C:   <capabilities>
>    C:     <capability>
>    C:       urn:ietf:params:xml:ns:netconf:base:1.0
>    C:     </capability>
>    C:   </capabilities>
>    C: </hello>
>    C: ]]>]]>
>
>
> Corrected Text
> --------------
> S: <?xml version="1.0" encoding="UTF-8"?>
>    S: <hello xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">
>    S:   <capabilities>
>    S:     <capability>
>    S:       urn:ietf:params:xml:ns:netconf:base:1.0
>    S:     </capability>
>    S:     <capability>
>    S:       urn:ietf:params:ns:netconf:capability:startup:1.0
>    S:     </capability>
>    S:   </capabilities>
>    S:   <session-id>4<session-id>
>    S: </hello>
>    S: ]]>]]>
>
>    C: <?xml version="1.0" encoding="UTF-8"?>
>    C: <hello xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">
>    C:   <capabilities>
>    C:     <capability>
>    C:       urn:ietf:params:xml:ns:netconf:base:1.0
>    C:     </capability>
>    C:   </capabilities>
>    C: </hello>
>    C: ]]>]]>
>
>
> Notes
> -----
> the netconf namespace is missing in the sample hello message (for  
> both client and server hello)
>
> Instructions:
> -------------
> This errata is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary.
>
> --------------------------------------
> RFC4742 (draft-ietf-netconf-ssh-06)
> --------------------------------------
> Title               : Using the NETCONF Configuration Protocol over  
> Secure SHell (SSH)
> Publication Date    : December 2006
> Author(s)           : M. Wasserman, T. Goddard
> Category            : PROPOSED STANDARD
> Source              : Network Configuration
> Area                : Operations and Management
> Stream              : IETF
> Verifying Party     : IESG
>
>
>
> No virus found in this incoming message.
> Checked by AVG - www.avg.com
> Version: 8.5.421 / Virus Database: 270.14.8/2425 - Release Date:  
> 10/09/09 08:10:00

---

From: "Bert (IETF) Wijnen" <[email-masked]>
Date: Tue, 13 Oct 2009 10:19:41 +0200

NETCONF WG participants,

Pls check the below and speak up if you do not agree or see any problems 
in approving this
errata report. If we hear no objections/concerns by 28 October 2009, we 
assume WG consensus
and we'll  ask our AD to approve the errata report as valid.

Bert and Mehmet

Margaret Wasserman wrote:
>> To: [email-masked] ; [email-masked] ; 
>> [email-masked] ; [email-masked] ; [email-masked] 
>> ;[email-masked]