Subject: [Netconf] FW: New Version Notification for draft-ietf-netconf-monitoring-09

From: "Mark Scott" <[email-masked]>
Date: Wed, 14 Oct 2009 13:47:09 -0400

Hello,

A new version (v9) of the NETCONF Monitoring Schema draft has been posted.

This version addresses mailing list comments received on v8:
- reversion of 'session-type' to 'transport'
- element naming consistency.  All lowerCamelCase names have been converted to 'hyphen-delimited' or 'netconf-style-naming' as it is sometimes referred to on the ML.  E.g.  'sessionType' -> 'session-type'.  This change impacts both the draft text and yang module.  
- <get-schema> operation updated:
	- now has only one mandatory parameter, 'identifier'
	- updated negative responses, including the rpc operation description in yang module
- comments added to the yang module indicating that the definition of 'session-id' is consistent with 4741bis 'session-id-type' and could be imported from that pending RFC.  Similar for 'netconf-datastore-type'.  This was in favour of adding further dependencies and delays by waiting for 4741bis to complete.
 
Please direct any comments on this version to the mailing list.

cheers,
Mark

-----Original Message-----
From: IETF I-D Submission Tool [mailto:[email-masked]] 
Sent: Wednesday, October 14, 2009 1:22 PM
To: Scott, Mark (CAR:2N00)
Cc: [email-masked]
Subject: New Version Notification for draft-ietf-netconf-monitoring-09 

A new version of I-D, draft-ietf-netconf-monitoring-09.txt has been successfuly submitted by Mark Scott and posted to the IETF repository.

Filename:	 draft-ietf-netconf-monitoring
Revision:	 09
Title:		 NETCONF Monitoring Schema
Creation_date:	 2009-10-14
WG ID:		 netconf
Number_of_pages: 30

Abstract:
This document defines a NETCONF data model to be used to monitor the
NETCONF protocol.  The monitoring data model includes information
about NETCONF datastores, sessions, locks and statistics.  This data
facilitates the management of a NETCONF server.  This document also
defines methods for NETCONF clients to discover data models supported
by a NETCONF server and defines a new NETCONF <get-schema> operation
to retrieve them.

The IETF Secretariat.

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 20 Oct 2009 14:36:24 +0200

Dear NETCONF WG, 

we had a good discussion on the NETCONF monitoring 
draft since the last WGLC in July. 

The draft Mark and Martin submitted solves the issues 
raised on the maillist and introduces the YANG model 
as normative. The new version of the draft appears to 
be stable for a final WGLC before we go one step further. 

With this mail we start a new WGLC for the NETCONF 
monitoring draft, which is planned to publish as a 
Proposed Standard RFC. The WGLC will run until 
November 2, 2009. 

All WG members PLEASE REVIEW the draft again and send 
your comments to the NETCONF maillist:

http://tools.ietf.org/html/draft-ietf-netconf-monitoring-09

Thank you. 

Mehmet

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of ext Mark Scott
> Sent: Wednesday, October 14, 2009 7:47 PM
> To: [email-masked]
> Subject: [Netconf] FW: New Version Notification 
> fordraft-ietf-netconf-monitoring-09
> 
> Hello,
> 
> - element naming consistency.  All lowerCamelCase names have 
> been converted to 'hyphen-delimited' or 
> 'netconf-style-naming' as it is sometimes referred to on the 
> ML.  E.g.  'sessionType' -> 'session-type'.  This change 
> impacts both the draft text and yang module.  
> - comments added to the yang module indicating that the 
> definition of 'session-id' is consistent with 4741bis 
> 'session-id-type' and could be imported from that pending 
> RFC.  Similar for 'netconf-datastore-type'.  This was in 
> favour of adding further dependencies and delays by waiting 
> for 4741bis to complete.
>  
> A new version of I-D, draft-ietf-netconf-monitoring-09.txt 
> has been successfuly submitted by Mark Scott and posted to 
> the IETF repository.
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Fri, 30 Oct 2009 16:10:51 +0100

Hi All,

this is a friendly reminder for the WGLC of the 
draft "NETCONF monitoring draft", which runs 
until November 2.

I would like to ask all to give the monitoring 
draft a chance and send your comments to the 
NETCONF maillist.

We are planning to bring the draft in the NETCONF 
session at IETF 76 to the next stage. So, please 
help to get it stable.

Thank you.

Mehmet

> [mailto:[email-masked]] On Behalf Of ext Ersue, 
> Mehmet (NSN - DE/Munich)
> Sent: Tuesday, October 20, 2009 2:36 PM
> To: [email-masked]
> Subject: [Netconf] WGLC for draft-ietf-netconf-monitoring-09
> 
> 
> Dear NETCONF WG, 
>