Subject: [netconf] Fwd: New Version Notification for draft-mahesh-netconf-https-notif-00.txt

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 26 Jun 2019 17:43:37 -0700

Just posted this new draft.

As the introduction says, the Subscribed Notifications draft defines a YANG module for configuring subscribed notifications. That module defines a subscription container that contains a list of receivers. But that draft defers the configuration and management of the receivers to other documents. This draft defines one of those transports and how to configure it.

Comments are welcome.

> Begin forwarded message:
> 
> 
> A new version of I-D, draft-mahesh-netconf-https-notif-00.txt
> has been successfully submitted by Mahesh Jethanandani and posted to the
> IETF repository.
> 
> Name:		draft-mahesh-netconf-https-notif
> Revision:	00
> Title:		An HTTPS-based Transport for Configured Subscriptions
> Document date:	2019-06-26
> Group:		Individual Submission
> Pages:		11
> URL:            https://www.ietf.org/internet-drafts/draft-mahesh-netconf-https-notif-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-mahesh-netconf-https-notif/
> Htmlized:       https://tools.ietf.org/html/draft-mahesh-netconf-https-notif-00
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-mahesh-netconf-https-notif
> 
> 
> Abstract:
>   This document defines a YANG data module for configuring HTTPS based
>   configured subscription, as defined I-D.ietf-netconf-subscribed-
>   notifications.  The use of HTTPS maximizes transport-level
>   interoperability, while allowing for encoding selection from text,
>   e.g.  XML or JSON, to binary.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 

Mahesh Jethanandani
[email-masked]

---

From: Qin Wu <[email-masked]>
Date: Thu, 27 Jun 2019 01:33:41 +0000

Interesting draft, a few quick questions?
1.Which other document are you refer to when you say "defers the configuration and management of the receivers to other documents"
Client server model documents? 
2.Does the mechanism defined this draft rely on call home to establish connection with the receiver or collector?
3. draft-ietf-netconf-restconf-notif also talks about HTTP based notification. Is this draft related to draft-ietf-netconf-restconf-notif-15? Or simply one focuses on configured subscription while the other focuses on dynamic subscription.

-Qin
-----邮件原件-----
发件人: netconf [mailto:[email-masked]] 代表 Mahesh Jethanandani
发送时间: 2019年6月27日 8:44
收件人: Netconf <[email-masked]>
主题: [netconf] Fwd: New Version Notification for draft-mahesh-netconf-https-notif-00.txt

Comments are welcome.

> has been successfully submitted by Mahesh Jethanandani and posted to 
> the IETF repository.
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 

Mahesh Jethanandani
[email-masked]

_______________________________________________
netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf