Subject: [netconf] RE： Adoption Call for draft-mahesh-netconf-https-notif-00

From: wangzitao <[email-masked]>
Date: Wed, 11 Sep 2019 07:58:06 +0000

Hi Kent,

Thank you for your reply.
I am trying to understand the relationship and usage of this draft and a set of netconf drafts:
This model present the receiver's information (such as IP, port, etc) and it augment the ietf-subscription-notification model that the user can specify multiple subscription receivers.
And the user also need to configure the server to specify receiver's port and IP (via ietf-client-server?). That the server can call home to the receivers.
Is my understanding correct? If yes, I suggest that a brief description of the workflow should be present in the draft.

Best Regards!
-Michael

发件人: Kent Watsen [mailto:[email-masked]]
发送时间: 2019年9月11日 13:16
收件人: wangzitao <[email-masked]>
抄送: [email-masked]
主题: Re: [netconf] Adoption Call for draft-mahesh-netconf-https-notif-00

Hi Michael,

IMHO, this model can be used in call-home scenarios, for example the server can initiate a transport session to those receivers in the subscription using the address and port specified.
Therefore, I suggest to add some attributes, such as Listen Port, to support call-home.

I'm not entirely sure I follow you.

Firstly, the draft is describing the NC/RC server initiating a protocol connection to a remote peer (the receiver).  So, in this since, it is "call home" already.

That said, maybe you mean "call home" in the sense of protocol-reversals (e.g., reverse TLS).  If so, note that the protocol being discussed here is more like Syslog than RESTCONF.   If it were Syslog, would you also to think there is a need to have a protocol-reversal?

Kent // as co-author

---

From: Kent Watsen <[email-masked]>
Date: Mon, 16 Sep 2019 16:00:48 +0000

Hi Michael,

> And the user also need to configure the server to specify receiver's port and IP (via ietf-client-server?).

What is " ietf-client-server" ?

> That the server can call home to the receivers.

This is a good suggestion.  We will add a section showing context.

Kent