Subject: Re: [netconf] Results of "Adoption Call for draft-mahesh-netconf-https-notif-00"

From: Qin Wu <[email-masked]>
Date: Wed, 11 Sep 2019 01:55:06 +0000

Agree with Warren's suggestion. I also believe this work can be progressed in parallel with client server model draft, at least TCP client server , TLS client server model draft. 
The model defined in these documents can be further reused in NETCONF client server model draft and RESTCONF client server model draft. 
What is tricky is where does ietf-http-client come from? It seems to me it come from draft-kwatsen-netconf-http-client-server-03, which is still an individual draft.

I also believe Martin's comments should be addressed.

-Qin
-----邮件原件-----
发件人: netconf [mailto:[email-masked]] 代表 Warren Kumari
发送时间: 2019年9月11日 5:05
收件人: [email-masked]; Ignas Bagdonas <[email-masked]>; Alissa Cooper <[email-masked]>
主题: [netconf] Results of "Adoption Call for draft-mahesh-netconf-https-notif-00"

Hi there all,

As both Netconf chairs are also authors of draft-mahesh-netconf-https-notif, they felt that it was inappropriate for them to also call consensus on this adoptionI'd suggest that the chair deputize a WG participant to make and needed consensus calls which may , and so have asked me to do so.

I've reviewed the meeting video, the minutes, and also the call for adoption thread (I wasn't subscribed to the mailing list, and so I read it on the archives, and cannot reply to the original thread). I view there being consensus for adoption of this document -- authors, please resubmit as draft-ietf-netconf-...  I'd also suggest that the chair deputize a WG participant to make and needed consensus calls which may come up during progression of the document.

As noted by Kent in
https://mailarchive.ietf.org/arch/msg/netconf/ndUBag_lngpt5nyBVol-CylPQpE,
Martin made a number of good points -- not sure if you'd like to address there before or after submitting the WG version of the document.
There was also a view that the WG should be focusing on getting the client-server work done -- this seems like a fine idea, but I think that, if the authors have time, they can work on this in parallel...

Thank you all,
W

--
I don't think the execution is relevant when it was obviously a bad idea in the first place.
This is like putting rabid weasels in your pants, and later expressing regret at having chosen those particular rabid weasels and that pair of pants.
   ---maf

_______________________________________________
netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Kent Watsen <[email-masked]>
Date: Wed, 11 Sep 2019 05:06:55 +0000

Hi Qin,

> What is tricky is where does ietf-http-client come from? It seems to me it come from draft-kwatsen-netconf-http-client-server-03, which is still an individual draft.

If you recall, we tried to adopt http-client-server at the same time as tcp-client-server, but the HTTPBIS chairs were troubled (the NETCONF chairs reached out to them as a curtesy).  We didn't have the energy at the time to walk them thru it, and the adoption didn't have to happen *immediately* (i.e., it's not one of the first three drafts NETCONF is trying to bring to Last Call).  All this to explain why it is still an I-D.   I think that this having both the https-notif and restconf-client-server drafts depending on http-client-server draft will help the HTTPBIS chairs understand the scope, specifically that it is minimal, which is what they wanted. 

Kent

---

From: Balázs Lengyel <[email-masked]>
Date: Wed, 11 Sep 2019 07:14:29 +0000

+1
Balazs

-----Original Message-----
From: netconf <[email-masked]> On Behalf Of Qin Wu
Sent: 2019. szeptember 11., szerda 3:55
To: Warren Kumari <[email-masked]>; [email-masked]; Ignas Bagdonas <[email-masked]>; Alissa Cooper <[email-masked]>
Subject: Re: [netconf] Results of "Adoption Call for draft-mahesh-netconf-https-notif-00"

-Qin
-----邮件原件-----
发件人: netconf [mailto:[email-masked]] 代表 Warren Kumari
发送时间: 2019年9月11日 5:05
收件人: [email-masked]; Ignas Bagdonas <[email-masked]>; Alissa Cooper <[email-masked]>
主题: [netconf] Results of "Adoption Call for draft-mahesh-netconf-https-notif-00"

Hi there all,

As noted by Kent in

Thank you all,
W