Subject: Re: [netconf] WGLC for draft-ietf-netconf-notification-capabilities

From: Qin Wu <[email-masked]>
Date: Wed, 11 Sep 2019 01:10:39 +0000

Support to move this work forward,  one quick question is
Since you have datastore level and node level capability, Is there any reason why module level capability is not included?

-Qin
发件人: netconf [mailto:[email-masked]] 代表 Mahesh Jethanandani
发送时间: 2019年9月11日 6:39
收件人: Netconf <[email-masked]>
主题: [netconf] WGLC for draft-ietf-netconf-notification-capabilities

Authors have published -04<https://tools.ietf.org/html/draft-ietf-netconf-notification-capabilities-04> version of the draft, which addresses comments they received in IETF 105. If you provided comments please check to make sure your comments have been addressed. At this point, the authors believe that the document is ready for WGLC.

This therefore starts a two week LC, ending on September 24th. Please provide any technical comments you might have on the document. If you believe the document is not ready for LC, please state your reasons.

We will issue a IPR poll separately.

Mahesh & Kent (as co-chairs)

---

From: Balázs Lengyel <[email-masked]>
Date: Wed, 11 Sep 2019 10:18:21 +0000

Hello Qin,

I did not add module level capabilities because:

In 99% of the cases module level capabilities can be handled  defining per-node-capabilities on one or a few top level containers, lists.   
No one proposed a use-case that could not be handled by the current YAM (Yang Module).
Adding a 4th level beside server/datastore/per-node would make the solution more complex, more difficult to understand.
Regards Balazs

From: netconf <[email-masked]> On Behalf Of Qin Wu
Sent: 2019. szeptember 11., szerda 3:11
To: Mahesh Jethanandani <[email-masked]>; Netconf <[email-masked]>
Subject: Re: [netconf] WGLC for draft-ietf-netconf-notification-capabilities

-Qin

发件人: netconf [ <mailto:[email-masked]> mailto:[email-masked]] 代表 Mahesh Jethanandani
发送时间: 2019年9月11日 6:39
收件人: Netconf < <mailto:[email-masked]> [email-masked]>
主题: [netconf] WGLC for draft-ietf-netconf-notification-capabilities

Authors have published -04 <https://tools.ietf.org/html/draft-ietf-netconf-notification-capabilities-04>  version of the draft, which addresses comments they received in IETF 105. If you provided comments please check to make sure your comments have been addressed. At this point, the authors believe that the document is ready for WGLC.