Subject: Re: [netconf] Adoption Call for draft-mahesh-netconf-https-notif-00

From: wangzitao <[email-masked]>
Date: Wed, 11 Sep 2019 01:55:44 +0000

Hi WG,

I support the adoption.
IMHO, this model can be used in call-home scenarios, for example the server can initiate a transport session to those receivers in the subscription using the address and port specified.
Therefore, I suggest to add some attributes, such as Listen Port, to support call-home.

Best Regards!
-Michael

发件人: netconf [mailto:[email-masked]] 代表 Kent Watsen
发送时间: 2019年8月27日 6:02
收件人: [email-masked]
主题: [netconf] Adoption Call for draft-mahesh-netconf-https-notif-00

This email begins a 2-week adoption poll for:

    https://tools.ietf.org/html/draft-mahesh-netconf-https-notif-00
In-room support for this draft was noted but, as always, it is necessary to confirm WG consensus on the list.  If interested in the WG defining an HTTPS-based solution for *configured subscriptions* (for which there are none to date), please voice your support for this draft's adoption.  If objecting, please state your reasons.

PS: Authors, please additionally respond to as if there is any IPR to disclose.

Kent and Mahesh // as chairs

---

From: Kent Watsen <[email-masked]>
Date: Wed, 11 Sep 2019 05:15:43 +0000

Hi Michael,

> Therefore, I suggest to add some attributes, such as Listen Port, to support call-home.

I'm not entirely sure I follow you.   

Firstly, the draft is describing the NC/RC server initiating a protocol connection to a remote peer (the receiver).  So, in this since, it is "call home" already.

That said, maybe you mean "call home" in the sense of protocol-reversals (e.g., reverse TLS).  If so, note that the protocol being discussed here is more like Syslog than RESTCONF.   If it were Syslog, would you also to think there is a need to have a protocol-reversal?

Kent // as co-author