Subject: Re: [netconf] RFC 8641 on Subscription to YANG Notifications for Datastore Updates

From: Qin Wu <[email-masked]>
Date: Wed, 11 Sep 2019 01:57:35 +0000

Congratulation to authors of YANG Push series drafts, good progress.

-Qin
-----邮件原件-----
发件人: netconf [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2019年9月10日 13:14
收件人: [email-masked]; [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]
主题: [netconf] RFC 8641 on Subscription to YANG Notifications for Datastore Updates

A new Request for Comments is now available in online RFC libraries.

        RFC 8641

        Title:      Subscription to YANG Notifications for 
                    Datastore Updates 
        Author:     A. Clemm,
                    E. Voit
        Status:     Standards Track
        Stream:     IETF
        Date:       September 2019
        Mailbox:    [email-masked], 
                    [email-masked]
        Pages:      58
        Characters: 120700
        Updates/Obsoletes/SeeAlso:   None

        I-D Tag:    draft-ietf-netconf-yang-push-25.txt

        URL:        https://www.rfc-editor.org/info/rfc8641

        DOI:        10.17487/RFC8641

This document describes a mechanism that allows subscriber applications to request a continuous and customized stream of updates from a YANG datastore.  Providing such visibility into updates enables new capabilities based on the remote mirroring and monitoring of configuration and operational state.

This document is a product of the Network Configuration Working Group of the IETF.

This is now a Proposed Standard.

STANDARDS TRACK: This document specifies an Internet Standards Track protocol for the Internet community, and requests discussion and suggestions for improvements.  Please refer to the current edition of the Official Internet Protocol Standards (https://www.rfc-editor.org/standards) for the standardization state and status of this protocol.  Distribution of this memo is unlimited.

This announcement is sent to the IETF-Announce and rfc-dist lists.
To subscribe or unsubscribe, see
  https://www.ietf.org/mailman/listinfo/ietf-announce
  https://mailman.rfc-editor.org/mailman/listinfo/rfc-dist

For searching the RFC series, see https://www.rfc-editor.org/search For downloading RFCs, see https://www.rfc-editor.org/retrieve/bulk

Requests for special distribution should be addressed to either the author of the RFC in question, or to [email-masked].  Unless specifically noted otherwise on the RFC itself, all RFCs are for unlimited distribution.

The RFC Editor Team
Association Management Solutions, LLC

_______________________________________________
netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 11 Sep 2019 12:58:17 -0400

I want to seconded Qin's congratulations for the authors of the notification
drafts. 
I also want to thank the authors as the I2RS co-chair and IDR chair for
their 
hard work in developing and progressing these needed features for
management. 

Sue Hares 

----------

-Qin
-----邮件原件-----
发件人: netconf [mailto:[email-masked]] 代表
[email-masked]
发送时间: 2019年9月10日 13:14
收件人: [email-masked]; [email-masked]
抄送: [email-masked]; [email-masked];
[email-masked]
主题: [netconf] RFC 8641 on Subscription to YANG Notifications for Datastore
Updates

        RFC 8641

        DOI:        10.17487/RFC8641

This document describes a mechanism that allows subscriber applications to
request a continuous and customized stream of updates from a YANG datastore.
Providing such visibility into updates enables new capabilities based on the
remote mirroring and monitoring of configuration and operational state.

This document is a product of the Network Configuration Working Group of the
IETF.

STANDARDS TRACK: This document specifies an Internet Standards Track
protocol for the Internet community, and requests discussion and suggestions
for improvements.  Please refer to the current edition of the Official
Internet Protocol Standards (https://www.rfc-editor.org/standards) for the
standardization state and status of this protocol.  Distribution of this
memo is unlimited.

For searching the RFC series, see https://www.rfc-editor.org/search For
downloading RFCs, see https://www.rfc-editor.org/retrieve/bulk

Requests for special distribution should be addressed to either the author
of the RFC in question, or to [email-masked].  Unless
specifically noted otherwise on the RFC itself, all RFCs are for unlimited
distribution.

The RFC Editor Team