Subject: [netconf] Upcoming updates to draft-ietf-netconf-udp-notif

From: Pierre Francois <[email-masked]>
Date: Thu, 22 Jul 2021 10:35:58 +0200

Hello everyone,

The changes brought to -03 followed feedback received from the group:

-- Added a private encoding option to allow for more verbose private
encoding description than what can be done in the ET Field.

-- Security section
We say this transport is not secure and alternative solutions should be
defined elsewhere so as to have a secure version of udp transport provided
by the IETF.
Note: One option could be draft-unyte-udp-notif-dtls, but we are not
mandating one particular solution in this draft.

We are suggesting the following changes in a -04 to be submitted once the
group agrees:

--IANA Section

Create IANA pools for Option type numbers and standard encoding type
numbers, and request values for the types already listed in the draft.

Once done, we could ping IANA to have an early allocation so that we could
release the collector code using the right values, and the Wireshark
dissector being developed could be merged into their main branch.

-- Update yang model
Adding segmentation configuration and maximum segment sizes.
Currently, only fragmentation configuration is supported.

IMHO, the -04 will be the version to be last called, but let's see how it
goes :)

Regards,

Pierre.

---

From: Kent Watsen <[email-masked]>
Date: Thu, 22 Jul 2021 11:29:29 +0000

Thank you, Pierre.

All, -03 was posted 10 days ago.  Here’s the direct link:  https://datatracker.ietf.org/doc/html/draft-ietf-netconf-udp-notif-03 <https://datatracker.ietf.org/doc/html/draft-ietf-netconf-udp-notif-03>.

More comments below.

K.

> On Jul 22, 2021, at 4:35 AM, Pierre Francois <[email-masked]> wrote:
> 
> 
> Hello everyone, 
> 
> We say this transport is not secure and alternative solutions should be defined elsewhere so as to have a secure version of udp transport provided by the IETF. 
> Note: One option could be draft-unyte-udp-notif-dtls, but we are not mandating one particular solution in this draft. 
> 
> We are suggesting the following changes in a -04 to be submitted once the group agrees:
> 
> --IANA Section
> 
> Create IANA pools for Option type numbers and standard encoding type numbers, and request values for the types already listed in the draft.

There is a discussion going on in the "Capability-fetching mechanisms” thread regarding switching from using an IANA-defined registry to using YANG identities.  I would be good to understand the pros/cons of each.  Ultimately it comes down to 1) writing RFCs requesting IANA to create new entries vs. 2) writing an RFC (or perhaps not) defining a YANG module that defines an identity that derives off a base identity defined in some new module (called, e.g., "ietf-notif-transport-capabilites”).  
.
K.

> Once done, we could ping IANA to have an early allocation so that we could release the collector code using the right values, and the Wireshark dissector being developed could be merged into their main branch. 
> 
> -- Update yang model
> IMHO, the -04 will be the version to be last called, but let's see how it goes :)
> 
> Regards, 
> 
> Pierre. 
> 
> 
> _______________________________________________
> netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf