Subject: Re: [Nethistory] DNS-in-a-wallet

From: "Ian Peter" <[email-masked]>
Date: Wed, 1 Jan 2014 19:58:45 +1100

pretty sure it would have only been numbers, but people here who were closer to the action might have some good anecdotal and additional  information

Ian Peter

From: Zach Lym 
Sent: Wednesday, January 01, 2014 6:28 PM
To: Ian Peter 
Cc: [email-masked] 
Subject: Re: [Nethistory] DNS-in-a-wallet

Thank you Peter, you have made my night!  Any chance you could help clarify if it was just IP addresses allocations or whether it included domain names as well? 

It part of a presentation I am giving on Namecoin DNS.  Bob's email would be idea?

Thank you, 
-Zach Lym

On Mon, Dec 30, 2013 at 10:53 PM, Ian Peter <[email-masked]> wrote:

  I think the original story is that Bob Kahn had it on one card in his pocket, but when it expanded to two cards he gave it to Jon Postel to manage. Bob refers to it here (towards the end of the article)

  http://www.nytimes.com/2013/12/31/science/viewing-where-the-internet-goes.html?_r=0

  Meanwhile a later piece of history is below – John Quartermans 1990 713 page book of all existing networks he could locate. Not all of these were TCP/IP at the time but over a period of about 3 years from then they would have all adopted TCP/IP or folded.

  http://books.google.com.au/books/about/The_Matrix.html?id=kwIjAAAAMAAJ&redir_esc=y

  Ian Peter

  From: Zach Lym 
  Sent: Tuesday, December 31, 2013 9:23 AM
  To: [email-masked] 
  Subject: [Nethistory] DNS-in-a-wallet

  My apologies if this is the wrong list to post this to, but I have a historical anecdote that I'm trying to chase down.  I thought this was the most appropriate forum to do so.

  I had a memory of one of the early internet engineers storing a copy of the IP address allocations or DNS mappings in her/his wallet.  Then if someone asked her/him for and IP or domain (I can't remember which) s/he would write it down on the list and then update the server when s/he got back to it.

  I would be grateful if you could direct me to a better list or circulate this email among knowledgeable individuals.

  Thank you, 
  -Zach Lym

------------------------------------------------------------------------------
  _______________________________________________
  Nethistory mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/nethistory

---

From: Guy Almes <[email-masked]>
Date: Wed, 01 Jan 2014 09:33:06 -0600

Ian / Zach,
   I strongly suspect that the days when all the IP address allocations 
fit on Bob's two cards were long before there were domain names.
	-- Guy

On 1/1/14, 2:58 AM, Ian Peter wrote:
> pretty sure it would have only been numbers, but people here who were
> closer to the action might have some good anecdotal and additional
> information
> Ian Peter
> *From:* Zach Lym <mailto:[email-masked]>
> *Sent:* Wednesday, January 01, 2014 6:28 PM
> *To:* Ian Peter <mailto:[email-masked]>
> *Cc:* [email-masked] <mailto:[email-masked]>
> *Subject:* Re: [Nethistory] DNS-in-a-wallet
> Thank you Peter, you have made my night!  Any chance you could help
> clarify if it was just IP addresses allocations or whether it included
> domain names as well?
> On Mon, Dec 30, 2013 at 10:53 PM, Ian Peter <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     I think the original story is that Bob Kahn had it on one card in
>     his pocket, but when it expanded to two cards he gave it to Jon
>     Postel to manage. Bob refers to it here (towards the end of the article)
>     Meanwhile a later piece of history is below – John Quartermans 1990
>     713 page book of all existing networks he could locate. Not all of
>     these were TCP/IP at the time but over a period of about 3 years
>     from then they would have all adopted TCP/IP or folded.
>     *From:* Zach Lym <mailto:[email-masked]>
>     *Sent:* Tuesday, December 31, 2013 9:23 AM
>     *To:* [email-masked] <mailto:[email-masked]>
>     *Subject:* [Nethistory] DNS-in-a-wallet
>     My apologies if this is the wrong list to post this to, but I have a
>     historical anecdote that I'm trying to chase down.  I thought this
>     was the most appropriate forum to do so.
>
>     I had a memory of one of the early internet engineers storing a copy
>     of the IP address allocations or DNS mappings in her/his wallet.
>     Then if someone asked her/him for and IP or domain (I can't remember
>     which) s/he would write it down on the list and then update the
>     server when s/he got back to it.
>     I would be grateful if you could direct me to a better list or
>     circulate this email among knowledgeable individuals.
>     Thank you,
>     -Zach Lym
>     ------------------------------------------------------------------------
>     [email-masked] <mailto:[email-masked]>

---

From: Geoff Thompson <[email-masked]>
Date: Wed, 1 Jan 2014 08:17:45 -0800

Guy-
My memory is from the 73-74 time frame.
The allocations on Bob's two cards would only have been for the top  
level
The ARPAnet was still quite small and the map diagrams of network  
hosts still fit on one 8 1/2 X 11 sheet of paper.
I believe that there were domain names at that point.
My earliest recollections of e-mail (that period) and finger had  
domain names

I would suggest asking Bob Taylor

Geoff

On Jan 1, 2014, at 7:33 AM, Guy Almes wrote:

> Ian / Zach,
>  I strongly suspect that the days when all the IP address  
> allocations fit on Bob's two cards were long before there were  
> domain names.
> 	-- Guy
>

---

From: Geoff Thompson <[email-masked]>
Date: Fri, 10 Jan 2014 22:59:30 -0800

With respect to naming...
(our discussion of a couple of weeks ago)
See the diagram on page 8 of the attachment.

	Geoff