Subject: [netlmm] For comments: draft about PMIPv6 service negotiation

From: xiayangsong 24512 <[email-masked]>
Date: Wed, 02 May 2007 22:09:41 -0500

Hi all

Comments are welcomed for the draft:
http://tools.ietf.org/wg/netlmm/draft-xia-netlmm-service-negotiation-00.txt

abstract:
      Proxy Mobile IPv6 (PMIPv6) is network based mobility protocol which
   provides IP session continuity for a mobile node without its
   involvement in mobility management.  PMIPv6 also can be viewed as a
   service and authorization provided by networks.  A mobile node can
   decide if it wants to use the service or not.  This proposal
   describes an Extensible Authentication Protocol(EAP) based mechanism
   for the service negotiation between a mobile node and an AAA server.

BR
Frank

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Frank Xia <[email-masked]>
Date: Fri, 11 May 2007 17:51:30 -0500

Hi Pierrick

Please refer to my inline comments

BR
Frank

----- Original Message ----- 
From: "SEITE Pierrick RD-RESA-REN" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Friday, May 11, 2007 9:36 AM
Subject: RE: [netlmm] For comments: draft about PMIPv6 service negotiation

Hi,

I went rapidly thought your document, it is well written but I have some questions for clarifications:

- it seems to me that service negociation using EAP is not specific to PMIP negociation, such a mechanism could be used to select/dynamically configure any network service on an AR/MAG. Did I miss something?

Frank=>Sure.  There are probably many parameters needs to negotiate using EAP,  such as bandwidth, priority and so on.
PMIP is just one of services.

- MAG needs to know if the MN chose to run CMIP or not (to perform PBU or not). In step 5, the AAA client configures itself and the MAG function. It is obvious if AAA client and MAG are collocated (MAG function and AR could not collocated), but it's worth to be clarified for a better understanding (IMHO).  

Frank=>OK.  In general speaking , these two entities are collocated

I have also some questions on use-cases given in the introduction:

One of the big advantages of PMIP is to make MN agnostic about mobility, thus enabling session continuity on CMIP non-capable MN. It is your use-case 1, but in this case there is nothing to negotiate for the MN. So what service negotiation brings here? 

Frank=>In this scenario, the result of the negotiaion is  PMIP service  which will be downloaded to MAG and MN. 

I do not understand scenario 2. "PMIPv6 is not necessary because simple IP host prefers local IP services, such as broadcast news, tourism information and so on". Do you mean that some applications do not need session continuity, so no need to run PMIP for MNs consuming such application? 

Frank=>Right.
In some scenarios, the simple IP MN node don't want any mobility service, and probably just want to access wireless networks.

Finally, one comment:

I think Use-cases 3 and 4 lead to the same question: should CMIP capable MN be allowed to run CMIP in a PMIP domain? From the network operator point of view, PMIP should be enabled by default to manage both non-CMIP and CMIP MN (especially if CMIP hosts can decide randomly to take benefit from PMIP or not). Actually, the motivation is to rationalise MN behaviour and to simplify attachment processes.

Frank=> There are several drafts about  PMIP6 and MIP6 interworking.  Some transitioning scenarios between PMIP6 and MIP6 are listed.
Our proposal just defines a machanism about how to enable transitioning.  As to specific deployment, only part of scenarios are necessary.

Nevertheless, EAP based mechanism could be used to activate CMIP on MN when PMIP is not available in the domain.
Frank => Sure.

Thanks.
Frank => Thank you too.   

Regards,
Pierrick

-----Message d'origine-----
De : xiayangsong 24512 [mailto:[email-masked]] 
Envoyé : jeudi 3 mai 2007 05:10
À : [email-masked]; [email-masked]
Objet : [netlmm] For comments: draft about PMIPv6 service negotiation

Hi all

abstract:

BR
Frank