Subject: [netlmm] I-D ACTION:draft-ietf-netlmm-mn-ar-if-02.txt

From: [email-masked]
Date: Tue, 22 May 2007 18:50:02 -0400

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.
This draft is a work item of the Network-based Localized Mobility Management Working Group of the IETF.

	Title		: Network-based Localized Mobility Management Interface between Mobile Node and Mobility Access Gateway
	Author(s)	: S. Narayanan, J. Laganier
	Filename	: draft-ietf-netlmm-mn-ar-if-02.txt
	Pages		: 25
	Date		: 2007-5-22
	
This document describes an interface between mobile nodes (MN) and
   mobility access gateway (MAG) of a network-based localized mobility
   management (NETLMM) domain.  The interface has two functions which
   are invocated when a MN attaches and detaches from a MAG.  The
   attachment function let the MAG authenticate the MN identifier, does
   address(es) and default router configuration for the MN, and inform
   the MAG about the multicast listener state of the MN.  During a
   successful execution of the detachment function, the NETLMM protocol
   is triggered between the MAG and the localized mobility anchor (LMA).
   The detachment function let the MAG detect that the MN has left so
   that it can deregister the MN at the LMA using the NETLMM protocol.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-netlmm-mn-ar-if-02.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of 
the message. 
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 
username "anonymous" and a password of your e-mail address. After 
logging in, type "cd internet-drafts" and then 
"get draft-ietf-netlmm-mn-ar-if-02.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-netlmm-mn-ar-if-02.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Julien Laganier <[email-masked]>
Date: Wed, 23 May 2007 09:14:57 +0200

Folks,

A new version (see below) of the MN-MAG interface draft 
has been posted. Since the scope of the document 
changed a lot, I'm flushing the issue tracker state so 
we can start from scratch tracking issues of the new 
doc.

--julien

On Wednesday 23 May 2007 00:50, 
[email-masked] wrote:
> A New Internet-Draft is available from the on-line
> Internet-Drafts directories.
> This draft is a work item of the Network-based
> Localized Mobility Management Working Group of the
> IETF.
>
> 	Title		: Network-based Localized Mobility
> Management Interface between Mobile Node and
> Mobility Access Gateway Author(s)	: S. Narayanan, J.
> Laganier
> This document describes an interface between mobile
> nodes (MN) and mobility access gateway (MAG) of a
> network-based localized mobility management (NETLMM)
> domain.  The interface has two functions which are
> invocated when a MN attaches and detaches from a
> MAG.  The attachment function let the MAG
> authenticate the MN identifier, does address(es) and
> default router configuration for the MN, and inform
> the MAG about the multicast listener state of the
> MN.  During a successful execution of the detachment
> function, the NETLMM protocol is triggered between
> the MAG and the localized mobility anchor (LMA). The
> detachment function let the MAG detect that the MN
> has left so that it can deregister the MN at the LMA
> using the NETLMM protocol.
>
> To remove yourself from the I-D Announcement list,
> send a message to [email-masked] with
> the word unsubscribe in the body of the message.
> You can also visit
> https://www1.ietf.org/mailman/listinfo/I-D-announce
> Internet-Drafts are also available by anonymous FTP.
> Login with the username "anonymous" and a password
> of your e-mail address. After logging in, type "cd
> internet-drafts" and then "get
> draft-ietf-netlmm-mn-ar-if-02.txt".
>
> A list of Internet-Drafts directories can be found
> in http://www.ietf.org/shadow.html
> 	"FILE
> /internet-drafts/draft-ietf-netlmm-mn-ar-if-02.txt".
>
> NOTE:	The mail server at ietf.org can return the
> document in MIME-encoded form by using the "mpack"
> utility.  To use this feature, insert the command
> "ENCODING mime" before the "FILE" command.  To
> decode the response(s), you will need "munpack" or a
> MIME-compliant mail reader.  Different
> MIME-compliant mail readers exhibit different
> behavior, especially when dealing with "multipart"
> MIME messages (i.e. documents which have been split
> up into multiple messages), so check your local
> documentation on how to manipulate these messages.
>
> Below is the data which will enable a MIME compliant
> mail reader implementation to automatically retrieve
> the ASCII version of the Internet-Draft.

---

From: Julien Laganier <[email-masked]>
Date: Wed, 23 May 2007 09:43:22 +0200

Folks,

It would be great if some of you take some time to read 
the (short) document update and comment on the mailing 
list.

Best,

--julien

---

From: Bruno Mongazon-Cazavet <[email-masked]>
Date: Wed, 23 May 2007 11:56:10 +0200

> the (short) document update and comment on the mailing 
Hi Julien & Sathya,

I took some time to read your draft at:
http://www.ietf.org/internet-drafts/draft-ietf-netlmm-mn-ar-if-02.txt

Generally speaking, i think your draft contains interesting 
"informational" data related to the operation of PMIPv6.
In particular, where the PMIPv6 draft only refers to existing IPv6 
standards (for the sake of concision), your draft provides pertinent 
details and useful protocol charts that may help to understand the whole 
picture. There are also some interesting points regarding deployment 
architecture and issues.

However i really don't understand the need for defining something you 
call "an interface"  between  MN and MAG.
My understanding of PMIPv6 is that "the interface" between MN and MAG is 
just regular IPv6.
I guess what you describe as an interface (with MN_ATTACH, MN_DETACH 
functions and sub-functions) is more a local and logical interaction 
trigger than a protocol interface. Having a paragraph with title 
"Attachment of mobile to the network"  would have been sufficient for me 
to describe what you call MN_ATTACH function.

In that sense, the "interface" term and related talks as carried in the 
title and along the draft is IMHO confusing and deserves the pertinent 
"information" you otherwise provide in the draft.

To summarize, i would think your draft can gain interest (it definitely 
has interesting information) if the "interface"-oriented terminology and 
focus is replaced by a "behavior"-oriented terminology. If you evolve in 
that sense, i would appreciate your draft to cover other operational 
aspects of PMIPv6 such as shared-link aspects.

Best regards, Bruno.