Subject: [netlmm] FW: some comments about your draft

From: qinxia <[email-masked]>
Date: Mon, 14 May 2007 17:06:46 +0800

Hello folks,

Below are reply to comments from Marco.
Welcome you join this discussion.

 * route optimization between CN and MAG

I am not sure, whether a local domain should allow a CN to set up
a route optimized path to the MN's MAG. One argument against is that
the domain's operator might not be interested in revealing address
information of infrastructure components to CNs (this is different
for client MIPv6!). 
Another reason is that such approach compensates
the location privacy effect of netlmm.

[qx] From the perspective of location privacy, CN would not like to make its current
location information (care-of address) known by mobile nodes. 
here, MN's MAG gets location information of CN, MAG is a network element and is
dependable. MN could not make use of CN location information without authorization. 

* Importance of return routability tests 

Relates to proxy home test and proxy care-of test procedure.
For the optimization of a route between MAGs, the return routability
tests should not be required, as MAGs of a local domain at least have an
indirect security association through the same set of LMAs. If MAGs
belong to different domains, security to set up an optimized route
should be arranged by means of roaming agreements.

[qx] proxy RRT method removes the requirement for detecting whether CN is behind the
MAG. wherever the CN is, Proxy home test message is sent to CN's home address. either
CN's MAG or CN itself can deal with this procedure.
sure, MAGs' security could be arranged by agreements. 

* Dependency on context transfer

Establishment of route optimization context on a handover MAG should
be possible without the need of a context transfer protocol. 
The handover procedure does not handle the case where both MNs hand off
at the same time 

[qx] for this point, I am not sure I understand your mean. in fig8, mobile node moves
from PMA1 to PMA2, PMA2 asks context from PMA1. PMA3 is searving for CN. Could you
clarify your question?

* Triggering with type 2 CNs (section 4)

The implicit mode will create problems in case the CN is a fixed node
without mobility support.
The explicit modes requires signaling from the MN, which is not really 
nice in the NetLMM context 

[qx] Fixed node may dump proxy RRT messages, or Fixed node's MAG can deal with route
optimization extension messages. IMO, no harm is done to fixed node. and this
extension does not support fixed node scenario.

* Signaling in 4.2

A 3 way handshake is used to setup route optimization. Wouldn't two 
messages be enough?

[qx] if only two messages are used, uni-directional tunnel is established, datagrams
are streamlined from  CN to MN, like this figure:
      PMA1                                              HA2        PMA3
       |                                                          |
|
       |  Binding Cache Request/Ack       |                  |
       |<------------------------------------------->|                  |
       |                                                          |
|
       |
|
       |           Proxy Binding Update                            |
       |---------------------------------------------------------- ->|
       |           Proxy Binding Acknowledgement         |
       |<------------------------------------------------------------|
       |
|
if you want datagrams from MN to CN are also transported over an optimal routing
path, you need do this again,like this figure:
      PMA1                                               HA2        PMA3
       |                                                            |
|
       |  Binding Cache Request/Ack         |                     |
       |<-------------------------------------------->|                     |
       |                                                            |
|
       |
|
       |           Proxy Binding Update                                |
       |--------------------------------------------------------------->|
       |           Proxy Binding Acknowledgement            |
       |<--------------------------------------------------------------|
       |
|
       |           Proxy Binding Update                               |
       |<-------------------------------------------------------------|
       |           Proxy Binding Acknowledgement          |
       |------------------------------------------------------------->|
       |
|
then you need four messages. In order to save signalling load,        
we proposes to use an 3 way handshake.

Best wishes
Alice
> -----Original Message-----
> From: Marco Liebsch [mailto:[email-masked]] 
> Sent: Wednesday, May 09, 2007 7:33 PM
> To: qinxia
> Cc: Julien Abeille
> Subject: some comments about your draft
> 
> Dear Alice,
> 
> as we had the chance to have a look to your proposal for 
> Proxy MIPv6 route optimization, please find some comments 
> below. I hope they are useful for some discussion.
> By the way, what was the reason to submit the I-D to MIPSHOP 
> and not to the NetLMM WG?
> 
> Best regards,
> marco
> 
> 
> 
> 
>  
> 
> 
> 
> 
> 
> 
> 
> 
_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Marco Liebsch <[email-masked]>
Date: Tue, 15 May 2007 17:03:37 +0200

Hi Alice,
please find our comments below.

>dependable. MN could not make use of CN location information without authorization. 
[ml] We were rather referring to the case, where the MN's location is revealed
to the CN, as the MAG establishes a direct route with the CN node.

>sure, MAGs' security could be arranged by agreements. 
[ml] In case route optimization between an MN's MAG and a CN, which is
not behind a MAG, is necessary, then the proxy RRT can be used, I agree.
But I am hesitating to support such scenario because of abovementioned reason.
In case each end-device has a MAG in the path, I don't see the
RTT as appropriate solution.

>from PMA1 to PMA2, PMA2 asks context from PMA1. PMA3 is searving for CN. Could you
[ml] What happens if CN moves from PMA3 to PMA4 while PMA2 sends the
PBU towards PMA3?

>extension does not support fixed node scenario.
[ja] The fixed node will indeed reject the messages, but it is not very 
nice to send unused signaling.

>       |  Binding Cache Request/Ack       |                  |

[ml] Yes, I see what you mean. But it might be possible to establish route
optimization states on both PMAs with one handshake, if the PBAck carries
all relevant information for PMA1.

Best regards,
marco

>>------------------------------------------------------------------------
>>
>>------------------------------------------------------------------------
>>
>>[qx] From the perspective of location privacy, CN would not like to make its current location information (care-of address) known by mobile nodes. 
>>here, MN's MAG gets location information of CN, MAG is a network element and is dependable. MN could not make use of CN location information without authorization. 
>>
>>[qx] proxy RRT method removes the requirement for detecting whether CN is behind the MAG. wherever the CN is, Proxy home test message is sent to CN's home address. either CN's MAG or CN itself can deal with this procedure.
>>[qx] for this point, I am not sure I understand your mean. in fig8, mobile node moves from PMA1 to PMA2, PMA2 asks context from PMA1. PMA3 is searving for CN. Could you clarify your question?
>>
>>[qx] Fixed node may dump proxy RRT messages, or Fixed node's MAG can deal with route optimization extension messages. IMO, no harm is done to fixed node. and this extension does not support fixed node scenario.
>>
>>* Signaling in 4.2
>>
>>[qx] if only two messages are used, uni-directional tunnel is established, datagrams are streamlined from  CN to MN, like this figure:
>>      PMA1                           HA2        PMA3
>>       |                              |           |
>>       |<---------------------------->|           |
>>       |                              |           |
>>       |                                          |
>>       |           Proxy Binding Update           |
>>       |----------------------------------------->|
>>       |<-----------------------------------------|
>>       |                                          |
>>if you want datagrams from MN to CN are also transported over an optimal routing path, you need do this again,like this figure:
>>      PMA1                           HA2        PMA3
>>       |                              |           |
>>       |<---------------------------->|           |
>>       |                              |           |
>>       |                                          |
>>       |           Proxy Binding Update           |
>>       |----------------------------------------->|
>>       |<-----------------------------------------|
>>       |                                          |
>>       |           Proxy Binding Update           |
>>       |<-----------------------------------------|
>>       |----------------------------------------->|
>>       |                                          |

---

From: qinxia <[email-masked]>
Date: Fri, 18 May 2007 15:23:43 +0800

Hi,

Some replys from Behcet, please see inlines.

Thanks

Alice 

> Sent: Tuesday, May 15, 2007 11:04 PM
> To: qinxia
> Cc: [email-masked]; 'Behcet Sarikaya'; 'Andy Huang'; 
> [email-masked]; Julien Abeille
> Subject: Re: FW: some comments about your draft
> 
> Hi Alice,
> >I am not sure, whether a local domain should allow a CN to set up a 
> >route optimized path to the MN's MAG. One argument against 
> is that the 
> >domain's operator might not be interested in revealing address 
> >information of infrastructure components to CNs (this is 
> different for 
> >client MIPv6!).
> >Another reason is that such approach compensates the 
> location privacy 
> >effect of netlmm.
> >
> >[qx] From the perspective of location privacy, CN would not like to 
> >make its current location information (care-of address) 
> known by mobile nodes.
> >here, MN's MAG gets location information of CN, MAG is a network 
> >element and is dependable. MN could not make use of CN 
> location information without authorization.
> >  
> >
> [ml] We were rather referring to the case, where the MN's 
> location is revealed to the CN, as the MAG establishes a 
> direct route with the CN node.
> 
[Behcet]It is MAG's address not MN's address that is revealed. We believe that should
be OK for most puposes, if not, there is possibility of using location privacy
between MAG and CN.

> >tests should not be required, as MAGs of a local domain at 
> least have 
> >an indirect security association through the same set of 
> LMAs. If MAGs 
> >[qx] proxy RRT method removes the requirement for detecting 
> whether CN 
> >is behind the MAG. wherever the CN is, Proxy home test 
> message is sent 
> >to CN's home address. either CN's MAG or CN itself can deal 
> with this procedure.
> [ml] In case route optimization between an MN's MAG and a CN, 
> which is not behind a MAG, is necessary, then the proxy RRT 
> can be used, I agree.

[Behcet] Happy to hear that.*

> In case each end-device has a MAG in the path, I don't see 
> the RTT as appropriate solution.
> 
> 

[behcet] OK, we will consider this in the revised draft.*

> >Establishment of route optimization context on a handover 
> MAG should be 
> >possible without the need of a context transfer protocol.
> >[qx] for this point, I am not sure I understand your mean. in fig8, 
> >mobile node moves from PMA1 to PMA2, PMA2 asks context from 
> PMA1. PMA3 
> >is searving for CN. Could you clarify your question?
> >  
> >
> [ml] What happens if CN moves from PMA3 to PMA4 while PMA2 
> sends the PBU towards PMA3?
> 
> 

[behcet] This is valid for MIP6 RO as well. We will consider a solution, there should
be one.*

> >[qx] Fixed node may dump proxy RRT messages, or Fixed node's MAG can 
> >deal with route optimization extension messages. IMO, no 
> harm is done 
> >to fixed node. and this extension does not support fixed 
> node scenario.
> >  
> >
> [ja] The fixed node will indeed reject the messages, but it 
> is not very nice to send unused signaling.
> 
[behcet] The point here is that CN could be a fixed node but it does implement Mobile
IPv6 CN behaviour. For fixed nodes that do not have CN functionality, no RO will be
attempted.*

> >      PMA1                                              HA2  
>       PMA3
> >      PMA1                                               HA2 
>        PMA3
> >       |           Proxy Binding Update                      
> >       |           Proxy Binding Update                      

[behcet] Yes, we will consider this, thanks.*

> >>[qx] From the perspective of location privacy, CN would not 
> like to make its current location information (care-of 
> address) known by mobile nodes. 
> >>here, MN's MAG gets location information of CN, MAG is a 
> network element and is dependable. MN could not make use of 
> CN location information without authorization. 
> >>
> >>[qx] proxy RRT method removes the requirement for detecting 
> whether CN is behind the MAG. wherever the CN is, Proxy home 
> test message is sent to CN's home address. either CN's MAG or 
> CN itself can deal with this procedure.
> >>[qx] for this point, I am not sure I understand your mean. 
> in fig8, mobile node moves from PMA1 to PMA2, PMA2 asks 
> context from PMA1. PMA3 is searving for CN. Could you clarify 
> your question?
> >>
> >>[qx] Fixed node may dump proxy RRT messages, or Fixed 
> node's MAG can deal with route optimization extension 
> messages. IMO, no harm is done to fixed node. and this 
> >>[qx] if only two messages are used, uni-directional tunnel 
> is established, datagrams are streamlined from  CN to MN, 
> like this figure:
> >>      PMA1                           HA2        PMA3
> >>       |                              |           |
> >>if you want datagrams from MN to CN are also transported 
> over an optimal routing path, you need do this again,like this figure:
> >>      PMA1                           HA2        PMA3
> >>       |                              |           |