Subject: [netlmm] Is DAD needed for MN-HoA in PMIPv6

From: Bruno Mongazon-Cazavet <[email-masked]>
Date: Mon, 21 May 2007 18:55:55 +0200

Hi all,

Just a question related to proxy mip6 draft:

If a Mobile Node is allowed/asked by a MAG to perform stateless address 
autoconf., does the mobile node needs to perform DAD procedure for the 
MN-HoA after it has received a MN-HNP and generated an interface identifier?

Thanks for your reply.
Bruno.

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Sri Gundavelli" <[email-masked]>
Date: Mon, 21 May 2007 18:58:18 -0700

Hi Bruno,

> -----Original Message-----
> From: Bruno Mongazon-Cazavet 
> [mailto:[email-masked]] 
> Sent: Monday, May 21, 2007 9:56 AM
> To: netlmm
> Subject: [netlmm] Is DAD needed for MN-HoA in PMIPv6
> 
> Hi all,
> 

The MAG has no control on this aspect. Just the considerations
from 2461 and 4429 (Optimisitic DAD) apply.

Sri

---

From: "Kandra Mohan-a22098" <[email-masked]>
Date: Tue, 22 May 2007 11:55:07 +0800

Hi Sri,

DAD is required only in case of shared prefix, right? In case of per-MN
prefix I think DAD is not required.
Is MN that intelligent in distinguishing between shared prefix and
per-MN prefix?

Regards,
Mohan

> From: Sri Gundavelli [mailto:[email-masked]]
> Sent: Tuesday, May 22, 2007 7:28 AM
> To: 'Bruno Mongazon-Cazavet'; 'netlmm'
> Subject: RE: [netlmm] Is DAD needed for MN-HoA in PMIPv6
> 
> Hi Bruno,
> 
>

---

From: RYUJI WAKIKAWA <[email-masked]>
Date: Thu, 24 May 2007 11:31:20 +0900

Hi Mohan,

On 2007/05/22, at 12:55, Kandra Mohan-a22098 wrote:

> Hi Sri,
>
> DAD is required only in case of shared prefix, right? In case of  
> per-MN prefix I think DAD is not required.
Whether the prefix is shared or per-MN doesn't matter. As Sri said,  
MN just follow the RFC2462.
> Is MN that intelligent in distinguishing between shared prefix and  
Why does MN need to know the prefix type?

ryuji

> > > If a Mobile Node is allowed/asked by a MAG to perform
>
> > > stateless address
>
> > > autoconf., does the mobile node needs to perform DAD
>
> > > procedure for the
>
> > > MN-HoA after it has received a MN-HNP and generated an
>
> > > interface identifier?
>
> > >
>
> >
>

---

From: "Kandra Mohan-a22098" <[email-masked]>
Date: Thu, 24 May 2007 12:31:47 +0800

Hi ryuji,

Please see online.

Thanks,
Mohan

> From: RYUJI WAKIKAWA [mailto:[email-masked]]
> Sent: Thursday, May 24, 2007 8:01 AM
> To: Kandra Mohan-a22098
> Cc: Sri Gundavelli; netlmm
> Subject: Re: [netlmm] Is DAD needed for MN-HoA in PMIPv6
> 
> Hi Mohan,
> 
[Mohan] In case of per-MN prefix as the prefix is unique, performing DAD
is not necessary, right, If DAD is enabled at MN.

> Why does MN need to know the prefix type?
[Mohan] I mean if MN can know the prefix type it can skip DAD operation
in case of per-MN prefix and the delay with DAD can be eliminated in
this case. That's it.

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 23 May 2007 23:07:42 -0700 (PDT)

> in case of per-MN prefix and the delay with DAD can be eliminated in

Global prefix is not shared, but both the MAG and the mobile is
sharing the same link. DAD is necessary for detecting link-local
address collision with the MAG. In any case, as Ryuji pointed
out, we are not attempting to change the host behaviour.

Sri

---

From: Ashutosh Dutta <[email-masked]>
Date: Fri, 25 May 2007 14:25:44 -0400

I guess if the interface on the mobile is *other* than "NOARP(e.g., 
PPP)", DAD should be performed independent of whether the prefix is 
Per-MN prefix or shared Prefix. Is that correct?

Thanks
Ashutosh

---

From: "Sri Gundavelli" <[email-masked]>
Date: Wed, 30 May 2007 23:22:32 -0700

Hi Ashutosh:

> From: Ashutosh Dutta [mailto:[email-masked]] 
> Sent: Friday, May 25, 2007 11:26 AM
> To: Sri Gundavelli
> Cc: Kandra Mohan-a22098; netlmm

Yes. DAD is used for establishing both the link-local address and
global address uniqueness on the link. So, it is independent of 
the prefix/link model. Even though we allocate a prefix for each
mobile, from the perspective of the mobile, its not leasing the
whole prefix, as in NEMO. Its just sharing the prefix.

W.r.t, link-local address uniqueness, for the PPP example, the
interface-identifier is negotiated by the peers as part of the
IPv6CP option negotiation. DAD may not be required for that case,
but that's just a recommendation.

As per IPV6CP [RFC-2472]:

"As long as the Interface Identifier is negotiated in the IPV6CP phase
of the PPP connection setup, it is redundant to perform duplicate
address detection as a part of the IPv6 Stateless Autoconfiguration
protocol [3].  Therefore it is recommended that for PPP links with
the IPV6CP Interface-Identifier option enabled the default value of
the DupAddrDetectTransmits autoconfiguration variable [3] be zero."

I think, we should just let the mobile decide on the DAD optimizations,
allow the normal host behavior, based on the link types and other
considerations such as ODAD, IMO.

Regards
Sri

---

From: Julien Laganier <[email-masked]>
Date: Thu, 31 May 2007 10:35:17 +0200

Hi Sri,

On Thursday 31 May 2007 08:22, Sri Gundavelli wrote:
> > From: Ashutosh Dutta
> > [mailto:[email-masked]] Sent:
> > Friday, May 25, 2007 11:26 AM
> > To: Sri Gundavelli
> > I guess if the interface on the mobile is *other*
> > than "NOARP(e.g., PPP)", DAD should be performed
> > independent of whether the prefix is Per-MN prefix
> > or shared Prefix. Is that correct?
>
> Yes. DAD is used for establishing both the
> link-local address and global address uniqueness on
> the link. So, it is independent of the prefix/link
> model. Even though we allocate a prefix for each
> mobile, from the perspective of the mobile, its not
> leasing the whole prefix, as in NEMO. Its just
> sharing the prefix.

If the MN has DNAv6, it will not re-DAD its MN-HoA 
after handover where the prefix advertized remains the 
same. DAD for MN-HoA only occurs at first attachment 
to a given NETLMM domain.

--julien

---

From: "Sri Gundavelli" <[email-masked]>
Date: Thu, 31 May 2007 20:14:44 -0700

Hi Julien,

> From: julien laganier [mailto:[email-masked]] On 
> Behalf Of Julien Laganier
> Sent: Thursday, May 31, 2007 1:35 AM
> To: [email-masked]
> Cc: Sri Gundavelli; 'Ashutosh Dutta'

Sure. The mobile may not do DAD in some cases, as in
for DNAv6. Now, that the link between the MN and the
AR is a p2p link, does DNAv6 spec cover the mobile's
behaviour on a p2p link ? For example it case of a 
PPP link ?

Thanks
Sri