Subject: Re: [netlmm] RtSol messages and draft-sarikaya-netlmm-prefix-delegation-00.txt

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 14 May 2007 08:22:59 -0700 (PDT)

Hello Kalin,
  If I understood well, you are talking about the scenarios in Figs. 3&4 which work as you described. In figs. 1 & 2, MAG does not have MN's profile (called policy store), so things start with RtSol.
  Did I miss something?

--behcet

----- Original Message ----
From: Kalin Getov <[email-masked]>
To: [email-masked]
Sent: Monday, May 14, 2007 7:51:16 AM
Subject: [netlmm] RtSol messages and draft-sarikaya-netlmm-prefix-delegation-00.txt

Hello all,

few toughts on the base draft and this (draft-sarikaya-netlmm-prefix-delegation-00) one, regarding PMIPv6...

is there a need to wait until the MN sends a RtSol message to the MAG? After a successful L2 access procedure the MAG gets the MN profile, right? If there is a HNP saved in the profile the MAG sends RA immediately, getting the prefix from it, if I got it correct. If not, the MAG waits until it gets the  home prefix from LMA or AAA, as described in 

draft-sarikaya-netlmm-prefix-delegation-00

only by initial connecton though, in the standard case (handover) the LMA already has a BCE for this MN with assigned HNP and sends it back with the PBAck message. One more time, should the MAG wait for RtSol from the MN? I prefer the case where the MAG sends the RA to the MN event triggered after successfuly getting the HNP in one way or another... This would accelerate the handover process also. 

-- 
******************************************
Best Regards
Kalin Getov

[email-masked]
******************************************

GMX FreeMail: 1 GB Postfach, 5 E-Mail-Adressen, 10 Free SMS.
Alle Infos und kostenlose Anmeldung: http://www.gmx.net/de/go/freemail

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Kalin Getov" <[email-masked]>
Date: Tue, 15 May 2007 13:09:27 +0200

Hello Behcet,

thanks for your answer,

yes I was keeping the base draft in mind, where the MAG should get the MN profile after authentication. Maybe in the next revision this will change. Is my assumption (to figs 3&4) that the RAs are sent event triggered after getting the HNP correct?  I mean without the need of small RA transmit intervals and timers.

Greetings,
Kalin

> Hello Kalin,
>   If I understood well, you are talking about the scenarios in Figs. 3&4
> which work as you described. In figs. 1 & 2, MAG does not have MN's profile
> (called policy store), so things start with RtSol.
>   Did I miss something?
> 
> --behcet
> 
> 
> Subject: [netlmm] RtSol messages and
> draft-sarikaya-netlmm-prefix-delegation-00.txt
> 
> 
> Hello all,
> 
> few toughts on the base draft and this
> (draft-sarikaya-netlmm-prefix-delegation-00) one, regarding PMIPv6...
> 
> is there a need to wait until the MN sends a RtSol message to the MAG?
> After a successful L2 access procedure the MAG gets the MN profile, right? If
> there is a HNP saved in the profile the MAG sends RA immediately, getting
> the prefix from it, if I got it correct. If not, the MAG waits until it gets
> the  home prefix from LMA or AAA, as described in 
> 
> only by initial connecton though, in the standard case (handover) the LMA
> already has a BCE for this MN with assigned HNP and sends it back with the
> PBAck message. One more time, should the MAG wait for RtSol from the MN? I
> prefer the case where the MAG sends the RA to the MN event triggered after
> successfuly getting the HNP in one way or another... This would accelerate
> the handover process also. 
> 
> 

[email-masked]