Subject: Re: Proposal forward on Global vs. Local Mobility (Re: [netlmm]Global vs. Local)

From: "Soininen Jonne (NSN FI/Espoo)" <[email-masked]>
Date: Fri, 18 May 2007 09:30:34 +0300

Kuntal,

Perhaps I was using a bit confusing term. What I mean was basically that
there is some way of creating the security association between the MAG and
LMA. In the lack of better words I used the "administrative relationship"
trying to avoid saying anything about MAG-MAG interaction.

I'm pretty sure there is somebody on the list who is capable of coming up
with a more accurate wording than I am... ;)

Cheers,

Jonne.

On 5/18/07 6:36 AM, "ext Chowdhury, Kuntal" <[email-masked]>
wrote:

> Hello Jonne,
> 
> Please clarify what you mean by administrative relationship between the
> MAGs. Did you intend to say security association between the MAG and the
> LMA? 
> 
> We have not discussed MAG - MAG interactions yet in the PMIP6 base
> draft. Also note that distribution of necessary credential(s) among the
> MAGs in a Proxy Mobile IPv6 Domain does not require context transfer
> between the MAGs. The credentials such as MN-ID can be distributed or
> obtained at a given MAG via the AAA infrastructure, or via context
> transfer or any other out-of-band methods.
> 
> Nevertheless, I am in agreement with the general concept in your
> proposal. Basically, we should define the requirements of the PMIP6
> protocol operation and leave the global vs. local applicability to the
> deployments.
> 
> Best regards,
> Kuntal
> 
> 
> 
> 
>> -----Original Message-----
>> From: Soininen Jonne (NSN FI/Espoo) [mailto:[email-masked]]
>> Sent: Wednesday, May 16, 2007 11:42 AM
>> To: [email-masked]
>> Subject: Proposal forward on Global vs. Local Mobility (Re:
> [netlmm]Global
>> vs. Local)
>> 
>> Hi everybody,
>> 
>> There now seems to have been a lot of discussion about this Global vs.
>> Local
>> issue. IMHO, I don't think we can come to even a rough consensus on
> these
>> two specific terms any time soon. However, there seems to be a need to
>> clarify the applicability of the protocol to make sure it fits the
> people
>> that would want to use it. I also checked rfc4830 and I tend to agree
> that
>> the definition of local might be a bit misleading.
>> 
>> <proposal> So, I would propose that we wouldn't continue the
> discussion
>> between global and local mobility management. Instead, we would kind
> of
>> add
>> text to the protocol document itself to clarify the applicability of
> the
>> protocol. Basically stating that the protocol can be used for mobility
> in
>> cases where there is an administrative relationship between the MAGs,
>> which
>> allows the needed credentials etc. to be distributed and to ensure the
>> handover is done securely. (I don't even try to propose the actual
> text
>> here.) </proposal>
>> 
>> How does this directions sound like? Would that satisfy the needs and
>> worries of (at least most of) the people involved in the discussion?
>> 
>> Cheers,
>> 
>> Jonne.
>> 
>> 
>> On 5/16/07 2:06 AM, "ext Chowdhury, Kuntal"
>> <[email-masked]>
>> wrote:
>> 
>>> Hi Julien,
>>> 
>>> Please see my comment inline...
>>> 
>>>> -----Original Message-----
>>>> From: Julien Laganier [mailto:[email-masked]]
>>>> Sent: Monday, May 14, 2007 9:49 AM
>>>> To: Alper Yegin
>>>> Cc: [email-masked]
>>>> Subject: Re: [netlmm] Global vs. Local
>>>> 
>>>> Alper,
>>>> 
>>>> I think we more or less agree.
>>>> 
>>>> In addition to NETLMM requirement 1) "presence of an SA
>>>> between LMA and MAG", I'll add requirement 2) presence
>>>> of a MAG in the access network. Since we can't assume
>>>> that both requirements are going to be satisfied on a
>>>> global basis in the Internet, I think NETLMM can't be
>>>> labelled as global mobility.
>>>> 
>>> [KC>] I think both the terms "global" and "local" are misleading. As
> you
>>> have pointed out the scalability issue of having SAs between all the
>>> possible MAGs and LMAs in the internet (i.e. the case against global
>>> applicability of PMIP6), similarly the term "local" w.r.t. PMIP6
>>> protocol is misleading if a MAG and a LMA in the internet has SA but
> are
>>> geographically far apart from each other.
>>> 
>>> Ideally, we should define the PMIP6 protocol such a way that as long
> as
>>> there is a SA between the MAG and the LMA, the security requirement
> for
>>> the protocol is satisfied. We should leave the "global" or "local"
>>> applicability to the deployment scenario.
>>> 
>>> 
>>>> OTOH I agree with you that 'local' might be misleading
>>>> (although in a local, hence limited, domain it is more
>>>> likely than 1) and 2) above are satisfied).
>>>> 
>>> [KC>] I think your statement aligns with that of mine :-)
>>> 
>>>> Best,
>>>> 
>>>> --julien
>>>> 
>>>> On Monday 14 May 2007 13:28, Alper Yegin wrote:
>>>>> Julien,
>>>>> 
>>>>> "Local" and "global" has something to do with
>>>>> geographic or topologic distance. The technical
>>>>> issue we are discussing is "presence of an SA
>>>>> between LMA and MAG". The two are not the same
>>>>> thing, and use of "local/global" to mean the latter
>>>>> does not make sense to me. You can have two adjacent
>>>>> networks that cannot run netlmm, whereas two
>>>>> worlds-apart networks can run it very well.
>>>>> 
>>>>>> In conclusion I think we can just continue to work
>>>>>> on NETLMM protocols and let people deploy those as
>>>>>> they see fit. I don't really think that NETLMM
>>>>>> isn't going to be deployed because of the 'L' in
>>>>>> NETLMM and LMA -- let's be confident in
>>>>>> engineering.
>>>>> 
>>>>> I never thought the extra L would be a show stopper.
>>>>> But it does not really represent the real intent
>>>>> (lack of SA). For that it is just going to cause
>>>>> confusion and generate unnecessary questions...
>>>>> 
>>>>> Alper
>>>> 
>>>> _______________________________________________
>>>> netlmm mailing list
>>>> [email-masked]
>>>> https://www1.ietf.org/mailman/listinfo/netlmm
>>> 
>>> _______________________________________________
>>> netlmm mailing list
>>> [email-masked]
>>> https://www1.ietf.org/mailman/listinfo/netlmm
>> 
>> --
>> Jonne Soininen
>> Nokia Siemens Networks
>> 
>> Tel: +358 40 527 46 34
>> E-mail: [email-masked]
>> 
>> 
>> 
>> _______________________________________________
>> netlmm mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/netlmm
> 
> 
> "This email message and any attachments are confidential information of
> Starent Networks, Corp. The information transmitted may not be used to create
> or change any contractual obligations of Starent Networks, Corp.  Any review,
> retransmission, dissemination or other use of, or taking of any action in
> reliance upon this e-mail and its attachments by persons or entities other
> than the intended recipient is prohibited. If you are not the intended
> recipient, please notify the sender immediately -- by replying to this message
> or by sending an email to [email-masked] -- and destroy all
> copies of this message and any attachments without reading or disclosing their
> contents. Thank you."

-- 
Jonne Soininen
Nokia Siemens Networks

Tel: +358 40 527 46 34
E-mail: [email-masked]

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Fri, 18 May 2007 11:51:57 -0700

Hello Jonne,

We could just re-defined Proxy Mobile IPv6 domain.

We currently have 

   Proxy Mobile IPv6 Domain (PMIPv6-Domain)

      It is a localized mobility management domain.  It is a portion of
      the access network where the mobility management of a mobile node
      is handled using Proxy Mobile IPv6 protocol as defined in this
      specification.

New definition would be

   Proxy Mobile IPv6 Domain (PMIPv6-Domain)

      Proxy Mobile IPv6 domain refers to the network where the mobility
      management of a mobile node is handled using Proxy Mobile IPv6 
      protocol as defined in this specification.  The Proxy Mobile IPv6
      domain includes the LMAs and the MAGs between which security 
      associations can be setup and authorization for sending Proxy 
      Binding Updates on behalf of the mobile nodes can be ensured.

Comments?

Vijay

> Sent: Thursday, May 17, 2007 11:31 PM
> To: ext Chowdhury, Kuntal; [email-masked]
> Subject: Re: Proposal forward on Global vs. Local Mobility 
> (Re:[netlmm]Global vs. Local)
> 
> Kuntal,
>