Subject: [netlmm] MN's subnet prefix and LMA: Discovery vs. Storage in MN's profile

From: Julien Laganier <[email-masked]>
Date: Tue, 15 May 2007 13:40:44 +0200

Folks, 

I'd like to discuss the issue of where the MAG get the 
subnet prefix and LMA of a MN that does an 
intra-domain handover. 

AFAIU, so far it's been assumed that the MN's LMA is 
stored in the MN's profile, and the LMA knows the MN's 
subnet prefix (or the prefix is stored in the prefix 
too.)

I thought about an alternative to this technique which 
does not rely on availability of a MN's profile at the 
MAG. It relies on a) the MN implementing DNAv6, and b) 
each LMA having an interface configured with the 
Mobile IPv6 Home-Agents anycast address for home 
subnet prefix of the MNs it is serving (note that this 
is a degenerated case of anycast since we expect only 
one LMA to serve a given MN, thus the anycast address 
is configured on only one LMA, and is a special kind 
of unicast address).

1. When the MN attach to a new MAG, it gets a link up 
indication, and DNAv6 kicks in. As part of DNAv6 the 
MN will send a RtSol containing its landmark prefix, 
which is the per-MN subnet prefix that it used 
previously.

2. Receiving this RtSol containing the landmark prefix, 
the MAG sends to the Mobile IPv6 Home-Agents anycast 
address a proxy binding update for the MN. This packet 
will be routed to the LMA in charge of the MN.

3. Receiving the proxy binding update, the LMA process 
it. If the subnet prefix of the MN is not valid at the 
MAG sending it (LMA and MAG in different NETLMM 
domains) the LMA can reply to the MAG with an error 
message.

This mechanism has the advantage of lower latency since 
as soon as the MN attaches and get links up, it gives 
its landmark prefix to MAG, and MAG can issue proxy 
binding update to the LMA via the anycast address.

However, the mechanism does not work for the first 
attachment of the MN inside a given domain (i.e. the 
MN just did inter-domain handover). For that case we 
could rely on more "classic" approaches such as MN's 
profiles, or reliance on AAA. In those cases latency 
is less of a concern since network access after 
inter-domain handover will take some time anyway.

What do you think?

--julien

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 15 May 2007 14:10:09 +0200

Sounds new...

Julien Laganier wrote:
> Folks,
> 
> I'd like to discuss the issue of where the MAG get the subnet prefix
> and LMA of a MN that does an intra-domain handover.
> 
> AFAIU, so far it's been assumed that the MN's LMA is stored in the
> MN's profile, and the LMA knows the MN's subnet prefix (or the prefix
> is stored in the prefix too.)
> 
> I thought about an alternative to this technique which does not rely
> on availability of a MN's profile at the MAG. It relies on a) the MN
> implementing DNAv6,

I don't think we can assume that MNs implement DNAv6 (nor DNAv4), from a
wide deployment perspective.

But of course, we can assume it if we want to.

> and b) each LMA having an interface configured with the Mobile IPv6
> Home-Agents anycast address for home subnet prefix of the MNs it is
> serving (note that this is a degenerated case of anycast since we
> expect only one LMA to serve a given MN, thus the anycast address is
> configured on only one LMA, and is a special kind of unicast
> address).

This is special.  It is not the 3775 anycast HA address, which is in
fact a pre-assigned IID for a prefix common to all MNs.

You seem to say only one LMA serves a given MN.  Do you assume as many
LMAs as there are MNs?

> 1. When the MN attach to a new MAG, it gets a link up indication, and
> DNAv6 kicks in. As part of DNAv6 the MN will send a RtSol containing
> its landmark prefix, which is the per-MN subnet prefix that it used 
> previously.

YEs, and you say later that the landmark prefix is initially configured
from the profile.

> 2. Receiving this RtSol containing the landmark prefix, the MAG sends
> to the Mobile IPv6 Home-Agents anycast address a proxy binding update
> for the MN. This packet will be routed to the LMA in charge of the
> MN.

Why need of anycast here?

> 3. Receiving the proxy binding update, the LMA process it. If the
> subnet prefix of the MN is not valid at the MAG sending it (LMA and
> MAG in different NETLMM domains) the LMA can reply to the MAG with an
> error message.

You seem to assume that a prefix is valid both at MAG and at LMA.  I
think a prefix is valid on only one link.

> This mechanism has the advantage of lower latency since as soon as
> the MN attaches and get links up, it gives its landmark prefix to
> MAG, and MAG can issue proxy binding update to the LMA via the
> anycast address.

I agree, it seems lower latency because the MN's prefix is not retrieved
upon each handover.

Alex

> However, the mechanism does not work for the first attachment of the
> MN inside a given domain (i.e. the MN just did inter-domain
> handover). For that case we could rely on more "classic" approaches
> such as MN's profiles, or reliance on AAA. In those cases latency is
> less of a concern since network access after inter-domain handover
> will take some time anyway.
> 
> What do you think?
> 
> --julien
> 
> _______________________________________________ netlmm mailing list 
> [email-masked] https://www1.ietf.org/mailman/listinfo/netlmm
> 

______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________

---

From: Julien Laganier <[email-masked]>
Date: Tue, 15 May 2007 14:41:34 +0200

On Tuesday 15 May 2007 14:10, Alexandru Petrescu wrote:
> Sounds new...
>
> Julien Laganier wrote:
> > Folks,
> >
> > I'd like to discuss the issue of where the MAG get
> > the subnet prefix and LMA of a MN that does an
> > intra-domain handover.
> >
> > AFAIU, so far it's been assumed that the MN's LMA
> > is stored in the MN's profile, and the LMA knows
> > the MN's subnet prefix (or the prefix is stored in
> > the prefix too.)
> >
> > I thought about an alternative to this technique
> > which does not rely on availability of a MN's
> > profile at the MAG. It relies on a) the MN
> > implementing DNAv6,
>
> I don't think we can assume that MNs implement DNAv6
> (nor DNAv4), from a wide deployment perspective.
>

Yes we can debate that :)

However, one point is that we can optimize for nodes 
who have DNAv6. DNAv6 is all about optimizing handover 
performance of mobile nodes.

Mobile nodes who don't have DNAv6 might experience 
pretty bad performance anyway (I mean besides getting 
the LMA/prefix information) if the default router has 
to be changed.

> > and b) each LMA having an interface configured
> > with the Mobile IPv6 Home-Agents anycast address
> > for home subnet prefix of the MNs it is serving
> > (note that this is a degenerated case of anycast
> > since we expect only one LMA to serve a given MN,
> > thus the anycast address is configured on only one
> > LMA, and is a special kind of unicast address).
>
> This is special.  It is not the 3775 anycast HA
> address, which is in fact a pre-assigned IID for a
> prefix common to all MNs.

Yes it is. Perhaps I was unclear. This is the 2526 
anycast HA address cited in 3775. 

Since only one LMA is serving a given MN, the anycast 
will only be assigned to one interface -- thus it 
*looks* like an unicast.

> You seem to say only one LMA serves a given MN. 

Yes. I thought that was the WG's opinion.

> Do you assume as many LMAs as there are MNs?

Nope. One LMA can serve many MNs. The LMA will just 
configure many anycast addresses, one for each per-MN 
subnet of the set of MN it is serving.

> > 1. When the MN attach to a new MAG, it gets a link
> > up indication, and DNAv6 kicks in. As part of
> > DNAv6 the MN will send a RtSol containing its
> > landmark prefix, which is the per-MN subnet prefix
> > that it used previously.
>
> YEs, and you say later that the landmark prefix is
> initially configured from the profile.

Yes, or some other mean outside the scope of this 
message :)

> > 2. Receiving this RtSol containing the landmark
> > prefix, the MAG sends to the Mobile IPv6
> > Home-Agents anycast address a proxy binding update
> > for the MN. This packet will be routed to the LMA
> > in charge of the MN.
>

We don't really need anycast, a per subnet reserved 
unicast address for LMA would work too.

But that would require an additional allocation of this 
reserved unicast address, whereas the anycast is 
already allocated by RFC 2526, and as I explained 
above, this is kind of similar to unicast since only 
one LMA has the anycast address configured. 

> > 3. Receiving the proxy binding update, the LMA
> > process it. If the subnet prefix of the MN is not
> > valid at the MAG sending it (LMA and MAG in
> > different NETLMM domains) the LMA can reply to the
> > MAG with an error message.
>
> You seem to assume that a prefix is valid both at
> MAG and at LMA.  I think a prefix is valid on only
> one link.

I'm not sure I understand you. I wanted to say that if 
a MN roams in a different NETLMM domain, and send in 
its RtSol a prefix that is not valid in this new 
NETLMM domain, the LMA can say so to the MAG.

> > This mechanism has the advantage of lower latency
> > since as soon as the MN attaches and get links up,
> > it gives its landmark prefix to MAG, and MAG can
> > issue proxy binding update to the LMA via the
> > anycast address.
>
> I agree, it seems lower latency because the MN's
> prefix is not retrieved upon each handover.

Right.

--julien

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 15 May 2007 14:52:05 +0200

Julien Laganier wrote:
[snipped some parts]
> will only be assigned to one interface -- thus it 

So an LMA serving a given MN will assign that MN's "anycast" (a kind of 
unicast) address on a interface.

> Yes. I thought that was the WG's opinion.

Ok.

> subnet of the set of MN it is serving.

So if a HA serves 65536 MNs (the number of prefixes between 48 and 64 
bit boundaries) then it will have to assign 65536 
anycast-special-unicast addresses on its interface?

> unicast address for LMA would work too.

Ok, I understand that.

> one LMA has the anycast address configured.

Ok, I understand, there is gain.

However, if an address has been reserved by 2526 for a certain meaning 
for HA address then I think it's difficult to use same address but with 
a different meaning.

> NETLMM domain, the LMA can say so to the MAG.

Ok.

Alex

---

From: Julien Laganier <[email-masked]>
Date: Tue, 15 May 2007 15:07:39 +0200

> [snipped some parts]

Mee too.

> >>> since we expect only one LMA to serve a given
> >>> MN, thus the anycast address is configured on
> >>> only one LMA, and is a special kind of unicast
> >>> address).
> >>
> >> address, which is in fact a pre-assigned IID for
> >> a prefix common to all MNs.
> >
> > Since only one LMA is serving a given MN, the
> > anycast will only be assigned to one interface --
> > thus it *looks* like an unicast.
>
> So an LMA serving a given MN will assign that MN's
> "anycast" (a kind of unicast) address on a
> interface.

Yes.

> > Nope. One LMA can serve many MNs. The LMA will
> > just configure many anycast addresses, one for
> > each per-MN subnet of the set of MN it is serving.
>
> So if a HA serves 65536 MNs (the number of prefixes
> between 48 and 64 bit boundaries) then it will have
> to assign 65536 anycast-special-unicast addresses on
> its interface?

Yes.

> > But that would require an additional allocation of
> > this reserved unicast address, whereas the anycast
> > is already allocated by RFC 2526, and as I
> > explained above, this is kind of similar to
> > unicast since only one LMA has the anycast address
> > configured.
>
> However, if an address has been reserved by 2526 for
> a certain meaning for HA address then I think it's
> difficult to use same address but with a different
> meaning.

I agree with the generic statement about reuse. However 
the meaning isn't that different since we're talking 
sending MIPv6 messages, albeit proxy, to a LMA -- or a 
HA as it's been argued :)

--julien

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 15 May 2007 16:08:53 +0200

Julien Laganier wrote:
>> Julien Laganier wrote: [snipped some parts]
> 
> Mee too.
> 
>>>>> and b) each LMA having an interface configured with the 
>>>>> Mobile IPv6 Home-Agents anycast address for home subnet 
>>>>> prefix of the MNs it is serving (note that this is a 
>>>>> degenerated case of anycast since we expect only one LMA to 
>>>>> serve a given MN, thus the anycast address is configured on 
>>>>> only one LMA, and is a special kind of unicast address).
>>>> This is special.  It is not the 3775 anycast HA address, which 
>>>> is in fact a pre-assigned IID for a prefix common to all MNs.
>>> Yes it is. Perhaps I was unclear. This is the 2526 anycast HA 
>>> address cited in 3775.
>>> 
>>> Since only one LMA is serving a given MN, the anycast will only 
>>> be assigned to one interface -- thus it *looks* like an unicast.
>> So an LMA serving a given MN will assign that MN's "anycast" (a 
>> kind of unicast) address on a interface.
> 
> Yes.
> 
>>> Nope. One LMA can serve many MNs. The LMA will just configure 
>>> many anycast addresses, one for each per-MN subnet of the set of 
>>> MN it is serving.
>> So if a HA serves 65536 MNs (the number of prefixes between 48 and 
>> 64 bit boundaries) then it will have to assign 65536 

Has one ever seen such an interface assigned 65536 addresses on it?
Can there be any problems with that?  Will it do DAD for each of those, etc.

>>> But that would require an additional allocation of this reserved 
>>> unicast address, whereas the anycast is already allocated by RFC 
>>> 2526, and as I explained above, this is kind of similar to 
>>> unicast since only one LMA has the anycast address configured.
>> However, if an address has been reserved by 2526 for a certain 
>> meaning for HA address then I think it's difficult to use same 
>> address but with a different meaning.
> 
> I agree with the generic statement about reuse. However the meaning 
> isn't that different since we're talking sending MIPv6 messages, 
> albeit proxy, to a LMA -- or a HA as it's been argued :)

:-) I think this word 'proxy' is used much as an excuse to do about
anything that one would like to do :-)

The meaning of 3775-anycast address is that several routers assign/join 
that address on one of their interfaces.  But this proposal's meaning is 
that one router assigns several anycast addresses on its interface.

Then, if one wants to use both this proposal 3775-DHAAD in the PMIP 
domain then one would have to assign this proposal's anycast addresses 
_and_ the 3775-anycast addresses on all HAs interfaces...

Alex