Subject: Re: [netlmm] Plan for Proxy Mobile IPv6 implementation.

From: "Shyam H" <[email-masked]>
Date: Mon, 20 Aug 2007 23:00:06 +0530

On Mon, 20 Aug 2007, Alexandru Petrescu wrote:

> Jong-Hyouk Lee wrote:
>> Dear John.zhao.
>>
>> The project aims for implementing a Proxy Mobile IPv6 implementation
>>  based on draft-ietf-netlmm-proxymip6-01. To do this, we will do this
>>  based on MIPL (Mobile IPv6 for Linux). That's it.
>>
>> Just want to know who is doing any others similar work.
>
>

Hello,

we have done the basic development of pmip6 protocol; including
implementation of LMA and MAG. Our implementation now is close to the latest
version of the draft (draft-ietf-netlmm-proxymip6-01.txt). This is built on
Linux, with WiFI as the access tech and we will add support for other radio
technologies; We have  our own context txfr msgs between MAGs.

Thank You

- Shyam

> I think many people work on this topic.
>
> I'd start by downloading the 802.16 plugin for wireshark and look at
> email addresses in c files.
>
> You sure realize that this netlmm group addresses a topic with a very
> strong industrial interest, interacting with SDOs like WiMax and IEEE
> 802.16... a place where IPRs are very many... and a place where
> implementation interests are least academic.
>
> Alex
>
_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 20 Aug 2007 22:59:30 +0200

Shyam H wrote:
>>> The project aims for implementing a Proxy Mobile IPv6
>>> implementation based on draft-ietf-netlmm-proxymip6-01. To do
>>> this, we will do this based on MIPL (Mobile IPv6 for Linux).
>>> That's it.
>>> 
> implementation of LMA and MAG. Our implementation now is close to the
>  latest version of the draft (draft-ietf-netlmm-proxymip6-01.txt).
> This is built on Linux, with WiFI as the access tech and we will add
> support for other radio technologies;

Hi Shyam, this is great news.

Could you please say a few words about what is the addressing 
architecture that you used on the wifi links and the mobiles?  Is it a 
prefix-per-mobile model (typical for ptp links)?  Or is it a shared 
prefix model (typical for wifi access)?

> We have  our own context txfr msgs between MAGs.

Does your implementation work without context transfer?

Alex

---

From: "Jong-Hyouk Lee" <[email-masked]>
Date: Wed, 22 Aug 2007 00:40:10 +0900

Dear Shyam.

This is great news! and I envy you that you're already done what I want.
Anyway, I'd like to have questions.

Is the implementation based on MIPL source code or others? Are you going to
publish the implementation as an open source project?

> This is built on Linux, with WiFI as the access tech and we will add
support for other radio technologies

WiMAX is a good choice.

Capital!!!

On 8/21/07, Shyam H <[email-masked]> wrote:
> version of the draft (draft-ietf-netlmm-proxymip6-01.txt). This is built
> on Linux, with WiFI as the access tech and we will add support for other
> radio technologies; We have  our own context txfr msgs between MAGs.
>
> Thank You
>
> - Shyam
>

-- 
Internet Management Technology Lab, Sungkyunkwan University.
Jong-Hyouk Lee.

#email: jonghyouk (at) gmail (dot) com
#webpage: http://www.hurryon.org
_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Shyam H" <[email-masked]>
Date: Thu, 23 Aug 2007 18:45:31 +0530

> prefix model (typical for wifi access)?

Dear Alex

We changed the HostAP driver for detecting the MN attachment and for mapping
the WiFi client id to mnid. But the link is not a p2p link; The addressing
is IPv6 pfx for each mobile; we are not doing Rtr Adv unicasting, ideally we
should be doing that on wifi link or implement virtual p2p link on WiFI
access. There is still todo things on access interface.

> Does your implementation work without context transfer?

We need ctx transfers, for avoiding a aaa lookup. We dont have "AAA" support
yet. So, we are moving the lma address, mn pfx to the other MAG using ctx
txfr. We had to create some interface between the hostap driver and the MAG,
for making this work. But, we are more interested on the network side, not
on the access side.

Hope it helps.

- Shyam

Alex

---

From: "Shyam H" <[email-masked]>
Date: Thu, 23 Aug 2007 18:58:14 +0530

On 8/21/07, Jong-Hyouk Lee <[email-masked]> wrote:

> Is the implementation based on MIPL source code or others? Are you going
> to publish the implementation as an open source project?
>

Dear Jong Hyouk,

This is not based on MIPL; we have developed mip4/mip6 home agent some time
back; we just used that for pmip; most development was on the mag and the
interface with the wifi driver. We need not have to release this code, we
have business plans around this product

> support for other radio technologies

right; we have to order some base stations and wimax client boards; we need
to work on this after we get this code to scale and fixing all the current
bugs.

- Shyam

---

From: Julien Laganier <[email-masked]>
Date: Thu, 23 Aug 2007 15:31:44 +0200

On Thursday 23 August 2007, Shyam H wrote:
> Dear Alex
>
> We changed the HostAP driver for detecting the MN attachment and for
> mapping the WiFi client id to mnid. But the link is not a p2p link;
> The addressing is IPv6 pfx for each mobile; we are not doing Rtr Adv
> unicasting, ideally we should be doing that on wifi link or implement
> virtual p2p link on WiFI access. There is still todo things on access
> interface.

FWIW, with an atheros-based 802.11 AP managed by the madwifi driver, it 
is possible to turn the bridging of 802.11 frames by the AP off, thus 
turning the shared 802.11 link into a point-to-multipoint. Thus from a 
MN perspective the link would be point-to-point.

That's done by issuing the private ioctl ap_bridge with parameter 0:

$ iwpriv ath0 ap_bridge 0

--julien