Subject: Re: [netlmm] Issue: MAG sends prefix hint to LMA (Was: Issue: Link-local address collision on the access link)

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 22 Aug 2007 08:54:24 -0700 (PDT)

As we mentioned in draft-sarikaya-netlmm-prefix-delegation-00.txt conceptually LMA as the requesting router may provide a prefix hint to DHCP/ AAA server if PD is being used. How would MAG provide the hint, in HNP?

----- Original Message ----
From: Julien Laganier <[email-masked]>
To: [email-masked]
Sent: Wednesday, August 22, 2007 10:23:31 AM
Subject: [netlmm] Issue: MAG sends prefix hint to LMA (Was: Issue: Link-local address collision on the access link)

On Wednesday 22 August 2007, Sri Gundavelli wrote:
> Please comment on these open issues. So far, only
> very few people commented on these issues. Please
> express your preference for one of the suggested
> options on each of these issues.
>
>
> 3. Should MAG be allowed to a send a prefix hint
>     to the LMA (Issue: 165 & 155)

I think it is better to allow it, and doesn't badly impact those that 
don't think it's useful since the LMA can simply disregard the 
information.

--julien

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 22 Aug 2007 09:16:22 -0700 (PDT)

Behcet,

Yes, the hint for the requesting prefix can be carried
in the HNP Option. However, LMA should have the right
to accept or reject the request for that prefix. This is
one opinion.

Today, a DHCP client can specify an address in the DHCP
request. The same logic can go here.

However, there are other opinions on this.

Sri

---

From: Julien Laganier <[email-masked]>
Date: Wed, 22 Aug 2007 18:23:31 +0200

> request. The same logic can go here.

I believe the issue Behcet is referring to is that there's no DHCP 
option to store an allocated prefix in a DHCP message -- there are 
fields for addresses (IA Address) and delegated prefixes (IA_PD Prefix) 
but none for *allocated* prefixes.

--julien

> > As we mentioned in draft-sarikaya-netlmm-prefix-delegation-00.txt
> > conceptually LMA as the requesting router may provide a prefix hint
> > to DHCP/ AAA server if PD is being used. How would MAG provide the
> > hint, in HNP?

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 22 Aug 2007 09:31:54 -0700 (PDT)

> but none for *allocated* prefixes.

Ok. There is some disconnect here. The MAG can potentially request
for a specific prefix from the LMA. We are not talking about the
MAG going to a DHCP server for a prefix. LMA on receiving the
PBU request with this prefix, MAY accept that binding and create a
tunnel route for that HNP. Or, as well may reject it. So, we
are not talking about DHCP at all.

Sri