Subject: [netlmm] Re: Help me about "Mobile Node Agnostic Fast Handovers for Proxy Mobile IPv6"

From: "Frank Xia" <[email-masked]>
Date: Mon, 6 Aug 2007 21:35:44 -0500

Hi Kang

I am very sorry because I am not familiar with IEEE802.11 Mac operation.

But I know the 802.16e layer 2 operation.

In [802.16e], The MN initiates handover by sending MOB_MSHO-REQ to the BS 
and receives MOB_BSHO-RSP from the BS. Also, the BS can initiate handover
by sending MOB_BSHO-REQ to the MN.

When the L2 handover decision is achieved (e.g. s-BS receive
MOB_HO-IND message from MN in [802.16e] ), the s-BS sends the
L2-HO-IND message to PAR

BR
Frank
  ----- Original Message ----- 
  From: 강주은 
  To: [email-masked] 
  Sent: Monday, August 06, 2007 8:57 PM
  Subject: Help me about "Mobile Node Agnostic Fast Handovers for Proxy Mobile IPv6"

  Dear Frank Xia,

  I'm a student of the Kyungpook National University in Korea.

  I read your draft which is Mobile Node Agnostic Fast Handovers for Proxy Mobile IPv6.

  And I have a question

  In Predivtive Mode procedure, s-BS send the LGD(Link Going Down) to the PAR, how s-BS know the LGD with the MN

  I mean....normally, in Mobile IPv6,  if we use the 802.11b MAC, MN received the beacon message periodically so MN know the LGD using the RSS or something like that.

  but in Proxy MIPv6, s-BS know the Link Going Down with the MN and sent the trigger to the PAR , How s-BS know the LGD

  Thank you for read this mail

  Have a nice day

  Best regards,

  Juny, Kang

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Frank Xia" <[email-masked]>
Date: Wed, 8 Aug 2007 21:38:55 -0500

Hi Juny

Please see my inline reply...

BR
Frank

  ----- Original Message ----- 
  From: 강주은 
  To: Frank Xia 
  Sent: Wednesday, August 08, 2007 1:10 AM
  Subject: Re: Help me about "Mobile Node Agnostic Fast Handovers for Proxy Mobile IPv6"

  Dear Frank Xia,

  Thank you for your response

  can I ask one more question?
  Frank=>Your comments are appreciated.

  you said, s-BS receive the handover message from the MN, does it means MN decide the HO and then send the request the L2 message to the s-BS?
  Frank=>In IEEE802.16e,  layer 2 handover is negotiated between MN and BS,  but MN decides the HO eventually , that is, MN sends indication (MOB_HO-IND) to S-BS. 

  In Proxy Mobile IPv6, MN need not participate in any mobility related signaling so the draft "Mobile Node Agnostic Fast Handovers for Proxy Mobile IPv6" the LGD in figure 1 is triggered in s-BS not from MN
  Frank=>"MN Agnostic"  is  layer 3  agnostic.  In fact, MN should implement specific layer 2  handover functions.

  so in figure 1 number 2 signaling procedure (L2 HO signaling), is the signal from MN to s-BS which is about the HO decision?
  Frank=>Step 2 includes a series of  negotiation and handover decision.  The HO decision is by MN. 

  I'm sorry to ask again, but i confused this part.  

  Thank you

  Best Regards,
  JUNY

    ----- Original Message ----- 
    From: Frank Xia 
    To: 강주은 
    Cc: [email-masked] 
    Sent: Tuesday, August 07, 2007 11:35 AM
    Subject: Re: Help me about "Mobile Node Agnostic Fast Handovers for Proxy Mobile IPv6"

    Hi Kang

    BR
    Frank
      ----- Original Message ----- 
      From: 강주은 
      To: [email-masked] 
      Sent: Monday, August 06, 2007 8:57 PM
      Subject: Help me about "Mobile Node Agnostic Fast Handovers for Proxy Mobile IPv6"

      Dear Frank Xia,

      And I have a question

      Have a nice day

      Best regards,

      Juny, Kang

---

From: "Frank Xia" <[email-masked]>
Date: Mon, 27 Aug 2007 21:11:03 -0500

Hi Juny

Please refer to my reply..

BR
Frank

----- Original Message ----- 
From: "강주은" <[email-masked]>
To: "Frank Xia" <[email-masked]>
Sent: Monday, August 27, 2007 8:22 PM
Subject: Re: Help me about "Mobile Node Agnostic Fast Handovers for Proxy Mobile IPv6"

> Dear Frank xia,
> 
> i read your draft and i have a question
> 
> first of all, in your draft when does PBU send to the LMA and received
> PBack from LMA
> (after NAR received LUP or after send RA to MN)

Frank=>I think New MAG should send PBU as soon as possible.
PBU should be after LUP.   As to sequence between PBU and RA,
I think that it does not matter.

> 
> and how RA know the MN's HNP? (from MN's link layer address in HI message?)

Frank=>The context including HNP is transfered from PMAG to NMAG before handover.

> 
> Thank you
> 
> Best Regards,
> JUNY
> 
> 
> 2007/8/9, Frank Xia <[email-masked]>:
> >
> > Hi Juny
> >
> > you said, s-BS receive the handover message from the MN, does it means MN
> > decide the HO and then send the request the L2 message to the s-BS?
> > Frank=>In IEEE802.16e,  layer 2 handover is negotiated between MN and BS,
> > but MN decides the HO eventually , that is, MN sends indication (MOB_HO-IND)
> > to S-BS.
> >
> > In Proxy Mobile IPv6, MN need not participate in any mobility related
> > signaling so the draft "Mobile Node Agnostic Fast Handovers for Proxy Mobile
> > IPv6" the LGD in figure 1 is triggered in s-BS not from MN
> > so in figure 1 number 2 signaling procedure (L2 HO signaling), is the signal
> > from MN to s-BS which is about the HO decision?
> > I mean....normally, in Mobile IPv6,  if we use the 802.11b MAC, MN received
> > the beacon message periodically so MN know the LGD using the RSS or
> > something like that.
> >
> > but in Proxy MIPv6, s-BS know the Link Going Down with the MN and sent the
> > trigger to the PAR , How s-BS know the LGD
> >