Subject: RE: [netlmm] Question about handover procedure in PMIP6

From: <[email-masked]>
Date: Sat, 18 Aug 2007 07:15:53 +0300

Hi Sri,

There is a small additional issue: when does the LMA start sending the packets down the new binding and when does it stop sending to the old? 

My personal preference would be that the new binding would effectively cancel the old binding. There is a small probability of race condition in the uncoordsinated handover case, but the signalling load and handover speed would be better in the coordinated case at least.

Please, document the handover explicitly to the document so the implementers won't get confused... ;)

Cheers,

Jonne.

-----Original Message-----
From: ext Sri Gundavelli
Sent: 18/08/2007 05:21:40
To: ext Sri Gundavelli;Soininen Jonne (NSN - FI/Espoo)
Cc: [email-masked]
Subject: Re: [netlmm] Question about handover procedure in PMIP6

Hi Jonne,

When a MAG detects that a  mobile node is no longer
attached to its access link, there are two possibilities:

a.) MN moved out of the PMIP6 domain
b.) Inter-MAG handoff (MN is attached to a different MAG)

The MAG will not be able to differentiate between the two,
unless there are context transfer/FMIP  schemes in place.

Now, as per the spec,

1.) MAG must ensure the mobile node is still on the access
link before extending binding lifetime with the LMA.
2.) If the MAG detects the mobile node is no longer attached
to the access link, it must deregister.

For scenario #a, this is sufficient and complete.

For scenario #b, #1 is correct. However, with #2, there
is potentially a race condition. The old MAG should
deregister only if there is no handoff. But, it would not
know that. However, it must deregister to make sure the
resources are cleaned up at the LMA, for covering scenario
#a.

The proposed solution (not the exact text):

- The LMA on receiving a Proxy Binding Update with
lifetime=0, SHOULD wait for MinDelayBeforeBCEDelete amount
of time before the BCE is deleted. However, it must
send the Proxy Binding Ack right away.

- During this time, if the LMA receives a non-zero
lifetime and with a later timestamp, it must not delete
the BCE,  but just update the entry.

Protocol Constant:

MinDelayBeforeBCEDelete = 1 Second (Default)

This issue was raised by Juny Kang, Kyungpook National Univ.

Thanks
Sri

On Fri, 17 Aug 2007, Soininen Jonne (NSN - FI/Espoo) wrote:

> Hello everybody,
>
> somebody asked me a question when doing an handover between two MAGs if the 
> old MAG was supposed to send a deregistration message to the LMA before the 
> old binding is going to be deleted - or will the new BU from the new MAG 
> already delete the binding. I didn't remember this exactly, but I checked the 
> spec. Actually, I couldn't find anything definite. I would guess the old MAG 
> does not have to deregister itself for the packets to flow to the new MAG. In 
> addition, I guess the new BU does change the routing to the new MAG. Am I 
> right?
>
> However, I don't think this is very clear in the document. I didn't really 
> find any description of the actual handover at all. The only place where I 
> found a hint of the handover procedures is in "5.8.1. Initial Proxy Binding 
> Registration". Perhaps it would be good to add to the section 5.8 a section 
> describing the actual handover. A signalling picture would not hurt either.
>
> Or if I missed the description could you please point me to the section where 
> the description is.
>
> Cheers,
>
> Jonne.
>
>
>
> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/netlmm
>
_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Sri Gundavelli <[email-masked]>
Date: Fri, 17 Aug 2007 21:39:53 -0700 (PDT)

Hi Jonne,

> My personal preference would be that the new binding would effectively cancel the old binding. There is a small probability of race condition in the uncoordsinated handover case, but the signalling…

I agree.

This is the make-before-break scenario. We are talking about a
small delay of ~ 1 sec. During this time, the old state i.e
BCE/tunnel/route state should survive, till the state is
deleted or updated. This is detail, I did not mention. I will
take care of this.

> Please, document the handover explicitly to the document so the 
implementers won't get confused... ;)

Sure. We can have a section on this.

Thanks
Sri

---

From: Vijay Devarapalli <[email-masked]>
Date: Sat, 18 Aug 2007 08:38:47 -0700

[email-masked] wrote:
> Hi Sri,
> 
> There is a small additional issue: when does the LMA start sending the 
> packets down the new binding and when does it stop sending to the old?
> 
> My personal preference would be that the new binding would effectively 
> cancel the old binding. T

Agree.

Vijay

here is a small probability of race condition
> in the uncoordsinated handover case, but the signalling load and 
> handover speed would be better in the coordinated case at least.
> 
> ------------------------------------------------------------------------
>