Subject: [netmod] Unknown idnits error

From: Balázs Lengyel <[email-masked]>
Date: Thu, 9 Sep 2021 17:12:11 +0000

Hello,

I am trying to check/submit a new version of my
draft-ietf-netmod-yang-instance-file-format-18.
 
The previous version did not have any idnits errors or warnings. Now
suddenly I get: 
 
== Couldn't figure out when the document was first submitted -- there may
     comments or warnings related to the use of a disclaimer for pre-RFC5378
     work that could not be issued because of this.  Please check the Legal
     Provisions document at https://trustee.ietf.org/license-info to
determine
     if you need the pre-RFC5378 disclaimer.
I did not change any boilerplate info. Why do I get this warning and how to
get rid of it?
 
I use xml2rfc. My draft includes:
 
<rfc category="std" ipr="trust200902"
docName="draft-ietf-netmod-yang-instance-file-format-18">
    <date year="2021"/>
 
Help, Balazs

-- 

Balazs Lengyel                    Senior Specialist
Ericsson Hungary Ltd. 

Mobile: +36-70-330-7909              email: [email-masked]

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 9 Sep 2021 11:15:12 -0700

I assume that this is during the submit process, and that you are not running this offline. Submit a report to [email-masked] <mailto:[email-masked]> and have them look at it.

> On Sep 9, 2021, at 10:12 AM, Balázs Lengyel <balazs.lengyel=[email-masked]> wrote:
> 
> Hello,
> I am trying to check/submit a new version of my draft-ietf-netmod-yang-instance-file-format-18.
>  
> The previous version did not have any idnits errors or warnings. Now suddenly I get: 
>  
>      Provisions document at https://trustee.ietf.org/license-info <https://trustee.ietf.org/license-info> to determine
> I did not change any boilerplate info. Why do I get this warning and how to get rid of it?
>  
> <rfc category="std" ipr="trust200902" docName="draft-ietf-netmod-yang-instance-file-format-18">
>     <date year="2021"/>
>  
> Help, Balazs
>  
>  
> -- 
> Balazs Lengyel                    Senior Specialist                       Ericsson Hungary Ltd. 
> Mobile: +36-70-330-7909              email: [email-masked] <mailto:[email-masked]>
>  
> _______________________________________________
> netmod mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>
Mahesh Jethanandani
[email-masked]

---

From: Balázs Lengyel <[email-masked]>
Date: Thu, 9 Sep 2021 21:17:28 +0000

I got this warning while running the web based idnits tool. https://tools.ietf.org/tools/idnits/

It might indicate some real problem, but it is impossible to understand from the failure message, what it is.

Regards Balazs

From: Mahesh Jethanandani <[email-masked]> 
Sent: 2021. szeptember 9., csütörtök 20:15
To: Balázs Lengyel <[email-masked]>
Cc: [email-masked]
Subject: Re: [netmod] Unknown idnits error

On Sep 9, 2021, at 10:12 AM, Balázs Lengyel <balazs.lengyel=[email-masked] <mailto:balazs.lengyel=[email-masked]> > wrote:

Hello,

 
     Provisions document at  <https://trustee.ietf.org/license-info> https://trustee.ietf.org/license-info to determine

 
Help, Balazs

-- 

Mobile: +36-70-330-7909              email:  <mailto:[email-masked]> [email-masked]

_______________________________________________
netmod mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/netmod> https://www.ietf.org/mailman/listinfo/netmod

Mahesh Jethanandani

[email-masked] <mailto:[email-masked]>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 9 Sep 2021 23:25:12 +0200

On 2021-09-09, at 19:12, Balázs Lengyel <balazs.lengyel=[email-masked]> wrote:
> 
> Couldn't figure out when the document was first submitted -- there may
>      work that could not be issued because of this.

My experience is that this message is caused by hiccups of the idnits tool in retrieving metadata.

https://datatracker.ietf.org/doc/draft-ietf-netmod-yang-instance-file-format/ certainly has no problems figuring that out.

(The question is whether you are copying from/evolving from material that was submitted before RFC 5378 went into force, in which case you might need a different ipr= attribute.  Most likely your text is not that old!  So this is a red herring.)

Grüße, Carsten

---

From: Balázs Lengyel <[email-masked]>
Date: Thu, 9 Sep 2021 21:39:00 +0000

Sadly [email-masked] <mailto:[email-masked]>  returns with “Unknown To address”

Balazs

From: Balázs Lengyel 
Sent: 2021. szeptember 9., csütörtök 23:17
To: Mahesh Jethanandani <[email-masked]>
Cc: [email-masked]
Subject: RE: [netmod] Unknown idnits error

Regards Balazs

From: Mahesh Jethanandani <[email-masked] <mailto:[email-masked]> > 
Sent: 2021. szeptember 9., csütörtök 20:15
To: Balázs Lengyel <[email-masked] <mailto:[email-masked]> >
Cc: [email-masked] <mailto:[email-masked]> 
Subject: Re: [netmod] Unknown idnits error

Hello,

 

 
Help, Balazs

-- 

Mahesh Jethanandani

---

From: Balázs Lengyel <[email-masked]>
Date: Thu, 9 Sep 2021 21:40:59 +0000

AFAIK I did not copy any old material. Balazs

-----Original Message-----
From: Carsten Bormann <[email-masked]> 
Sent: 2021. szeptember 9., csütörtök 23:25
To: Balázs Lengyel <[email-masked]>
Cc: [email-masked]
Subject: Re: [netmod] Unknown idnits error

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 10 Sep 2021 00:09:18 +0200

> AFAIK I did not copy any old material. Balazs

Indeed, so you can ignore this message.

> Sadly [email-masked] returns with “Unknown To address”

I think [email-masked] was meant here.

But I don’t think new light will be generated there, except for the observation that the idnits backend is up for some re-integration work, so hiccups like this are currently not unlikely.

Grüße, Carsten