Subject: [Netslices] Reliability & Availability in NetSling

From: "qiangli (D)" <[email-masked]>
Date: Thu, 10 Aug 2017 02:04:09 +0000

Hi All,

I was confused when I was reading some NetSlicing related materials. It seems that "Reliability" supported by Netslicing refers to the probability that a network slice could work stably, or other similar metrics. But, shouldn't this be the defination of "Availability"? Then what does reliability mean in NetSlicing?

Best regards,

Cristina QIANG

---

From: GENG Liang <[email-masked]>
Date: Thu, 10 Aug 2017 02:44:09 +0000

Hi Cristina,

Interestingly we were discussing this confusion with few industrial partners recently. In telecommunication language we normally use "Reliability" to refer the probability a network is stably run (i.e. 99.999% of time). This is also regarded as network "Availability". However, "Reliability" in industrial verticals is more comprehensive - including not only network availability parameter but also mechanics, electricity etc.

Personally I think, network slicing is still looking at network regime where I believe Reliability means the percentage of time a connection is available. But we you sell this concept to industrial verticals, they may think differently.

________________________________
Liang GENG
China Mobile Research Institute

From: qiangli (D)<mailto:[email-masked]>
Date: 2017-08-10 10:04
To: [email-masked]<mailto:[email-masked]>
Subject: [Netslices] Reliability & Availability in NetSling
Hi All,

I was confused when I was reading some NetSlicing related materials. It seems that “Reliability” supported by Netslicing refers to the probability that a network slice could work stably, or other similar metrics. But, shouldn’t this be the defination of “Availability”? Then what does reliability mean in NetSlicing?

Best regards,

Cristina QIANG

---

From: Pedro Martinez-Julia <[email-masked]>
Date: Thu, 10 Aug 2017 13:42:00 +0900

Dear all,

I personally think it is better to use the industrial definitions but,
being purist, we can find important differences between them. While
availability is the probability for a system to work as expected in some
period of time (99.999% of time), reliability is a broader term that
refers to the different situations in which a system will be able to
overcome without breaking. In some cases, the latter can incorporate the
former, but not in all of them.

For network slicing we can keep the definition commonly used by industry
with the necessary details to make clear the aspects that differentiate
them. I would keep "working as expected for some period of time" related
to availability and "resistant to disparate situations" to reliability.

Regards,
Pedro

> _______________________________________________
> Netslices mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netslices

-- 
Pedro Martinez-Julia
Network Science and Convergence Device Technology Laboratory
Network System Research Institute
National Institute of Information and Communications Technology (NICT)
4-2-1, Nukui-Kitamachi, Koganei, Tokyo 184-8795, Japan
Email: [email-masked]
---------------------------------------------------------
*** Entia non sunt multiplicanda praeter necessitatem ***

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 10 Aug 2017 10:57:47 +0100

In general at IETF we associate reliable with the probability of packet 
delivery, and a reliable transport protocol is one that retries (at a 
cost of delay) until the packet is delivered or other factors intervene. 
Availability tends to refer to the ability of the network to receive 
packets for attempted delivery.

I looked for a formal definition in IPPM which is the WG that is 
concerned with measuring such things but could not find a definition.

 From the ITU we can find:

*Term*:availability (performance)
*Definition*:The ability of an item to be in a state to perform a 
required function under given conditions at a given instant of time or 
over a given time interval, assuming that the required external 
resources are provided.
NOTE 1 – This ability depends on the combined aspects of the reliability 
performance, the maintainability performance and the maintenance support 
performance.
NOTE 2 – Required external resources, other than maintenance resources 
do not affect the availability performance of the item.

*Term*:reliability (performance)
*Definition*:The ability of an item to perform a required function under 
given conditions for a given time interval.
NOTE 1 – It is generally assumed that the item is in a state to perform 
this required function at the beginning of the time interval.
NOTE 2 – Generally, reliability performance is quantified using 
appropriate measures. In some applications, these measures include an 
expression of reliability performance as a probability, which is also 
called reliability.

or
*Term*:reliability characteristic
*Definition*:The Mean Time Between Failures (MTBF) to maintain a defined 
QOS requirement.

- Stewart

---

From: "qiangli (D)" <[email-masked]>
Date: Fri, 11 Aug 2017 07:47:42 +0000

Hi All,

The phrase “working as expected” inspired me. For a network slice, what people expect is not only the stable working probability/time, but also the guaranteed SLA.

Try to consider from tenant’s perspective, I would be very concerned about how much the promised SLA could really be achieved. I am not sure which one (availability/reliability) this concept should belong to according to ITU’s definitions.

Best regards,

Cristina QIANG

From: Netslices [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Thursday, August 10, 2017 5:58 PM
To: [email-masked]
Subject: Re: [Netslices] Reliability & Availability in NetSling

In general at IETF we associate reliable with the probability of packet delivery, and a reliable transport protocol is one that retries (at a cost of delay) until the packet is delivered or other factors intervene. Availability tends to refer to the ability of the network to receive packets for attempted delivery.

I looked for a formal definition in IPPM which is the WG that is concerned with measuring such things but could not find a definition.

From the ITU we can find:
Term : availability (performance)

Definition : The ability of an item to be in a state to perform a required function under given conditions at a given instant of time or over a given time interval, assuming that the required external resources are provided.
NOTE 1 – This ability depends on the combined aspects of the reliability performance, the maintainability performance and the maintenance support performance.
NOTE 2 – Required external resources, other than maintenance resources do not affect the availability performance of the item.

Term : reliability (performance)

Definition : The ability of an item to perform a required function under given conditions for a given time interval.
NOTE 1 – It is generally assumed that the item is in a state to perform this required function at the beginning of the time interval.
NOTE 2 – Generally, reliability performance is quantified using appropriate measures. In some applications, these measures include an expression of reliability performance as a probability, which is also called reliability.

or
Term : reliability characteristic

Definition : The Mean Time Between Failures (MTBF) to maintain a defined QOS requirement.

- Stewart

Dear all,

Regards,

Pedro

Hi Cristina,

Liang GENG

From: qiangli (D)<mailto:[email-masked]><mailto:[email-masked]>

Date: 2017-08-10 10:04

To: [email-masked]<mailto:[email-masked]><mailto:[email-masked]><mailto:[email-masked]>

Hi All,

Best regards,

Cristina QIANG

Netslices mailing list

[email-masked]<mailto:[email-masked]>

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 11 Aug 2017 09:26:17 +0100

From a tenant's perspective, which arguably is the most important 
perspective the key characteristics of interest is  surely "The Mean 
Time Between Failures (MTBF) to maintain a defined QOS requirement." 
together with the duration of those periods.

With that information you can the viability of your application over the 
slice, and the impact on your business.

- Stewart

On 11/08/2017 08:47, qiangli (D) wrote:
>
> Hi All,
>
> The phrase “working as expected” inspired me. For a network slice, 
> what people expect is not only the stable working probability/time, 
> but also the guaranteed SLA.
>
> Try to consider from tenant’s perspective, I would be very concerned 
> about how much the promised SLA could really be achieved. I am not 
> sure which one (availability/reliability) this concept should belong 
> to according to ITU’s definitions.
>
> Best regards,
>
> Cristina QIANG
>
> *From:*Netslices [mailto:[email-masked]] *On Behalf Of 
> *Stewart Bryant
> *Sent:* Thursday, August 10, 2017 5:58 PM
> *To:* [email-masked]
> *Subject:* Re: [Netslices] Reliability & Availability in NetSling
>
>
> In general at IETF we associate reliable with the probability of 
> packet delivery, and a reliable transport protocol is one that retries 
> (at a cost of delay) until the packet is delivered or other factors 
> intervene. Availability tends to refer to the ability of the network 
> to receive packets for attempted delivery.
>
> *Term* : availability (performance)
>
> *Definition* : The ability of an item to be in a state to perform a 
> NOTE 1 – This ability depends on the combined aspects of the 
> reliability performance, the maintainability performance and the 
> maintenance support performance.
> *Term* : reliability (performance)
>
> *Definition* : The ability of an item to perform a required function 
> under given conditions for a given time interval.
> NOTE 1 – It is generally assumed that the item is in a state to 
> perform this required function at the beginning of the time interval.
> *Term* : reliability characteristic
>
> *Definition* : The Mean Time Between Failures (MTBF) to maintain a 
> defined QOS requirement.
>
>
> - Stewart
>
>         Interestingly we were discussing this confusion with few
>         industrial partners recently. In telecommunication language we
>         normally use "Reliability" to refer the probability a network
>         is stably run (i.e. 99.999% of time). This is also regarded as
>         network "Availability". However, "Reliability" in industrial
>         verticals is more comprehensive - including not only network
>         availability parameter but also mechanics, electricity etc.
>
>         Personally I think, network slicing is still looking at
>         network regime where I believe Reliability means the
>         percentage of time a connection is available. But we you sell
>         this concept to industrial verticals, they may think differently.
>
>         <mailto:[email-masked]>
>
>         Date: 2017-08-10 10:04
>
>         To: [email-masked]
>         <mailto:[email-masked]><mailto:[email-masked]>
>         <mailto:[email-masked]>
>
>         I was confused when I was reading some NetSlicing related
>         materials. It seems that “Reliability” supported by Netslicing
>         refers to the probability that a network slice could work
>         stably, or other similar metrics. But, shouldn’t this be the
>         defination of “Availability”? Then what does reliability mean
>         in NetSlicing?
>
>         Best regards,
>
>         Cristina QIANG
>
>         [email-masked] <mailto:[email-masked]>
>

---

From: "qiangli (D)" <[email-masked]>
Date: Mon, 14 Aug 2017 03:53:33 +0000

Hi Stewart and All,

Thank you for your suggestion. According to your information, it seems that the words “reliability” is more suitable for the context of network slicing with SLA guarantee.

As Liang mentioned, industrial verticals and other partners have different views on “reliability”. Even within IETF, different WGs may have different understandings. A standardized definition of “reliability” in NetSlicing scope is quite necessary IMHO, then NS service provider can further classify the “reliability” and adopt the appropriate implementation technology accordingly. I would like to know your opinion on this, and do we need to define the slicing specific “reliability”?

Best regards,

Cristina QIANG

From: Stewart Bryant [mailto:[email-masked]]
Sent: Friday, August 11, 2017 4:26 PM
To: qiangli (D); [email-masked]
Subject: Re: [Netslices] Reliability & Availability in NetSling

From a tenant's perspective, which arguably is the most important perspective the key characteristics of interest is  surely "The Mean Time Between Failures (MTBF) to maintain a defined QOS requirement." together with the duration of those periods.

With that information you can the viability of your application over the slice, and the impact on your business.

- Stewart

Best regards,

Cristina QIANG

or

- Stewart

Dear all,

Regards,

Pedro

Hi Cristina,

Liang GENG

Date: 2017-08-10 10:04

Hi All,

Best regards,

Cristina QIANG

Netslices mailing list

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 14 Aug 2017 09:51:23 +0100

Well, we do need a definition to point to even if we reuse an existing 
definition. That way we all have a common understanding of the term and 
can provide a common explanation to the tenants.

- Stewart

On 14/08/2017 04:53, qiangli (D) wrote:
>
> Hi Stewart and All,
>
> Thank you for your suggestion. According to your information, it seems 
> that the words “reliability” is more suitable for the context of 
> network slicing with SLA guarantee.
>
> As Liang mentioned, industrial verticals and other partners have 
> different views on “reliability”. Even within IETF, different WGs may 
> have different understandings. A standardized definition of 
> “reliability” in NetSlicing scope is quite necessary IMHO, then NS 
> service provider can further classify the “reliability” and adopt the 
> appropriateimplementation technology accordingly. I would like to know 
> your opinion on this, and do we need to define the slicing specific 
> “reliability”?
>
> Best regards,
>
> Cristina QIANG
>
> *From:*Stewart Bryant [mailto:[email-masked]]
> *Sent:* Friday, August 11, 2017 4:26 PM
> *To:* qiangli (D); [email-masked]
> With that information you can the viability of your application over 
> the slice, and the impact on your business.
>
> - Stewart
>
>     what people expect is not only the stable working
>     probability/time, but also the guaranteed SLA.
>
>     Try to consider from tenant’s perspective, I would be very
>     concerned about how much the promised SLA could really be
>     achieved. I am not sure which one (availability/reliability) this
>     concept should belong to according to ITU’s definitions.
>
>     Best regards,
>
>     Cristina QIANG
>
>     *To:* [email-masked] <mailto:[email-masked]>
>     packet delivery, and a reliable transport protocol is one that
>     retries (at a cost of delay) until the packet is delivered or
>     other factors intervene. Availability tends to refer to the
>     ability of the network to receive packets for attempted delivery.
>
>     *Definition* : The ability of an item to be in a state to perform
>     a required function under given conditions at a given instant of
>     time or over a given time interval, assuming that the required
>     external resources are provided.
>     NOTE 1 –This ability depends on the combined aspects of the
>     NOTE 2 –Required external resources, other than maintenance
>     resources do not affect the availability performance of the item.
>
>     *Definition* : The ability of an item to perform a required
>     function under given conditions for a given time interval.
>     NOTE 1 –It is generally assumed that the item is in a state to
>     NOTE 2 –Generally, reliability performance is quantified using
>     appropriate measures. In some applications, these measures include
>     an expression of reliability performance as a probability, which
>     is also called reliability.
>
>
>     or
>
>             industrial partners recently. In telecommunication
>             language we normally use "Reliability" to refer the
>             probability a network is stably run (i.e. 99.999% of
>             time). This is also regarded as network "Availability".
>             However, "Reliability" in industrial verticals is more
>             comprehensive - including not only network availability
>             parameter but also mechanics, electricity etc.
>
>             percentage of time a connection is available. But we you
>             sell this concept to industrial verticals, they may think
>             differently.
>
>             materials. It seems that “Reliability”supported by Netslicing refers to the probability that a
>             network slice could work stably, or other similar metrics.
>             But, shouldn’t this be the defination of “Availability”? Then what does reliability mean in NetSlicing?
>
>             Best regards,
>
>             Cristina QIANG
>