Subject: [Netslices] draft-arkko-arch-virtualization-01

From: Jari Arkko <[email-masked]>
Date: Tue, 6 Mar 2018 11:53:56 +0200

We wrote a new version of this draft, with more discussion of various technologies and issues that we think are related also to slicing.

https://tools.ietf.org/html/draft-arkko-arch-virtualization-01 <https://tools.ietf.org/html/draft-arkko-arch-virtualization-01>

Comments and discussion appreciated!

Jari

---

From: Kiran.Makhijani <[email-masked]>
Date: Tue, 13 Mar 2018 02:53:54 +0000

Dear Authors,
Thank you for posting this document. It is a good summarization of what everyone has talked about slices.

Apologies for lengthy comments. I just wanted to get better understanding of the motivation.
Regards
Kiran

As one of the initial contributor to netslices, some of my comments may be biased, here they are in any case:

1.  "In particular, whether one calls a particular piece of technology "virtualization", "slicing", "separation", or "network selection" does not matter at the level of a system".
^^^^
IMO, it should matter. virtualization is an old 'concept'. And what you call a particular piece of technology is important for clear differentiation. They may seem conceptually same at the top and may use common tools at the bottom but in-between techniques, usecases and methods would differ. Or perhaps you are alluding that all virtualization methods/technologies be uniformly done?

2. For section 2, few things that raise curiosity is a) what is the purpose of many different definitions without inclination to a particular one or conclusive remark? b) to me discussion on NFV seems unnecessary here.

3. The discussion 5.2 to 5.5 were covered well in the problem statement-gap-analysis (https://tools.ietf.org/html/draft-qiang-netslices-gap-analysis-01). only the narrative is different.

4. https://tools.ietf.org/html/draft-netslices-usecases-02 also has 2 items that you touched upon (1) 3GPP-usecase (section 4.1), (2) role of virtualization (section 5). On the other hand, you do not talk about 5GEX type of usecases. Basically, are you saying that slices are only relevant for 5G?

5. I think 5.5 is a very important discussion we need to have. As you say service models should just define characteristics, NSaas should be like that - important for IETF work.

6. In architectural principles - Data model layering,
this is a very good observation; To me it means E2E integration which is a challenge in data models today; but the way you suggest, it sounds like a 'network design' problem. Should we tackle it here? Wouldn't a simpler way to connect different existing DMs together be sufficient (I think YANG allows to reference one DM from other - maybe develop this further)? maybe consider using a term other than 'layering'.

7. The ability to specify "statistical" rather than hard performance parameters.
I don't understand the motivation here. The hard performance has been cited as a differentiator for slices (think URLLC type services), so it may not be a correct thing. Also think about if I want to map my parameters to DETNET YANG model, will I use statistical info? Although I agree on principle that TE models should have configs changes for different timescales.

8. Mapping from high abstraction level specifications to concrete network configurations.
I think this is not specific to slices area and should be applicable to any service related work in data modeling space. It is an independent effort in itself that slices would directly benefit from.

9. cross-domain: quite an important aspect - if this is the only outcome from the slice activity, it would have served the purpose.

Overall the focus in the document is too much on modeling. It is ok to acknowledge that solutions are available at disposal but we should not completely eliminate/exclude work that may be needed in control and data plane (even though as extensions to existing protocol).

========

From: Netslices <[email-masked]> on behalf of Jari Arkko <[email-masked]>
Date: Tuesday, March 6, 2018 at 1:54 AM
To: "[email-masked]" <[email-masked]>
Subject: [Netslices] draft-arkko-arch-virtualization-01

https://tools.ietf.org/html/draft-arkko-arch-virtualization-01

Jari

---

From: Jari Arkko <[email-masked]>
Date: Wed, 14 Mar 2018 21:01:14 +0200

Kiran,

Thanks for discussing this important topic, and thanks for the feedback on our document. 

Please note that our doc is work in progress; we are all trying to describe how we envision future networks to be built (including 5G), and trying to converge our different findings. Sort of like each of us describing a different part of an elephant.

> IMO, it should matter. virtualization is an old 'concept'. And what you call a particular piece of technology is important for clear differentiation. They may seem conceptually same at the top and…

I think it is indeed very important to recognise those differing use cases and methods. 

But for what it is worth, my approach to things is usually to try describe the characteristics of things that I see, and while naming things is important, it is not as important as actually describing the things we try to convey. Admittedly, our document does not go very far in this direction either, but I think we can agree that we need to describe the different concepts and find their relations and differences.

And I don’t think we have a single concept nor a uniform solution for everything. I actually think that even for the 5G case, we actually have a collection different technologies that we have to put into use together. From cloud tech to network virtualisation to radio and whatever new things we will need to realize the business needs and concepts that are categorised under the term “slicing”.

> 2. For section 2, few things that raise curiosity is a) what is the purpose of many different definitions without inclination to a particular one or conclusive remark? b) to me discussion on NFV se…

Clearly, more work is needed. What I would like to see is an explanation how the different concepts relate to each other. Clearly, NFV (and many other things) has a role, but is not the entirety of network slicing or virtualisation.

> 3. The discussion 5.2 to 5.5 were covered well in the problem statement-gap-analysis (https://tools.ietf.org/html/draft-qiang-netslices-gap-analysis-01). only the narrative is different.

Good!

I have added some discussion of that document (and few others) under a new section for related work.

> 4. https://tools.ietf.org/html/draft-netslices-usecases-02 also has 2 items that you touched upon (1) 3GPP-usecase (section 4.1), (2) role of virtualization (section 5).

Yes.

> On the other hand, you do not talk about 5GEX type of usecases.

Probably should...

> Basically, are you saying that slices are only relevant for 5G?

Not at all, but again, I’m trying to describe concepts, and I see a toolbox of virtualisation - slicing - management - cloud tools that together are used in many networks (including 5G). Whether or not we call something “slicing” …

I can make that clearer in the next revision.

> 5. I think 5.5 is a very important discussion we need to have. As you say service models should just define characteristics, NSaas should be like that - important for IETF work.

Right.

> this is a very good observation; To me it means E2E integration which is a challenge in data models today; but the way you suggest, it sounds like a 'network design' problem. Should we tackle it here? Wouldn't a simpler way to connect different existing DMs together be sufficient (I think YANG allows to reference one DM from other - maybe develop this further)? maybe consider using a term other than 'layering’.

Re: should we tackle it here. For any work on data models at the IETF or elsewhere, one needs to have a clear picture of how that model fits to the rest of the world. For instance, it would be beneficial to understand that the goal of a model is to be an abstract model that ultimately maps to something more concrete in specific underlying device data models, for instance. So I’d say if we do data model work, we MUST understand how they are connected to the rest of the picture.

(But it doesn’t necessarily follow that we have to have the entire solution, or be able to solve all problems. But we have to understand what role we intend our creations to play.)

> I don't understand the motivation here. The hard performance has been cited as a differentiator for slices (think URLLC type services), so it may not be a correct thing. Also think about if I want…

Your comments are correct with respect to e.g. URLLC services. But what we intended to say was that you’ll need different types of guarantees, and I think at least one of my co-authors was arguing that today’s tech allows hard limits easier than statistical ones. So that might be a gap in current tech.

Do you agree or disagree? I’m not trying to argue the case either way, but I think we can find agreement that we actually need both types of guarantees in different circumstances. If we do agree, the only thing to find out is whether our current tech has some gaps on either.

> I think this is not specific to slices area and should be applicable to any service related work in data modeling space. It is an independent effort in itself that slices would directly benefit fro…

Right.

> 9. cross-domain: quite an important aspect - if this is the only outcome from the slice activity, it would have served the purpose.

Right, agree.

> Overall the focus in the document is too much on modeling. It is ok to acknowledge that solutions are available at disposal but we should not completely eliminate/exclude work that may be needed in…

Ok. What were you thinking in terms of control and data plane work?

Jari

---

From: Kiran.Makhijani <[email-masked]>
Date: Thu, 15 Mar 2018 21:04:32 +0000

Ok. What were you thinking in terms of control and data plane work?
^^^^^
Frankly, I don't know clearly yet. Just maybe: Things added to describe (a) newer QoS or reliability       aspects better and have them distributed from controller to devices. (b) virtual-networks type work: let's say I want to augment exchange tenant's policies from head-end of a slice to alter a flow dynamically, (c) Stitching of subnets with different kinds of isolations (VXLAN, VPN etc.).

For now, COMS has focused on 2 interfaces (1) from slice provider to infrastructure, (2) tenant to slice    provider. So 3rd thing will be how controllers of infrastructures will delegate tasks to devices for efficiency and dynamicity.

I may be wrong with the above examples. But more importantly, thinking about data-models should be done after we have identified what we want to do; it should not be starting architectural principle which to me is reversing the process.

-Kiran

On 3/14/18, 12:01 PM, "Jari Arkko" <[email-masked]> wrote:

    Kiran,

    

    

    

    Good!

    
    Yes.

    Probably should...

    

    Right.

    

    

    Right.

    Right, agree.

    
    Jari