Subject: [Netslices] Initial Draft Agenda for COMS BoF

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 7 Mar 2018 17:48:35 -0000

Hi,

Thanks all for posting updates to drafts and thanks to Liang for thoughts on how
we might approach this.

Gonzalo and I spent some time discussing the agenda today and we came up with
the following straw man. We are lucky that the scheduling goddess has given us
150 minutes not the 120 that was originally planned, and the ADs say it is OK if
we use the time. 

This is an initial draft agenda. Discussion is welcome.

We will be looking to the proponents to suggest names for the "TBD" below.
Please consider communication skills as well as enthusiasm:-)

We will also need the slides. These should probably a combined effort: you
should certainly use the chairs and IAB shepherds (Jari and Jeff) to help write
them, and making use of co-authors and this mailing list would be wise. Keep
coming back to the list of questions- you do not have to answer them directly in
the slides, but you have to supply the material (across all of the
presentations) that will allow the questions to be easily answered by you / the
chairs / the meeting room.

Thoughts?

Adrian and Gonzalo

=================

COMS BoF
IETF-101, London
Thursday March 22nd, 2018
09.30 - 12.00

DRAFT AGENDA

1. Administrivia - chairs [2 mins : 2/150]

2. Objectives of the BoF - ADs [3 mins : 5/150]

3. Overview of Questions to be Answered - chairs [5 mins : 10/150]
Refresher on the questions the ADs want answered.
See item 8 on the agenda.

4. Setting the Scene - Jari Arkko [20 mins : 30/150]
Reference draft-arkko-arch-virtualization

5. What are we trying to do? - TBD [40 mins : 70/150]
The COMS Use Cases. What is in scope and what is a stretch goal?
Multiple mini-sessions for each use case, each followed by questions.
(Could use multiple presenters)
Reference draft-qiang-coms-use-cases

6. What is COMS? - TBD [20 mins : 90 /150]
How do the concepts fit together? What resources are in scope?
Top down versus bottom up.
Reference draft-geng-coms-problem-statement

7. Architecture overview - TBD [20 mins : 110/50]
Components and interfaces.
How does it fit with other work? What would we work on?
Reference draft-geng-coms-architecture

8. The Questions - chairs [30 mins : 140/150]
Move through the questions one-by-one getting clarity on the answers.

9. Wrap up - ADs [10 mins : 150/150]

---

From: Alex Galis <[email-masked]>
Date: Thu, 8 Mar 2018 20:02:37 +0000

8th March 2018

Dear BoF Chairs,

Re: Agenda revisited - COMS BoF at IETF101 (i.e. Thursday 22nd March 2018; Balmoral room)

Thank you for your message of 7th March 2018 and initial draft agenda for COMS BoF at IETF101. 

In parallel the BoF proponents have worked on the agenda based on the 3 questions from the AD and 5 objectives from the BoF Chairs.

These questions/objectives are:

AD’s (Benoit’s) questions to be addressed in the COMS BoF (message of 9th February 2018)
- (Q1) clarify the problem space (i.e. proponents interpretation : why, what, when, how, priorities)
- (Q2) find out whether IETF is the right place for this type of top down approach
- (Q3) how would that top down approach meet bottom up (being worked on in different WGs) 
COMS BoF Chairs (Gonzalo and Adrian) objectives to be addressed in the COMS BoF (message of 26th February 2018) 
- (O4) What is the problem space? This is not just what is in scope, but also what is out of scope.
- (O5) In particular, it is the focus of the problem: *the* thing that you want to achieve in an operational network.
- (O6) What is your proposed solution architecture?
- (O7) What interfaces (precisely!) are you proposing should be worked on?
- (O8) What deliverables do you envision and (since no one can have everything they want immediately) how would you prioritize the deliverables and where would you draw the line between "must have" and "can live without for now”?

Please find enclosed revised draft agenda as proposed by the BoF proponents,  which is integrated with your proposal as follows:

REVISED DRAFT AGENDA with reference to the 8 questions/objectives

1. Administrivia - chairs [2 mins : 1-2]

2. Objectives of the BoF - ADs [3 mins : 3-5]

3. Overview of Questions to be Answered - chairs [5 mins : 5-10]
Refresher on the questions the ADs want answered.
See item 8 on the agenda.

4. Setting the Scene - Jari Arkko [20 mins : 10-20]
Reference draft-arkko-arch-virtualization

5. Why are we trying to provide NS solutions [30 mins : 20-50]
2 presenters (20 mins presentations + 10 min Q&A)
What are operators relevant COMS UseCases?
What group of problems are important from operators, tenance and deployers of a network slicing technology viewpoints? 
What impact would be produced by NS solutions from operators, tenance and deployers of a network slicing technology viewpoints?
Why now? 
Questions/Objectives addressed: Q1 /O4 + O5
Reference: draft-qiang-coms-use-cases;
Supporting references: draft-geng-coms-architecture, draft-homma-coms-slice-gateway

6.  What are we trying to do?  [45 mins: 50 -95]
3 presenters (35 mins presentations +10 mins Q&A) 
COMS problem statement + Relationship between Use Cases and problem statement
COMS architecture, Components and Interfaces.
COMS architectural design enablers & artefacts
Questions/Objectives addressed: Q1 / O4+ O6 +O7
Reference: draft-geng-coms-architecture;
Supporting references: draft-defoy-coms-subnet-interconnection, draft-homma-coms-slice-gateway, draft-qiang-coms-netslicing-information-model 

7.  How do the concepts fit together? [15 mins : 95 -110]
1 presenter (10 mins presentation +5 mins Q&A) 
What resources are/ are not in scope?
Top down versus bottom up.
Top-bottom Interplay
How do the concepts fit together in IETF
Questions/Objectives addressed: Q2+ Q3 +O8
Reference: draft-geng-coms-architecture

8. The Questions - chairs [30 mins : 110 - 140]
Move through the questions one-by-one getting clarity on the answers.

9. Wrap up - ADs [10 mins : 140 -150]

Feedback is welcomed. 
We are working on presentation slides, which will be shared with Jari and Jeff for their reviews as you kindly suggested.
Thank you in advance.

Best Regards

Alex
(in the name of COMS BoF proponents)

> On 7 Mar 2018, at 17:48, Adrian Farrel <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> Netslices mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netslices

---

From: Jari Arkko <[email-masked]>
Date: Wed, 14 Mar 2018 21:50:43 +0200

FWIW, my personal opinion is that there critical issue is demonstrating we
can actually connect the top-down and bottom-up in some way. Sometimes
it is useful just as a thought exercise to consider what would be the smallest
possible thing we could do and how that relates to existing pieces. E.g., "we
will extend a data model from WG X in this manner". Or "we make a new
construct that can be mapped to something in WG Y". Does someone have
an idea what the possible answer might be? Once we know an answer (or
some), we can then extend to bigger things and see how far we want to
go.

Jari