Subject: Regarding Pseudo file system of NFSv4 . . .

From: kvs sivak <[email-masked]>
Date: Tue, 22 Feb 2000 12:40:40 +0000 (GMT)

Hello,
    I would like to know more about the Pseudo File
System of NFSv4. The ietf-draft-03.00 specifies only
that a PFS should be built using the list of all
exported directories on the server, and that a path
should exist for every exported dir from the root.

Can you through some light on how exactly this is to
be achieved.

Is it better to build an interface similar to the VFS
or just maintain a tree with each node containing one
exported dir and the list of clients having access on
it?

What happens if the underlying file/dir is deleted
while it is in use by some client?

Note : Please also specify how a File Handle is
generated. is this implementation dependant?

awaiting a reply soon.

yours
   kvs-sivak. 

____________________________________________________________
Do You Yahoo!?
Get your free @yahoo.co.uk address at http://mail.yahoo.co.uk
or your free @yahoo.ie address at http://mail.yahoo.ie

---

From: Brent Callaghan <[email-masked]>
Date: Tue, 22 Feb 2000 09:34:39 -0800 (PST)

> should exist for every exported dir from the root.

That's correct.

> exported dir and the list of clients having access on

No, a full-blown VFS isn't necessary.  The pseudo-filesystem
can be implemented completely within the NFS server. It
doesn't need to be visible outside the server.  Think of
it as a series of linked data structures (like vnodes)
within the server's memory.

> while it is in use by some client?

It'll be the same for a pseudo filesystem directory as
for a regular directory.  If it is deleted from underneath
the client, then the client will receive a stale filehandle
error when it tries to access it.

Note that the pseudo-filesystem needs only to support
directories.  It's needed only to span the gaps in
the server's namespace.

> generated. is this implementation dependant?

Yes.  Filehandle content is determined completely by
the server - as it is for NFS v2/v3.  In the case of
a pseudo-filesystem, it may be easier for the server
to generate volatile filehandles, though this shouldn't
be a problem if the client tracks the paths for each
pseudo-filesystem filehandle.  Nothing tremendously
exciting happens in pseudo filesystems.

	Brent