Subject: RE: RENAME clarifications

From: "Noveck, Dave" <[email-masked]>
Date: Thu, 3 Feb 2000 10:41:56 -0800

> Two clarifications/mods for RENAME...
> 
> 1)
> 
> It has been pointed out that the RENAME operation does not
> make a statement about the value of the current filehandle
> after successful completion.  I have added such a statement
> and think it is appropriate but the requirement to have
> the current filehandle set to the new file system object
> is an additional piece of work for the server.

There is no new file system object.  There is an old file
system object that has a new name.

> 
> --
> 
> DESCRIPTION
> 
>   The RENAME operation renames the object identified by oldname in
>   the source directory corresponding to the saved filehandle, as set
>   by the SAVEFH operation, to newname in the target directory
>   corresponding to the current filehandle.  The operation is required
>   to be atomic to the client.  Source and target directories must
>   reside on the same file system on the server.  On success, 
> the       |
>   current filehandle corresponds to the newname object.       
>          |

How about, On success the current file handle corresponds to the 
object renamed.  When the filehandle is volatile, the current
filehandle may be different from the one which would designate
that object before the RENAME operation.

---

From: Mike Eisler <[email-masked]>
Date: Thu, 3 Feb 2000 11:10:05 -0800 (PST)

> system object that has a new name.

The object corresponding to the current file handle hasn't
changed names.

The problem with the proposal which Spencer has now withdrawn is
it assumes the client is interested in the file handle
of the object being renamed. It often isn't.

	-mre