Subject: Re: RENAME clarifications

From: Salit Gazit <[email-masked]>
Date: Thu, 3 Feb 2000 11:35:23 -0800 (PST)

Spencer Shepler wrote:
>Mike Eisler wrote:
>> I don't see why the current file handle has to be perturbed. If a
>> client wants the file handle of the newname object, then it can piggyback
>> a LOOKUP onto the compound procedure.
>> 
>> Consider the client that does a block of renames from one
>> directory to another. If the saved and current file handles are
>> left unperturbed, then this can be done efficiently in one compound
>> procedure.
>
>Ahh.  Good idea.  I like it and therefore withdraw my previous
>modification and suggest that the verbage now be:
>
>"On success, the current filehandle will continue to be the
>target directory."

I suggest that link follows the same logic as rename. It is currently
defined to change the current file handle from the target directory to
the link file upon success.

Salit

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 03 Feb 2000 14:37:51 -0600

> the link file upon success.

This seems reasonable to have rename/link exhibit similar behavior.

Spencer