Subject: RE: [reiserfs-list] Directory cookie issues

From: "dshaffer" <[email-masked]>
Date: Tue, 6 Feb 2001 11:52:50 -0600

Ran,

	I believe your customer hat is a little lopsided :). I would
take exception to your assumption about NFS and Microsoft users. We sell
into this market and contrary to the opinion expressed there is still a
significant base of Users in the Microsoft world using NFS. In striving
to make the NFS spec useable by the widest variety of OS's the User is
being best served. If the Protocol was designed to only operate in a
Unixcentric world and not meshing well with other OS's would be a big
mistake and limit it's usability.

Dan Shaffer
[email-masked]
Ph:  (256) 890-0077 x107
Fax: (256) 890-9133

-----Original Message-----
From: RJ Atkinson [mailto:[email-masked]]
Sent: Tuesday, February 06, 2001 6:37 AM
To: Hans Reiser
Cc: [email-masked]
Subject: Re: [reiserfs-list] Directory cookie issues

	I'll put on my customer/user hat about now.  As noted
earlier on, I'm NOT tremendously happy about the extra gorp 
already added to NFSv4 to accomodate certain platforms that 
are broken wrt to NFS concepts and architecture.  Those changes 
are likely to reduce my interoperability in practice, 
though they were justified as improving interoperability 
with Microsoft (which is not of concern to a large subset 
of the NFS installed base, to be honest).

	I will be even less happy if we alter/change/add
stuff to support yet another unique filesystem, given
that Linux Ext2 works OK now with NFSv4.  I have nothing 
against folks doing new filesystems or kinds of filesystems.  
I have a lot of issues with every filesystem group trying
to tweak the NFS spec to "better" support their particular
file system implementation and model.

	My blunt suggestion is that if the technical challenges
are as high as seem to be claimed, maybe the ReiserFS folks 
should consider jut NOT supporting NFS and instead roll your 
own distributed file system or try AFS or something else (SMB?).

Yours for a simpler and more reliable NFS,

Ran
[email-masked]

---

From: RJ Atkinson <[email-masked]>
Date: Tue, 06 Feb 2001 12:50:43 -0500

At 12:52 06/02/01, dshaffer wrote:
>        I would take exception to your assumption 
>about NFS and Microsoft users. 

        Be careful.  I didn't make an assumption.  
I use NFS on Windows daily.

>We sell into this market and contrary to the opinion expressed there 
>is still a significant base of Users in the Microsoft world using NFS. 

        I'm one of them.  The existing products that I use
support only NFSv3 and work JUST FINE on NT 4.0 and Win9x
with several different NFS servers.  No special NFSv4 changes
were needed.  Gosh !

        All this begs the question of why more changes were
needed in NFSv4 to support Windows.  Since there is an existence
proof that this works fine now, why make all the changes that
make NFSv4 even more complex, hard to troubleshoot operationally,
and harder to test ?  (At this point, its mostly a rhetorical
question).

Ran
[email-masked]