Subject: RE: Formal proposal to add a type field to 'struct LOCK4denied'

From: "Noveck, Dave" <[email-masked]>
Date: Wed, 7 Feb 2001 20:22:45 -0800

> > It looks like we just made a mistake here.  Let's say "Oops!" and fix
it.

> I agree, particularly since I think the fix will require a very minor
> change, both in terms of changes to the spec and changes to existing
> server implementations.  I would like to make a "formal proposal" to
> change the definition of 'struct LOCK4denied' in the protocol from
> 
>      struct LOCK4denied {
>             nfs_lockowner4  owner;
>             offset4         offset;
>             length4         length;
>     };
>
> to
>
>     struct LOCK4denied {
>            nfs_lockowner4  owner;
>            offset4         offset;
>            length4         length;
>            nfs_lock_type4  locktype;
>     };
>
> for purposes of improving a POSIX client's ability to map the NFSv4 file
> locking semantics to its own.

Is there anybody that thinks we shouldn't do this?

---

From: Bill Ricker <[email-masked]>
Date: Thu, 08 Feb 2001 11:27:47 -0800

> Is there anybody that thinks we shouldn't do this?

Not I.
-- 
bill