Subject: Re: LINK a symbolic link?

From: Jim Rees <[email-masked]>
Date: Tue, 27 Nov 2001 13:13:55 -0500

LINK won't let you create a link to a directory

That's not what the spec says.  I had assumed you could only link to a
regular file, but now Spencer says you can link to non-regular files.  Since
the spec doesn't say which non-regular files you can link to, I assume an
implementation is free to allow links to directories.  If that's not the
case, maybe we should fix the spec.

My preference would be to disallow links to non-regular files.

---

From: Spencer Shepler <[email-masked]>
Date: Tue, 27 Nov 2001 12:25:53 -0600

> My preference would be to disallow links to non-regular files.

There is precedence in NFSv2/v3 for linking to non-regular files
(except for directories).

-- 
Spencer