Subject: fattr4_mode

From: Peter Åstrand <[email-masked]>
Date: Wed, 28 Nov 2001 18:21:54 +0100 (CET)

Should fattr4_mode contain the file type, nowadays? It did so in NFSv2, 
which was stated as a protocol bug. NFSv3 fixed that. How about NFSv4? The 
Linux server and Ethereal seems convinced that the file type should be 
included. GETATTR(FATTR4_MODE) returns things like "0100777", even after 
doing SETATTR(FATTR4_MODE(0777)). 

-- 
Peter Åstrand                Telephone: +46-13-21 46 00
Cendio Systems               E-mail: [email-masked]
Teknikringen 3
583 30 Linköping
Sweden

---

From: Brent Callaghan <[email-masked]>
Date: Wed, 28 Nov 2001 11:03:10 -0800

> doing SETATTR(FATTR4_MODE(0777)).

The argument goes that it's silly to have the file type show
up in two places.  There's also some ambiguity - what if they're
different?  It's easy for UNIX clients to insert the filetype
into the mode - so why burden the protocol with unnecessary
redundancy ?

	Brent

---

From: Spencer Shepler <[email-masked]>
Date: Wed, 28 Nov 2001 15:56:47 -0600

> doing SETATTR(FATTR4_MODE(0777)). 

I agree with Brent that the mode attribute should be just that -- mode.

Will add an issue to specify the allowable values for mode.

-- 
Spencer

---

From: Ric Werme <[email-masked]>
Date: Wed, 28 Nov 2001 17:21:57 -0500

> > which was stated as a protocol bug. NFSv3 fixed that.

Brent notes:
> different?

In one or two cases at Connectathon some server returned different values.
I forget who it was, but I was pleased to be able to come up with a good
reply to "It works with XYZ's client, why doesn't it work with yours?"

Mode bits are mode bits, not file type....

	-Ric